Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×

Weapon Stats Incorrectly Modding


WF_Needs_Auction_House
 Share

Recommended Posts

Mutalist Cernos appears to be the only weapon I know of getting this glitch, but as you can see, after adding an extra elemental damage mod in, it actually loses damage.

Started back in I believe November. Made a couple threads on other forums with no response, then made a support ticket last night which got a response directing me to this forum.

20200202220247_1.jpg20200202220301_1.jpg

Link to comment
Share on other sites

15k Electricity? I'm pretty sure THAT'S the issue. You don't lose damage, when you add the elemental mod it shows the actual damage. The other thing is broken.

Then again, you have a riven. Maybe that janks up the math.

Edited by Asphyxxia
Link to comment
Share on other sites

35 minutes ago, Lacuda said:

Mutalist Cernos appears to be the only weapon I know of getting this glitch, but as you can see, after adding an extra elemental damage mod in, it actually loses damage.

 

7 minutes ago, Asphyxxia said:

15k Electricity? I'm pretty sure THAT'S the issue. You don't lose damage, when you add the elemental mod it shows the actual damage. The other thing is broken.

Regardless, something is going on.

Would you mind posting the stats of the riven?

Link to comment
Share on other sites

1 minute ago, Asphyxxia said:

15k Electricity? I'm pretty sure THAT'S the issue. You don't lose damage, when you add the elemental mod it shows the actual damage. The other thing is broken.

Unless that riven has some extra electricity %. I found another thread with the same issue, without an unknown riven and the numbers on the electricity line up properly.

The corrosive on that build shouldn't be there unless its counting the toxin on the cloud. Even then the numbers don't really make any sense. Both use toxin mods for the dual element so that might be related because of the toxin cloud.

OP can you try replacing infected clip with hellfire and see if the radiation value is different from the corrosive one?

 

Link to comment
Share on other sites

The riven is an Electric and Base damage riven with unknown multipliers, but I'm going to assume that the electricity is positive, and that the base damage is also positive at around 50-60%. 

There might be an unknown negative, but that hardly matters. 

Look at the stat numbers, Electricity and Corrosive are separate regardless of M. Cernos being a Toxin innate weapon and not a corrosive innate weapon. Simply, the stat screen math on the M. Cernos is wrong again

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...