Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Trading > Mods. ALWAYS shows "equipped" warning even if you sell r0 mods


---.CCC.---TradeFrame
 Share

Recommended Posts

u1IIbeG.png

 

I trade a lot and my pet peeve is that there's no way of visually identifying which mods you have already equipped, if you have multiple maxed ranked mods.

What happens is I end up equipping a maxed primed continuity on saryn, then another on volt, then another on nekros etc etc, till I "use" every maxed primed continuity I have.
Then when I sell a maxed primed continuity, it un-equips from one the warframes.

What makes matter worse is recent updates have exacerbated this issue by expanding this error message to even r0 mods, even if it's not equipped.
Sometimes it gets fixed, but a few updates later, the problem comes back with a vengeance.

If mods could be marked as "being used", it would ensure that you don't end up equipping every copy of the mod you have.
Can we have some mark on a mod is being used on another frame (a small dot on the corner of the mod or something).
The mechanic is already present in the game (re:sentinel weapon/warframe weapon mods).

 

 

  • Like 1
Link to comment
Share on other sites

It even prompts you two times, first when you select it, second when you confirm the item. I understand it's a failsafe feature but srsly, we don't need these 2 steps if we can simply identify at first glance which mods are equipped.

Link to comment
Share on other sites

On 2020-02-12 at 10:47 PM, IronHair said:

I trade a lot and my pet peeve is that there's no way of visually identifying which mods you have already equipped, if you have multiple maxed ranked mods.

-Snip-

If mods could be marked as "being used", it would ensure that you don't end up equipping every copy of the mod you have.
Can we have some mark on a mod is being used on another frame (a small dot on the corner of the mod or something).

There is actually a way much like the one you are asking for. Except it seems not to work properly in the new trading UI. I'll demonstrate with a couple of screenshots.

xz0ZyY7.png

If you look closely on above image, there is a small hexagon at the bottom middle part of (top right corner) unranked Adaptation mod (and all other variously ranked Adaptation mods). But not on the (middle right side) unranked Adaptation mod. That hexagon should indicate that said mod is currently equipped on one or more of applicable items.

Now unfortunately it seems currently the new trade UI doesn't show these hexagon markers properly. You can see it from the following screenshot. Where it just stacks both unranked Adaptation mods, even though one of them is equipped on a frame.
NWFkhxk.png

Also it seems that most mods in trade UI don't even show that hexagon at all, regardless whether they are equipped or not. Hopefully DE can fix this. 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...