Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Died, but not really?


Blank1891
 Share

Recommended Posts

So I was lich hunting with Limbo, was in the rift and tried mercy on the first healthbar on my lich (my teammate brought down her health) it didnt trigger any animation or showing that the requiem mod was right or wrong but it brought her down to her second health bar, tried again but this time she grabbed me and I presses X for mercy about at the same time (Still in the rift, did not think about it) when she despawned, probably because my second mod was wrong I got thrown into a sort of ragdoll mode where I could not move shoot or do absolutely anything except for writing in chat. Mind I still got full healthbars and no bleedout phase.

When I figure out how to, I'll post screenshots.

Link to comment
Share on other sites

I got a similar glitch today. I was playing solo. I tried to mercy while in the void, nothing seemed to happen so I left the void. No animation happened, but I went on the ground looking like I had died, but I still had health and shields left. The kuva lich left. Couldn't move or respawn. Tried to /unstuck, didn't work. I got system logs, but forgot to take a screenshot.

The irony of this limbo state.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...