Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Unable to Revive


(XBOX)Dark Ryuk13
 Share

Recommended Posts

I'm not sure what caused the bug, however the last few days if I go down, I am unable to revive. If I am playing co-op and a friend catches me before I bleed out then I'm alright, but if I bleed out in Co-op play or I go down in solo play I cant use a single revive. For the last few days I've had 4 revives to use, the game just wont let me. It doesn't matter if I am in a Nightmare mission, a normal mission, Syndicate, or even in Orbs Valley or The Plains. IF I GO DOWN, I CANNOT REVIVE. Its actually very annoying having gone through so much progress on a node or in a mission only to go down and be forced to exit the mission and restart it. I have tried changing the controller, i have tried restarting the game, i have unplugged the xbox for a full day, it hasn't helped. While I am trying to revive, i can spin the camera I can talk in chat, i can use the menus. I can do everything as is normal, except revive myself tapping A holding A, swapping controllers and holding/tapping A using a corded controller, doesn't work. Is there a way to fix this? I dont mind going down i know it'll happen, i just find it frustrating having to be forced to restart levels after going down a single time.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...