Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

"The Sacrifice" quest, glitch/bug.


Lokanahta
 Share

Recommended Posts

"After fighting Umbra on Neptune, and going to the Cinematic with Ballas and Issah, I am unable to place black pieces on the board game with Ballas. After restarting the mission 16 hours later, Again beating Umbra and going to the Cinematic, I was able to place two black pieces on the board game with Ballas. When prompted to look at the musical instrument by Issah, I could not continue to place anymore pieces on the board game when prompted by Ballas. All I can do is look around at the room. Cannot progress. This is happened twice now."

I'm having the exact same problem as reported above. I've restarted my game 4 times, played the mission with 3 different warframes, and the same bug occurred. I'm not sure what the problem is, but I can't seem to progress through the quest past this point.

 

*Fixed* restarted again, this time it worked. still not sure what the issue was but now it's fixed.

Edited by lushelocution
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...