Jump to content
[DE]Bear

Warframe Revised: HDR Visual Megathread

Recommended Posts

HDR Preview
Players with a Graphics Card and Monitor that supports High Dynamic Range will be able to preview our new technology!

Why:
Warframe is a vibrant game - and including HDR support will allow those with the hardware to experience a new richness! 

Please remember to leave your feedback in a constructive and civil manner! Remember, this thread is for FEEDBACK ONLY. If you have a bug, please make sure you submit your bug on this thread and follow the new guidelines!

Share this post


Link to post
Share on other sites

HDR Support don't seem to work, I've done the following settings it requires, but it still is grayed out. Is there something I am missing?. I have an HDR Monitor (I have a small HDR button I can click to enable it, that swaps with HDR and B.I.+), Have Windows 10 installed and all settings as max as possible.

  • Like 1

Share this post


Link to post
Share on other sites

Same here as Circle of Psi. I'm not able to enable it despite doing all the options it asked me to enable it to and disabled the other one. Still won't ungray out??? Is it currently bugged or?

Share this post


Link to post
Share on other sites
Posted (edited)
14 minutes ago, Circle_of_Psi said:

HDR Support don't seem to work, I've done the following settings it requires, but it still is grayed out. Is there something I am missing?. I have an HDR Monitor (I have a small HDR button I can click to enable it, that swaps with HDR and B.I.+), Have Windows 10 installed and all settings as max as possible.

What's your GPU? Also, did you enable it in the launcher? As they showed it, it won't be in the in-game UI without checking the opt-in option.

I myself can't test it until I get home though.

Edited by Jarriaga

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, Jarriaga said:

What's your GPU? Also, did you enable it in the launcher? As they showed it, it won't be in the in-game UI without checking the opt-in option.

Oh...let me check that..

 

Edit: It's all on, GPU Acceleration is on and that new settings that came up.  Also have: GeForce GTX 1018 Ti

Edited by Circle_of_Psi

Share this post


Link to post
Share on other sites
30 minutes ago, Circle_of_Psi said:

HDR Support don't seem to work, I've done the following settings it requires, but it still is grayed out. Is there something I am missing?. I have an HDR Monitor (I have a small HDR button I can click to enable it, that swaps with HDR and B.I.+), Have Windows 10 installed and all settings as max as possible.

i have the same problem, i have i5-9600KF and RTX 2060 SUPER, i have original windows 10 pro, enabled optimized flip-model, antialiasing TAA 8X (high) and disabled dynamic resolution.
and it still doesnt let me enable HDR output

Share this post


Link to post
Share on other sites

You also need to activate HDR in Windows System and then display settings. After i did that the option became available in game.

Share this post


Link to post
Share on other sites
31 minutes ago, Jelmer0611 said:

You also need to activate HDR in Windows System and then display settings. After i did that the option became available in game.

Not gonna lie, I really don't like that. Turning on the windows system toggle basically washes out everything else on your display since everything else is displayed as SDR content in windows unless it can find anything outputting in the proper HDR colour ranges. 

yDSp1k2.png

However, the requirement will probably be patched out in the future, seeing as the feature is still experimental and other games (ie. The Division 2, Destiny 2, Assassin's Creed Origins/Odyssey) can all automatically enable it in the display. So I guess there's nothing too big to worry about.

Share this post


Link to post
Share on other sites
2 minutes ago, HiImOuira said:

Not gonna lie, I really don't like that. Turning on the windows system toggle basically washes out everything else on your display since everything else is displayed as SDR content in windows unless it can find anything outputting in the proper HDR colour ranges. 

yDSp1k2.png

However, the requirement will probably be patched out in the future, seeing as the feature is still experimental and other games (ie. The Division 2, Destiny 2, Assassin's Creed Origins/Odyssey) can all automatically enable it in the display. So I guess there's nothing too big to worry about.

Yeah i know… It sucks! But this is what we have to work with at the moment. So here is to hoping it will be patched indeed! 🙂

Share this post


Link to post
Share on other sites

I've been trying to get this to work for a while now.  I have HDR turned on in windows 10 (it works fine on my other HDR games, such as Destiny 2, Mortal Kombat 11, Assassin's Creed Origins, Devil May Cry 5.   So there's no issue with HDR working on my system in other games.  My monitor, OS, and graphics card can all handle it (Rtx 2070 Super).  I also have Deferred Rendering turned on in the launcher.

I have TAA x8 Turned on, enabled optimized flip model turned ON, and disabled dynamic resolution.  The option for HDR will not turn on, no matter what.  I have tried Windowed mode, Borderless Fullscreen mode in native and scaled, fullscreen mode in multiple resolutions....

So far nothing i have tried has allowed the HDR button to be toggled.

Either something is broken, or there is something not being explained that is a hidden requirement..... anyone have any ideas?   I'm running a 4k monitor which i PREFER running at 1440 since getting 60fps out of 4k at with max graphic settings is not always reliable.    Thanks in advance.

Share this post


Link to post
Share on other sites

Blacks are too black and lose a lot of detail. Overall image loses a lot of vibrancy.

Share this post


Link to post
Share on other sites

Have all settings as requested, HDR compatible monitor and graphics card, deferred rendering enabled, box greyed out. 😅5700XT graphics card with R9 3900X processor. It should have plenty of horse power to run it.IQE8Gq1.png

Share this post


Link to post
Share on other sites

HDR is grayed out for me while having all the prerequisites. 2080 ti and X35 monitor. HDR is enabled in windows display settings.

Share this post


Link to post
Share on other sites

Windows 10 have "Play HDR games and apps" turned on, but Warframe HDR output fails and is grayed out.

My YouTube HDR video show this problem. Use windows 10, HDR monitor, Edge or Chrome, to see YouTube videos in HDR.

 

Share this post


Link to post
Share on other sites
Posted (edited)

No HDR for me either. Can't enable even with the correct options set up, the button remains grayed out. 2070 Super, Sony X800D TV.

Edited by cynicalking

Share this post


Link to post
Share on other sites

Can confirm HDR Output also greyed out w/ PG35VQ when meeting all the requirements.

ky0EXNL.png

Share this post


Link to post
Share on other sites
il y a 5 minutes, FPSrad a dit :

Can confirm HDR Output also greyed out w/ PG35VQ when meeting all the requirements.

ky0EXNL.png

Have the same monitor. Works for me. It is important that you enable HDR in Windows. Have you done that?

8d599cd9d044543c744a9e1dc7e74147.png

Share this post


Link to post
Share on other sites
2 minutes ago, Winterfalke said:

Have the same monitor. Works for me. It is important that you enable HDR in Windows. Have you done that?

Yeah 😕

If you'd be so kind as to tell me what the HDR variables are called in your EE.cfg file? Location: C:\Users\[Username]\AppData\Local\Warframe

Wondering if I could enable it that way, my settings are as follows:

Spoiler

[Windows_Config,/EE/Types/Base/Config]
Graphics.AntiAliasing=AA_TEMPORAL
Graphics.AutoDetectGraphicsSettings=0
Graphics.BloomIntensity=0.37
Graphics.DisplayAspectRatio=PanoramicWideScreen21x9
Graphics.EnableDOF=0
Graphics.EnableMotionBlur=0
Graphics.EnableSwapChainFlipModel=1
Graphics.FullScreen=1
Graphics.FullScreenSizeX=3440
Graphics.FullScreenSizeY=1440
Graphics.GPUParticlesQuality=GPQ_MEDIUM
Graphics.GeometryDetail=GD_HIGH
Graphics.MaxFrameRate=179.981
Graphics.ParticleSysQuality=PQ_HIGH
Graphics.RefreshRate=179.981
Graphics.ShadowQuality=SQ_HIGH
Graphics.TextureQuality=TQ_HIGH
Graphics.TrilinearFiltering=TF_ON
Graphics.VSyncMode=VSM_NEVER_SYNC

 

Share this post


Link to post
Share on other sites

I'm having issue with Operator's Stealth modes White Filter that it adds. It is abnormally bright. And makes things hard to see, especially at nights in dark place. Otherwise so far HDR is beautiful.

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, FPSrad said:

Yeah 😕

If you'd be so kind as to tell me what the HDR variables are called in your EE.cfg file? Location: C:\Users\[Username]\AppData\Local\Warframe

Wondering if I could enable it that way, my settings are as follows:

  Hide contents

[Windows_Config,/EE/Types/Base/Config]
Graphics.AntiAliasing=AA_TEMPORAL
Graphics.AutoDetectGraphicsSettings=0
Graphics.BloomIntensity=0.37
Graphics.DisplayAspectRatio=PanoramicWideScreen21x9
Graphics.EnableDOF=0
Graphics.EnableMotionBlur=0
Graphics.EnableSwapChainFlipModel=1
Graphics.FullScreen=1
Graphics.FullScreenSizeX=3440
Graphics.FullScreenSizeY=1440
Graphics.GPUParticlesQuality=GPQ_MEDIUM
Graphics.GeometryDetail=GD_HIGH
Graphics.MaxFrameRate=179.981
Graphics.ParticleSysQuality=PQ_HIGH
Graphics.RefreshRate=179.981
Graphics.ShadowQuality=SQ_HIGH
Graphics.TextureQuality=TQ_HIGH
Graphics.TrilinearFiltering=TF_ON
Graphics.VSyncMode=VSM_NEVER_SYNC

 

Np this is what mine is saying:

Spoiler

[Windows_Config,/EE/Types/Base/Config]
Graphics.AntiAliasing=AA_TEMPORAL
Graphics.AutoDetectGraphicsSettings=0
Graphics.BlurLocalReflections=0
Graphics.Borderless=1
Graphics.EffectsIntensity=0.80000001
Graphics.EnableGlare=0
Graphics.EnableSwapChainFlipModel=1
Graphics.EnableTessellation=0
Graphics.FullScreenSizeX=3440
Graphics.FullScreenSizeY=1440
Graphics.GPUParticlesQuality=GPQ_MEDIUM
Graphics.HDROutput=1
Graphics.HDRPaperWhiteNits=1000
Graphics.HLODDistanceScale=0.80000001
Graphics.HighDPI=HDM_NATIVE
Graphics.ImposterDistanceScale=0.80000001
Graphics.LocalReflections=0
Graphics.RefreshRate=143.97501
Graphics.SSAO=0
Graphics.TAASharpen=0.30000001

Also here are my launcher settings. Don´t know if it is related or not.

Spoiler

2b139bbcbd52a7c500c09cae8d56972b.png

 

Edited by Winterfalke

Share this post


Link to post
Share on other sites
32 minutes ago, Winterfalke said:

Np this is what mine is saying:

  Reveal hidden contents

[Windows_Config,/EE/Types/Base/Config]
Graphics.AntiAliasing=AA_TEMPORAL
Graphics.AutoDetectGraphicsSettings=0
Graphics.BlurLocalReflections=0
Graphics.Borderless=1
Graphics.EffectsIntensity=0.80000001
Graphics.EnableGlare=0
Graphics.EnableSwapChainFlipModel=1
Graphics.EnableTessellation=0
Graphics.FullScreenSizeX=3440
Graphics.FullScreenSizeY=1440
Graphics.GPUParticlesQuality=GPQ_MEDIUM
Graphics.HDROutput=1
Graphics.HDRPaperWhiteNits=1000
Graphics.HLODDistanceScale=0.80000001
Graphics.HighDPI=HDM_NATIVE
Graphics.ImposterDistanceScale=0.80000001
Graphics.LocalReflections=0
Graphics.RefreshRate=143.97501
Graphics.SSAO=0
Graphics.TAASharpen=0.30000001

Also here are my launcher settings. Don´t know if it is related or not.

  Reveal hidden contents

2b139bbcbd52a7c500c09cae8d56972b.png

 

Thanks for the settings, unfortunately couldn't force it that way, even setting it to read-only haha. Oh well was worth a try, hopefully they figure out what's going on.

Share this post


Link to post
Share on other sites

As others have said, it doesn't seem to work. I meet the listed requirements. Windows 10, TXAA, optimised flip, dynamic resolution disabled. I've tried with and without the Windows 10 HDR setting, both in fullscreen and borderless mode, with my monitor in or out of the HDR profile in its menu. The option is always greyed out.

Also, I hope that these requirements are only temporary? I prefer SMAA for how it looks, and I also use the dynamic resolution setting for a 4k UI with most of the game running at 1440p.

Share this post


Link to post
Share on other sites
Posted (edited)

Just tested. Worked beautifully for me! It's the first time EVER I can actually tell the colors apart in the Saturated color palette! I'm happy!

Test settings:

Windows 10 Pro (Build 1809)

GTX 1070 (Driver version: 441.12)

TV: LG 43UH6100 (HDR10 standard; does not support Dolby Vision)

Deferred rendering: OFF

Zeskit HDMI 2.0b certified cable

Some notes:

1) Ouch on having to disable dynamic resolution. I normally play at 3200x1800 with DR on set to auto so it can handle Earth/Venus. Having to disable it was a huge hit in Cetus (Stress test) until I dropped my resolution to 1440p.

2) There was no launcher menu option for me. At first I thought the game was broken or not detecting my setup as valid, but the in-game toggle was active for use once I set the requirements. 

3) An in-game color calibration menu would have been appreciated. I think the image is over-saturated when taking into account my standard TV settings, so having "sample" images to match in order to make the game look as you guys intend would be nice.

4) Some menu items are inconsistent with the implementation. In the foundry for example, the category icons for WF/Primary/Gear/ETC at the top are white and bright, but the blueprint contents look rather dull and washed-out.

Other than that, I like the implementation a lot on its own. I will now test deferred rendering with it.

Edited by Jarriaga

Share this post


Link to post
Share on other sites
Posted (edited)

I was only able to get it working by switching to windowed borderless, alt+tab out, turn on windows HDR, then go back in game. After that the option wasn't greyed out. For me, HDR does not work when fullscreen.

This was after setting the correct options (TXAA 8x, dynamic res off, optimized flip-model on).

Windows 10 Pro 1909 (build 18363.693)

GTX 1080, 442.50

Monitor: Dell S3220GDF, 1440p @ 165hz

 

Edit: I also had to disable freesync on the monitor.

Edited by Kalvelis
Forgot

Share this post


Link to post
Share on other sites

After some tinkering, I got it to work.

The HDR option became available for me after setting the output to (422 / 10bit / limited) in the NV control panel.

Vyki2kx.png

Hope it helps someone.

 

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...