Jump to content
General Bug Report Guidelines - Please Read ×

Vidar Reactors Mk3 lost their component modifiers [Fixed]


Hedrax
 Share

Recommended Posts

I have a similar problem: the Vidar reactor I have installed and the repaired Zetki reactor I have available do show the Component Modifier, but the Vidar reactor wreckage I just picked up in a mission does not.55027612E278BE118C5A1ADEC1D2AF1B785FAB58

Edited by N64Gamefreak
Link to comment
Share on other sites

Same again here. Relogging hasn't worked, nor swapping components. In fact I've manage to get one to drop as wreckage, with no modifiers on it and its definitely mk3. I think either it's gone or that particular modifier is for some reason not displaying. I'm fairly sure it's just that modifier too. Shame as the one that dropped is better than my current one lol

Link to comment
Share on other sites

vidar reactors can roll either a 50% extra speed for tenno exiting the railjack or a 2x increase of invulnerability time after major breaches. The later one is the one that has gone MIA since I had several reactors with that buff in my inventory (including the one I'm currently using) and they are all buffless now, just like  in your screenshot. The reactors that had the speed boost were unaffected by this.  It's as if DE removed this buff but forgot to replace it. Or it's just a UI bug.

Edited by EDM774
  • Like 2
Link to comment
Share on other sites

You must be talking about the bonus that gives 30% of Shield Damage is diverted to increase Turret Damage by up to 300 for the next shot fired.
Mine also has lost the bonus showing, I think it's Vidar reactors missing their bonus because all my Vidar reactors have blank bonus, I hope that the bonus isn't gone for good and it is just a visual bug like other parts of Railjack menus.

[edit]
Except for my Vidar one with tenno gain speed boost when deployed, like mentioned above.

 

 


 

Edited by Slayer-.
Link to comment
Share on other sites

i just noticed my vidar reactor that i have been using, that had the buff of 2x increase of invulnerability time after major breaches, is now gone from it. It just appears as a reactor that has no special ability 😞

Link to comment
Share on other sites

6 hours ago, Cavern said:

i just noticed my vidar reactor that i have been using, that had the buff of 2x increase of invulnerability time after major breaches, is now gone from it. It just appears as a reactor that has no special ability 😞

I have that on one of my other ones as well, don't worry DE will put it right eventually.

Link to comment
Share on other sites

Recently, I've completed missions in the Veil Proxima where I have obtained a Vidar Reactor, however neither of the 2 I have received had a modifier on them. This is an extremely frustrating bug, as the drop chance for them is so low.
This bug needs to be fixed asap.
I'd be interested to know if anyone else has encountered this bug, and if they contacted support. I tried contacting them to have this fixed, however they told me that replacing the reactors would give me reactors with no modifiers.
DE please fix this.


qeulpTT.png

Link to comment
Share on other sites

Hey, yeah a friend and I have run into the same issue, both our Vidar Reactors dropped with no bonus modifer to them. We were initially thinking they could potentially drop without a bonus stat, but the wiki says that parts should always drop with one, regardless of house or MK.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...