Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Corpus Orbiter's Glitch


Virga_Wo1f
 Share

Recommended Posts

So I haven't been on in about half a year. So I went in and I'm on Phobos, doing the Archwing mission. Turns out when The Lotus says "Destroy the Orbitors" The orbitors are not even an entity. They are like those back ground ships that you find on a Mobile FPS game.... it's stupid. You can't kill the transports like they say you can. Please fix your S#&$!!!! I tried scanning the transport to see if that enables the orbitors but nothing. I've tried shooting these mobile background entities but nothing. Please FIX IT IN NEXT UPDATE OR TELL ME HOW TO KILL THEM

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...