Jump to content

Clients in Disruption issues after Host De-sync (Fixed)


(NSW)DankestLunala

Recommended Posts

In Disruption missions, a bug has been happening to me a few times since the Old Blood update brought out more Disruption missions. The round number will not update, as one of, if not several conduits, register as not being completed for that player. Any rewards gained in that round, or following rounds until it (sometimes) fixes itself, are gained for the other players that are not bugged. I was farming for Gauss parts on Kelpie when it happened, and I did not get the neuroptics, the last part I need to build Gauss. I hope that DE is working to fix this in order to make it so that I can actually get Gauss parts without needing to solo farm the Disruption, which for some reason, the glitch has not yet happened to anyone I know that does solo Disruption. Below are the images from my screen, as well as my squadmate's reward screen. IMG_20200323_144535.jpgIMG_20200323_144537.jpg?width=820&height

My screen is shown belowEpoghPMjFL8pF_rXtVrkH4kr_HSNcwgvjQqFDiYyzuh2cgdwbF89GNRIHqA1ZWQTIb2Vwv29tSmhUoPl

I wish DE will fix this soon, I have now acquired the neuroptics, but the glitch was a setback in the process of building him.

Anyone else who has had this happen to them, I share your pain in this matter. 

Sincerely, A Tenno grinding for Gauss parts

Link to post
Share on other sites

Literally any time I do play any disruption mission, I only ever get rewards from the 1st round. The HUD freezes somewhere during the 1st round and then I will receive only a reward from the 1st round. Subsequent rounds do not reward anything. This bug has been in the game since they expanded disruptions to appear on more planets. This appears to be a client side issue as it never happens when I'm host (but it happens to my teammates).

Furthermore, during disruption sorties it still has the HUD freeze sometime in the first round, but after the 2nd round it seems to fix itself and allow for extraction.

Oddly though, if there is a host migration, even if I do not become the host, I start earning rewards as intended.

 

Does this bug happen to others? I haven't seen a topic about this so I apologize if I'm blind and its already been reported.

 

Link to post
Share on other sites

Since teh Saint of Altra there is a bug on Disrupstions for the client side that freezes the progression for them, making it unable to recieving ANY reward between waves.

Screenshots:
https://ibb.co/C2fhjTZ
https://ibb.co/CMsgNt0
 

EDIT: For context, both of those images are examples of the U.I frozen on a wave, and the game progressing. If it was just a U.I freeze problem, ok not as bad, but it just freezes everything, the game continues, the waves passes and the reward just doesn't come, even if everyone decides to extract, the rewards are not there, you don't get anyting. Farming any relic or Gauss itself on a group has been a nightmare because you don't know if the progression will just freeze out of nowhere.

Link to post
Share on other sites

This happened most of the time for my friend when farming In Apollo, lua. The rewards dont show, we found out that he gets them when host extract first. Forcing host migration. Once he also extracted he was back In orbiter and all ten relics are obtained. Hope this helps for you To try out. 🙂

Link to post
Share on other sites
On 2020-04-06 at 3:16 AM, (NSW)kurunipsu said:

This happened most of the time for my friend when farming In Apollo, lua. The rewards dont show, we found out that he gets them when host extract first. Forcing host migration. Once he also extracted he was back In orbiter and all ten relics are obtained. Hope this helps for you To try out. 🙂

For me leaving first didn't work, but I never tired host migration. Gonna try that one day.
Thanks

Link to post
Share on other sites

Following the bug reporting guidelines outlined for Scarlet Spear in the hopes that this might finally get resolved somehow:

TYPE: In-Game/Mission

DESCRIPTION: Ever since Hostile Mergers back in June 2019, there's been an issue with Disruption where anyone playing as a client has a high chance of the progression freezing and they stop getting rewards even though they're still in the mission and the host is still showing progress as normal. I have posted about this before and even got a reply from @[DE]Danielle (here, when we got The Old Blood) saying that it's been replicated and a fix was being researched, but as of today's Scarlet Spear update on PS4, it's still happening. I just ran Apollo on Lua twice with a squadmate with me as host and her as client, and it froze on her on both attempts. The first attempt, it froze for her on round 1 and we left after 2, so I got 2 Axi relics and she got nothing. The second attempt, it froze for her on round 5 and we left after 6, so I got 6 Axi relics and she got 4.

VISUAL: These screenshots are our mission rewards from the second attempt. The top two are mine; bottom two are my client squadmate's:

Gdpi5Ck.jpg

Sb2FXzp.jpg

o4JnVgQ.jpg

9b5bZOz.jpg

REPRODUCTION: Run Disruption with a squad of more than one person. This also used to happen in Sanctuary Onslaught but I haven't had it happen there in a while so maybe it's fixed there but not in Disruption?

EXPECTED RESULT: Both I and my squadmate should have gotten the same number of relic rewards at the end of the mission.

OBSERVED RESULT: Only I got full rewards at the end of the mission.

REPRODUCTION RATE: Literally every time. Sometimes it happens sooner rather than later, but every time we try to run this game mode together or in a trio with one of our other friends, at least one of us ends up missing rewards, no matter which one of us is hosting.

Link to post
Share on other sites
  • TYPE: In-Game.
  • DESCRIPTION: This bug happen in all disruption mission nodes, just the host get the rotation rewards... the UI seems to freeze in the objective progress, Like Ex: Any color Conduits, random buff/debuff, random time remaining not counting...
  • VISUAL: https://imgur.com/a/hwcuDEj
    • upon extraction reward table from me and two friends.
    • UI frozen and not showing any progress....
  • REPRODUCTION: Mission with more than 1 player, all clients can have this bug.
  • EXPECTED RESULT: The entire party receive the rewards at the end of each rotation.
  • OBSERVED RESULT: Clients do not received rotation rewards but host do...
  • REPRODUCTION RATE: All the time in every disruption node.
Link to post
Share on other sites

MISSION: Disruption-type Arbitration mission on the Jupiter Gas City tileset. Game version 27.3.11.

IMPORTANT CIRCUMSTANCES: The host migration happened because the host extracted while a round was ongoing. The 60 countdown started with the "EXTRACTING IN" message, during this 60 seconds, the remaining players finished the ongoing Disruption round, and the "next round starting in" countdown, which happen after every Disruption round also started. The host extracted BEFORE the next round for Disruption could start. When the host migration finished I became the new host, but the UI for the Disruption game mode was broken and showed HTML closing tags.

HCj3IBt.jpg

Part of EE.log from the host migration:

Quote

3652.083 Script [Info]: Disruption: Host migration
3652.083 Script [Info]: Disruption: Initializing host...
3652.083 Script [Info]: Disruption: Artifact spawn data setup...
3652.084 Script [Info]: Disruption: Artifact 1 status=0, timer=0, auraId=1, tile=6
3652.084 Script [Info]: Disruption: Artifact 2 status=0, timer=0, auraId=1, tile=9
3652.084 Script [Info]: Disruption: Artifact 3 status=0, timer=0, auraId=1, tile=6
3652.084 Script [Info]: Disruption: Artifact 4 status=0, timer=0, auraId=1, tile=9
3652.084 Script [Info]: Disruption: Artifact spawn data setup complete
3652.084 Script [Info]: Disruption: Restoring levelauras after host migration...
3652.084 Script [Info]: Disruption: Done restoring levelauras
3652.084 Script [Info]: Disruption: Initialize host complete
3652.084 Script [Info]: Disruption: Initializing host/client...
3652.084 Script [Info]: Disruption: Initialize host/client complete
3652.093 Script [Info]: Starting Vignette close animation...

 

Link to post
Share on other sites

Sedna Kelpie, host migration just after round 2 ended before round 3 had started. No conduits spawned for round 3, there were a few mobs hanging around but no new ones seemed to spawn and the mission ui was broken hypertext. The new host went to extraction, I hung around for another host migration out of curiosity, but nothing changed.

OuCoKrL.jpg

Link to post
Share on other sites
On 2020-04-05 at 11:16 PM, (NSW)kurunipsu said:

This happened most of the time for my friend when farming In Apollo, lua. The rewards dont show, we found out that he gets them when host extract first. Forcing host migration. Once he also extracted he was back In orbiter and all ten relics are obtained. Hope this helps for you To try out. 🙂

i tried this on kelpie a few days ago and it didn't work for gauss farming i have to use platinum to use him 

Link to post
Share on other sites
  • [DE]Danielle changed the title to Clients in Disruption issues after Host De-sync

The host was AFK and died in the very beginning. He remained dead until the first round of disruption was just about to be completed. He quit out during the slow-mo, so the host migration happened before we could see our rewards. Once we got back in to the game the reward window didn't pop up and forced another round with the previously equipped relic. Lith T3 (Radiant) in my case. The enemies who were present during the host migration remained, but the new ones wouldn't appear. The normal conduit info box on the left side of the screen bugged out and showed the following text:
"</b> </font> </p>
</b> </font> </p>
</b> </font> </p>
</b> </font> </p>"

Obviously we had to quit the mission, but the relics were consumed as well.

EDIT:
Reward was later sent to me by Ordis.

Link to post
Share on other sites
  • [DE]Danielle changed the title to Clients in Disruption issues after Host De-sync (Investigating)
On 2020-04-24 at 11:06 AM, [DE]Danielle said:

Hey guys! We're investigating lingering issues with this related to Host Migrations. Thanks for reporting!

Good news! We released a fix on PC in Hotfix 27.3.11 that addressed a script crash in Disruption missions that was causing issues. So that will be coming with the next console update. But we are also taking a look at lingering (possibly related) issues with ESO rewards with Host de-sync in the meantime! 

Link to post
Share on other sites
16 minutes ago, [DE]Danielle said:

Good news! We released a fix on PC in Hotfix 27.3.11 that addressed a script crash in Disruption missions that was causing issues. So that will be coming with the next console update. But we are also taking a look at lingering (possibly related) issues with ESO rewards with Host de-sync in the meantime! 

Are consoles going to get any of the last seven updates that PC got before Scarlet Spear ends? Or are these only planned to come with the next full build? The reason I ask is that one of the hotfixes on PC increased the armor of the satellite in Scarlet Spear (among other fixes).

Link to post
Share on other sites
  • 2 weeks later...
On 2020-04-27 at 4:21 PM, [DE]Danielle said:

Good news! We released a fix on PC in Hotfix 27.3.11 that addressed a script crash in Disruption missions that was causing issues. So that will be coming with the next console update. But we are also taking a look at lingering (possibly related) issues with ESO rewards with Host de-sync in the meantime! 

This is live now on PS4, XB1, and Switch with this morning's update! 

Link to post
Share on other sites
  • [DE]Danielle changed the title to Clients in Disruption issues after Host De-sync (Fixed)

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...