Jump to content
General Bug Report Guidelines - Please Read ×

Sands of Inaros quest not progressing


(NSW)Denny-Jo
 Share

Recommended Posts

Hi all, this is regarding the Sands of Inaros quest on Nintendo Switch.

The first stage required volatile runners, which worked fine, filled the vessel as previously done on PC version. The 2nd vessel is for Hyekka Masters (or at least the vessel image is a Hyekka Master). However, this is not working.

Kills on Hyekka Masters, both Solo and in a Squad have not resulted in the vessel filling up, nor Baro appearing on screen indicating that this was the correct enemy. 

Also tested Brood Mothers and Railgun MOAs incase it was a UI bug. Vessel is not filling up, nor is Baro indicating enemies killed are correct.

I'm aware of how the quest works (from PC) and have checked everything against the Wiki.

Yes the quest was set as active, yes the vessel was equipped. 

Any info regarding this?

Link to comment
Share on other sites

  • 1 month later...
  • 11 months later...
On 2021-05-27 at 5:45 AM, (PSN)RoxasBlaze278 said:

I'm having the same issue on ps4 too. With the Hyekka Masters

Unfortunately this never seemed to be brought up, but one day (a month or so later) I finally started getting progression from kills. Good luck and hope yours works soon! (One thing is that corrupted hyekka masters from relic runs definitely did not count)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...