Jump to content

Railjack Revisited (Part 1): Bug Report Megathread (Read First Post!)

Recommended Posts

Posted (edited)

1. I don't have exact steps to reproduce, but we had troubles finishing a railjack mission when one player was sitting in forward artillery. I was hosting, mission was in Veil with anomaly, we did all the objectives, mission end screen (with rewards) appeared, i selected dock in starmap and nothing happened. Starmap was disabled, but literally nothing was happening. We were in this state for some time, i noticed one crew member is sitting in artillery, i asked him to leave artillery, he did and transition to dock started right after that, then we successfully arrived to dock.

2. Sometimes enemies don't spawn in railjack missions. Again, i don't have exact steps to reproduce and i'm not sure what could be the reason of this. This happens when transition between missions takes a long time. We arrive to a mission, but fighters and crewships do not spawn, there are also no objectives to kill N fighters and M crewships, but "boarding objective" (with radiators) might generate and work, however finishing this objective does nothing, mission doesn't end. Starmap stays active all the time during such bugged mission and if mission is restarted, sometimes bug may reproduce, sometimes mission starts normally.

I had this bug with a friend who was using VPN to connect, i was hosting all the occurrences when this bug reproduced, didn't have any "large ping" complaints or anything. But when this happens, void transition between mission takes really long time, it looks like we're in infinite transition, but if we wait long enough, transition actually ends and we arrive to destination (mission or dock). This transition length is very noticeable, it was pointed out by another player that we might be stuck in infinite loading.

Edited by 32768
Link to post
Share on other sites
Posted (edited)
  • TYPE: In-Game
  • DESCRIPTION: People without railjacks can't scrap their wreckage parts when limit is reached
  • VISUAL: It's complicated
  • REPRODUCTION: 1. Reach wreckage parts limit without building your own railjack 2. Join a squad 3. Ask host to start railjack mission (from dry dock) 4. Ask host to interrupt launch cutscene when starting 5. Try to scrap your parts
  • REPRODUCTION: when you disconnected from squad after performing steps 1-5, 6. Ask host for invite 7. Try to accept invite 8. Observe result 9. Ask host what did they see on their screen
  • EXPECTED RESULT: It should be possible to scrap parts and join the mission
  • OBSERVED RESULT: Player at parts limit is being disconnected from the squad and can not join mission when invited. Invite messages are also misleading and not helping to understand why someone can't connect to the mission.
  • REPRODUCTION RATE: Always, i assume, but i have railjack and don't have this issue, so can not confirm that
Edited by 32768
  • Like 1
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Kuva lich fighting other grineer
  • REPRODUCTION: Go to neptune kuva lich node, spawn lich.
  • EXPECTED RESULT: Lich and grineer join forces to fight me, lich converts grineer to thralls
  • OBSERVED RESULT: Lich and grineer fight each other, no thralls are converted.
  • REPRODUCTION RATE: Don't know, liches aren't exactly easy to spawn.
Link to post
Share on other sites

TYPE: Mission

DESCRIPTION: Able to pick up heavy ammo in a mission even though there's no archgun cooldown ongoing 

VISUAL: not necessarily required

REPRODUCTION: Play as a client, then go to a heavy ammo pickup nearby

EXPECTED RESULT: shouldn't be able to pick up heavy ammo when there's no archgun cooldown ongoing

OBSERVED RESULT: can pick up heavy ammo as usual


Link to post
Share on other sites

Giant warframe Bug. 

  • TYPE:In-game
  • DESCRIPTION: after completing a RJ mission I was teleported out into space while I was in Razorwing. I manually entered the RJ and noticed I was stuck. I used /unstuck to no success. Only to try operator mode and then noticed a giant Titania shaped leg in the wall. I returned to warframe to see it still stuck (fig 1) I went to the bridge as operator to see it it would free my frame, it did not. It just moved my 30 ft tall titania to the bridge, where again, she could not move. (Fig 2)
  • VISUAL:https://imgur.com/a/Ou1bNmU
  • REPRODUCTION: Finish sentient mission while in razorwing, get teleported out of sentient ship, enter railjack manaully. 
  • EXPECTED RESULT: [I should have stayed the same size and not grown 20 extra feet. 
  • OBSERVED RESULT: My frame grew 20 extra feet 
  • REPRODUCTION RATE: I have only witnessed this once, but the fact that it could not be undone without returning to dry dock is more than annoying. jIXEQyU.png
  • Fig.1 



Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Messing around with avionics on my railjack.
    • Hyperflux +99%'s math is wrong
      • Base flux capacity is 350 (no reactor bonuses)
        350 + 99% = 696.5 + 200 = 896.5 Flux, 200 is from a maxed Lavan. Game shows 820
        350 + 99% = 696.5 + 100 = 796.5 Flux, 100 is from maxed Sigma/Vidar, Game shows 720
        350 + 99% = 696.5 + 300 = 996.5 Flux, 300 is from maxed Zekti, game shows 920
        If it was taking into account the flux capacity after reactors, the bonus we should get would be even higher.
  • VISUALs0xYvy8.pngOLDwc0W.png
  • REPRODUCTION: Throw Lavan hyperflux on a blank railjack avionic tree, math is wrong no matter what level the grid is.
    • These are with maxed reactor values.
      • MK3 Sigma with maxed hyperflux should give 796.5. Not 720
      • MK3 Vidar with maxed hyperflux should give 796.5. Not 720
      • MK3 Lavan with maxed hyperflux should give 896.5. Not 820
      • MK3 Zetki with maxed hyperflux should give 996.5. Not 920
  • OBSERVED RESULT: Hyperflux is giving 76.5 less flux than it should.
  • REPRODUCTION RATE: 100% of the time
Link to post
Share on other sites
Posted (edited)
6 hours ago, Emperor said:

OBSERVED RESULT: Hyperflux is giving 76.5 less flux than it should.


I got numbers for all the Hyperflux ranks (0 - 10, last 3 from upgraded grid slot), plugged them into a spreadsheet and the formula seems to be this:

    TotalFlux = (2450 * (1 + Hyperflux%) + 700) / 9 + ReactorFlux

The actual numbers I got were 272.22... base flux and 77.77... innate bonus flux, but multiplying by 9 gets us the nicer 2450 and 700.

  • Vidar Mk3 reactor (+100) with no Hyperflux: (2450 * (1 + 0.00) + 700) / 9 + 100 = 450
  • Vidar Mk3 reactor (+100) with Hyperflux r4: (2450 * (1 + 0.45) + 700) / 9 + 100 = 572.5, rounded to 573
  • Vidar Mk3 reactor (+100) with Hyperflux r10: (2450 * (1 + 0.99) + 700) / 9 + 100 = 719.5, rounded to 720

So I got the math to work with the percentages from the Hyperflux avionic, but I haven't figured out yet why there's an innate bonus flux component that -- in addition to the reactor's bonus flux -- is not affected by the Hyperflux avionic.


Silly me. There's a much simpler explanation.

The UI says 9%, 18%, ..., 99%, but the actual values used in the calculation are 7%, 14%, ..., 77%:

  • Vidar Mk3 reactor (+100) with no Hyperflux: 350 * (1 + 0.00) + 100 = 450
  • Vidar Mk3 reactor (+100) with Hyperflux r4: 350 * (1 + 0.35) + 100 = 572.5, rounded to 573
  • Vidar Mk3 reactor (+100) with Hyperflux r10: 350 * (1 + 0.77) + 100 = 719.5, rounded to 720
Edited by __jag__
Simpler explanation
Link to post
Share on other sites
  • TYPE: In-Game, Menu UI
  • DESCRIPTION: According to the 27.4 patch notes: "Added a new ‘LANDING CRAFT’ option under Equipment. The previous ‘Select Landing Craft’ and ‘Customize Landing Craft’ that were part of the ‘ORBITER’ option will be housed there now."
  • REPRODUCTION: In your Orbiter, open the menu and go to "EQUIPMENT"
  • OBSERVED RESULT: No "LANDING CRAFT" menu item, and the aforementioned sub items are still under "ORBITER"
Link to post
Share on other sites

Turning my earlier comment into a proper bug report:

  • TYPE: In-Game, Railjack config UI
  • DESCRIPTION: The text on the Hyperflux avionic does not match the values actually used in calculating the total flux. For a maxed Vidar Mk3 reactor and a maxed Hyperflux in a maxed grid slot, I'd expect (350 + 99/100 * 350 + 100) = 796.5 max flux, but I only get (350 + 77/100 * 350 + 100) = 719.5 max flux.
  • REPRODUCTION: Install any rank of the Hyperflux avionic
  • EXPECTED RESULT: Gained flux matches the percentage shown on the avionic (350 + x% of 350 + flux from reactor)
  • OBSERVED RESULT: Gained flux matches 7/9ths of the percentage shown on the avionic (350 + 7/9 of x% of 350 + flux from reactor)


One more observation: in all of the "Railjack statistics" boxes (shown on the Components, Armaments, and Avionics tabs) the value is 720 (719.5 rounded up), and when I'm piloting my Railjack or looking at the tactical menu, it also shows 720 flux when I'm all filled up. However, when I look at the Payload tab in the dry dock, or at the on-board Forge UI, it shows 796 (796.5 truncated) as the max flux.

Link to post
Share on other sites

TYPE: Mission

DESCRIPTION: when the crewship explodes with the client inside in operator (destroyed by ordnance), the game glitches and loses most functionality with an invisible operator stuck in space, and requires a force quit even after the host returns to dojo. Access to chat/menus also lost

VISUAL: <the cold emptiness of space, but with the operator's invulnerable UI on top>

REPRODUCTION: Play as a client, enter operator while inside a crewship, have host destroy it with ordnance. May or may not need to be in void mode inside the ship

EXPECTED RESULT: Should put client player outside the exploded ship in warframe archwing mode

OBSERVED RESULT: end up outside the ship in operator mode with no abilities, invisible, invulnerable, and unable to interact with objects. only able to move on a flat plane, slide, and crouch. State is not fixed after forced return to ship by going to new mission/dojo. Can't tell the rest of the group that bug is occurring until the mission is moving on

REPRODUCTION RATE: reproduced once after first loss of function. Second time bugged two players in the same mission

  • Like 1
Link to post
Share on other sites
  • TYPE: In-Game, Railjack
  • DESCRIPTION: Trying to use valence fusion on a 33.1% Zetki Photor Mk ⅠⅠⅠ by using a 60% Zetki Photor Mk ⅠⅠ , I get a popup saying the Mk ⅠⅠⅠ is already maxed.
  • REPRODUCTION: Get a 60% Mk ⅠⅠ/Mk Ⅰ and a matching Mk ⅠⅠⅠ , fuse the lower ranked weapon into the ⅠⅠⅠ
  • EXPECTED RESULT: Get the dialog showing the effect of fusing the Mk ⅠⅠ into the Mk ⅠⅠⅠ with the "Type FUSE to confirm" textbox.
  • OBSERVED RESULT: Got a popup saying the Mk ⅠⅠⅠ was already maxed and and the Mk ⅠⅠ offered no unique traits.
  • Like 1
Link to post
Share on other sites

Using RJ abilities breaking (tested on controller)



  • TYPE: In-Game
  • DESCRIPTION: Piloting Railjack using controller (not through Steam), and everything works fine when solo. As soon as ppl join it breaks.
  • VISUALhttps://imgur.com/WcaQkif
  • REPRODUCTION: Pilot Railjack in a crew, and use Vortex on quick selection or Tether normally
  • EXPECTED RESULT: Shoot out Tether or Vortex
  • OBSERVED RESULT: Both immediately activated a second time, causing them to explode immediately (like a double press)
  • REPRODUCTION RATE: For Tether 50 % ish of the time using it. 100 % occurrence in mission. For Vortex on quick selection (tapping RB) it happens 100 % of the time and I'm forced to use the ability normally (RB and A on controller) for it to work.
Link to post
Share on other sites
Posted (edited)
  • TYPE: In-Game
  • DESCRIPTION: Attempting to start a profit taker mission from Eudico in Fortuna. Mission counts down like it is going to start, then just shows Eudico standing there. Have to alt-f4 to quit game from that point.
  • VISUAL: https://youtu.be/p_3uV-gO3jg
  • REPRODUCTION: Try to start a profit taker mission, i tried 1 and 3.
  • EXPECTED RESULT: Profit taker mission should start.
  • OBSERVED RESULT: Just shows Eudico standing.
  • REPRODUCTION RATE: Tried 4 times, happens every time, 100%
Edited by Hbombre
Link to post
Share on other sites
Posted (edited)

TYPE: in Game

DESCRIPTION: The ability menu dont apear and cant be used in control Xbox(in xbox console), when its on LB button

Visual: No need

REPRODUCTION: first assign Focus and tranferencs to another button(that dont be Lb)

, second one assign the ability menu in LB button, go to everymision day or railjack, and try to use it.

EXPECTED RESULT: the ability menu dont apear and cant use the abilitys.

OBSERVED RESULT: the abilitys are imposible to use in every mision.


this apear in the recently xbox update of today may 12

Edited by (XB1)legendariadgj
  • Like 1
Link to post
Share on other sites
Posted (edited)
On 2020-05-01 at 10:03 AM, -SR-Newswordman777 said:

All the avionic i had that were max and equipped on my rj are gone even the predator mod i spent plat on to get but my rj ability mods are still equipped.

Mine are also gone... everything has disappeared from my integrated section of my avionics 


Correction:  upon further research, the effect is intended. Found in patch notes under avionics section. 

Edited by (PS4)DJ_Sonic_20
Found evidence to cancel my bug support
Link to post
Share on other sites
On 2020-04-30 at 8:51 AM, [DE]Bear said:

Greetings, Bug-Squashing Tenno!

With the release of Railjack Revisited (Part 1), we have been working hard to tackle as many bugs as possible. That is not to say that some may slip through the cracks. If you do encounter a bug, please use this thread to report it so we can address it ASAP!

Notable changes with Railjack Revisited (Part 1):

  • Increased item vacuum and base speed on Railjacks
  • Weapon, Avionic, and Railjack statistics have changed
  • Enemy damage values have changed
  • Enemy Health values have changed
  • Healing Abilities now affect objects (like Defense Targets)
  • Other fixes and Quality of Life changes

For a full list of changes in Warframe Revised: Railjack Revisited (Part 1), you can read the Update Notes by clicking on this link.


  • Include a video or a screenshot if possible! Visual references can help direct us to issues faster than without them.
  • Steps to recreate the bug, if known. Again, this is to help us locate the issue faster.
  • If you saw the Warframe Crash Handler and got a WAR number  (looks like this: WAR-1234567) then add it to your post.  Also please be sure to be as descriptive as possible in the Crash Handler's comment box!


  • TYPE: [Launcher, In-Game, Chat, etc.]
  • DESCRIPTION: [Tell us what you were doing when the bug occurred. Details here are helpful]
  • VISUAL: [This is where you would add your screenshot or video]
  • REPRODUCTION: [Tell us how we can replicate this bug, if known]
  • EXPECTED RESULT: [Tell us what you think should have happened, ex: “I should have drawn my weapon”]
  • OBSERVED RESULT: [What actually happened, ex: “I went into a T-Pose”]
  • REPRODUCTION RATE: [How often it happens when you try to reproduce it, ex: “It only happens half the time / when I am crouching / when using Hydroid.”]

Using the format above helps us identify issues, hunt down the cause, and fix problems faster than telling us “this thing is broken”. As with all cases, please make sure your bug reports are constructive and civil, and we want to thank you for your patience as we work on fixes.


Xbox One X.

My friend, Rampaged Sheep, logged into warframe after today's update only to see that all of his equipped integrated avionics have been unequipped and deleted. 

The Avionics are gone.

Can't be reproduced to our knowledge.

Should have viewed all previously equipped and leveled avionocs

All avionics under the "Integrated" avionics were missing

Unable to tell how often this occurs.


Link to post
Share on other sites
  • TYPE: In game
  • DESCRIPTION: Was in a crewship in operator mode when teammates destroyed it using artillery. Ship exploded and I was stuck in space in operator mode, which was glitched and invisible. Had to alt F4 to solve it.
  • REPRODUCTION: Simply stay in operator mode when a crewship explodes.
  • EXPECTED RESULT: Should have transitioned me to archwing mode at least.
  • OBSERVED RESULT: Game got glitched into a stuck state, had to alt F4. Not even the abort menu shows up.
Link to post
Share on other sites
26 minutes ago, (XB1)ShmittyG said:

Xbox One X.

My friend, Rampaged Sheep, logged into warframe after today's update only to see that all of his equipped integrated avionics have been unequipped and deleted. 

The Avionics are gone.



They've been converted into their counterparts in the new system (only one house per avionic, with the best stats from the old system, and less drain). Any Dirac spent on upgrades has been refunded. Just gotta sit down a few minutes and put the new ones in your RJ, should be able to get your old build or better. Easiest is to install the avionics first, then upgrade them.

Link to post
Share on other sites
  • TYPE: In-game, in mission.
  • DESCRIPTION: Railjack missions 2 player - When my buddy boards enemy crew ships by way of launching, 1-2 enemies spawn in the back of the railjack, this is without getting hit by ram sledes.
  • VISUAL: Dont have footage.
  • REPRODUCTION: 2 players one as pilot and the other in the launcher, when he spawns in the enemy ship, 1-2 enemies spawn in the back of the railjack, can be prevented by the pilot being in the middle of the railjack when the launched player enters the crew ship. tested on Spiro gap within the range of 1.5km and 3.4km. My guess is that the mobs that are suppose to spawn on the enemy crew ship recognizes the railjack as a spawn.
  • EXPECTED RESULT: 1-2 enemies spawn in the back of the ship.
  • OBSERVED RESULT: 1-2 enemies spawn in the back of the ship.
  • REPRODUCTION RATE: so far we have seen this every 2/3 of launches, depending on the remaining players position.


Link to post
Share on other sites
  • TYPE: In-game(gameplay and Healing changes)
  • DESCRIPTION: trying to cast warding halo on defense target
  • VISUAL: https://www.youtube.com/watch?v=rTIxOBnijLc&feature=youtu.be
  • REPRODUCTION: try to cast the power on non-operative defense target
  • EXPECTED RESULT: the target should get the halo like it was mention in the healing objective changes
  • OBSERVED RESULT: the target isn't what the power can affect
  • REPRODUCTION RATE: as long as you try to cast the power = 100%
Link to post
Share on other sites
  • TYPE: In Game/Controls/Xbox
  • DESCRIPTION: All game play
  • VISUAL: none
  • REPRODUCTION: Bind Ability Menu to LB
  • EXPECTED RESULT: Pressing LB should open ability Menu
  • OBSERVED RESULT: Ability Menu doesn't open
  • REPRODUCTION RATE: Everytime 100%

    I'm on Xbox, and I have ability menu mapped to LB, but it doesn't work. I tried resetting to default controls, which maps ability menu to RB, and it works there, but whenever I map to my preferred controls, ability menu won't function when I bind it to LB. I'm wondering if it has something to do with, in the railjack controls menu, ability menu cannot be mapped anywhere else than RB, but I really don't know.
Link to post
Share on other sites
Le 03/05/2020 à 19:55, JoeMania a dit :
  • TYPE: In-game
  • DESCRIPTION: Iron Skin loses its status/cc immunity at seemingly random
  • VISUALExample video
  • REPRODUCTION: Simply activate iron skin (I always do an ironclad charge then archgun summon for Tanker, if that helps with reproducing)
  • EXPECTED RESULT: Iron Skin with full status/knockdown immunity
  • OBSERVED RESULT: Iron Skin as usual, until it randomly loses its immunity to controlling/status effects
  • REPRODUCTION RATE: Seemingly happens half the time after losing some iron skin (potentially due to the visual degradation)

    Side note: My guess is this has something to do with Atlas' pvp augment [Rumbled] having a similar health layer, and getting a fix after being released for pve. Purely speculation, I'm not a dev or anything.

Edit: I've been told that Nezha now shares this bugged layer of hp, going from 90% DR to full immunity but also with no effect immunity. 



Le 04/05/2020 à 11:05, T-Shark69 a dit :
  • TYPE: In-game
  • DESCRIPTION: Iron Skin is affected by status procs and states. Seemingly at random, you can get afflicted by a status like slash, knockdown etc.
  • VISUAL: Video https://youtu.be/1hhSmeEdPzw | Screenshot of taking shield damage (448/450) https://i.imgur.com/LhOnr19.jpg
                   Screenshot of multiple status effects https://i.imgur.com/0ZRNe5L.png 
  • REPRODUCTION: Simply activate Iron Skin on Rhino and play a mission with enemies that can inflict status effects on warframes.
  • EXPECTED RESULT: Status effect shouldn't have been applied while Iron Skin is active.
  • OBSERVED RESULT: Rhino got knocked down, energy drained and in some cases can take damage from status effects even though Iron Skin is active.
  • REPRODUCTION RATE: Seemingly at random, but it happens often enough to be noticable and affect normal gameplay.

And Same

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...