Jump to content
(XB1)WarBelly

Railjack Revisited (Part 1): Bug Report Megathread (Read First Post!)

Recommended Posts

Omni-Tool Teleport Exit Breaks 'Kill Galleon Captain' Quest

  • TYPE: In-Game, blocks progress
  • DESCRIPTION: This occurred during a Railjack Mission: Flexa in the Veil Proxima. I was playing Volt. I killed the Pyr Captain on the Galleon, along with another team member, as required. The red marker left him, as expected, and then a green marker appeared leading me out of the Galleon. The other team member left the Galleon (I do not know if he used the exit or an Omni tool). However, instead, I ran a ways toward the exit but then used my Omni-tool to automatically teleport back to the ship. The whole team's quest progress still said to kill the Pyr Captain. There were no indicators telling us where to go from there, because the Captain was already dead. Another player went into and out of the Galleon, ensuring the captain was not there. Progress was still not fixed. Then, I went back into the Galleon, and ran all the way through it and left via the green indicated path (near where the Captain was). My exiting of the Galleon updated progress for the team, allowing us to win the mission and leave the area. So, my leaving with an Omni-Tool did not register as my having completed the "Kill Pyr Captain" part of the mission.
  • VISUAL: N/A
  • REPRODUCTION: Do a mission requiring killing a Galleon Captain. Kill the captain. Leave the Galleon via Omni Tool instead of the indicated method. Notice that the quest does not update for the team, and mission success is impossible.
  • EXPECTED RESULT: The mission should have updated, indicating that the captain was dead, once I killed him and left the Galleon via Omni Tool.
  • OBSERVED RESULT: The mission did not update that the captain was dead, and we were stuck in the mission until I re-entered the Galleon and exited properly.
  • REPRODUCTION RATE: I do not know, I have not tried to re-create.
  • Like 1

Share this post


Link to post
Share on other sites

TYPE: In game, communications
DESCRIPTION: I am getting communications from my own name that are from a future date. Started yesterday, I have only gotten 2, they are blank messages. It's wierd.
 

No idea how to attach the screenshot. Not much to it,


REPRODUCTION: I have no idea. It seems to happen randomly when I log in.
EXPECTED RESULT: I shouldn't get random messages from myself with no content and from future dates?
OBSERVED RESULT: The opposite of that.
REPRODUCTION RATE: I seem to have no control over it.

Share this post


Link to post
Share on other sites
  • TYPE: [Railjack Configuration]
  • DESCRIPTION: Almost every maxed avionic is gone.
  • VISUAL: None
  • REPRODUCTION: None - simply launched the game today (18 May).
  • EXPECTED RESULT: Having the mods at least in my inventory if not in my RJ loadout.
  • OBSERVED RESULT: I lost most of them.
  • REPRODUCTION RATE: I guess non-applicable.

Share this post


Link to post
Share on other sites
16 minutes ago, TR3NCH18 said:
  • TYPE: [Railjack Configuration]
  • DESCRIPTION: Almost every maxed avionic is gone.
  • VISUAL: None
  • REPRODUCTION: None - simply launched the game today (18 May).
  • EXPECTED RESULT: Having the mods at least in my inventory if not in my RJ loadout.
  • OBSERVED RESULT: I lost most of them.
  • REPRODUCTION RATE: I guess non-applicable.

They are on your inventory. You have to upgrade them and install them again.

Check the patch notes:

 

Avionics Changes:

  • When it comes to Avionics changes, there’s an overarching goal: Simplify Avionic management.
  • Each Integrated Avionic Type will now only exist with a single Manufacturer rather than three Manufacturer flavors. What this means is that there won’t be 3x variants of the same Avionic.
  • Consolidated Avionics have had their Avionic Capacity Drain altered so that on average the Integrated Avionics now consume 20% less. This ensures players can more comfortably fit the builds they want in the new consolidated system based on Feedback from the Public Test Cluster.
  • The ‘retired’ Integrated Avionics will be removed from players inventory via a script on login.
  • The remaining Integrated Avionic for each Type will take on the values of the previously highest valued Avionic of its Type.
  • ALL Dirac used to upgrade Integrated Avionics will be refunded. This applies to both retired and remaining Avionics.
  • ALL remaining Integrated Avionics will have their Upgrades drained.

 

  • Like 1

Share this post


Link to post
Share on other sites

Not sure if this has been mentioned yet.

Type: railjack mission

Description: after the first rj mission the number of fighters is constant to the number of the first mission.

Visual: number of fighters stays the same

Reproduction: start any mission on a different proxima, complete that mission, start a mission on a different proxima.  Have tested going from earth to veil and veil to earth. 

Expected result: different fighter count each mission.

Observed result: fighter count only randomized for first mission after dojo.

Reproduction: 100%.

  • Like 1

Share this post


Link to post
Share on other sites

Got the locked green door in the Pulse Turbine again on Spiro Gap, Saturn Proxima.  This time I was alone.  Again, this is a mission-critical glitch, DE, so I hope you fix this soon. 😒

Share this post


Link to post
Share on other sites
On 2020-05-12 at 11:14 AM, __jag__ said:

 

They've been converted into their counterparts in the new system (only one house per avionic, with the best stats from the old system, and less drain). Any Dirac spent on upgrades has been refunded. Just gotta sit down a few minutes and put the new ones in your RJ, should be able to get your old build or better. Easiest is to install the avionics first, then upgrade them.

Thank you!! Was able to figure it out shortly before the forum notified me of your reply. 

Share this post


Link to post
Share on other sites

Type: In-Game, Arbitrations
Description: After killing Arbitration Drones with my Operator, formerly-protected enemies sometimes become seemingly intangible to some attacks, most notably Exalted Weapons. This is observed from a total lack of damage numbers, not even grey 0s that would be observed to protected enemies.
I was a client in all of the observed instances.
Reproduction: Titania Prime is the frame I encounter this bug with most frequently. With Razorwing active, I switch to Operator to destroy the Arbitration Drones, then transference back into Titania and attempt to shoot the now-vulnerable enemies with Dex Pixia (Prime).
Expected Result: After killing Arbitration Drones, enemies should be vulnerable to all sources of damage including Exalted Weapons.
Observed Result: On occasion, after killing the Drones, enemies become intangible to some sources of damage including Exalted Weapons.
Reproduction Rate: Low, seems to increase with ping/quality of connection to host.

Share this post


Link to post
Share on other sites

Here's an incredibly weird Railjack bug:

  • TYPE: In-Game
  • DESCRIPTION: After playing the Nsu Grid Skirmish mission in Veil Proxima, my friends and I hung around in the aftermath of the mission inside the Railjack. I immediately noticed that after a while, my friend's Tenno was flying around in the old Madurai laser animation from before The War Within (complete with the laser). I asked him how he got the laser back and he nor my other friend had any idea what I was talking about so this was purely a client-side bug. However, the more that he used Tenno mode, the more I noticed that he also dropped strange clones of his Warframe every time he activated it. The Warframe would be slumped over also in the old pre-War Within pose when you activated the old Tenno mode. Even stranger, some of the clones would turn into headless Excaliburs after a while. The game seemed to be removing the oldest clone and replacing it with the placeholder headless Excalibur after testing. He was also able to move the Madurai laser around with his mouse controls. Further, after a while of testing this bug I noticed that his real Tenno was invisible and moving around independently of the laser Tenno with only the Amp being visible and an indication of where he really was.
  • VISUAL:

    Video: https://gfycat.com/scratchynippyiguana

Image: gJfDf1Z.jpg

  • REPRODUCTION:
  1. Enter Nsu Grid in Veil Proxima in a Squad (in our case we were 3 players total).
  2. Complete the Mission.
  3. Instead of leaving the Mission after the objective is complete, stay behind in the Railjack.
  4. Have the players continuously use Tenno mode (5 key). The "cloned" Warframe seemed to be created with 100% success rate every time he fired his amp and then immediately deactivated Tenno mode.
  5. The effects may take a while to manifest, and may only be observable by one Squad member.
  • Notes: We entered Nsu Grid after having already completed a different Railjack Skirmish Mission in Earth Proxima. I don't know if that matters for reproduction.
  • Likewise, the host had to invite us to the first mission manually, due to issues of it kicking us out through host migration if we try to load in together.
     
  • EXPECTED RESULT: Tenno mode behaving normally (e.g. not flying around using the old Madurai laser, not dropping clones of his frame everywhere)
  • OBSERVED RESULT: My friend's Tenno flying through the air in the old Madurai laser animation, dropping a clone of his Warframe every time he activated Tenno mode, fired his amp, and deactivated Tenno mode.
  • REPRODUCTION RATE: Only seems to happen for one member in the squad. However, once the bug is active there's a 100% success rate in producing the clones and activating the laser animation from the other player.

Share this post


Link to post
Share on other sites
  • TYPE: In-game/steam UI
  • DESCRIPTION: Steam achievements broken/ not syncing for almost 5 years now
  • VISUAL: None
  • REPRODUCTION: at MR 23, 6 shot the Jackal, forma a weapon,  reach rank 30 with Brahma, fang prime dual blade mastery, complete 3 sorties, and entering the dry dock, 
  • EXPECTED RESULT: i get steam achievements 
  • OBSERVED RESULT: i don't get steam achievements 
  • REPRODUCTION RATE: Every time i do my sorties and kill a lich i am reminded of the inconsequential actions i preform to get steam achievements, why are we still here? Just to suffer?
 
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Type: In-game (weapon)
Description: Have a strange issue where my paris prime (and some other projectile weapons) deals a lot less damage after the first hotfix. I went from consistently dealing red/orange crits that dealt 70 000- 150 000 damage per charged shot on lv. 115 corrupted heavies to dealing under 30 000 on lv. 50 enemies. Sometimes red crits as low as 5000. I sometimes deal more damage without my riven. I've also seen occurences where it dips down to yellow crits for some strange reason. I hope for a quick reply, I love the weapon even with its usability issues. Its damage was the only reason to use it over something like the bramma or any wave clearing weapon for that matter. I'd hate to put it on the shelf.

The weapon in question:

Skjermbilde_10.png?width=1019&height=573


This is a picture from before the hotfix:

unknown.png?width=1019&height=573

 

And this is after:

unknown.png?width=1019&height=573

 

I'd like to know if this was intended or if it was a frickup.

Edited by The_Reaper_of_Dawn
want a response...

Share this post


Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Ivara & Ivara prime lose their heads when they enter Artillery post when Prowl is active.
  • VISUAL: 97882501_10158133486078213_7269104188519
  • REPRODUCTION: Go to RJ mission with Ivara or Ivara Prime, activate Prowl, enter Artillery station.
  • EXPECTED RESULT: The head should be on top of the warframes shoulders 😉
  • OBSERVED RESULT: Warframe was invisible and distorted normally, just without a head.
  • REPRODUCTION RATE: Every time

Share this post


Link to post
Share on other sites

TYPE: In-Game/Any mission

DESCRIPTION: When you transfer in and out to operator mode in rapid succession,the frame is unable to melee,  use primary, secondary, even transfer out again in operator mode. 

Plus the animation of frame bullet jumping or any locomotion remains stuck in one and only one direction, making it literally look like Michael Jackson's moon walk, and bullet jumping in reverse

REPRODUCTION: Transfer in and out of operator mode in rapid succession, in missions to trigger it

REPRODUCTION RATE: 2 out of every 10 missions approx

 

Share this post


Link to post
Share on other sites
On 2020-05-18 at 6:28 AM, TheIvoryKitty said:

Omni-Tool Teleport Exit Breaks 'Kill Galleon Captain' Quest

  • TYPE: In-Game, blocks progress
  • DESCRIPTION: This occurred during a Railjack Mission: Flexa in the Veil Proxima. I was playing Volt. I killed the Pyr Captain on the Galleon, along with another team member, as required. The red marker left him, as expected, and then a green marker appeared leading me out of the Galleon. The other team member left the Galleon (I do not know if he used the exit or an Omni tool). However, instead, I ran a ways toward the exit but then used my Omni-tool to automatically teleport back to the ship. The whole team's quest progress still said to kill the Pyr Captain. There were no indicators telling us where to go from there, because the Captain was already dead. Another player went into and out of the Galleon, ensuring the captain was not there. Progress was still not fixed. Then, I went back into the Galleon, and ran all the way through it and left via the green indicated path (near where the Captain was). My exiting of the Galleon updated progress for the team, allowing us to win the mission and leave the area. So, my leaving with an Omni-Tool did not register as my having completed the "Kill Pyr Captain" part of the mission.
  • VISUAL: N/A
  • REPRODUCTION: Do a mission requiring killing a Galleon Captain. Kill the captain. Leave the Galleon via Omni Tool instead of the indicated method. Notice that the quest does not update for the team, and mission success is impossible.
  • EXPECTED RESULT: The mission should have updated, indicating that the captain was dead, once I killed him and left the Galleon via Omni Tool.
  • OBSERVED RESULT: The mission did not update that the captain was dead, and we were stuck in the mission until I re-entered the Galleon and exited properly.
  • REPRODUCTION RATE: I do not know, I have not tried to re-create.

Can confirm the bug, especially after host migration after the captain is dead. 

Share this post


Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: Corpus Survival Arbitration - Jupiter, Host Migration locks door to extraction point.
  • VISUAL: N/A
  • REPRODUCTION: Our host left within the first ten minutes causing a Host Migration. When the Host Migration resolves, three players remain and the "alarm" that triggers arbitration will reset to locked. Any players outside of range of extraction will be unable to follow any pathway to extraction.
  • EXPECTED RESULT: I should have been able to pass this locked door through normal means (defusing an alarm or simply walking to extraction).
  • OBSERVED RESULT: The team was unable to punch through the door and we all decided to allow our warframes to be defeated after about 10 minutes of deciding what to do.
  • REPRODUCTION RATE: 100% for 3 players

Share this post


Link to post
Share on other sites

Type: In-Game, Modding Screen

Description: Using Forma on equipment that has more than the default 3 mod configs sometimes removes all mods from some of the extra configs. (e.g. for configs A,B,C,D, the mods in config D are sometimes removed upon using Forma) Has been observed on both Kuva Hind and Dex Pixia (Prime).

Visual: N/A

Reproduction: Use Forma on equipment that has additional mod configs.

Expected Result: All mod configs are preserved as far as capacity allows.

Observed Result: All mods in configs after the default three are sometimes removed from those configs.

Reproduction Rate: Maybe 50-75%? Does not occur all the time, but often enough to be frustrating especially when installing multiple Forma.

Share this post


Link to post
Share on other sites
Posted (edited)

Disregard

Edited by Fox

Share this post


Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: When hosting a RJ session, whether public, invite only, or friends only, all players in party upon start will be host migrated into their own individual missions. They have to then abort in order to be re-invited by the host. 
  • REPRODUCTION: This happens each time I host a RJ session with people in my party. The only correlation for my issue is the fact that I'm on college wifi... which ALSO causes the issue of failed invites 2-3 times PER person. 
  • EXPECTED RESULT: I should have kept my party as host upon starting mission.
  • OBSERVED RESULT: All party members were kick into their own solo sessions. Leaving me on my own as well, and having others join or needing to reinvite
  • REPRODUCTION RATE: 100%

Share this post


Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: When playing a RJ mission, so happened to be the blip for sentient ship in veil, anytime I needed to transfer out of ship, inside a crewship, inside the sentient ship, etc... it would cause a black screen. Also, it took a long time to enter Crewships... I would hit the x key some amount of times and nothing would happen other than stagger me and the Crewship. This black screen was sometimes resolved with movement, however when attempting to enter the sentient ship there was no resolving the issue... I had a black screen, was stuck outside (I could move around and hear my archwing, melee weapon usage, and me bumping into things). 
  • REPRODUCTION: I was hosting, should have good ping, I was running with a group of 3/4 on a sentient ship mission. I am on college wifi, which could contribute to this issue. They block certain games, though they're allowed? It just causes issues that I don't have anywhere else (Have no confirmed if I DO NOT have this issue on another wifi)
  • EXPECTED RESULT: Enter and Exit all stages in Railjack without black screening and should have smooth transitions.
  • OBSERVED RESULT: Entering and Exiting any stage in a Railjack mission caused a black screen, and sometimes inhibited transitions to other locations, such as the sentient ship. 
  • REPRODUCTION RATE: 50% (Of the 2 times I've played Railjack recently)

Share this post


Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: Using L window in Railjack, pressing the button beside Join Warp on an ally. Caused the target ally to disconnect from the mission. I tried 3 times (as a client), and everyone disconnected after I pressed the button on them, including the host (caused host migration). My ping was fluctuating between 600 and 1000 ms. It happened halfway through a Sentient Anomaly mission that was going smoothly, so while it's possible they all decided to leave in that order coincidentally, it seems unlikely. I pressed the button on one guy, he DCd. Then a few seconds later I do it on another, he DCs. Then I try the host, and I get a host migration. Unlikely...
  • REPRODUCTION: Pressing the button beside Join Warp on the L window in Railjack.
  • EXPECTED RESULT: I don't know what that button's supposed to do, but probably not this
  • OBSERVED RESULT: The ally disconnects from the mission, possibly crash
  • REPRODUCTION RATE: In the one game where I found it, I tried on each ally, and it happened to all of them in turn. Afterwards, I tried again (asked for permission before trying it, someone said they were fine with helping), but nothing happened. This time I had normal ping (40-70ms)

Share this post


Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Directly following the issue I posted above, I was unable to use the ship's navigation to select a new mission after completing the current one alone (I became host through host migration, so it wasn't my ship). The UI still said to investigate the Sentient Anomaly, but I had already done that (and confirmed by checking mission progress. I had an Anomaly Shard, which should mean the Anomaly was completed). So I was stuck in the mission and had to abort, losing all progress (checked inventory afterwards, didn't get the Shard, presumably lost everything else too)
  • REPRODUCTION: As above. Complete mission after host migration, try to navigate out
  • EXPECTED RESULT: Able to use navigation console to return to Dojo, start new mission, etc
  • OBSERVED RESULT: Unable to use console, forced to abort
  • REPRODUCTION RATE: Could not test this because I couldn't reproduce the first bug (posted above)

Share this post


Link to post
Share on other sites
1 hour ago, Sabreenya said:
  • TYPE: In-Game
  • DESCRIPTION: When hosting a RJ session, whether public, invite only, or friends only, all players in party upon start will be host migrated into their own individual missions. They have to then abort in order to be re-invited by the host. 
  • REPRODUCTION: This happens each time I host a RJ session with people in my party. The only correlation for my issue is the fact that I'm on college wifi... which ALSO causes the issue of failed invites 2-3 times PER person. 
  • EXPECTED RESULT: I should have kept my party as host upon starting mission.
  • OBSERVED RESULT: All party members were kick into their own solo sessions. Leaving me on my own as well, and having others join or needing to reinvite
  • REPRODUCTION RATE: 100%

I am having the same issue. Me and a friend are trying to complete the RJ nightwave mission and every time after we load into the mission the host migrates and whoever is hosting is alone and the other is stuck alone on the hosts rj. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...