Jump to content
-Alleluia-

In-game FPS Cap not working Windows 10 May 2020 Update

Recommended Posts

Posted (edited)

Since updating Windows 10 to version 2004 the in-game fps cap is not working as intended and will limit my fps to a lower value than what is selected, for example if I select 120 FPS as the cap the FPS will be limited to 65.
The fps cap only works correctly when v-sync is enabled which isn't ideal as many players such as myself prefer to use g-sync or freesync as opposed to v-sync.

Things I've tried that have NOT worked.
Reinstalling Warframe
Reinstalling Steam
Clearing the Appdata Folder
Reseting all in-game settings to default
Updating/Reinstalling my graphics card drivers (AMD)
Disabling Game Mode within Windows 10
Disabling Full Screen Optimisations within Windows 10
Disabling Variable Refresh Rate Option via Windows 10 Graphics Options

Workaround;
Setting the in-game FPS Cap to unlimited and then capping your FPS with a third party tool or your Graphics Card's manufacturers software.

Edit: This issue has been fixed as of the 17th of June 2020 deploying with hotfix 25.0.08
My thanks to DE for the speedy resolution of this issue.

 

Edited by -Alleluia-
  • Like 3

Share this post


Link to post
Share on other sites
On 2020-05-28 at 1:36 PM, -Alleluia- said:

So I've been playing Warframe for years on a 1440p 144hz Freesync monitor with vsync turned off as I use Freesync, without issue. 

However today when I started up the game I noticed my fps seemed to be capped at 65 despite having the settings in-game set to 144 for both the Display rate and max framerate.
Nothing I do in the settings of either the game or my GPU tools fixes this and the only way I can get the FPS above 65 is to turn Vsync on which I do not want as it introduces input lag and Freesync is much better overall.

I have no idea what has caused this change and I've tried everything from reinstalling both steam and Warframe including deleting any information in the appdata folder etc.
I'm at my wits end, honestly. 

Bump, because after updating to windows 10 2004 (may update) i started experiencing the same issue. I usually have 165hz on a gsync monitor. Now it is capped at 60~65fps for no reason. Nothing I did could fix it. 

And warframe is the only game where I experience this issue. I also play Forza Horizon 4 where I got a major increase in FPS (80~100 to 120-140). Where did things go wrong?

Thing I've tried: Changing compatibility settings, double checking nVidia control panel settings. Checking game mode whether there's a difference while disabled (none). Reinstalling my nVidia drivers. 

I don't know what else to do frankly, besides rolling back. I find it silly however to do a rollback to the previous version while it is in fact one of the most stable updates Microsoft has pushed so far, looking back at their previous updates this past half year that just broke the OS. I hope this gets attention soon.

Share this post


Link to post
Share on other sites
Posted (edited)
21 minutes ago, Contiguous said:

Bump, because after updating to windows 10 2004 (may update) i started experiencing the same issue. I usually have 165hz on a gsync monitor. Now it is capped at 60~65fps for no reason. Nothing I did could fix it. 

And warframe is the only game where I experience this issue. I also play Forza Horizon 4 where I got a major increase in FPS (80~100 to 120-140). Where did things go wrong?

Thing I've tried: Changing compatibility settings, double checking nVidia control panel settings. Checking game mode whether there's a difference while disabled (none). Reinstalling my nVidia drivers. 

I don't know what else to do frankly, besides rolling back. I find it silly however to do a rollback to the previous version while it is in fact one of the most stable updates Microsoft has pushed so far, looking back at their previous updates this past half year that just broke the OS. I hope this gets attention soon.

It must be the Windows 10 2004 update causing this issue then, as it was the only thing changed on my PC from one day to the next. I didn't even force the latest Windows 10 update, it was brought to my attention via the usual windows update. 

Edit: The workaround I've found is to set the FPS in-game to Unlimited and then limit your FPS with MSI Afterburner or whatever tool of your choice, not an ideal solution but it somewhat works. 

Edited by -Alleluia-

Share this post


Link to post
Share on other sites
23 minutes ago, -Alleluia- said:

It must be the Windows 10 2004 update causing this issue then, as it was the only thing changed on my PC from one day to the next. I didn't even force the latest Windows 10 update, it was brought to my attention via the usual windows update. 

Edit: The workaround I've found is to set the FPS in-game to Unlimited and then limit your FPS with MSI Afterburner or whatever tool of your choice, not an ideal solution but it somewhat works. 

Seems like Warframe was not ready for windows 10 2004. I guess we have to wait for a patch.

Share this post


Link to post
Share on other sites

I face the same issue. I have my fps locked to 120 but instead it's limited to 65. Also there's some weird stutter when while in mission I press ESC or bring up the P menu.
PC Specs Ryzen 5 3600 (No OC), RAM @3200GHz and GPU nVidia 1660 Super(No OC)

Share this post


Link to post
Share on other sites

same , got win 10 2004, and capped in game at 144 - i get 66 fps in orbiter and 80 in game. I have 2080 and i7 6700k , if i remove frame caps, i get 300 in orbiter and 200+ in game

  • Like 1

Share this post


Link to post
Share on other sites

Same!

Nvidia 446.14

May 2020 (2004) Windows 10 Update.

Would Warframe have been affected by WDDM being upgraded from 2.6 to 2.7?

Not only the framerate gets locked but it looks like frametime gets doubled, the only fixes are to manually lock frames from RTTS/Nvidia Control panel or enable Vsync on my Gsync monitor to get 144hz. Which basically makes gsync worthless if I get frame drops like in Cetus/Fortuna.

I've included a video capture of changing settings ingame and the different effects they have -

https://youtu.be/dxzO5069gk0

Share this post


Link to post
Share on other sites

Same.

FPS Limit set        Actual fps limited to

     30                            25

     40                            32

     50                            42

     60                            47

     72                            63

    120                           63

Before Windows 10 update 2004 I was getting a solid 60fps with a limit of 60 set. Now i have to set a limit of 72 to get a solid 63.

 

   

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Bumb. Same issue here with May 2020 (2004) Windows 10 Update.

Rest of the specs:

AMD Ryzen 7 3700X 8-Core Processor

GeForce RTX 2070

16GB RAM

Edited by Smiky

Share this post


Link to post
Share on other sites

Thank god am not the only one. Bugged me out since I just did a fresh format and a clean install of the game itself. Definitely a Win 10 2004 issue!

How to fix in the meanwhile:

Go to nVidia control panel > Manage 3D settings > set Max Frame Rate to your desired value.

Turn off V Sync if full screen.

Set Refresh Rate to max value depending on your monitor.

Set Max Frame Rate to No Limit.

Share this post


Link to post
Share on other sites
15 hours ago, DanGuarneri said:

Same.

FPS Limit set        Actual fps limited to

     30                            25

     40                            32

     50                            42

     60                            47

     72                            63

    120                           63

Before Windows 10 update 2004 I was getting a solid 60fps with a limit of 60 set. Now i have to set a limit of 72 to get a solid 63.

 

   

Accurate!

Share this post


Link to post
Share on other sites
Posted (edited)

Just to add further information, Overwatch/Rainbow six siege/Assassin's Creed Odyssey all work perfectly fine with Gsync/Adaptive getting the full 144fps.

So it seems the cause is directly related with Warframe and it's interactions with either 2004 + gpu driver or just 2004 WDDM 2.7.

Edited by tweakoli

Share this post


Link to post
Share on other sites

I'm glad I didn't update my Windows then 😛

 

How is the new windows 10 2004 ? 

Any performance increase or decrease overall ?(not just WF in general).

I'll hold for a while before I update it. 

 

 

Share this post


Link to post
Share on other sites

finally i found the righht thread. DE PLEASE UPDATE IM NOT GOING TO PLAY AND BUY PLATINUM UNTIL ITS FIXED LUL

Share this post


Link to post
Share on other sites

I have been having this same issue as well since the windows update. After updating my graphic drivers and latest windows 10 cumulative update today, I can't even play the game anymore. It crashes right on startup... :(

Share this post


Link to post
Share on other sites
On 2020-06-03 at 7:38 PM, NasaNhak said:

Thank god am not the only one. Bugged me out since I just did a fresh format and a clean install of the game itself. Definitely a Win 10 2004 issue!

How to fix in the meanwhile:

Go to nVidia control panel > Manage 3D settings > set Max Frame Rate to your desired value.

Turn off V Sync if full screen.

Set Refresh Rate to max value depending on your monitor.

Set Max Frame Rate to No Limit.

This doesnt work for me at all. My framerate is still completely unlocked.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi everyone,

Just an update: I can confirm that we have been able to reproduce this issue, and it does appear to be related to Windows 10 version 2004. Unfortunately, we do not yet have a solution, but I can assure you that we are in the process of tracking down the culprit now.

We'll try to get this fixed in a timely manner. Sorry for the inconvenience!

Edited by [DE]Linkski
  • Like 3

Share this post


Link to post
Share on other sites
Posted (edited)
On 2020-06-02 at 12:29 PM, DanGuarneri said:

Same.

FPS Limit set        Actual fps limited to

     30                            25

     40                            32

     50                            42

     60                            47

     72                            63

    120                           63

Before Windows 10 update 2004 I was getting a solid 60fps with a limit of 60 set. Now i have to set a limit of 72 to get a solid 63.

 

   

So the windows update did this?! It was driving me crazy trying to figure out why my fps is a constant 25.

 

edit: BTW, I play Edler Scrolls Online and it is affected by this weird fps change too. But when I open Radeon Software Panel and keep it active my fps goes back up to exactly what it is supposed to be locked at. I thought maybe that information would be useful to someone.

Edited by Redfeather75

Share this post


Link to post
Share on other sites

What is working for me -

Nvidia Control panel (I have gsync monitor):

Turn Gsync and Vsync on.

FPS limit - set to 141 (3 below refresh rate)

Ingame:

No vsync

FPS set to 200.

Capped at 141 ingame, but on loading screens still getting that drop to 25fps when it should sit on 30fps.

Share this post


Link to post
Share on other sites

After making a Player Questions thread on the matter, I've come to the conclusion that this is, in fact, a bug. The frame limiter does not appear to limit frames correctly. Anything above 60 FPS results in 63 FPS, as mentioned earlier in the thread. I've also tried updating my drivers, setting my monitor refresh rate to 120 Hz (it was already set to that) and verifying the game's cache. The only solution I could find is similar to what was listed earlier in the thread. Uncap Warframe's framerate, cap my own system's framerate to 120 via the nVidia Control Panel.

For me, this issue happened only across the last few days. It was either the latest Warframe update which did it, or else the latest Windows Service Pack. I think it's the latter, since I would have noticed earlier. The only reason I noticed my framerate cap in the first place was the overall choppiness I was experiencing.

Share this post


Link to post
Share on other sites

Updated my PC to the Windows 10 2004 update, can confirm that Warframe is only running 65FPS down from the normal 144 I get. Something must have gone wrong somewhere here.

Share this post


Link to post
Share on other sites

This is also happening to me. Just updated to Windows 10 Version 2004.  I have a 165Hz monitor and when I cap it at 165Hz or 200Hz in game I get only 65Hz. Playing on 'no' limit' until issue is resolved.

Share this post


Link to post
Share on other sites
On 2020-06-11 at 8:03 PM, [DE]Linkski said:

Hi everyone,

Just an update: I can confirm that we have been able to reproduce this issue, and it does appear to be related to Windows 10 version 2004. Unfortunately, we do not yet have a solution, but I can assure you that we are in the process of tracking down the culprit now.

We'll try to get this fixed in a timely manner. Sorry for the inconvenience!

Thanks for the heads up 👍

Share this post


Link to post
Share on other sites

😧 Wish i knew this before uninstalling to reinstall again. Gotta wait on a 31GB download now. 

Share this post


Link to post
Share on other sites
45 minutes ago, Arcon said:

😧 Wish i knew this before uninstalling to reinstall again. Gotta wait on a 31GB download now. 

you people should really, really stop with the absolutly useless try of uninstalling anything from the game, to steam upto the whole windows for every single bug you encounter... i wish i had the time some people have doing this nonsense. and before any wisearse  mention it: yes, it can help - but only if one had it's rig infected by really nasty bugs, and even those could be cleared by running an antivirus prog from an external source (e.g. OS with a fresh AV from a USB-stick).

hopefully you will take your wasted time to heart the next time and please never suggest the stupid 'reinstall' solution anywhere - at least not until everything else was tried (and that means doing some research in the net too).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...