Jump to content

Problem in trying to render in Marmoset


Recommended Posts

I've loaded my lowpoly and highpoly into Marmoset Toolbag. I load in the maps i've baked but from the beginning to then, the emissive textures takes up the entire space of the body (lowpoly). How can i isolate the emissive map to only show where i've set emissive zones?

I have the same result whether i exported the original lowpoly with textures or without.

7f127a34ec4594c0f0aef465d68329f3caafceec

192e44368b80e88145861f46e02421c14da4be9a

Link to post
Share on other sites

In Emissive tab, the 'Glow' color slot should be black as it applies flat glow color to the whole mesh, and it should be left black in all cases except for FX meshes(for additional effect), and also the main emissive color is set to black, change it as well. 

If you want to see a single map ,then you can disable other maps(uncheck the tick beside the map slots)

Edited by A1stLight
Link to post
Share on other sites

Thanks. I set the emissive glow to black, but it makes the whole body black. Even with my texture maps plugged in they won't show up and i can only see black. I don't know how to solve this, i baked many of the maps in Marmoset and should be able to use it for rendering as well. I don't think i can submit this or other works if i can't make renders of them

8b3841112c9f9e2cac6e2d5ab85704c7d254cca2

Link to post
Share on other sites

Well , create a fresh new material in the scene(or duplicate the default marmoset material) and apply that to the model and then add textures and then lastly any custom shader if you want, this should work out and also check the lowpoly normals. 

Link to post
Share on other sites

Ah, it's easier than i thought. I think it's the same in Substance Painter as well as you can drag a material on to the model, i tend to drag it into the layer stack. I'm old. Thanks so much for your help.

I have a new problem though, i don't know whether to create a new thread for it or to post it here, but here goes.

The metal texture from Substance Painter is only showing through with the scratches and dirt on that material, but the metallic shine itself isn't coming through in Marmoset. I baked using the metalness/roughness workflow in Substance. I had baked maps in Marmoset as well. The results are the same whether i select specular or metalness in Marmoset.

This is the map from Substance

0bd2b68a3cac442bd7fb13fe5fca6c9d0c847057

And this is the map from Marmoset

6484b17029d11f14d4bd57a64674435b17eeb832

Link to post
Share on other sites

Are you using roughness map or gloss map?  , cause roughness map is actually inverse of gloss map so make sure you apply it in correct slot , as I m seeing you are using gloss map slot so change it to roughness or you can just check the invert button down in the tab

Link to post
Share on other sites

I figured it out, i was plugging in the albedo map that i baked in Marmoset so the materials i had applied in SP weren't showing up. I think i should only bake the normals in Marmoset and leave the other maps for SP. The roughness map was showing up all glossy so i inverted it in Photoshop, now it works.

If i keep the invert box checked in Marmoset, will that only affect it as it appears in Marmoset? So i would still need to invert it in another program for it to work correctly?

ab11dbba0a92f512d3f4782185fa9dcd23894272

Link to post
Share on other sites
Quote

If i keep the invert box checked in Marmoset, will that only affect it as it appears in Marmoset? So i would still need to invert it in another program for it to work correctly?

if you had to invert it while in gloss map slot , then there is no need to invert the actual map it is correct as it was.

also check in the tennogen tool as well so you will know if there is any problem with the maps 

Edited by A1stLight
Link to post
Share on other sites
16 hours ago, SpiralViper said:

Is it the same for normal maps in having to flip the Y channel?

Normal maps can be confusing at first , cause there are 2 format/type of it , one is DirectX format which is mostly used by games and the other is OpenGL format. There is only one difference between them and it's the green channel (Y channel) , For DirectX, the green channel is flipped and for OpenGL its not. So It's important in which format you bake the normal map. As Each software has its defaults , like Marmoset bakes the normal map in OpenGL format by default so you might have to change it to directX. Also it uses OpenGL by default for all the meshes.

That's why you should check the maps in the tennogen tool first,as it uses DirectX format. 

So if you have baked the normal map in Marmoset and didn't change any baker's setting and it displays correctly on the mesh then the normal map is in OpenGL format , but you can change it to DirectX by flipping the green channel of the map or change the baker setting to DirectX and then bake (in Baker's setting > change Tangent Space to '3D Studio Max' OR check the tick 'FlipY' in normals setting down in the Maps tabs ) and then when you want to see the meshes normal map correctly in Marmoset ,check FlipY in the materials settings for normal map

Link to post
Share on other sites

Alright, it took a lot of searching before i could find the setting, but i set the Tangent Space to 3D Studio Max. So will this cause Marmoset to bake all maps in DirectX from now on? I must have been baking most of them in OpenGL so far, except for when i flipped the Y channel on normal map baking. Very good to know, thank you for helping me with this

I did some renders, still very amateur though. Do you have any suggestions on how i could improve them? I found a tutorial that went through the settings between the render menu, lights and camera menu. It seems like i'll have to learn image editing before i can be any good at it though

5e56944cd4b65a4f6bf26067a9d8f629155a0f3b

b2107d6682e990f5b3dabe4452c53545f3c6ad6c

1c9514b506320d41fd8e7b233b3bee79cd8b5938

3d77b5d4eea48abcb743c408bb23243eba79f65e

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...