Jump to content

Heart of Deimos: Bug-Hunting Megathread (Read First Post!)

Recommended Posts

  • TYPE: In Game
  • DESCRIPTION: Telos Boltace's passive doesn't work.
  • EDIT #1 (Post-HotFix) : Still happening
  • EDIT #2 (Post Another-HotFix) : I think it's already fixed
  • EDIT #3 (Post Another-HotFix) : Nope, still happening
  • VISUAL: None.
  • REPRODUCTION: Go with a squad without being the host to any mission.
  • EXPECTED RESULT: It is expected to attract and drive away enemies with the atack.
  • OBSERVED RESULT: It doesn't or has a very late effect.
  • REPRODUCTION RATE: Very often.
Edited by AJAL8000
EDIT #3 (Post Another-HotFix) : Nope, still happening
Link to post
Share on other sites
7 hours ago, Veneratus said:
  • TYPE: In-game
  • DESCRIPTION: Necramech repair heart failure (mission cannot be completed)
  • VISUAL: N/A (sorry)
  • REPRODUCTION: Swap weapons after receiving "Omni" as part of quest
  • EXPECTED RESULT: Swap from omni to weapon, and back to omni
  • OBSERVED RESULT: Swapped from omni to weapon, cannot re-equip omni or exit nercamech through any means
  • REPRODUCTION RATE: First try, accidental. I assume it will reproduce every time.

I can confirm this occurs after Hotfix 29.0.1 . Thank you for your report.

Link to post
Share on other sites

If you drop the bait in the Isolation Vault bounty, it turns into a power cell and you can't throw it at the door, rendering the bounty impossible to complete. C'mon, DE! :thinking:

Edit: appears to be fixed now.  Thanks!

Edited by N64Gamefreak
Bug has been squashed!
Link to post
Share on other sites

Gave about 15 fishes to Daughter to cut game announces 1 of each possible ressources for the fish given and then doesnt give me the ressources stealing my fish for no rewarded ressources am kinda mad since cant upgrade standing without the fish ressource

  • Like 1
Link to post
Share on other sites
  • TYPE: In game (PC)
  • DESCRIPTION: In the Vox Solaris quest, during Biz's section you need to "find his tea." They all spawn in on the ground, but are impossible to interact with as the player is never prompted to do so. 
  • REPRODUCTION: Biz’s section of the Vox Solaris quest 
  • EXPECTED RESULT: An interaction node should appear to let me scan the bodies
  • OBSERVED RESULT: No interact prompt appears over the body.
  • REPRODUCTION RATE: 100%. Infuriatingly so.
Link to post
Share on other sites


  • TYPE: in Game
  • DESCRIPTION: Hunting Bugs
  • VISUAL: Not bothering cause its so bad with all the bugs
  • REPRODUCTION: doesnt work consistently
  • EXPECTED RESULT: lack of hunts
  • OBSERVED RESULT:after an hour of zoning I gave up

Hunting IN Heart of demios is bad. Setting waypoints....animal spores is buggy....you arrive spore isnt there sometimes at all ....and when u check the waypoint has moved. You try to start the track from the spore. Somtimes it wont let you start. Tracks sometimes dont appear so you fly to yellow area and wander around till u find the spore. calling animals....really seems difficult to match a sound to be able to mimic. When you finally able to summon the animal....it wont show after u successfuly call. So you have to zone out and back to reset the waypoints otherwise the map remains bugged by the called locations. The mobs in the air you cant see them if at all to shoot them....and since they dont show different colours from rest of the enemy on the map ...your left wandering looking at everything and finally give up again and rezone. 


And to add to the insult you made these hunts are requirement to get thru rank standing ......did noone test this?



Link to post
Share on other sites
  • TYPE: In Game EDIT #2 (Post Another-HotFix) : Still happening
  • DESCRIPTION: Limbo Prime's shoulders and armor are misplaced when he has Harrow's animations (THIS DOESN'T HAPPEN WITH THE NORMAL LIMBO)
  • REPRODUCTION: Limbo Prime with Harrow's animation. (Only with Limbo Prime)
  • EXPECTED RESULT: Good FashionFrame
  • OBSERVED RESULT: Bad FashionFrame
  • EDIT #1 (Post-HotFix) : It seems to be worse than before now
  • EDIT #2 (Post Another-HotFix) : Still happening
Edited by AJAL8000
​​​​​​​EDIT #2 (Post Another-HotFix) : Still happening
Link to post
Share on other sites
  • TYPE: UI (?)
  • DESCRIPTION: Mother isnt displaying a T4 bounty, instead gives T1, T1, T2, T3, T5, T5(Steel Path). Displayed this exact tier set of missions for three cycles now. Steel Path not enabled. Bounties persist as seen form despite changing to or from Steel Path. Person without SP unlocked confirmed they can see T4 bounty.
  • REPRODUCTION: Talk to mother, unsure what the trigger is as I've had no change from this state personally ever since release. Somehow related to Steel Path is all I can figure out.
  • EXPECTED RESULT: One bounty for each tier
  • OBSERVED RESULT: Two T1 bounties, no T4 bounty.
  • REPRODUCTION RATE: Every time I talk to mother, persisted through hotfix.
Edited by Kelshiso
Link to post
Share on other sites
5 hours ago, RamPuppy said:
  • TYPE: In-Game
  • DESCRIPTION: Every time there is an update, it blows away my gear wheel
  • VISUAL: It looks like a normal gear wheel - w/ the first 10 options or so - everyting after that is gone. no screenie - sorry.
  • REPRODUCTION: Every update
  • EXPECTED RESULT: Update Happens - my gear wheel is intact - no missing items.
  • OBSERVED RESULT: Update Happens - Everything after the first circumference of the wheel is gone (usually thats apothics and specters)
  • REPRODUCTION RATE: Consistently - on larger updates.

Just had the same issue happen to my account with the Heart of Deimos hotfix update (i.e. the 29.0.1 update). First time that this has happened to my account, however.

Link to post
Share on other sites
  • TYPE: In Game (Why only the Telos Boltace always have problems or bugs?)
  • DESCRIPTION: Maruta tonfa skin's texture disaster in RailJack's mission. (It only happens with the Telos Boltace)
  • EDIT #1 (Post-HotFix) : Still happening
  • EDIT #2 (Post Another-HotFix) : Still happening
  • EDIT #3 (Post Another-HotFix) : Still happening
  • REPRODUCTION: Go to any RailJack mission with that skin equip in a Telos Boltace and drive the RailJack for a moment.
  • EXPECTED RESULT: Good FashionFrame
  • OBSERVED RESULT: Bad FashionFrame
  • EDIT #1 (Post-HotFix) : Still happening
  • EDIT #2 (Post Another-HotFix) : Still happening
  • EDIT #3 (Post Another-HotFix) : Still happening
Edited by AJAL8000
​​​​​​​EDIT #3 (Post Another-HotFix) : Still happening
Link to post
Share on other sites

Type: In-Game

Description: I was attempting to farm the Spinal Core Section by fishing for Vitreospina fish. Upon capturing two fish, I went to Space Stepsister Daughter to cut them up. Those first two Vitreospina yielded one Spinal Core Section each. After the hotfix, I caught another Vitreospina and brought it to Daughter for dissection, which yielded nothing. Frustrated, I farmed another one, went to Daughter, but this time I clicked on "Details," which revealed this:




I expected to see a description of the respective fish, but instead observed a description regarding alloy plates for Grineer armor.

This seems to happen with pretty much every fish I catch.

I don't know squat about game design, but I hypothesize that the fish were somehow mixed up with the alloy plates. So when I dissected the fish, I must have gotten alloy plates instead of fish parts. 

  • Like 1
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Conservation hunting for Avichaea is very buggy and extremely difficult to see
  • EXPECTED RESULT: animal flies to its nest normally.
  • OBSERVED RESULT: animal sometimes doesn't show up, gets stuck in terrain, and/or is generally very difficult to spot.
  • REPRODUCTION RATE: only 1 hunt out of 4 went without any issues.  Spawn points near Cerebrum Magna is where I had spawns get stuck in terrain. can't recall where the one that never showed up was at.
Link to post
Share on other sites

I just cut up some of the new fish. Didn't get any of the resources. Also weird that when I cut more then 1 fish of the same type, it only shows me getting the resources of cutting 1 of the same type of fish. I also exited necralisk to see if that would fix it. Did not. I rebooted the game and still didn't get any of the fish resources. Not going to be able to get to rank 1 at this rate.

Link to post
Share on other sites
  • TYPE: UI (ingame)
  • DESCRIPTION: When I finish any open world mission, buttons in top left (profile icons, matchmaking mode selector and invite button) simply disappear.
  • VISUALscreenshotvideo
  • REPRODUCTION: Enter open-world mission and exit into the city through doors
  • EXPECTED RESULT: After "mission result" screen to see icons in top-left
  • OBSERVED RESULT: Icons are gone and
  • REPRODUCTION RATE: Every time I exit with "mission success"
  • Like 2
Link to post
Share on other sites
  • TYPE: in game
  • DESCRIPTION: gravid blastema sometimes not popping as soon as it touches the surface, as a result, it has to be destroyed manually
  • VISUAL: -
  • REPRODUCTION: simply shoot the gravid blastema to make it fall down
  • EXPECTED RESULT: has to be destroyed as soon as it touches the surface
  • OBSERVED RESULT: it didn't pop to collect the resources
  • Like 1
Link to post
Share on other sites
2 hours ago, winnerschnitzel said:

Same for me. 

I waited a good 10 minutes for transition, nothing happened. 

Travelling to Necralisk node directly from orbiter results in the same endless Loading.

Is there a way to reset quest?


Veryfing the download cache, and cleaning solved the issue!

When I enter Transition room a Mission Completed will be shown and I can progress.

Link to post
Share on other sites

I have run into a few minor bugs that I don't know how to recreate beyond how they happened(as in specifics are lost). I was only able to screenshot one but as it was on ps4 I dont know how to transfer it, if necessary I might be able to dm it on ps4.

The glitches were as follows: whenever I pass the blue orb outside the demios hub my game lags, it doesn't do this anywhere else

(Screenshoted) when returning from a mission the door is missing for half a minute.

And two when talking to daughter: near the end she repeated the "only air they breathe line" mid sentence then stopped having audio, the second glitched happened in the same convo where the last line's subtitles dissapeared after only a second. 

Link to post
Share on other sites
7 hours ago, Kylo. said:

TYPE: In-Game
DESCRIPTION: Cutting vitreospina to get spinal core sections.
VISUAL: unknown.png
REPRODUCTION: Cut vitreospina and don't get spinal core. Not sure though, I don't get any, my friend does.
EXPECTED RESULT: I should get spinal core sections
OBSERVED RESULT: I don't get any spinal core sections
REPRODUCTION RATE: Happens all the time or rather it doesn't.

Yep it seems pretty random I have cut around 15 and gotten a total of 6

Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Was progressing through "Descent To The Heart" mission and just before the door to the heart decided to make a stop at one of the rooms that caught my attention... (It has a circular portal in the middle, attacked the reactive triggers with void damage opened the portal and accidentally (didn't even see it until the assembly animation started) got into necromech. I am now stuck in front of the heart with the necromech basically soft locked myself. The trigger is not activating while I am in the mech and it seems that I can't use any abilities (tried every key possible to get out and it just didn't work) it keeps on saying "Ability in use"
  • VISUAL: https://youtu.be/NIGYb3urWvU (Sorry for S#&$ty framerate OBS is drunk on ram) The end of the video is the teleport room
  • REPRODUCTION: Most was said in description.
    1. Find a necromech room (I assume there are multiple, I got the one with spinning portal, end of the Video)
    2. Activate it.
    3. Go to the room with the heart.
    4. ????
    5. Clem-ofit
  • EXPECTED RESULT: I should either not be able to get into mech or be able to leave it
  • OBSERVED RESULT: Got stuck in the necromech
  • REPRODUCTION RATE: Only tried once but I assume it should happen everytime I get my dirty hands on the mech

    Overall not a big issue bug just something annoying as I have to restart the mission now (and lose all of the resources I got)
  • Like 1
Link to post
Share on other sites
5 hours ago, kukonstantinos said:

Basically.........Y'all broke ma dog.....:(


and i've tried changing it's appearance, it changes back to normal, but then returns to this when i exit the menu.


I get that it's applying a certain skin model to my dog but without the relevant textures, but it's just sooooo hideous, please fix it, or it's getting put down.cXaxBxf.png

I can second this.  

  • Like 1
Link to post
Share on other sites
  • TYPE: In-game, In any mission, not just the Cambian Drift
  • DESCRIPTION: Melee attacking with the Scindo Prime, and then pressing right click to equip a primary weapon, a trail appears to the left of the warframe's head. It stays there until you switch back to Scindo, and then pressing Q to switch to a primary as opposed to right click.
  • VISUALhttps://imgur.com/a/ep7bInI (50% if this works or not)
  • REPRODUCTION: Go into a mission with Scindo Prime equipped, press E, press right click, observe.
  • EXPECTED RESULT: A flying energy colored trail shouldntve appeared to the left of my warframe's head.

    Please remove that trail that appear at the bottom of scindo this floating thing leaving an orange trail is so annoying that i cant use my favourite melee weapon anymore, cuz it annoys my OCD that much. Fix this ASAP, i know you have better things to attend to, but get to this one cuz its really goddamn annoying.

    I have a very easy fix for ya: Just remove that goddamnt trail effect from the pommel of Scindo, and Done, bug fixed
Edited by Cheese_Moon
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...