Jump to content

Heart of Deimos: Bug-Hunting Megathread (Read First Post!)

Recommended Posts

On 2020-08-26 at 7:16 AM, Veneratus said:
  • TYPE: In-game
  • DESCRIPTION: Deimos open world, Operator actions / dashing
  • VISUAL: cbf
  • REPRODUCTION: Enter operator mode, attempt to dash
  • EXPECTED RESULT: Standard movement, dash on command
  • OBSERVED RESULT: Low gravity falling animations, inability to dash without re-entering void mode several times

Edit:how do I delete these? Mobile forum seems hard to use

Edit2:desktop mode still no option to delete, not sure why the comment just kept posting without reloading the page and clearing the reply feild

Edited by madgamer990
Link to post
Share on other sites
  • TYPE: In-Game [XBox One]
  • DESCRIPTION: Just started running through the new content, and I'm not entirely sure what's going on. Perhaps it has something to do with the world cycles, but I'm running bounties and randomly find that I'm incapable of using my Operator's Void Dash, instead she just hops around in Void form. I also sometimes get locked out of transferring back into my frame.
  • VISUALhttps://streamable.com/m0v21g
  • REPRODUCTION: Just play, I guess? Literally just questing and it happens, not really doing anything out of the ordinary.
  • EXPECTED RESULT: You'll randomly lose your Void Dash, but none of the other Tenno powers.
  • OBSERVED RESULT: See above.
  • REPRODUCTION RATE: Seemingly every time until I cycle back into Necralisk.
Edited by (XB1)o Z IE R 0 x
  • Like 1
Link to post
Share on other sites


  • TYPE: In-Game
  • DESCRIPTION: I was fishing in Cambion Drift, I went down into one of the caves, and also got various minerals while I was there. After a while(I think the day/night was about to change) I threw out bait as I had several times before, aimed, and for some reason the spear wouldn't throw. After a few more tries, I tried moving around, text chatting, switching weapons, tools. I forgot to see if the map was working: The only things that worked were: Escape button, all of the buttons in the escape menu. Tab menu and thats all I found. I task-managered and ended task. 
  • VISUAL: I didn't take any aside from the resources I lost due to this.
  • REPRODUCTION: My best guess is fish around the time of day/night cycle change.
  • EXPECTED RESULT: Spear thrown, movement doable, any action aside from esc, tab. or aim working.
  • OBSERVED RESULT: None of the above actions worked.
  • REPRODUCTION RATE: Haven't tried to reproduce as of yet, will update or reply to post if it happens again.
Link to post
Share on other sites
  • TYPE: In-Game [PC]
  • DESCRIPTION: Wierd Visual Colour/Lighting issue 
  • VISUALunknown.png
  • unknown.png
  • REPRODUCTION: Came out from the nekralisk, "1h Until Vome", was flying around near the sky limit and this area was out of the render distance initially as i flew toward it.
  • EXPECTED RESULT: It to be normal coloured like the rest of the map.
  • OBSERVED RESULT: See above. The cave was also wierd coloured.
  • REPRODUCTION RATE: Haven't yet tried, but it didn't go away when flying away across the map and back again.
Link to post
Share on other sites
  • TYPE:  In-Game
  • DESCRIPTIONkilling with a heavy attack using gunblade does not trigger the carnis mod set.
  • VISUAL: none
  • REPRODUCTION: just kill mobs with gunblade
  • EXPECTED RESULT: killing with a heavy attack does not trigger the carnis mod set. 
  • OBSERVED RESULT: carnis mod set not triggered

sorry for my English, I used Google translate

Link to post
Share on other sites
  • TYPE: In-game [PC]
  • DESCRIPTION: We were farming Necramech Parts with friends by doing Vault Bounties. A Nekros was being used to gain additional drops from the Necramechs. The issue is Damaged Necramech Parts that drop from a destroyed Necramech only being received by one player in the group. When we were three players, a non-host player received a drop, while both the host and another host did not receive it. Later, with two players, the bug reoccured. This affected all the drops of Damaged Necramech Parts during the run (3 drops in total). Other loot from the Necramechs (e.g. Mods, Orientation Matrix drops) is not affected by this.
  • VISUAL: Screenshot 1  Screenshot 2
  • REPRODUCTION: No idea how to reproduce this specifically, these were normal play-conditions.
  • EXPECTED RESULT: A resource drop being available to pick up to every player in a group.
  • OBSERVED RESULT: A specific resource (Damaged Necramech Parts) not being available to pick up for every player in a group, but rather just one player.
  • REPRODUCTION RATE: It affected all relevant drops across several missions and squads.
Link to post
Share on other sites
  • TYPE: [Economy]
  • DESCRIPTION: [The Sepulcrum is uncraftable at the tier you unlock it at. While it and most of the materials to craft is unlocked at the Acquaintance tier, it requires Trapezium Xenorhast, which requires Associate tier.]


While not a bug in the traditional sense, it's a tad bit annoying to unlock the gun, get excited to craft it, only to realize it's essentially locked behind the next tier. Right now it's essentially worthless that it's unlock at Acquaintance, as it does require Associate to craft. Why not unlock the gun at Acquaintance, or the gem at Associate?

Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: Can not guild max level Vulpaphyla
  • REPRODUCTION: Level a vulpahyla to 30 then visit son in the Necralisk. Select Experimental Procedures then Guild.
  • EXPECTED RESULT: Vulpaphyla is guilded.
  • OBSERVED RESULT: A message is displayed saying that you must have a unguilded max level companion.
Link to post
Share on other sites
  • TYPE: In game [Version Hotfix 29.0.3 - ongoing since 28.3.3]
  • DESCRIPTION: Energy Siphon on party member and/or Arcane Aegis immediately removes overshields granted via Pillage on Hildryn. .
  • REPRODUCTION: See below threads
  • EXPECTED RESULT: Overshields maintained regardless of Aura or Arcane equipped to warframe.
  • OBSERVED RESULT: See below linked threads
  • REPRODUCTION RATE: Whenever Arcane Aegis and/or Energy Siphon is equipped to party member.


Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: Description bug when right clicking on fish in the Cut menu (haven't tested elsewhere), it has the 1500 alloy plates description.
  • VISUALunknown.pngunknown.png
  • REPRODUCTION: Right click the fish in cut menu
  • EXPECTED RESULT: Correct description
  • OBSERVED RESULT: Incorrect description
  • REPRODUCTION RATE: Likely high, worked on the two i tested.
Link to post
Share on other sites
  • TYPE: In-Game 

  • DESCRIPTION: Bounty 5 in Cambion Drift 

  • VISUAL:  


  • REPRODUCTION: Mount k-drive outside the main door of necra, fall through floor 

  • EXPECTED RESULT: Not fall through floor 

  • OBSERVED RESULT: Fell through floor 

  • REPRODUCTION RATE: Not sure, happened following hotfix 29.0.3, did not happen before, should probably add, /unstuck does not fix this. 

Edited by willho01
Link to post
Share on other sites


  • TYPE: In-Game
  • DESCRIPTION: Limbo couldn't dash into the Rift after I used and exited the Archwing
  • VISUAL: Don't know how to put video here
  • REPRODUCTION: Go into open world as Limbo, enter then exit Archwing, then try to enter rift by pressing Shift
  • EXPECTED RESULT: Limbo should have entered the Rift, becoming invulnerable
  • OBSERVED RESULT: Limbo created a portal, but the entry sound didn't play, and I could still be damaged by enemies outside the Rift
  • REPRODUCTION RATE: Every time I used the Archwing in the open world
Edited by Xyvren
Link to post
Share on other sites


I played Heart of Deimos shortly after it's release  yesterday, day one. No issues.  

Today I started playing shortly before 6 pm EST knowing that I would need to wait a bit for my daily standing to reset.  It is now 7:30 pm EST and my daily standing has still not reset.  I am unable to rank up the new faction at all.  All other factions such as syndicates, nightwave, etc are working normally and have reset if that was a feature.  Upon further recollection I also do not remember getting my daily log in either.  However it's possible that it was nano spores and I purged that from memory.  

Further when I start a bounty no one joins at all.  

I have tried logging out and logging back in, router reset, verified game files, optimized etc. and the issue persists.  

Edited by LEGI0N47
Link to post
Share on other sites

TYPE: Mother Bounty lvl 15-25. Solo mode.
DESCRIPTION: Unable to complete bounties since latest hotfix.
The stage where you have to keep a control area - but there's nothing for me to control. Literally nothing. Yet the control percent goes down to 0%. Bounty failed.
A stage where you have to clear the area - but there are no enemies to clear. There was a small circle on the HUD over a cave area so I checked the cave and the circle grew larger. But I was unable to progress through the cave because it's blocked by one of the 'doors' you need to blow up in the vault raid missions. The door never opened. Bounty failed.
REPRODUCTION: Try playing solo bounty.
EXPECTED RESULT: Enemies for me to kill should've spawned.
REPRODUCTION RATE: 2 bounties so far.

  • Like 1
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Cutting up more then 1 fish results in most of your mats are lost
  • VISUAL: 42 of the same fish different sizes. fish_glitch.PNG
  • Cutting up 1 fish Fish_glitch_1.PNG
  • REPRODUCTION: Use Kaeli to cut up some fish
  • EXPECTED RESULT: We should get all of the mats for all of the fish that we cut up not just 1 resource from the fish 
  • OBSERVED RESULT: Didn't get all of the resources. 
Link to post
Share on other sites

TYPE: In-game
DESCRIPTION: After returning from Cambion Drift/Necralisk, the orbiter window is set to a random planet skybox
REPRODUCTION: Return to orbiter from the Necralisk
EXPECTED RESULT: Orbiter window should show skybox depicting Deimos
OBSERVED RESULT: Orbiter window shows random planet
REPRODUCTION RATE: Happens after every return to orbiter

  • Like 1
Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: In the part of the quest where you go to the heart vault and your warframe becomes "broken" as the heart gets destroyed. Once it gets to the part where you must sneak past the giant robots the waypoint tells you to go to one place then changes. After that once you get to the esophagus it brings you close to Necralisk (?) It starts looping the way point back to the original esophagus. Doesnt stop no matter how many times you go through.
  • REPRODUCTION: Its everytime i try it, seems to break if i get caught once. Not sure if it breaks when you do it flawlessly
  • EXPECTED RESULT: Way point should point me back to the necralisk and let me complete the mission ( if i try to just go to it then it says mission failed)
  • OBSERVED RESULT: Way point loops back to the esophagus not letting you finish the mission
  • REPRODUCTION RATE: Everytime i try to complete the quest
  • Like 1
Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: The toggle to aim option doesn't work when aiming in a k-drive.
  • REPRODUCTION: Aiming in a k-drive with toggle to aim active.
  • EXPECTED RESULT: Weapon should stay in Aim Mode when tapping the button (Since toggle to aim is active) and should at least stop the K-drive Turbo (Shift Button) when toggle to run is active.
  • OBSERVED RESULT: Can't use k-drive weapon effectively.
  • REPRODUCTION RATE: 100% consistent for me.
Link to post
Share on other sites

I'm resubmitting this bug because Otak's mining display in the Necrolisk calls attention to it again and my previous thread on it was archived without it being fixed:

  • TYPE: In-Game, Art
  • DESCRIPTION: Gallium resources are missing their specular/reflection map textures. As a result, Gallium deposits and bars appear as a dull dark blue-green, instead of the lustrous white color that is shown in its inventory and market icons, and its previous appearance in older versions of the game (about ~2 years ago). A prominent example is Otak's mining display seen below. For more details and images, you can see my previous thread on the subject above.
  • VISUAL: How it looks in-game:XoWspQm.png
    How it's supposed to look (note the white lustrous hue):
    (Video credit: Zilaria on Youtube)
  • REPRODUCTION: Examine any Gallium deposit or bar model in-game, such as the orbiter decorations, resource containers in missions, or mining displays in NPC hubs.
  • EXPECTED RESULT: I expect Gallium to have its shiny white appearance, not a dull, dark blue-green appearance.
  • OBSERVED RESULT: It has a dull, dark blue-green appearance.
  • REPRODUCTION RATE: 100% - Every Gallium texture is broken.
Edited by Fireshock
Link to post
Share on other sites
  • TYPE: In-game, Faction ranking
  • DESCRIPTION: When I upgraded rank with the Entrati from Stranger to Acquaintance, I was ask to give a Zymos. I was construction the Zymos at this point, but the option to give it was still there. When I increased rank, the Zymos in construction disappeared, the Barrel and Receiver weren't in my inventory and all progress was lost.
  • REPRODUCTION: I can't reproduce this bug.
  • EXPECTED RESULT: I should have been able to use that blueprint to rank up
  • OBSERVED RESULT: Î rank up and lost the blueprint, and both constructed part.

If I could get the part back, so I don't have to build them again, I would appreciated.


Have a great day.

Link to post
Share on other sites
  • TYPE: Deimos vault bounty
  • DESCRIPTION: during the bounty in the 3rd vault was unable to transfer back into warframe with the message ability use prevented, this happened every time after words and was not a one off occurrence
  • REPRODUCTION: fighting the necromechs in the 3rd vault, possible transferring multiple times quickly (just to stay alive)
  • EXPECTED RESULT: operator transfer shouldn't be blocked by enemy abilities (looking at you nullifiers also)
  • OBSERVED RESULT: constant blue flashes indicating ability blocking
  • REPRODUCTION RATE: was my first 3 vault run, not sure if multiple necromechs spamming things was the cause
Link to post
Share on other sites

Just to uphold the unwritten rule that Shadows Of The Dead breaks something with every update 😉
Further to my previous comment about the 'defend the area' part of a bounty, I just tried it with Nekros and his shadows seem to count as enemies in terms of the control level. Control level went from 100% to 0% in the space of 50 seconds as soon as he had 7 summons.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...