Jump to content

Heart of Deimos: Bug-Hunting Megathread (Read First Post!)


Recommended Posts

  • TYPE In-Game
  • DESCRIPTION: Playing Heart of Deimos quest daughter force me to catch fishy but when i do catch one with lanzo spear the counter won't go up. After that i change to fortuna fishing spear right, right after the spear hit fishy i alt+tab to see similar issue in the forum then when i go back game froze few second and my warframe couldn't move at all while a duplicate fortune spear stuck in mid air.(quest played after 17 September huge patch)
  • VISUAL: Untitled.png
  • REPRODUCTION: Try catch fish as soon as catch fish counter show up.
  • EXPECTED RESULT: The quest won't bugged.
  • OBSERVED RESULT: Should just skip fishing part or optional.
  • REPRODUCTION RATE: I am not going back to get bugged again.
  • Like 1
Link to post
Share on other sites

(ISSUE RESOLVED: 9/19/2020)

 

Type: Mission/In-Game

Description: So for this mission, everything is fine until I get to the fishing portion where my objective is to catch 3 fish. Once I equip my fishing spear, I see that my objective is "0/3 fish," but it never updates when I actually catch a fish. Even the little yellow quest tracker will highlight a fish, but when I catch it the objective still doesn't update. I have tried just catching 3 fish and then returning to Sister, but it just says I fail the mission, and deletes all the fish from my inventory.

Visual:

Top pic shows the objective, and second pic shows my inventory with my caught fish.

warframe01.png

warframe02.png

Reproduction: I have restarted the game and quest about 8 times now, even given a full day before trying again. I redo the "Exocrine Expedition" to get back to the fishing part.

Expected Result: Quest objective updates and is completed when I catch 3 fish.

Observed Result: Objective never updates when I catch fish at the marked zone.

Reproduction Rate: I have had this issue every time when I restarted the quest/game (about 8 times now).

Edited by FerYetti
Bug fixed for me
  • Like 1
Link to post
Share on other sites
On 2020-09-08 at 5:16 AM, kertasA4 said:
  • TYPE: In game, Cambion Drift bounties
  • DESCRIPTION: as you can watch in the video, im forever falling
  • REPRODUCTION: when i use k-drive, i jump from kdrive while it hit something 
  • EXPECTED RESULT: i shoud just not falling forever and be denied my bounties
  • OBSERVED RESULT: im falling ferever in a loop
  • REPRODUCTION RATE: This happens 2/3 times from my experience. just this once i decided to record it

I got this to happen as well, but when i spawned my k-drive on a grind-able surface (i replicate the bug from my archwing in my video, though it originally happened while on foot)

After showing what i did to start clipping (spawning the kdrive the first time in my video) i start spamming the archwing launcher (tried to do it like i did first time around when i panicked)

Edited by Ropuce
Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: Game breaking bug in The Exocrine Expedition during the fishing sequence. Fish are collected, but the 0/3 counter is never updated.
  • VISUAL
  • REPRODUCTION: Play The Exocrine Expedition mission.
  • EXPECTED RESULT: I catch a fish and the fish counter goes up.
  • OBSERVED RESULT: Fish is caught, I'm down its size, fish counter stays at 0.
  • REPRODUCTION RATE: 100%. Happens on solo play and public play. Happens with multiple Warframes (Vauban and Nidus attempted). Happens after exiting to Necrolisk, Orbiter, or restarting the game.

[Edit] Aw, reading all the other reports of this make me feel a connection to everyone through shared frustration.

[Edit2] Appears fixed.

Edited by uninvitedguest
Update
  • Like 3
Link to post
Share on other sites

TYPE: In-game

DESCRIPTION: Xaku's Grasp of Lohk weapons shoots Gaze targets and invulnerable targets like turrets from Kuva Fortress

VISUAL: 

REPRODUCTION: Have Grasp of Lohk activated and it shoots an invulnerable target.

EXPECTED RESULT: It shoots the invulnerable target.

OBSERVED RESULT: It shoots the invulnerable target.

REPRODUCTION RATE: 100% of the time.

Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: On the fishing part of the mission i'm unable to advance through the fishing part
  • VISUAL: https://imgur.com/a/FYmFccl  https://imgur.com/KqyR6zn
  • REPRODUCTION: Restarted the game multiple times to try sort this doesn't work.
  • EXPECTED RESULT: At least catch a fish
  • OBSERVED RESULT: Still no progress
  • REPRODUCTION RATE: 100% consistent for me.
  • Like 2
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Empower does not scale with power strength
  • VISUAL: [This is where you would add your screenshot or video]
  • REPRODUCTION: Infuse Empower to any frame
  • EXPECTED RESULT: Empower scales with power strength like every other ability
  • OBSERVED RESULT: Empower gives flat +50 strenth
  • REPRODUCTION RATE: 100%
Link to post
Share on other sites

      

On 2020-06-17 at 5:39 PM, DoveCannon said:
  • TYPE: In-game
  • DESCRIPTION: Garuda's Talons not effected by Blood Rush, Weeping Wounds, Gladiator set bonus. Exalted melees not effected by Gladiator set bonus.
  • VISUAL:
    • IjMoC7N.png
    • 7MReYS9.jpg
    • s0ZZfVc.png
    • ty6Fs9C.jpg
    • B6KKK6z.png
    • HzWqaZ6.jpg
  • REPRODUCTION: Equip the mods, get a combo counter.
  • EXPECTED RESULT:
    • Garuda's Talons: at 12 combo counter: crit chance 216% (orange-red crits), status chance 173% (every hit gives 1-2 status)
    • Valkyr: at 12 combo counter: crit chance 180% (yellow-orange crits)
    • Excal: at 12 combo counter: crit chance 172% (yellow-orange crits)
  • OBSERVED RESULT:
    • Garuda: white-yellow crits instead of orange-red crits and not getting status on every hit.
    • Valkyr: white-yellow crits instead of yellow-orange crits.
    • Excal: white-yellow crits instead of yellow-orange crits.
  • REPRODUCTION RATE: Happens every time.
  • EXTRA NOTE: Has been this way since 27.5.5

This is still broken in 29.1.1

 

Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Mirage's eclipse always stays in shadow state on plains of eidolon
  • VISUALhttps://imgur.com/6orLLOI
  • REPRODUCTION: I've Eclipse on titania in 3rd slot. With Total Eclipse augment. 
  • EXPECTED RESULT: Well it should change to day (damage state) cause it is day.. 
  • OBSERVED RESULT: No matter which weather and daytime it is, eclipse is always in night form, anywhere except plains entrance ladder 
  • REPRODUCTION RATE: Always
Link to post
Share on other sites

I am going to keep this really short since it has a reproduction rate of 100% and seems quite simple to understand.

Energized Munitions allows wild frenzy to have a not empty mag at the end of the alt-fire.

One would expect the mag to be empty and the alt-fire to last longer due to the 75% chance not to use ammo, neither of this seems to be the case somehow.

Short summary of expected/intended behaviors:

Energized Muntions should give a 75% chance not to use ammo when firing (apparently the alt-fire counts as firing ONCE and thus it doesn't get an extension)

Wild Frenzy should empty your magazine completely at 400% fire-rate and refund the mag if you made 2 or more kills.

What happens instead is that you are left with a mag that is still 75% of what it had at the start. e.g. 120 -> 90 -> 67-68 ->50 etc. This also breaks the ammo refund of the wild frenzy mod even if you killed 2 or more during the alt-fire.

Edited by Quimoth
Link to post
Share on other sites
  • TYPE: Gameplay
  • DESCRIPTION: After leaving my necromech in the isovault, I could no longer use archwing, or accept the next vault mission. (Choosing the archwing gave the "invalid location" error, and I wasn't given the option to accept/not accept the mission.) Another player was bugged out as well. A host migration fixed the issue.
  • VISUAL: none
  • REPRODUCTION: Do iso vault missions as client, leave necromech underground and switch to your warframe.
  • EXPECTED RESULT: To be able to use archwing, progress to the next mission
  • OBSERVED RESULT: Couldn't use archwing, but could use K-Drive, had to tell others to force the mission to start.
  • REPRODUCTION RATE: Maybe 1 in 10 missions? It seems random.
Link to post
Share on other sites
  • TYPE: UI (End of mission display)
  • DESCRIPTION: The rank of the arquebex on the end of mission screen is random if you don't use your necromech. (I haven't tested when using one.)
  • VISUAL: Compare the rank of the Arquebex with the Arca Scisco I was levelling.
  • RZ8bTKA.jpg

 

tGVdKqP.jpg

 

KLqW8Ro.jpg

  • REPRODUCTION: Happens all the time. 
  • EXPECTED RESULT: Should see the current tank (currently 23)
  • OBSERVED RESULT: See a random rank, which varies up and down per mission.
  • REPRODUCTION RATE: Every mission.
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Helminth Segment Blueprint not having "owned" checkmark
  • VISUAL

PJgVosM.png

OgjHNaI.jpg

8p6aAuy.png

  • REPRODUCTION: Allways
  • EXPECTED RESULT: Checkark at item and being able to filter by "Hide owned"
  • OBSERVED RESULT: No checkmark, cant filter by "Hide owned"
  • REPRODUCTION RATE: Allways
Link to post
Share on other sites

Still unable to fish with deimos spears, I completely lock up. I don't know why it was assumed it's when you hit a fading fish, when feedback from everyone specifically said that was not the case.

I've reported already that locking up seemed to be when hitting any item, but I did some testing today hoping the fix had made a difference, and locked up just missing a fish I was trying to catch and hitting the water.

 

I don't usually say this, but this is game breaking, this and thaumica not dropping from mining.

This may be an issue where people without the sunpoint drill widgets get it, and people with the widgets don't. I say that because I was farming with a friend who didn't have the widgets, and he mined 134, and I mined, as per every other mining trip I've taken, a total of 0. I have only obtained it from vaults and it is not common to see it in them. 

 

Because DE has almost implemented a mandatory playing of every type of activity, people need to be able to do fishing, mine, and do conservation to use the token system and get resources from each to make all the weapons and such. Furthermore, you are forced to choose between using resources to build all the stuff from the Necralisk and trading your tokens in for grandmother tokens or faction.

Some people don't like all the open world activities that DE has made.

 

These are things that I find it hard to believe were not something the devs were aware of.

 

If you would just open a test server and give people a month in advance to test your content, instead of continually making PC test for bugs, you could release content without as many bugs and reduce player burn out and/or leaving.

It would help if priority bugs were actually handled and something reported was explored fully to make sure everything related was working properly. It would also be great if DE stopped ignoring the player base when they report issues.

 

I don't want to complain about the nerf of M4D but it's kind of weird how fast DE can respond by nerfing things that are too popular (I really do believe the "not intended" posts are in bad faith and popularity is the metric you use, based on your own comments,) but they seem to be unable to fix the things that are completely broken in the game in any timely manner.

Edited by SpicyDinosaur
Link to post
Share on other sites

Also, the 2nd deimo fishing spear, the more expensive one, still sometimes alert fishes as they sped away the moment I throw my spear at them. The spear description said it is totally quiet and the fishes won't know it. So either it's a bug or the description is meant to mislead.

Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Avionics in end mission screen shows as warframe mods
  • VISUAL

W5YQRAj.jpg

iJoOzFY.jpg

  • REPRODUCTION: Finish mission in railjack mode
  • EXPECTED RESULT: Correct, Avionic visual
  • OBSERVED RESULT: Mods visual
  • REPRODUCTION RATE: tried only once for NW - cant tell rate
  • Like 1
Link to post
Share on other sites
  • TYPE: In-Game
  • DESCRIPTION: Was in my necramech in the Cambion drift, when to fight the hostile necramech, gets "killed". Goes back to warframe without being able to you my abilities.
  • REPRODUCTION: Summon necramech, go into operator mode in the caves, die, and get thrown back into the surface.
  • EXPECTED RESULT: I can go back into my operator, and use all my abilities, and swing my melee.
  • OBSERVED RESULT: Normal movement, can only use my primary and secondary.
  • REPRODUCTION RATE: Very rare, since the prerequisites must be calculated.
Link to post
Share on other sites
  • TYPE: In-game
  • DESCRIPTION: When releasing unguilded sly vulpaphayla to Son, I received no son tokens
  • REPRODUCTION:  release unguilded sly vulpaphayla to Son in experimental procedure tab
  • EXPECTED RESULT: get 10 son tokens, lose vulpaphayla
  • OBSERVED RESULT: got nothing, lost vulpaphyla
Link to post
Share on other sites

I am not sure if this is a bug or just a change in the game, but I've played for a few days always with the 'exit' option at the end of missions and, since today, that option is gone. I have to press ESC to leave. I don't know if I'm still getting the loot from missions without the 'exit' button. Sorry if it's not a bug, I'm very new to the game.

 

  • TYPE: In-Game
  • DESCRIPTION: End-of-mission screen does not show 'exit' option.
  • VISUAL

Warframe0000.jpg

  • REPRODUCTION: Finishing missions.
  • EXPECTED RESULT: 'Exit' option next to 'repeat mission' option.
  • OBSERVED RESULT: The only way to exit is by pressing ESC and I'm not sure if I'm still getting the loot from the mission.
  • REPRODUCTION RATE: After every mission except free roam.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...