Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Helminth not working/subsume logs me out (Fixed)

(XBOX)Fatal o0o King

Recommended Posts

Ok, so im playing on the xbox one s and i just installed my new helmith to subsume. Ive fed the helmith to get the 3 things i need to subsume rhino and everytime i type confirm, i get a message that says "failed to connect to server. You will be logged out". Ive reset my game, power cycled my xbox, reset my net, cleared mac address and everything else i can think of. My friends helminth works but mine is a waste of space and hours of grinding for nothing. Please fix this bug!

Link to comment
Share on other sites

Newly installed Helminth segment, fed it, etc.

- Had Nekros Prime equipped, UI indicates primes cannot be subsumed as expected, no option to select another frame

- Switch to the frame I want to subsume (Mesa w Tennogen stuff attached), UI indicates it can be consumed, confirm and then get => "Failed to connect to server.  You will be logged out."

- Reloaded, removed all fashion frame stuff, weapons, companions, etc  etc same result.


This has happened 5x now.

Update: Also power cycled my xbox, same results.  The Helminth is just broken.

Link to comment
Share on other sites

I even uninstalled and reinstalled the game. Tried making sure it wasnt rhino that was bugged as well. I switched through several frames (non prime frames) and nothing worked. Just keeps logging me out everytime i type confirm. Ive grinded my a** off for nothing. I really hope someone sees this and provides some information on what the issue is.


Link to comment
Share on other sites

  • 2 weeks later...
On 2020-09-02 at 7:46 PM, (XB1)Sandman3269 said:

Whatever yall did I was finally able to sacrifice a frame ty ty ty

On 2020-09-02 at 7:55 PM, (XB1)Fatal o0o King said:

Just tried subsuming and i was FINALLY able to subsume my rhino. No idea what you have done but mine just worked for the 1st time since i installed it. THANK YOU!

Glad to hear it! It looks like it resolved itself with the update and hotfixes. We were looking at it from a network stability related issue, so its possible that there was resolution on that front from player end. So if it starts to act up again let us know :) We actually have a fix that needs to go through Cert that will hopefully prevent this in the future - so that'll be coming in the next update.

Thanks for checking back in, Tenno! Happy subsuming. 


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...