Jump to content

C'mon DE-- oh wait, they fixed it... almost


Recommended Posts

THEY FIXED IT! I can't believe it, so much time has passed-- *Sniffle* 😥 I- I had almost lost hope 😭😭😭, but they did it. And honestly, they did a better job of fixing it than I thought they would. They fixed nearly all of the problems which people were complaining about, as well as some that I hadn't even noticed until they fixed it. But there are still a hand full of small problems I noticed right away, but they're nothing compared to the mess mobile forums was before, so I wouldn't be surprised if DE & Invision just ignored them.

 

Small issues I've noticed with forums even after the update fix:

-There are 27 editing tools available to use when on the pc version of warframe forums, but on the mobile version there are only 7.

The mobile version:

KRlOH08.png?1

The pc version:

yFx82j3.png

-This isn't specific to the mobile version, but the way a spoiler tab is set up, you often can't move it after filling it with text. The way the spoiler tab is now, you can only move it from the top left, which is fine, so long as you don't want to move it down. And it doesn't function the same way your mouse does when selecting text. If you try to drag down while moving a spoiler tab, it doesn't scroll to the bottom of the page. Right now, the only way to move a spoiler tab down after having filled it, is to empty it first, which sucks. One easy fix would be to allow the spoiler tab to be moved from the bottom as well.

 

 

Back when mobile warframe forums was still bad:

Spoiler

Warframe forums has been left pretty deformed after the recent update.

Sure, they ended up fixing this problem👉 4e0d9183aa1abef797a7a83a6db63173.png but the mobile version of forums is still an absolute abomination.

 

Just in case you don't use the mobile version, Here are some of its newest features since the recent update 🙂:

-The profile tab... gone

-Account settings not accessible

-Can't view list of posts you've made in the past

-Notifications not working properly

-There's a giant pointless empty space to the right of the page

-Sometimes text gets locked into a certain color and cannot be reverted to automatic (I think this was always a problem, even before the update, but I thought I'd throw it in the list anyway)

-You can't edit or comment posts when using safari and a number of other internet browsers (This was also always a problem, even before the update, but I thought I'd throw it in the list too)

-Also, not necessarily about mobile version, but now you can only see a post's view/ reply count as decimal when in the thousands. That's a downgrade, change this back please.

 

Also, this is what the mobile version looks like now (Need I say more?):

308d05da346f0c1e65cdfddf5fa09213.png

 

Other Grievances: (I tried to make these actual quotes, but couldn't make it work on the OP)

Me (this one's not a quote): Lately, if all I have is my phone and I want to check up on one of my posts, I have to go into the search bar on the forums website to find it. But lately even that hasn't been working, some of my posts just aren't showing up. So instead I have to search for a different post that I made, and from there go into my account. Then scroll down until I finally find the post I was looking for... Gahhhh!!!

Lei-Lei_23 said:

"On mobile, even with desktop mode requested, I still don’t have my Profile linked and shown on the top right (just like how it’s shown on the OP’s pic).

It’s been like this since the forum’s changed.

I’m on Safari, iPhoneXR, iOS 14.0. Does anyone know what to do to make it appear?

edit: Disregard. A quick google search on Invision Community forums desktop mode detailed that you have to completely minimize Reader View in order to request Desktop Mode and show my Profile Link. This is really jank.

edit2: AND you need to rotate your phone to widescreen in order to fully utilize desktop mode for the forums. Really, REALLY JANK."

thowed said:

"Old forums were better.  Hate when companies won't just admit a mistake and change things back."

Talinthis said:

"yeah mobile version is very poor too. cant look at your profile or who responds to your messages. they usually fix things in about two years so dont worry!"

GearsMatrix301 said:

"I just hope it’s a sign that the forums are still being worked on. I need my toolbar back :("

Lei-Lei_23 said:

"Yeah, on mobile the accessibility is very limited. You’re forced to zoom out to 50% Reader View and have your phone or mobile device tilted sideways in order to expand to desktop mode, giving you the full amenities of the forum options. It wasn’t like this before, or at the very least the only options affected was certain post privileges like bullet/number points etc. Prior to the changes you could access your Profile, Notifications and Latest Staff Replies, and the forums form-fitted themselves to the view of the mobile device’s screen without breaking toward the right and portraying empty space.

This is just very inconvenient."

 

Edited by (XBOX)Mentor0fHeroes
  • Like 2
Link to post
Share on other sites

Golden Globes Reaction GIF by IMDb

Ok, I guess kids this days expect more.

 

14 minutes ago, (XB1)Rez090 said:

So your first thought is to blame DE, even though they don't control the development of the forums.

However they hire people that manage those stuffs. So yeah, they are partially to blame...
... however it's so insignificant that I'm not sure if I should laugh.

  • Like 6
Link to post
Share on other sites

oh I didnt even notice. Dont forget that they forgot to give us dark theme on the day they redesigned the forum look a bit. The mobile version is just a trainwreck currently. For anyone curios I give you 3 tasks:

  • Login (or out)
  • Search for the latest staff replies
  • zoom out

The reward for completing (or failing) these tasks is a headache.

It looks like they just got someone from fiverr to update the forum for them.

  • Like 3
Link to post
Share on other sites

On mobile, even with desktop mode requested, I still don’t have my Profile linked and shown on the top right (just like how it’s shown on the OP’s pic).

It’s been like this since the forum’s changed.

I’m on Safari, iPhoneXR, iOS 14.0. Does anyone know what to do to make it appear?

edit: Disregard. A quick google search on Invision Community forums desktop mode detailed that you have to completely minimize Reader View in order to request Desktop Mode and show my Profile Link. This is really jank.

edit2: AND you need to rotate your phone to widescreen in order to fully utilize desktop mode for the forums. Really, REALLY JANK.

Edited by (PS4)Lei-Lei_23
  • Like 1
Link to post
Share on other sites
22 minutes ago, quxier said:

However they hire people that manage those stuffs. So yeah, they are partially to blame...

... however it's so insignificant that I'm not sure if I should laugh.

No they don't, another whole separate company develops and maintains the software and hardware for the forums. Literally, their name is on the bottom of the screen.

Link to post
Share on other sites
26 minutes ago, Drachnyn said:

oh I didnt even notice. Dont forget that they forgot to give us dark theme on the day they redesigned the forum look a bit. The mobile version is just a trainwreck currently. For anyone curios I give you 3 tasks:

  • Login (or out)
  • Search for the latest staff replies
  • zoom out

The reward for completing (or failing) these tasks is a headache.

It looks like they just got someone from fiverr to update the forum for them.

 

2 minutes ago, (XB1)Rez090 said:

No they don't, another whole separate company develops and maintains the software and hardware for the forums. Literally, their name is on the bottom of the screen.

From about fifteen seconds of using right click: 

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>9RFSBS2SDZ6Q0WBG</RequestId>
<HostId>GqUtO6bFS6ynWw4lMkAB9N3ba9t746cy1V1a/UvEYx00QMTGGBssHbjZB6HSKqWqBVRHWnXAG2Y=</HostId>
</Error>
 
from 
 
content.invisioncic.com
 
which is a forum platform from 
 
https://invisioncommunity.com/buy/cic/ 
 
It could be denied for multiple reasons, but one of the most basic reasons could be... Invision did maintenance. 
  • Like 1
Link to post
Share on other sites
15 minutes ago, (XB1)Rez090 said:
39 minutes ago, quxier said:

 

No they don't, another whole separate company develops and maintains the software and hardware for the forums. Literally, their name is on the bottom of the screen.

So, you are telling me that Invision people manage this forum for free? Don't joke.
They are paying Invision people money, that's for sure. We just don't know details.
ps. unless there is some free plan

Link to post
Share on other sites
22 minutes ago, (XB1)Rez090 said:

Why are you even quoting me? That is literally what I said in my post, the forums are designed and maintained by another company. Quoting me wasn't even necessary.

As it's your point I'm fleshing out, since clearly no one else was willing to make the simple observations and weren't taking "not the right company you're complaining to" as an answer. 

Link to post
Share on other sites
3 hours ago, quxier said:

... however it's so insignificant that I'm not sure if I should laugh.

It's not really about the broken logo forums pic. If that were the only thing wrong with forums then I wouldn't have made a post about it. It doesn't effect me and I would assume they would fix it whenever they got around to it. But this is not the first thing to go wrong with forums since the update. There appears to be a pattern forming and not the good kind.

This post isn't me saying they made a mistake in forums, this post is me saying they made YET ANOTHER mistake in forums, and the mistakes are beginning to accumulate. This isn't just about the picture, this is about the trend.

And on top of everything that has gone wrong with forums so far, don't you think messing up your own logo is a bit unprofessional, or at the very least embarrassing? I know I'd be embarrassed. If I were in charge of warframe forums and found out about this I would drop everything and fix it right away.

Edited by (XB1)Mentor0fHeroes
Link to post
Share on other sites
4 hours ago, (XB1)Rez090 said:

So your first thought is to blame DE, even though they don't control the development of the forums.

Well... yeah. I didn't know Invision oversaw warframe forums, but DE has their signature all over this website, was it so crazy for me to think they are the ones to blame? And in all likelihood they are still partially responsible, but that's hardly the point.

It doesn't really matter who is to blame, only that something is wrong and it needs to be corrected. And I'm not just talking about the picture, I'm talking about warframe forums as a whole. This update has made the mobile version unusable and the laptop version is just a little bit worse than it was before. Whoever is responsible needs to fix what is broken here.

Edited by (XB1)Mentor0fHeroes
Link to post
Share on other sites
3 minutes ago, (XB1)ShadowBlood89 said:

look at the bottom of the page an it says "Powered by Invision Community"

Someone else said something similar, this was my response:

2 hours ago, (XB1)Mentor0fHeroes said:

It doesn't really matter who is to blame, only that something is wrong and it needs to be corrected. And I'm not just talking about the picture, I'm talking about warframe forums as a whole. This update has made the mobile version unusable and the laptop version is just a little bit worse than it was before. Whoever is responsible needs to fix what is broken here.

 

  • Like 1
Link to post
Share on other sites
5 hours ago, (XB1)Rez090 said:

Yes but Invision still made the software and is hosting the forums on their servers. If something goes wrong on the forums, there is only so much that DE can even do.

Doesn't matter. It's DE's responsibility 100%, as a large video game company, to keep their forums working smoothly. 

Even if they outsourced it entirely, which I doubt, then they are to blame for outsourcing it. It doesn't shift the responsibility from DE in the slighest. 

If as a company you have something you are supposed to maintain, and it isn't maintained properly, you don't shift blame when the consumer complains by saying "but I outsourced it to a third party!" you say "sorry about that inconvenice", and you get it fixed, even if it means changing third parties, putting pressure on them, or switching to doing it yourself. You fix the problem. You don't take a lazy cop out by going "but it's a third party so it's not my fault" and ignore the issue. That's just bad customer service and not how a competent company works. 

Edited by Tesseract7777
  • Like 6
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...