Jump to content

Warframe stuttering every few seconds with FPS drop.


Recommended Posts

As the title says, recently I've started to experience a permanent stuttering of Warframe with the screen freezing for like half a second and my FPS dropping from 60 to 42 every 5-ish seconds.

If you want to have an idea of how it felt to play, I've found a couple of pretty old videos on youtube that match what I'm talking about (not mine and probably not the same issue, but similar results) https://www.youtube.com/watch?v=DfjEOPB8ZTk https://www.youtube.com/watch?v=X0PlK4YlluQ

I've already fixed the problem, but I'll share my testing procedure for other to see. Scroll to the bottom if you're not interested.

  1. I'm on a less than 1yo computer with RTX2080 so I was sure the problem wasn't just hardware but some software config or driver, so first thing I updated all the drivers, verified the WF files, optimized the cache and closed all the other programs in background. No improvement.
  2. I've read a lot of posts talking about how it could be a VSync problem, so I played around with in-game settings and NVIDIA Control Panel. No improvement.
  3. Last time I had a similar issue, it was because of stupid overlays, so I've checked
    • Steam (right click on Warframe > Properties > set both Steam Input Per-Game Setting overlays to "Forced off")
    • Windows (Settings > Gaming > Xbox Game Bar, and Settings > Gaming > Game Mode both set to off),
    • Discord (Settings > Overlay > Enable in-game overlay set to off).
  4. Since there was still no improvement, I delved deeper and found out that a recent Windows security update forced an anti-exploit setting for all the applications that was causing stuttering on several different games (none of which I had installed, so I didn't know any better). To revert it back go on Windows Settings > Update & Security > Windows Security > App & browser control > Exploit protection settings > set both Force randomization for images (Mandatory ASLR) and Randomize memory allocations (Bottom-up ASLR) to "Off by default"

This step, after several hours of trials, googling and reading forum posts, finally made the stuttering go away and made the game enjoyable again.
I'm aware this is not strictly a Warframe-related issue, but this may help others in the same situation and I hope [DE] manage to replicate the issue and work on a fix that doesn't involve shutting down a security feature on Windows (regardless of how controversial its forced application is).

TL;DR
Windows forced anti-exploit settings made Warframe stutter.

  • Like 2
Link to post
Share on other sites
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...