Jump to content

Archived

This topic is now archived and is closed to further replies.

Kynian

Need Help With Directx! (Screenshot!)

Recommended Posts

Thanks Rikov,  thats what I was looking for.  I don't know how you figured that out.

 

Though the directory for me was: steam/steamapps/common/warframe/drivers/directx9

Share this post


Link to post
Share on other sites

Thanks Rikov,  thats what I was looking for.  I don't know how you figured that out.

 

Though the directory for me was: steam/steamapps/common/warframe/drivers/directx9

Ah, I figured it out because it was what I had to do with BF3, and after trying to find some way to fix the DirectX problem and coming up with nothing, I figured I'd just go "Might as well try it when I run the launcher" and it worked.

Share this post


Link to post
Share on other sites

Wanted to update that the patch did not resolve this issue,  but the work-around still works after the patch.

Share this post


Link to post
Share on other sites

*Sigh.* I have found a 'fix" for this. It is no solution, but it will allow you to play the game at the very least. You need to go to the steam/common/warframe/drives/directx9 folder and then run the launcher. As SOON as you run the launcher you need to remove every file except 3 from the directx9 folder, the three fires are DSETUP.dll, dsetup32.dll, DXSETUP.exe, do this AS SOON as you run the launcher and it should fix the direct x cannot update problem.

 

Please note, you will have to do this EVERYTIME you run the warframe launcher, it is a hassel but at least you can play the game. I put in a support ticket, and am hoping to have this little addition removed from the launcher's required assets, it should be an optional thing.

Thanks a lot, working for me... for now. :)

Share this post


Link to post
Share on other sites

I have a Direct X problem, I am playing on my laptop and my systems are more than suited to run Warframe smoothly, but sometimes when it gets heated slightly or just by random chance my Direct X 11 is deactivated, so when I play Warframe it is terribly laggy and it's pixelated alot more than usual. I can still run the game but the gameplay is so bad I might as well not play it. After I shut my Laptop down and vent it out a bit, Direct X is back and the gameplay is legendary as Warframe usually is, but I want to fix this error as it is annoying me and messing up my schedules x.X

Does anyone else have a similar problem with Direct X?

Share this post


Link to post
Share on other sites

Looks like a bug with the Warframe launcher, I assume my DirectX version is actually too new for the game and it thinks it can't update. As you can see the update works perfect if you run it yourself but the launcher still errors. No idea why you can't bypass this message either because there's every chance the game would still work anyway (I mean it was working yesterday so why not today?).

 

Since there are posts about this issue from last year I guess the only way to fix it is to reinstall Windows entirely as they don't plan on fixing it or adding a bypass.

 

 

ssCiHND.jpg

 

AbJzFSh.png

Share this post


Link to post
Share on other sites

I recently had this error while trying to log-in the game, and in this topic someone said to go to http://www.microsoft.com/en-us/download/details.aspx?id=35 and run that, as soon as I ran the program I got an error telling me that some DirectX files were missing or corrupted and it couldn't be executed, so I did some digging and found a reply in Microsoft Support forums from a Microsoft support guy that said: 

 

"If that (the above link) doesn’t help, then try installing it in clean boot state and check if it helps:

http://support.microsoft.com/kb/929135

NOTE: After you have finished troubleshooting, make sure you put back the computer to normal startup mode."

 

So I followed the steps in the link, restarted my computer, tried running the program again and it worked, then I started Warframe and it downloaded everything it had to download and I managed to get in, so I set the computer back to the normal startup mode, restarted my computer again, and now Warframe starts correctly without any problem, hope it helps.

Share this post


Link to post
Share on other sites

Rikov Thank you so much, as annoying as that work-around is It is the only thing that has worked for me. Thank you so much after 3 days of essentially bashing my head into my desk I can finally play!

 

I really really hope they fix the Launcher to make checking directX version optional this is highly annoying!

Share this post


Link to post
Share on other sites

it's not a fix per se but if you click into the launcher settings and click verify, let it run it will run normally afterwards. not exactly sure how to permanently fix this though.

Share this post


Link to post
Share on other sites

×
×
  • Create New...