Jump to content

End of Mission Reward Bug - Credit Caches are not being granted


Recommended Posts

Missions: SPY, SABOTAGE, EXCAVATION
Problem Description: At end of mission, credits earned from Cache, Vault or Round Rewards are not being applied to player credit total.

Example: Went into a Spy (Oceanum, Pluto) Mission with exactly 5,000,000 credits.
Earned 18,072 (pickups, reward, credbooster, vault cache) credits, which shows in Mission End breakdown screen.  However, my credit total is only 5,015,572 - exactly 2500 credits short of what it should be.  The Vault credit cache is exactly 2500 credits.

Problem also occurred on Sabotage (Cervantes, Earth), and Excavation (Heiracon, Pluto)

 

  • Like 3
Link to post
Share on other sites
  • 3 weeks later...

This just happened to me and a friend as well. Twice in a row.

Second time I recorded it and uploaded it to youtube: https://youtu.be/pEx-I19mNm8?t=570

As you title says, "regular" credits work as intended, but caches don't.

Tried a third time today, failed again. That's 3/3 attempts that have failed to pay out credit caches. If this persists it really gimps my ability to earn credits. :sad:

Not only did I missed out on 390k cred today because of it, but everyone on the same team as me experience it as well 😞

Originally posted about it here: https://forums.warframe.com/topic/1235522-why-are-credit-caches-rewarded-from-mission-end-screen-not-payed-out-multiple-attempts-solution-probably-a-bug/?do=findComment&comment=11930995

Edited by AnorZaken
Changed the link to a follow-up post that explains the problem with more clarity perhaps
Link to post
Share on other sites

Tested again today.

Credit Caches are still not being payed out. (Had just slightly over 100k prior to this mission.)

5SqTI8D.png

Was payed the 268k, and the 104k,

But not the 360k from caches. :sadcry:

Did two more shorter runs after the above one - same problem. 😢

Edited by AnorZaken
Link to post
Share on other sites

I can confirm this happening for me as well.

I needed credits since I only had 5k left, so I did Laomedeia on Neptune, since that rewards only Credit Caches and the occasional Universal Medallion.

Did three full rounds of Disruption, got 81k from it being my first mission of the way, 31k from pickups and x11 10k credit caches for a total of 110k Credits.

Except that I didn't actually get the credits for those credit caches.

And since Laomedeia, as mentioned, gives only credit caches, that means I did three full rounds of Disruption for no ding-dang reward at all. (Ok, technically I got a reward in the form of the credits from mission and pickups, but if I'd done a different Disruption, I'd have gotten that and three relics).

Edited by RobrechtvE
  • Like 1
Link to post
Share on other sites

Received a reply to my support ticket today:

Quote

Hello AnorZaken,

Apologies for the delay in responding to your request, we are currently experiencing an extremely high volume of tickets. Thank you so much for your request and your patience with us.

Thank you for letting us know. I will pass this information along to the rest of the team to look at. Unfortunately we don’t have any further information about this at the moment, but we'll be sure to follow up with an investigation.

You can stay up to date with the latest changes in Warframe by keeping an eye on our patch notes:
Warframe PC Update & Build Notes

Thank you for taking the time to contact us.

I'll keep posting if I get any more updates.

Edited by AnorZaken
  • Like 1
Link to post
Share on other sites

This bug is especially annoying since I'm always low on credits. My mod upgrading has stalled, since the last levels require .75 - 3Mcreds per level to upgrade.

Cheers!

O/T, but Before someone suggests: I just abhor Index's gameplay. It's like Unreal Tournament 2004 but 3rd person shooter instead of FPS, against bots without real people, and worse in every other way, too. My main source(s) of credits are Arbitration and Seimeni at the moment, and I'm trying to gain enough rep with Solaris United to try out Profit-Taker Orb, to see if that mission is more worthwhile gameplay-wise and to earn credits. Also, I "clean out" my inventory regularly.

Edited by WildPenguin82
Not vox sol but United!
  • Like 1
Link to post
Share on other sites

Actually got a new reply pretty fast this time! 😀 (I mentioned that others have started to complain about the same issue now, so not just me anymore)
 

Quote

We're sorry that you are experiencing this. However, the forums is still the best avenue for your request and feedback as this allows other players with similar issues to chime in and at the same time give our developers a better sample of the issue.

Rest assured though that we will relay the information you have provided through the proper channels.

Thanks again for contacting us and we do hope you continue to enjoy playing Warframe.

 

  • Like 1
Link to post
Share on other sites

Glad to hear that it's reached the relevant ears, just gonna repost my own screenshots from Zaken's thread for further confirmation:

Spoiler

Ended the mission (also Disruption on Laomedeia, Neptune) with 357,051 credits and expecting a 796,862 payout for an expected total of 1,153,913 credits.

https://i.imgur.com/LKvAGx3.jpg

Instead only came away with 893,913 credits total; 260,000 down the drain, presumably from the 26 10k credit caches earned in the mission.

https://i.imgur.com/G0KQKFm.jpg

 

Link to post
Share on other sites

can confirm this: tested it with a quick solo excav on pluto, got 2 times the 3k cache reward and exactly those 6k creds are missing when the total amount of creds getting added to the account after the mission.

wouldn't that be a good time to finally remove the cache rewards for good? at least do so for steel path, because who needs credits that much at this point - usually we have millions upon millions then and nothing to spend them on...

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Same problem here and still not fixed and i am running out of credits and that missions seems to be the best way to get credits fast and now its not really worthy so i hope it get fixed fast because it took too long and its really annoying 

- is it fixed for you guys or same problem

 

Edited by OnE._.TargeT
  • Like 2
Link to post
Share on other sites
On 2020-12-06 at 4:12 PM, OnE._.TargeT said:

Same problem here and still not fixed and i am running out of credits and that missions seems to be the best way to get credits fast and now its not really worthy so i hope it get fixed fast because it took too long and its really annoying 

- is it fixed for you guys or same problem

 

It's not fixed yet.

Like a week ago they closed the ticket. Apparently tickets auto-close unless the OP makes a new reply to the ticket. 
As soon as I made a new post on the ticket it automatically was set back to open.

....
It seems a little counter intuitive though considering the support staff is telling me to sit tight, wait, and read the release notes for upcoming patches - but unless I bump the ticket every month it closes automatically. 🙃

Edited by AnorZaken
  • Like 1
Link to post
Share on other sites

I do have the exact same issue.

I noticed it first on Laomedeia, Neptune, disruption, where the actual payout was roughly 30k credits short of what it should have been (I did get 3x10k credit cache).

Then I did a short test on Everest, Earth, excavation. I did get a 2'000 credit cache from the first excavation. The end screen said 9'014 credits but the payout was 7'014.

On Cambria, Earth, spy, the payout was again 1x1'500 credit cache too low. Thus it does not seem to be related to the mission type.

  • Like 2
Link to post
Share on other sites
  • 2 weeks later...

All righty, I posted about Spy mission rewards not seeming to pay out 3 Identified rewards. Turns out Credit Cache got moved to total credits payout (bad as it causes confusion). Worse, when DE changed that, they indeed broke actual rewarding of those as I found out the next time I did Disruption Spy to test my initial question. So I ended up here, You're having a good run I see, up since October 29.

  • Like 2
Link to post
Share on other sites
  • 2 weeks later...

Yeah did a few runs yesterday because Index is very boring (just waiting for enemies to spawn 70% of the time). Putting in multiple keys simultaneously you get a lot of fun action, and since the rewards don't work there is no down-side to just go ham with the keys, but yeah.... I've lost track of how many millions of cred the game has failed to pay out at this point.

Keep in mind that you only need to defend one conduit per round! The reward for a better defense is more Credit Caches... oh wait.

Put in every key you see, making sure you kill at least one demo unit per round to not fail the mission, and advance through the rounds as fast as possible. 🙄
(The support ticket had auto-closed again due to inactivity, so bumped it again to keep it alive.)

  • Like 1
Link to post
Share on other sites

I have the same issue: Reward-screen shows credit earnings of 528,670 but total credit bank only moved up to 277,364.

I am only playing for a few weeks (pretty regularly though) and this bug really annoys me - especially since I decided to invest quite some money in this otherwise awesome game.

 

  • Like 1
Link to post
Share on other sites

checking during the mission, during Laomedia it specifically said around 219k credits, however, testing if the pickups are really that much or if that is already the caches added onto it, we only got 21k from Lua Disruption, that mission type does not have credit caches.

So our working theory is that it is wrongly adding the caches onto the final result double, meaning that we are getting the right amount of credits, just getting shown double the cache for some reason. Thoughts?

Link to post
Share on other sites

So this is definitely just a display bug as I ran a few tests on Laomedeia last night, didn't take screenshots but took lots of notes regarding credit values.

Essentially after extraction a percentage (not consistent, I don't know what determines it) of the cache money is added to your Mission Credits (what you picked up) and the rest to the Credit reward (the credits for completing the node). You can confirm it by checking your Mission Credits just before you extract and then comparing against the value the end of mission screen shows which will be higher (much higher for longer runs). If you work out the difference then subtract that from the cache total then subtract what's left of the cache from the Credit Reward you will end up with 3400 which is the standard reward for Laomedeia. This value is consistent with other missions on Neptune, the exterminate awards 3800 per run. The problem ofc is that it then adds the cache value again to the displayed credits but doesn't give you them, leading to folk thinking they aren't receiving the full reward.

Here's the SCIENCE bit 🙂, so for example: I picked up 701 credits in a run but the end of mission screen showed I picked up 5829, the difference being 5128. If you subtract that from the cache value (30000) you have 24872 left. The credit reward was 28272, so take away the remainder of the cache from it and you have 3400, the actual reward. The end of mission screen showed 64101 total but ofc I had only gained 34101 which is correct when you add actual Mission Credits and Credit Reward to the Cache value.

The fact that folk were looking at doubled credit rewards and thinking "Yup, that looks about right!" shows that hope truly springs eternal. 😁

 

  • Like 1
Link to post
Share on other sites
10 hours ago, CaitSidhe said:

So this is definitely just a display bug as I ran a few tests on Laomedeia last night, didn't take screenshots but took lots of notes regarding credit values.

Essentially after extraction a percentage (not consistent, I don't know what determines it) of the cache money is added to your Mission Credits (what you picked up) and the rest to the Credit reward (the credits for completing the node). You can confirm it by checking your Mission Credits just before you extract and then comparing against the value the end of mission screen shows which will be higher (much higher for longer runs). If you work out the difference then subtract that from the cache total then subtract what's left of the cache from the Credit Reward you will end up with 3400 which is the standard reward for Laomedeia. This value is consistent with other missions on Neptune, the exterminate awards 3800 per run. The problem ofc is that it then adds the cache value again to the displayed credits but doesn't give you them, leading to folk thinking they aren't receiving the full reward.

Here's the SCIENCE bit 🙂, so for example: I picked up 701 credits in a run but the end of mission screen showed I picked up 5829, the difference being 5128. If you subtract that from the cache value (30000) you have 24872 left. The credit reward was 28272, so take away the remainder of the cache from it and you have 3400, the actual reward. The end of mission screen showed 64101 total but ofc I had only gained 34101 which is correct when you add actual Mission Credits and Credit Reward to the Cache value.

The fact that folk were looking at doubled credit rewards and thinking "Yup, that looks about right!" shows that hope truly springs eternal. 😁

 

It was a bit confusing to follow, but essentially you are saying:

  • You picked up 701 credits
  • You should get 3400 credits from the mission
  • You should get 30,000 credits from the caches

That totals 34,101 credits, and that's what the game gave you - but the reward screen reports all kinds of numbers wrong.

Great work looking into it, I will pay more attention and do some more test-runs of my own, maybe tonight. 🤠

Edited by AnorZaken
  • Like 1
Link to post
Share on other sites
15 hours ago, AnorZaken said:

It was a bit confusing to follow, but essentially you are saying:

  • You picked up 701 credits
  • You should get 3400 credits from the mission
  • You should get 30,000 credits from the caches

That totals 34,101 credits, and that's what the game gave you - but the reward screen reports all kinds of numbers wrong.

Great work looking into it, I will pay more attention and do some more test-runs of my own, maybe tonight. 🤠

Yeah essentially. The end of mission screen displays the Mission Credits and Credit Reward wrong as it adds the cache value to them but then adds the caches themselves again to the total.

I guess my maths example is a little confusing :) but basically I knew how much I picked up (701 credits) so worked out how much extra the display added to the Mission Credits (an extra 5128). Since I suspected that the caches were being added to these values I took the 5128 from the cache value to see how much was unaccounted for (30000-5128=24872). If you subtract that from the Credit Reward you end up with 3400 which is the actual reward for that map node.

It's kinda more confusing because the percentages aren't consistent, it doesn't just add 20% of the cache to the Mission Rewards and 80% to the Credit Reward, there might be a pattern but I have no idea. But the same technique always works as long as you know how much the display added to your Mission Credits and it always leaves 3400 as the real Credit Reward regardless of how many rounds you do (well ignoring first mission bonus/boosters etc).

Link to post
Share on other sites

Sorry for the delay...

My support ticket is now marked as solved, and I cannot reply to it / comment on it any longer.

I did a test run to confirm @CaitSidhe's theory :

  1. Had 6,079,533 cred before the mission.
  2. Picked up 659 cred from killing enemies.
  3. Completed the first round, all conduits: 30,000 cred.
  4. Pressed 'P' just before I exited the level to see my inventory - correctly listed 30,659 cred.
  5. Exited - Mission Success:"64,059" cred.
  6. New account balance: 6,113,366 cred.

Reported gain: 
64,059 = 30k + 30k + 659 + 3,400

Expected gain: 
34,059 = 30k + 659 + 3,400

Actual gain: 
33,833 = 6,113,366 - 6,079,533 = 30k + 659 + 3,174 😵

Discrepancy:
(-)226 = 33,833 - 34,059

That's still wrong. 🤨
But admittedly the error is very small, small enough to not really care about, and just as @CaitSidhereported the cache reward was counted twice when displayed in the success screen - in other words there are no missing millions to be found here, we were too greedy. 😅

Honestly I'm not sure how I feel about this at the moment.
I'm ready to put this behind me, but I am none the less still perplexed by that small error.
Since the ticked is now locked and marked as 'solved' I guess we'll have to wait for the next patch to come out...
The broken UI really fooled me hard, heh.

At this point it has become a fascinating wild ride, and I'm genuinely curious to see what the next patch brings to our missing-cred plot! 🧐

Edited by AnorZaken
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...