Jump to content

Unbearable problem with FPS which makes the game unplayable.


Recommended Posts

Hello,

I began playing the game after a yearlong break and I've been getting a very annoying issue which you can witness on the video. While I can maintain on the highest settings stable 144 fps after sometime or at specific places my FPS are getting massacred. I'm playing on a DELL G5 laptop with an i7 9750h, NVIDIA RTX 2070maxQ and 16GB RAM. I tried verifying and optimising from the launcher with no luck. My nvidia drivers are 457.09. Is there a fix or something to help me with this problem?

Video

Edit: I disabled steam overlay and MSI afterburner, ran the same mission and it was resolved so far. I will test further to confirm if that was the fix.

Edit2: After 2-3 hours of continuously playing I still got low fps, is this a symptom of some kind of memory leak?

Edit3: Problem is still there, after 1-2 hours of playtime FPS are getting massacred with no obvious pattern as to what is causing it. It can happen anywhere and no settings seem to fix the issue. Restarting the game is fixing the FPS issues.

Edited by VERSUz
  • Like 1
Link to post
Share on other sites

I'm not sure if any of this will help you as my fps problems seem to be substantially different to yours, but here are a few things I've noticed causing fps problems in warframe specifically as of the last few months:

Chat, friends, web pages or community hub open in the Steam Overlay causes me terrible lag.

Web pages being open at the same time in google chrome. Generally all websites, but websites with animations or videos seem to destroy my fps more. This one seems to consistently interfere with the foundry worse than anything else, but still causes me some issue outside of the foundry.

Having a controller plugged in with a mouse as well, when the mouse moves it changes from controller to mouse inputs (and visa versa) and during this time I get excessive lag spikes, sometimes lingering until I unplug and plug it back in, or just leave it unplugged.

 

Not sure if this is what you've been dealing with, but I thought it'd be worth mentioning just in case any of this helps.

 

  • Like 1
Link to post
Share on other sites
21 minutes ago, NecroPed said:

I'm not sure if any of this will help you as my fps problems seem to be substantially different to yours, but here are a few things I've noticed causing fps problems in warframe specifically as of the last few months:

Chat, friends, web pages or community hub open in the Steam Overlay causes me terrible lag.

Web pages being open at the same time in google chrome. Generally all websites, but websites with animations or videos seem to destroy my fps more. This one seems to consistently interfere with the foundry worse than anything else, but still causes me some issue outside of the foundry.

Having a controller plugged in with a mouse as well, when the mouse moves it changes from controller to mouse inputs (and visa versa) and during this time I get excessive lag spikes, sometimes lingering until I unplug and plug it back in, or just leave it unplugged.

 

Not sure if this is what you've been dealing with, but I thought it'd be worth mentioning just in case any of this helps.

 

I disabled steam overlay and MSI afterburner, ran the same mission and it was fixed, never thought that they play a role concerning performance, will test further to confirm. Thank you!

Link to post
Share on other sites
22 minutes ago, VERSUz said:

I disabled steam overlay and MSI afterburner, ran the same mission and it was fixed, never thought that they play a role concerning performance, will test further to confirm. Thank you!

That's good to hear! 

This is entirely speculation, but I believe this particular issue may be on steams end possibly as an indirect result of Warframes coding, as it only happened to me after the steam chat system was updated with animated backgrounds/profile pictures etc. 

Link to post
Share on other sites
  • 2 weeks later...

have you tried using the classic graphics engine instead of the enhanced
I can run classic fine at max but with enhanced it doesnt have a good time.

never mind that /|\ didn't watch the video far enough before trying to be helpful
no idea what would be causing that.
something is seriously going wrong though.

Edited by Doom_Gaming
I needed to watch more
Link to post
Share on other sites

I've tried every trick in the book, from changing in game settings to tinkering with nvidia settings to no avail. 

I'm getting stutter and fps dips (more evident in  a squad of 4) which make the game unejoyable since sometime around Nezha prime update.

 

Specs : 32gb ddr4 ram @ 2666mhz 7700k @ 4.9ghz 2060 rtx windows 10 64bit(20h2 version)

Edited by White_Matter
  • Like 1
Link to post
Share on other sites

No idea what the issue is, but I've tried both rendering engines using DX11 on my no graphics card potato notebook and I am getting dips from 45-60 FPS down to 3 FPS in the UI screens in the orbiter and in missions today.  When I started playing this game 1 1/2 years ago my FPS was pegged at 60 all the time, but today the game is unplayable.  I don't know if it's Win10 updates (not going to roll it back again) or the game software, but I'm going to log out for a week and check back next week to see if it's worth trying playing.

Link to post
Share on other sites

Looks like I may have found the solution to my particular issue.   Microsoft supposedly patched  Win10 to prevent manual installs of some incompatible drivers that were causing a looping misbehavior of the OS updater.  It seems, though that it DOES not prevent other apps from installing those same faulty drivers.  My Intel branded driver updater app installed a graphics chip driver that is supposed to be for my chipset on Win10, but the driver appears to be incompatible with my current OS build.  Microsoft's updater meanwhile was trying to install the best driver and failing every time due to the Intel supplied driver being a later release.  Anyway, uninstalling the driver completely and letting Microsoft Update install its version "appears" to have fixed most if not all of my performance issues with this game, judging from a short run through my orbiter.  I'm hoping it fixes the duplicate cursor issue too (Windows cursor enabled on my game screen in UI windows), given that might be lag/FPS related.

Link to post
Share on other sites
1 hour ago, RunsWithChainsaws said:

Looks like I may have found the solution to my particular issue.   Microsoft supposedly patched  Win10 to prevent manual installs of some incompatible drivers that were causing a looping misbehavior of the OS updater.  It seems, though that it DOES not prevent other apps from installing those same faulty drivers.  My Intel branded driver updater app installed a graphics chip driver that is supposed to be for my chipset on Win10, but the driver appears to be incompatible with my current OS build.  Microsoft's updater meanwhile was trying to install the best driver and failing every time due to the Intel supplied driver being a later release.  Anyway, uninstalling the driver completely and letting Microsoft Update install its version "appears" to have fixed most if not all of my performance issues with this game, judging from a short run through my orbiter.  I'm hoping it fixes the duplicate cursor issue too (Windows cursor enabled on my game screen in UI windows), given that might be lag/FPS related.

Thank you for this info! Could you share some more details about the incompatible drivers? Would you happen to know which driver version you had installed when you experienced most of your performance issues, and which driver is installed now?

Link to post
Share on other sites

I have also experienced stuttering and fps drops, which make the game unplayable for me. The problems happen in all missions, open world areas and railjack & in orbiter, when entering various functions, such as mods, foundry, arsenal, navigation, to name a few. My PC (i7-10700 at 4.8GHz, RTX 3080, 32Gb of RAM at 3200 MHz) runs many games more demanding than Warframe without any issues, and it also ran Warframe absolutely perfectly until a Windows update around the middle of November, after which the stuttering began. I'm on Windows 10 Home, version 2004, current OS build 19041.685. It seems most likely that something that came with the update is somehow causing issues, because I've tried to:
-reinstall Warframe on different drives
-made sure files are validated and download cache is optimized
-tried to reduce in-game settings
-try both classic and enhanced engine
-try windowed, borderless windowed and fullscreen modes
but nothing helps, and I'm quite certain it is not a hardware issue. If anyone knows or has any tips on what I should look into to fix this, I would be grateful.

Link to post
Share on other sites
14 hours ago, somnolentsloth said:

I have also experienced stuttering and fps drops, which make the game unplayable for me. The problems happen in all missions, open world areas and railjack & in orbiter, when entering various functions, such as mods, foundry, arsenal, navigation, to name a few. My PC (i7-10700 at 4.8GHz, RTX 3080, 32Gb of RAM at 3200 MHz) runs many games more demanding than Warframe without any issues, and it also ran Warframe absolutely perfectly until a Windows update around the middle of November, after which the stuttering began. I'm on Windows 10 Home, version 2004, current OS build 19041.685. It seems most likely that something that came with the update is somehow causing issues, because I've tried to:
-reinstall Warframe on different drives
-made sure files are validated and download cache is optimized
-tried to reduce in-game settings
-try both classic and enhanced engine
-try windowed, borderless windowed and fullscreen modes
but nothing helps, and I'm quite certain it is not a hardware issue. If anyone knows or has any tips on what I should look into to fix this, I would be grateful.

 

Around Nezha prime update(which I believe broke the game for me) I also installed a(or couple) windows update(s) too.

I also haven't been able to isolate the problem sadly.

 

edit :

I also have a weird stutter in the navigation screen. It is easily replicatable Hovering your curser above mission nodes or holding the mouse button and dragging the screen around seems to reduce the fps, causing a stutter.

 

Edited by White_Matter
Link to post
Share on other sites
On 2020-12-13 at 5:31 AM, Madison said:

Game need to be optimized yes. 

 

On 2020-12-13 at 7:14 PM, White_Matter said:

 

Around Nezha prime update(which I believe broke the game for me) I also installed a(or couple) windows update(s) too.

I also haven't been able to isolate the problem sadly.

 

edit :

I also have a weird stutter in the navigation screen. It is easily replicatable Hovering your curser above mission nodes or holding the mouse button and dragging the screen around seems to reduce the fps, causing a stutter.

 

Yeah i had for years huge drops on warframe but after nezha i was locked on 35-40fps... i play with GTX 1660Ti  and for some reason only on warframe i use only 30% of my gpu... 
GG DE 

Link to post
Share on other sites
  • 1 month later...

Sorry I didn't see the DE Linkski's reply to my post.  My particular driver is very unlikely to be anyone else's problem given it's for an ASUS  notebook from 3 years ago with Intel integrated graphics.  If it becomes a problem again, I'll list the driver version.  I'm holding off installing Intel's newest driver for the chip since Microsoft doesn't list in the optional updates available for my machine.  Hopefully I'll not have to be using this potato for very much longer.

Link to post
Share on other sites

Performance issue came back, but it's a different culprit this time.  This time, Microsoft's most recent (February 12, 2021) feature update hosed my performance.  After the update on that date my FPS would dip to 2-4 FPS approximately every 20 seconds on the average.  The performance of my machine outside of the game was also significantly affected.  My CPU is pretty fast for a 3 year old machine, but apparently Microsoft taxes even a machine normally capable of 4K movie play.  I'm betting that any machine with integrated graphics will take a hit with this most recent Win10 update.  I uninstalled the part of the update not marked as "security update" and my frames went back to a mostly 30-60 range except at the start of cells.

Link to post
Share on other sites
On 2020-12-13 at 12:14 PM, White_Matter said:

 

Around Nezha prime update(which I believe broke the game for me) I also installed a(or couple) windows update(s) too.

I also haven't been able to isolate the problem sadly.

 

edit :

I also have a weird stutter in the navigation screen. It is easily replicatable Hovering your curser above mission nodes or holding the mouse button and dragging the screen around seems to reduce the fps, causing a stutter.

 

Most of the worst pauses in the game are in the UI screens.  It definitely has something  to do with windows and some interaction it has with the game or just the general load on the CPU (pretty sure it's a CPU 100% issue mostly, not a GPU issue, given my machine doesn't have a dedicated one of those).  When the pauses happen, I notice my sound pauses, my game pauses (I'm not in solo mode), and I end up with a windows cursor on my game screen in addiction to the game cursor.  The windows cursor accepts input (can move) but cannot interact with the game elements that are all still visible.  The game cursor on the other hand, along with the rest of the game, is frozen.  I just have to wait until the game becomes active again.  I never saw this behavior outside of a UI screen, but I've had maybe 2-3 instances of it happening during a mission recently (maybe in the last 1-2 months).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...