Jump to content

Deimos: Arcana: Hotfix 29.5.1


Recommended Posts

Hey, thanks for the update, the front of the orbiter looks better, nice surprise. I have collected a few thing for you guys to fix/look into:

  • Apply the tear and wear settings to the front walls of the ship, now parts of the wall seems to be ignoring the player prefernces
  • Xaku Kintsu helmet is clipping with its shoulders (at least on the market it does, I didnt buy it because of this, so I dont know if it is a thing during gameplay)
  • There is a mission breaking bug in railjack, that the doors in PulseTurbine are not opening, therefore the mission can not be completed. Apparently its been an issue over a year.
  • In railjack it seems to be impossible to completely fill up flux energy (possibly other resources too): 706/782 I craft 150 and the ammount stays at 706. 
  • I still think the new UI is terrible in most aspect, but seems to be that you are persistent about it so please fix the following:
    • The intrinsics counter does not update at all, not during mission, not after mission, host can check it at console in dojo, but others seems to need to go back to the orbiter and memorise the ammount of intrinsics point before the mission to be able to calculate how many they got
    • During fast lvling equipment, the UI does not respond after a while: only the lvl of the equipment updates, the progress bar seems to be stuck on max fill, indicating that the equipment only needs a couple of affinity to lvl up, but this is not the case.
    • The importance ordering is still not working properply: for example Steel Essence gets behind relics and certain mods, that I have hundres of. I believe only new mods should be placed on top.
  • I think that the new mastery icons are terrible. The old ones symbolised how the Tenno became more whole in the process of recovering their long forgotten skills and arsenal, reaching the circle (which is the symbol of both neverending eternity and the archetype of wholeness) icon only at the end of the process. The icons followed the Tenno's journey on self-recovery, self-exploration and just like the Tenno: they never changed completley, they just became more whole and each of them contained all the previous icons, which was not only practical in the sense that it clearly showed the experience of the Tenno, but a beautyfull  detail symbolising the Tenno's journey. This detail is completely missing from the new ones: they dont have a clear hierarchical structure and has nothing to do with each other whatsoever.
  • The Voidrig necramech seems to be listed both in the warframe and vehicles category in the profile/equipment menu.
  • Khora got an unannounced nerf: most likely because people used it for Steel Essence farming. Well they wont farm it anymore, as you have removed this possibility (lets be honest, NERFED), but why destroy a frame you had no problem with for year? Not to mention that sliding in "fixes" like this without telling us about it is not very straightforward. 
  • I did not think necramechs can get any worse than they were. They are useless, impossible to lvl, has little to no customization options, and now I gotta form them 5 times to master them, not to mention they are ugly af. Why do you insist on the corn design? I can not even think about them as robots, they are just ridiculous. They are a definite hard pass form me until you figure out how to let us take it into ESO (gear needs to be enabled to deploy).
  • Like 11
Link to post
Share on other sites

Also, Voidrig shows in the warframe section of profile, greyed out, but in the vehicle section as not greyed out and at rank 30 with ofc space to reach 40. Bonewidow only shows in vehicle tab, but i don't have it yet so can't say it won't show in warframe tab too.

  • Like 2
Link to post
Share on other sites
4 minutes ago, MarshallBanana0815 said:

after leaving deimos where i did the new vault missions the hotfix was already deployed.
went to foundry to cancel the bonewidow part, but when clicking cancel and ok nothing happened. tried it several times.
so i closed the game and updated. but now when i try to cancel it tells me i get the scrap back, not the tink. now i tink, is this ui problem, and in fact i get back tink, or would some dev have to tinker with it, because i would indeed only get the scrap back? :tinking:

It is because you cancelled it after the hotfix, so it no longer required Tink, but scrap, hence you got scrap back. Megan has said they will be looking at the back end to try and fix it for those who rushed before the hotfix, so may be worth opening a ticket.

  • Like 1
Link to post
Share on other sites
22 minutes ago, .Raf said:

Is it intentional that I could only obtain 3/4 blueprints for the new K-Drive? I did every single race that's available on the Cambrion Drift, hitting every flag on each of them.

Which races are up each day rotates, so may be there are more than available today. Works that way with fortuna anyway.

Link to post
Share on other sites

good job, good updates here, thank you about the hard work, but...
the following new Deimos Challenges still not working!!! :(

    Bug Out Ride
        Ride 20 Velocipods.

    Jugger-Not
        Kill 5 Juggernauts in Cambion Drift.

    Kill It With Fire
        Burn 100 Infested pods.

several Juggernauts killed in Cambion Drift, as well as Infested Pods and Velocipod riding, and none of the challenges updated.
I just hope that despite not tagging challenges as complete it still records them somewhere so that we don't need to chase that 100 pods after being done with Deimos some time in the future.

I would also like to complement, saying that many old bugs still remain unsolved...
the more new contents appears, the more bugs will appear as well and it will be more difficult to solve the old ones, too!!!  :(

  • Like 2
Link to post
Share on other sites

BUG: Pharoma(fishing tool thingie) disappears after touching the ground.

While fixing that one, could you also have a look at fish pathing? Fishes frequently swim into the ground, making them literally impossible to catch.

Link to post
Share on other sites
1 minute ago, SergeantBanane said:

Infested K-Drive Parts still missing in the Foundry

Once you’ve acquired the Ferverspine, Gristlebuck, Nodulite, and Steeba parts visit your friend Roky in Fortuna to build the Infested K-Drive!   May want to read the patch notes. Parts, not BPs.

Link to post
Share on other sites
18 minutes ago, zaturalma2 said:

Khora got an unannounced nerf: most likely because people used it for Steel Essence farming. Well they wont farm it anymore, as you have removed this possibility (lets be honest, NERFED), but why destroy a frame you had no problem with for year? Not to mention that sliding in "fixes" like this without telling us about it is not very straightforward. 

Also, hitting things with khora's whipclaw is already difficult enough if you don't have max range. She didn't need the nerf.

  • Like 7
Link to post
Share on other sites
1 minute ago, SergeantBanane said:

0xWWkUk.png

Well they worded that badly then, have you tried just searching the name in the foundry? Stupid question i know, but i had to to find the Bonewidow and Morgha parts.

Link to post
Share on other sites

Otak tokens can incorrectly show up as highlighted (purchaseable) even if not enough namalon or heciphron available in player inventory (eg, 2/10 heciphron, 0/9 namalon, token still highlighted)

Confirmed that no obelisk I interacted with spawned enemies during obelisk uptime.

Exchange for family tokens is similarly bugged; I have switched filter to 'requirements met' and none of the exchanges are hidden despite not having met the requirements for them (grandmother tokens also showing as highlighted for purchase, despite not meeting requirements)

Edited by Wyvaud
Additional information and confirmation
Link to post
Share on other sites

Pretty sure Macro Arcroid and Macro Thymoid unintentionally had their names swapped.

 

Looking at standard Arcroid and Thymoid, Arcroid has higher crit and status stats, whereas Thymoid has higher magazine, with slower reload.

Looking at their Macro equivalents, you'd expect to see the same, albeit with the higher base magazine and slower reload of both Macro loaders, however Macro Thymoid becomes the loader with the higher crit and status stats, and Macro Arcroid becomes the one with the higher magazine with slower reload relative to the other Macro loader, which derails the point of a naming scheme like 'Macro (name of smaller loader)', which seems unintentional.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...