Jump to content
General Bug Report Guidelines - Please Read ×

Nintendo Switch graphics worse after Deimos Arcana update


(NSW)AegisFifi

Recommended Posts

First of all, thanks to everyone that have worked hard to give us this excellent new update.

I've noticed that the global graphics, overall the warframe graphics and textures,  got really worse after I've made Deimos Arcana update on my Nintendo Switch. Very often the screen gets blurred. Sometimes, whem the warframe moves, it looks almost as it was pixelated. A friend noticed the same thing. Now, it's hard to play at Deimos, because the bad graphics confuses my eyes and I can barely see the infested.

Is there a reason for this ? Can it be fixed ?

Thank you very much.

Link to comment
Share on other sites

Hey Aegisfifi, it sounds like two different issues -- blurry visuals, and pixelation

We added Temporal AA in docked mode this update which can make things look blurry. I'm assuming this is what you're seeing, could you undock and see if you're noticing the same thing?

Also screenshots / clips are always helpful

Link to comment
Share on other sites

Hi, JoshB,

Thanks very much for your kind answer. I think you are right, even though I don't know what is a Temporal AA. Will it be always like this on docked mode ?

It looks better when undocked and I don't see the screen getting blurred, neither getting  pixelated.. I'm feeling a bit dumb for not having tried to take a look at graphics on undocked mode before.Je

I don't know how to export screenshots or clips to this forum, sorry.

 

Link to comment
Share on other sites

Hello @[DE]JoshB,

I noticed the same issues after receiving the Deimos Arcana update yesterday. Disabling motion blur helped a bit, but the image quality is still much worse than it was before the update. Using the handheld mode seems to improve things, but it is hard to tell because the built-in Switch screen is very small.

If this is happening because of Temporal AA, is there a way to disable it in game settings? If not, what are the options?

Link to comment
Share on other sites

@(NSW)BalticBarbarian,

I noticed that sometimes it gets better, but it is not as it was before the update.

Today, I've made a mission under rainy weather and it was very hard to play because the effect of rain was saturating the screen. Rain was not the way before.

It's still playable, but visuals are not as they were before.

Link to comment
Share on other sites

Hey guys I'm really sorry for the forced temporal AA. It seems like this change isn't being taken too well. I'm looking for a possible fix, but in the meantime there's a workaround you can use -- 

When you swap to docked mode the game will automatically change to temporal AA. You can force it back to old AA by updating your display settings. It doesn't matter what you change in display settings, as long as you change something while docked it should secretly change AA back

Link to comment
Share on other sites

1 hour ago, [DE]JoshB said:

When you swap to docked mode the game will automatically change to temporal AA. You can force it back to old AA by updating your display settings. It doesn't matter what you change in display settings, as long as you change something while docked it should secretly change AA back

Thank you for the workaround. That will explain why switching off motion blur helped.

Would this workaround persist between restarting the game? I only play handheld while traveling, and I haven't been doing all that much traveling this year (for obvious reason) - so my Switch is almost always docked these days.

Link to comment
Share on other sites

Il y a 2 heures, [DE]JoshB a dit :

Hey guys I'm really sorry for the forced temporal AA. It seems like this change isn't being taken too well. I'm looking for a possible fix, but in the meantime there's a workaround you can use -- 

When you swap to docked mode the game will automatically change to temporal AA. You can force it back to old AA by updating your display settings. It doesn't matter what you change in display settings, as long as you change something while docked it should secretly change AA back

@[DE]JoshB,

Thank you very much for your clear answer and for your efficiency. 

This really explains why after changing some display settings it looks better.

 

 

Link to comment
Share on other sites

@[DE]JoshB I noticed on first login bloom and motion blur were forced on. Going into options and turning them on and off again, then confirming fixed it. However, forced auto-exposure still makes the game unbearable at times, and certain menus are still flickering wildly as they load in as a result. Thanks for taking the time to respond to us.

Link to comment
Share on other sites

Hi, @[DE]JoshB,

Just to give feedback : things are much better and I'm really thankfull to you for fixing this problem (and you did it very fast).

Nevertheless, I've noticed that the screen shake effect is always active, even if the option is disabled at the menu. Is there a way to avoid this problem ?

Again, I wish to thank you for your attention and patiance.

Have a nice day.

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

hey guys i was super excited for arcana coming then all when im in kuva fortress, railjack, and when im close to objectives the screen wiil either turn completely black or will start flickering black squares. When i replayed the war within on the transference part the screen was completely black i could do anything normally but the screen was just completely black

Link to comment
Share on other sites

On 2021-01-19 at 11:09 AM, (NSW)Voltmania said:

hey guys i was super excited for arcana coming then all when im in kuva fortress, railjack, and when im close to objectives the screen wiil either turn completely black or will start flickering black squares. When i replayed the war within on the transference part the screen was completely black i could do anything normally but the screen was just completely black

I had the exact same issue this last week, especially on the War Within. To fix the screeb blacking out on NSW, go to settings, display, and almost all the way at the bottom is the option for Bloom. Disable that and the black screen issue will no longer occur on Kuva Fortress, Railjack, or quests. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...