Jump to content
Temporary sub-forum for Update 30: Call of the Tempestarii ×
  • 1

Fluctus not leveling up in OV event?


Question

So before i started having this problem, I had joined a public squad in ov. Then host migration happened, nad my connection to the host was lost. When i checked the level of my fluctus, it showed unranked eventhough it had ranked up to 4 in the mission. After that, my fluctus's rank kept resetting to unranked whenever i extracted. Although my fluctus levels up fine if i use it in archwing missions and bounties. Is this a bug or do i need to install a gravimag or something?

Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
5 hours ago, ZodPrime83 said:

So before i started having this problem, I had joined a public squad in ov. Then host migration happened, nad my connection to the host was lost. When i checked the level of my fluctus, it showed unranked eventhough it had ranked up to 4 in the mission. After that, my fluctus's rank kept resetting to unranked whenever i extracted. Although my fluctus levels up fine if i use it in archwing missions and bounties. Is this a bug or do i need to install a gravimag or something?

Should be fixed in the current patch as of Wednesday.

  • Fixed an issue where Affinity collected in a Necramech wouldn't propagate to your Arch Gun if you Transferenced in from the Operator.

 

Link to post
Share on other sites
  • 0

This has happened to me for over a week.  New patch did nothing for my Fluctus.  It starts at rank 17 and maxes out at 30 at end of mission screen in OV.  When I go to the arsenal it's back to 17.  This is so annoying!!

Link to post
Share on other sites
  • 0

I had this problem on PC. I had mine equipped as both my mech weapon and my 'heavy weapon' / archwing weapon. Unequipping it from the other slots only equipping it as a mech weapon fixed the problem for me

Edited by --Q--Trekk
Spelling error
  • Like 1
Link to post
Share on other sites
  • 0
1 hour ago, --Q--Trekk said:

I had this problem on PC. I had mine equipped as both my mech weapon and my 'heavy weapon' / archwing weapon. Unequipping it from the other slots only equipping it as a mech weapon fixed the problem for me

This.

Try equipping different archguns on your archwing, heavy weapon, and necramech.

It worked for most of us back on pc.

  • Like 1
Link to post
Share on other sites
  • 0
On 2021-01-25 at 7:16 PM, --Q--Trekk said:

I had this problem on PC. I had mine equipped as both my mech weapon and my 'heavy weapon' / archwing weapon. Unequipping it from the other slots only equipping it as a mech weapon fixed the problem for me

Going to try this

 

Update - This workaround fixes the bug

Edited by (PSN)True_Reclaimer
  • Like 1
Link to post
Share on other sites
  • 0
On 2021-01-26 at 3:24 AM, Soy77 said:

This.

Try equipping different archguns on your archwing, heavy weapon, and necramech.

It worked for most of us back on pc.

I wish I had known this while the event was active on PC...

I made ~6-10 OV mission with Prisma Dual Decurion. They just stayed at level 16 all the time. I was like, oh well... I think I red there are bugs somewhere.

Then a single ArchWing mission later (after OV) and they rank up as they are supposed to (maxed with 2-3 missions IIRC).

If people are still experiencing this, report it to DE via the bug report form. The more people report this the more likely it gets fixed. I'm fairly certain they know about this already - it's such a blatant glaring bug it is hard to believe it wasn't noticed by DE.

Edited by WildPenguin82
a few TYPOs
  • Like 1
Link to post
Share on other sites
  • 0
3 hours ago, WildPenguin82 said:

It wish I had known this while the event was active on PC...

I made ~6-10 OV mission with Prisma Dual Decurion. They just stayed at level 16 all the time. I was like, oh well... I think I red there are bugs somewhere.

Then a single ArchWing mission later (after OV) and they rank up as they are supposed to (maxed with 2-3 missions IIRC).

if people are still experiencing this, report it to DE via the bug report form. The more people report this the more likely it gets fixed. I'm fairly certain they know about this already - it's such a blatant glaring bug it is hard to believe it wasn't noticed by DE.

Funnily enough, they do know -and more hilariously, released patches in multiple hotfixes. It's clearly there on the patchnotes.

yet the problem is still there, i guess people just gave up reporting it and simply do the changing weapon solution.

I was pretty sure that they'll at least fix it by the time console release, but here we are...

  • Like 1
Link to post
Share on other sites
  • 0

Yup same thing happened to me trying to level Fluctus. Patch has done nothing. I thought it might have something to do with having the same weapon in both Archwing and Mech weapon slot but that doesn't seem to be it. I had to level the weapon separately in Salacia.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...