Jump to content
Temporary sub-forum for Update 30: Call of the Tempestarii ×

Can't use Switch Gun, have to use Switch Weapon to use Secondary on K-Drive

Recommended Posts

Title says it all really - which is a bit silly since both keys equip the secondary, it even does for a moment with the other key just disappears straight away. Should be able to use either.

Edited by PoistyNZ
Link to post
Share on other sites

I can confirm this is exactly what happens. I kept trying to equip my secondary and it would pop up for a brief moment and then stow itself. I tried reloading the game, multiple guns, and multiple frames before searching the forum to find this post. Tried using "Switch Weapon" instead of "Switch Gun" and it worked first time.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...