Jump to content
General Bug Report Guidelines - Please Read ×

Update 29.10.0: Bug Hunting Megathread (Read First Post!)


Message added by [DE]Danielle,

Please note: All known and fixed bugs, popular and live feedback, and more are being tracked on our Trello board: https://trello.com/b/K34ACrAu

We will not be updating this forum thread with the above. 


Recommended Posts

  • TYPE: In-Game: Railjack
  • DESCRIPTION: Electric hazard persists even after fixing it.
  • VISUALWarframe0204.jpgWarframe0203.jpg
  • REPRODUCTION: Get an electric hazard on your ship and fix it. I was on solo mode. I think I was boarding an enemy ship when the hazard occurred. 
  • EXPECTED RESULT: HUD unscrambles after fixing electric hazard
  • OBSERVED RESULT: HUD stayed scrambled for the entire 1 hour mission before I aborted
  • REPRODUCTION RATE: 100% rate out of 1 electrical hazard I am NOT testing this again
  • Like 3
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Unable to exit mission rewards screen after loading into another Railjack mission directly after completing one
  • REPRODUCTION: Seems to happen after completing Defense mission types - had it happen today both on Pluto and Veil, as well as Neptune (though can't remember if it was the Defense node or not).  Happens in both solo and in groups (observed as client, but host had the bug too).
  • EXPECTED RESULT: able to exit out of the mission rewards screen normally after new mission starts
  • OBSERVED RESULT: cant exit the mission rewards screen, unstuck does not work, requires Alt+F4 or Host Migration to fix
  • REPRODUCTION RATE: 75% of the time for me. The one on Venus didn't seem to have this problem, but I also finished it right after yesterday's hotfix dropped mid-mission, so not sure if that affected anything.
  • Like 1
Link to comment
Share on other sites


  • Aborting a Railjack Mission after fully completing one prior will result in the loss of all Bonus XP from that Mission Chain
  • Aborting a Railjack Mission after fully completing one prior can result in the loss of all Rewards from that Mission Chain
  • Completing multiple Railjack Missions and returning to a Dojo Drydock after can result in the loss of Bonus XP from that last mission
  • Aborting a Railjack Mission may require a force closure of the game as the Mission Failed screen can run at 1 FPS.
  • Moving from one Railjack Mission immediately to another Railjack Mission can lead to the Mission Results screen being locked and only way out is to Abort
    • If it is the host that has this issue, then the mission must be Aborted
      • Which then can lead to the above issues
  • Nechramechs may not gain any XP at all even if only one Railjack mission was completed before returning to the Drydock.
  • Crewships can be invincible which then requires the mission to be Aborted
  • The effect of an Electrical Malfunction (both HUD and disabling the Tactical Menu) can persist even after repairs
  • Sometimes the HUD can vanish
  • The Railjack Navigation can be unusable when returning to the Drydock
  • Upon starting a Railjack Mission, the Railjack itself may be unable to move
  • Clients are unable to vote / ready up when in a Railjack Mission
  • Corpus Ship Bases (not Crewships) may be unable to be entered
  • The Orphix Percentage can randomly spike and lead to a quick / near-instant failure
  • Game itself has felt choppier since the update
  • The playerlist that shows on the HUD can get locked so even if a player leaves, the list will show them as still there
  • Improve glass floor textures for the Corpus Railjack Bases
    • There's a specific tile with an Orphix node below the floor that requires the player to go to an adjacent tile to access. The sides of the room have glass, but it really looks like there's no texture at all. The middle has a hole, but as the sides have collision, the middle piece looks the same, and when in a Nechramech, the middle has collision too.



  • Add an Extract / Continue option for Clients upon completing a Railjack Mission
    • The fact that this hasn't been added despite being an obvious flaw for over a year is baffling
  • Add transparency to Mission Complete screens
    • Allow the ability to disable seeing other players' frames in this screen as it's just a waste of space
  • Add text-shadow to Mission Progress (hold TAB) text as white text in a white environment leads to invisible text
  • Allow the healthbar of Crewships to be customizable and give them better icons
    • When their bar is depleted, it's a dark red color which then blends in with dark backgrounds


The current issues make the update incredibly frustrating, especially when trying to level equipment since the majority of time, XP gains are not saved for one reason or another.


Edited by Sean
Link to comment
Share on other sites

Crew Members don't know how Range works:

Been using an On Call Crew Member for fun in normal missions and he kept firing at enemies out of range with the Primary Gaze I gave him. So he'll just channel the beam at nothing for long periods of time due to targeting an enemy in far distance and it not reaching.


Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Missing 3 or more enemy types: Orm Basilisk + Elite; Orm Weaver + Elite On Veil proxima (New corpus Missions) + Only Elite Taro Vasilisk are shows on misiions
  • EXPECTED RESULT: Placed on low level veil proxima that enemy ship's (Like "Calabash")

    This Post Explain this!
Edited by iLeXeRi
Typo + Share Post
Link to comment
Share on other sites

Railjack UI screw from an electrical emergency persists when leaving the railjack,

  • TYPE: In-Game
  • DESCRIPTION: On leaving the railjack while an electrical emergency was underway, the UI screw persisted and remained for the rest of the mission, including Operator mode, Archwing, etc.


  • REPRODUCTION: It's unclear because it's inconsistent. I've left my railjack under the same circumstances before without the same result. I believe I left using the archwing catapult during the electrical emergency, rather than using the airlock.
  • EXPECTED RESULT: UI screw affecting the railjack should be canceled on leaving the railjack and return if the player returns to the railjack with an ongoing electrical problem.
  • OBSERVED RESULT: UI screw persisted.
  • REPRODUCTION RATE: I've only had this result once so far, so it seems infrequent.
Edited by CopperBezel
Added a detail
Link to comment
Share on other sites

  • TYPE: In-mission collision
  • DESCRIPTION: The excavators no longer have collision
  • REPRODUCTION: Happens in all Excavation missions
  • EXPECTED RESULT: Pre-update the excavator was a physical item that you couldn't walk through and could stand on top of. 
  • OBSERVED RESULT: You can walk right through it, you can't stand on it, but you can still wall jump off it.
  • REPRODUCTION RATE: Every excavation mission
  • Like 1
Link to comment
Share on other sites

On 2021-03-20 at 3:40 AM, krrysis. said:

they have kinda made railjack like normal missions, where in normal missions you only host when there are no open squads, similarly the same has been implemented to railjack system. The main reason is player carrying their own mods and having a personal ship doesn't matter much now since you carry your own plexus mods for battle tactical etc. that being said, i'd still love the feature of hosting my own railjack missions but that can be only possible in invite only/ friends only.  or whomsoever is the host of party before starting the mission.

It removes player choice, I can't choose to take the ship i've built new weapons and parts for, with the skin I paid for, to do missions in public.

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Try the level-up predasite and vulpaphyla companions from the Son. They get to level 30 after the patch, but my profile doesn't update the progression, Profile -> Equipment
  • REPRODUCTION: Get a companion level it up gild it. Check your profile if you see the mastery/level progression of the companion. 
  • EXPECTED RESULT: That you can see the level/mastery/max rank in your profile of gilded companions.
  • OBSERVED RESULT: Profile shows no level progression not even that i own the companion. Before the companion level-up patch this still works after the patch it broke.
  • REPRODUCTION RATE: Seems it's broken for everything gilded, like zaws/companions/kitguns.
Link to comment
Share on other sites

TYPE: Arva Vector (Neptune Proxima) Defense Mission Main Defense Objective Bugged
DESCRIPTION: After completing the other required objectives for Railjack, I boarded the enemy ship and went to do the defense objective. Door was bugged closed with no way to enter. Terminal for opening wasn't there.
VISUAL: Door to Defense Objective Bugged With No Way In (Arva Vector, Neptune Proxima)

EXPECTED RESULT: Door should have opened to begin defense objective
OBSERVED RESULT: Door had no means of opening
REPRODUCTION RATE: First time experiencing this bug

Edited by Scholar_Andrew
Link to comment
Share on other sites

  • TYPE: In-game
  • DESCRIPTION: I never received my full rank Railjack mods back from the Lotus message.
  • VISUALhttps://imgur.com/a/VcCEdoQ
  • EXPECTED RESULT: I should have received the full rank Railjack mods from the Lotus message.
  • OBSERVED RESULT: I didn't get any of them that were in the message.
Link to comment
Share on other sites

  • TYPE: Ingame, Mastery Rank Affinity, Equipment, Profile, Carmine Penta
  • DESCRIPTION: Leveled up my Carmine Penta to level 30, shows as not completed, forma'd it once, leveled it again, still shows as uncompleted in profile -> Equipment
  • VISUALhttps://imgur.com/a/FErtIqA
  • REPRODUCTION: unknown, level up Carmine Penta
  • EXPECTED RESULT: Penta should show up as "Maxed" in Equipment screen in profile after reaching lvl 30
  • OBSERVED RESULT: Shows as unranked after maxing it twice
  • REPRODUCTION RATE: unknown, 100%
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: I have experienced when on-board a corpus crew ship where my up/down axis was off center. I could not look up all the way correctly, and I was able to look down past the point where my character would change movement direction (the game thought I was looking behind me).
  • VISUAL: I unfortunately forgot to do this part.
  • REPRODUCTION: N/A so far.
  • EXPECTED RESULT: Proper alignment of axis.
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Playing Corpus Railjack Missions
  • VISUAL: n/a
  • REPRODUCTION: Just join mission as non-host? It has happened to me 1 out of 3 times.
  • EXPECTED RESULT: I should have had Weapon/Pet/Warframe Maximum level and items as displayed in the Mission Complete Screen.
  • OBSERVED RESULT: After finishing a mission, my Mission Complete Screen will show many items and Weapons at Maximum Level, when I Return to Orbiter my items are no longer maximum and there is no Previous Mission Rewards tab with pressing escape. (i cannot tell if items go missing as well because i cannot keep track with the amount i am receiving, but i think these are also missing).
  • REPRODUCTION RATE: 33%: 1/3 attempts this will happen. I have not managed to find a pattern where this happens but i know it is not leaving a mission before returning to dry docs. It also seems to only happen when i am not the host.
Link to comment
Share on other sites

16 hours ago, Pebelo said:

Just to let you know, that's not a bug. You need to hit those weakpoints with the forward artillery.

Yeah, my clanmate already clarified it. I'm dumb, sorry about that.

  • Like 1
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: I came out of an invasion mission (last of 3 in Abaddon, Europa; Grineer vs Corpus exterminate) and after completion went to the clan dojo
  • EXPECTED RESULT: After loading screen I should be in the dojo
  • OBSERVED RESULT: After loading screen, the "mission complete" window from the latest mission appeared again, after closing that I was in the dojo. It also happened when I went back to the orbiter after that.
  • REPRODUCTION RATE: Couldn't reproduce, at least without going on another mission.
Link to comment
Share on other sites

  • TYPE: In-game/Railjack components
  • DESCRIPTION: It is impossible to upgrade a railjack component with 2 upgradable stats when 1 of them is maxed (or maybe first).
  • VISUAL: -
    • Get a (primary) Lavan Reactor MK3 with +60% Battle Mod duration and Battle Mod Strength +39% or less.
      Edit: This bug affects all components that have 2 rollable stats, that have the first one maxed. Already seen it on Armor plating of 2 types too.
    • Get a (secondary) second Lavan reactor (MK 2 or MK 3 with the same trait).
    • Attempt to perform valence fusion on primary reactor, trying to consume secondary reactgor.
  • EXPECTED RESULT: Confirmation message pops up, that asks you to input "FUSE", which when confirmed would upgrade the primary reactor.
  • OBSERVED RESULT: Message saying "LAVAN REACTOR MK III has maximized stats and the fusing component offers no unique traits."
Edited by Jitsuryoku
  • Like 1
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: After applying forma to enhance the weapon, the Arquebex weapon stopped levelling up and always stays unranked.
  • EXPECTED RESULT: Even i use it constantly, the Arquebex weapon should be gaining up level.
  • OBSERVED RESULT: Arquebex weapon isnt levelling up as its intended to be. I tried restarting the game, applied another forma to Voidrig, which didnt solve the problem.
  • Like 1
Link to comment
Share on other sites

Launching Railjack from orbiter will bug the return to dojo on completion of mission (especially as host).

Seen this happen at least twice now, but not 100% certain how repeatable this is. It would seem if I launch a railjack mission from my orbiter and end up hosting the mission with my own railjack, upon completion of the mission and then using the navigation terminal to return to dojo, immediately starting the countdown. The countdown will fail to start and all the mission nodes in the solar map gets grayed out. There is no way to complete the mission from this point on.


It seems the only option is for the host to force close the game and lose all progress made!


Additional info: upon relogging into the game, if you then travel to your dojo, instead of spawning normally at your dojo, you will enter on your railjack as it returns to the drydock



Edited by Skye_Archer
additional info
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: When piloting a RJ and there's a nearby health drop, it sticks to the warframe piloting
  1. Take Protea to Free Flight RJ node.
  2. Spawn a Dispensary near the pilot "seat". Wait for health orbs to drop.
  3. Engage the pilot seat (press X to activate). The health orb will float to you and move off the ground and into the center of your warframe (even at full health).
  4. After disengaging from the seat, the orb will fall back to the ground. 
  5. Repeat steps 3-4 as needed


  • EXPECTED RESULT: The Health Orb will not interact with a full-health Warframe while piloting, will stay on the ground where it spawned
  • OBSERVED RESULT: The health orb will float to you and move off the ground and into the center of your warframe (even at full health).
Edited by Ivi104
Link to comment
Share on other sites

  • TYPE: In-game
  • DESCRIPTION: Enemy Sentient "balls" on walls don't consider Necramech as an enemy
  • VISUAL: These dudes:
  • Warframe0003.jpg
  • REPRODUCTION: Jump into a necramech. Aproach the enemy.
  • EXPECTED RESULT: They should jump of the wall and explode, just as they do with Warframes and Operators
  • OBSERVED RESULT: They just chill.
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...