Jump to content
General Bug Report Guidelines - Please Read ×

Update 29.10.0: Bug Hunting Megathread (Read First Post!)


[DE]Danielle
 Share

Message added by [DE]Danielle,

Please note: All known and fixed bugs, popular and live feedback, and more are being tracked on our Trello board: https://trello.com/b/K34ACrAu

We will not be updating this forum thread with the above. 

 

Recommended Posts

  • TYPE: In-game (visual)
  • DESCRIPTION: Crew heads vanish when they are in guns
  • VISUAL:

5lISU2S.jpg

  • REPRODUCTION: Assign a crew as Gunner and observe him. Don't know if this also happens with human players
  • EXPECTED RESULT: No decapitation
  • OBSERVED RESULT: Decapitation
  • REPRODUCTION RATE: 100% when a crew is a gunner
  • Like 1
Link to comment
Share on other sites

  • TYPE: In-game.
  • DESCRIPTION: Companion getting stuck on walls or far behind the player. I thought this was issue in the new in-Railjack map layouts, but it's been happening on normal maps as well.
  • VISUALhttps://files.catbox.moe/p2ydqn.mp4
  • REPRODUCTION: Move faster on any map and the companion will get stuck.
  • EXPECTED RESULT: Prior this update(29.10.0) the companion would simply be teletransported to the side of the player.
  • OBSERVED RESULT: Companion gets stuck.
  • REPRODUCTION RATE: Every time.
Link to comment
Share on other sites

  • TYPE: In-game, regular Missions, Kavat AI
  • DESCRIPTION: Kavat fights and does not follow, even when traversing multiple rooms, kavat stays way back and prefers to fight (and die!)
  • VISUAL:
  • REPRODUCTION:
  • EXPECTED RESULT: kavat follows and does not prefer fighting when you are leaving the room
  • OBSERVED RESULT: kavat stays behind, fights and dies
  • REPRODUCTION RATE: every mission, in survival missions is really noticeable
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: FPS drops in the new Railjack interior and missions with enhance graphics engine and DX11.
  • REPRODUCTION: Stay inside the railjack or complete regular objectives during the new railjack missions and compare the framerate with version 29.9.1 (Around 30 fps less).
  • EXPECTED RESULT: The fps rate in the new Railjack interior and missions should be the same or higher compared to version 29.9.1.
  • OBSERVED RESULT: The fps rate dropped significantly compared to version 29.9.1.
  • REPRODUCTION RATE: The much lower fps rate is always present in any of the new missions and inside the new railjack.
Link to comment
Share on other sites

list of bugs,

- mission cannot complete due of strange bug of unable enemy that summon a warship or crew ship into battle for it won't spawn for it only spawn fighter instead

- mission cannot complete switching into 2nd phase mission which I believed it have to do with players aren't spawning forcefully and quick enough to to get out the RJ or off the gun which I dunno cause a bug that they stay in the RJ

- voting mission that deleted the check box to go next mission

- mission cannot complete which I dunno what happen but this is on after you finish mission orphix mission it just some how once you get into RJ it doesn't want make consul work or anything even thou you selected a mission with a group this just don't want go no where which deleted the host check box or go button

I don't remember much but I ran into lots of bugs that keep looping the same thing such as these.

Link to comment
Share on other sites

  • TYPE: In Game
  • DESCRIPTION: Railjack Crewman refuses to leave guns
  • VISUAL
  • REPRODUCTION: Setting my first crewman gunnery, either by default or by in mission assignment, and then he will never leave the guns unless i complete the final corpus POI.  I've only observed this with the crewman in slot 1, and haven't switched them around or seen it with other crewmen yet.  This occurs with both the top and bottom gunnery positions.
  • EXPECTED RESULT: Crewman leaves the gunnery controls to do another task
  • OBSERVED RESULT: Crewman stays on the guns, shooting the enemies I try to scan
  • REPRODUCTION RATE: 100% of the times I've ordered him to switch railjack tasks, about 6-7 missions so far
  • TYPE: In Game 
  • DESCRIPTION: Unable to select some attachments for crewman appearance
  • VISUALCB96B1E51305BA7DB06D8817BA3BC7B45063B392
  • AAE8ADA9EB509790D877F32722EC1748F4CDF84D
  • REPRODUCTION: Attempt to select the Saturn 6 Right Knee plates or Left Shoulder Plates and the game selects a different nearby attachment instead.  For me it was those specific attachments I had issues with, unknown if there are other 
  • EXPECTED RESULT: Clicking the attachment the mouse is over will select that attachment
  • OBSERVED RESULT: A different attachment not being clicked on is applied
  • REPRODUCTION RATE: 100% for all 3 crewmen, I have.

 

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Able to assign more crewmates to a role than intended if done fast enough, breaking their AI and locking seats (the verification if role is occupied is actually checking if there is a crew already in the seat the moment you try to assign instead of a crew assigned)
  • VISUAL:

3 gunners: 3rd crew walks in circles/hugs the wall near forward artillery

Spoiler

E7Hfg6p.jpg

3 pilots: one to the pilot seat, one to the gun, one walking in circles near the navigation console

Spoiler

AOTrCYz.jpg

Broken AI after assigning all as gunner then all as pilot: The #1 pilot is in gunner seat, will accept commands but won't leave the gun. The #2 engineer is in another gunner seat, will accept commands but won't leave the gun. The #3 defender can move to engineer or pilot. All 3 can't be assigned as gunner because the 2 gunner seats are ocuppied (even if there is no crew assigned as gunner, and even the ones already in the gunner seat can't be assigned). As the two crews in the guns won't exit, the player can't use the guns anymore.

Spoiler

05FTN2X.jpg

  • REPRODUCTION: Quickly assign the same role for 2 or 3 crew members before the seat is ocuppied
  • EXPECTED RESULT: the 2nd and 3rd (only 3rd if gunner) will say that it's not possible to do, and won't change roles
  • OBSERVED RESULT: they see that no one is ocuppying the spot and try to go there. If 3 gunners, the 3rd will keep walking in circles hugging the wall near the forward artillery. If 3 pilots, one will go to guns and the other will keep walking around the navigation console. In both cases, their roles will be what I assigned
  • REPRODUCTION RATE: 100% if done before any crew enter the assigned seat
Edited by Daiwulf
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Valence-fusing armor plating doesn't increase their armor value, only HP.
  • VISUALF349D075AC0851C4C2B71FBA90075672C108AF45
  • REPRODUCTION: Take any armor plating and try to valence-fuse it with a scrapped one. You'll see HP getting increased, but armor stays the same.
  • EXPECTED RESULT: Both HP and Armor values getting increased.
  • OBSERVED RESULT: Only HP is getting increased, Armor value doesn't change.
  • REPRODUCTION RATE: 100%
Link to comment
Share on other sites

2 hours ago, Rotaken said:

Exiting Railjack piloting seat and turrets doesn't work unless interact key has been defaulted to X. Setting interact key to custom (E) and then back to X without using "defaults" at the bottom also breaks functionality. Bug has been present since sometime after the first launch of railjack, though custom keybinds did initially work.

Can somewhat debunk this since I am using E for interaction and F to exit and everything works as intended.

Link to comment
Share on other sites

Do we have the same problem again this time.. as in there is no normal Orm enemies in the game? All are Elite version.

Also another same problem is that there are Taro enemies in Veil where it supposed to have Orm enemies! 

These mistake resulted in some mods unobtainable. All mods are obtainable now

Edited by kyori
Link to comment
Share on other sites

  • TYPE: Navigation Window Visual Bug
  • DESCRIPTION: When you hit Esc to leave the navigation window while hovering one of the tabs on the upper right hand corner of the screen, the text box that appears while hovering these tabs sticks to the cursor. 
  • VISUAL: https://imgur.com/a/4tOZdnv (Capture with F6 Key doesn't capture the stuck text box).
  • REPRODUCTION: Enter Navigation from the front Orbiter console. Hit Escape once to zoom out on the navigation pane. Hover one of the tabs in the upper right of the screen, then hit escape to leave Navigation.
  • EXPECTED RESULT: Nothing stuck to the cursor
  • OBSERVED RESULT: The words from the textbox of the particular menu tab follows your mouse around in your Orbiter.
  • REPRODUCTION RATE: Reproduced it all but one time trying all of the tabs in the upper right of navigation.
Edited by ChetChetterson
Link to comment
Share on other sites

TYPE: In-Game

DESCRIPTION: I was trying to upgrade a mod from the plexus modding screen via the mod button.  When I got there, I had only a tiny subset of my mods, and the equipped category was not even present.

VISUAL: I've uploaded a screenshot at https://1drv.ms/u/s!At_BqQr6RY2Oibk48tsG-GizhZwUqA?e=3udeco

REPRODUCTION: This occurred when accessing the mod UI via the mods button in the plexus modding screen.  I'd left a filter on the mods from a previous day.  The filter was kept from the previous day and didn't match any equipped mods.  There was no indicator in the UI that I was looking at a subset of my mods other than the fact that most of them were missing.

EXPECTED RESULT: Accessing the mod UI via the button on a modding screen shows equipped mods to be upgraded regardless of filter.  Set filters should either reset when reopening the mod UI, or there should be a prominent indicator that the results are filtered.

OBSERVED RESULT: Mod UI contains only a small subset of my owned mods.  The equipped category may not appear when invoked from the modding screen.  Unable to see or upgrade my equipped mods as a result.

REPRODUCTION RATE: The condition is persistent until the filter is manually reset.

P.S. I collected a full process dump before I figured out what was going on in case this ended up not being a reliable repro.  Now that I've found the cause and have a reliable repro, that should not be necessary and I'm reclaiming my 5GB of disk.  I can easily create a new one if you're unable to repro

Link to comment
Share on other sites

  • TYPE: Gameplay
  • DESCRIPTION: In Railjack missions - Air-support Wukong [Celestial Twin] will be targeted by other Railjack Air-support abilities
  • VISUAL: https://streamable.com/7tytkp
  • REPRODUCTION: Use the tactical ability screen with an Allied Wukong in the team to summon a Celestial Twin ally. Use the Tactical ability screen to use an ability with unit targeting on the ally location.
  • EXPECTED RESULT: Second ability used would target an enemy in range or do nothing
  • OBSERVED RESULT: The Celestial twin ally is targeted by the ability
  • REPRODUCTION RATE: Consistent reproduction
Link to comment
Share on other sites

1 hour ago, souldead341 said:
  • TYPE: In Game
  • DESCRIPTION: Railjack Crewman refuses to leave guns
  • VISUAL
  • REPRODUCTION: Setting my first crewman gunnery, either by default or by in mission assignment, and then he will never leave the guns unless i complete the final corpus POI.  I've only observed this with the crewman in slot 1, and haven't switched them around or seen it with other crewmen yet.  This occurs with both the top and bottom gunnery positions.
  • EXPECTED RESULT: Crewman leaves the gunnery controls to do another task
  • OBSERVED RESULT: Crewman stays on the guns, shooting the enemies I try to scan
  • REPRODUCTION RATE: 100% of the times I've ordered him to switch railjack tasks, about 6-7 missions so far
  • TYPE: In Game 
  • DESCRIPTION: Unable to select some attachments for crewman appearance
  • VISUALCB96B1E51305BA7DB06D8817BA3BC7B45063B392
  • AAE8ADA9EB509790D877F32722EC1748F4CDF84D
  • REPRODUCTION: Attempt to select the Saturn 6 Right Knee plates or Left Shoulder Plates and the game selects a different nearby attachment instead.  For me it was those specific attachments I had issues with, unknown if there are other 
  • EXPECTED RESULT: Clicking the attachment the mouse is over will select that attachment
  • OBSERVED RESULT: A different attachment not being clicked on is applied
  • REPRODUCTION RATE: 100% for all 3 crewmen, I have.

 

as for the 2nd bug, you can equip the armor part by getting out of the crewmen screen (or at leat back to crew overview) and then into appearance again to then select the armor piece you want. it might also happen when double-clicking the armor-piece (the way i usually do) instead of one-clicking and then using the button - this way i didn't get this problem.

Link to comment
Share on other sites

1 hour ago, kyori said:

Do we have the same problem again this time.. as in there is no normal Orm enemies in the game? All are Elite version.

Also another same problem is that there are Taro enemies in Veil where it supposed to have Orm enemies! 

These mistake resulted in some mods unobtainable.

There are some specific taro enemies that spawn in all corpus proxima locations.  Specifically from my scans one variety of Taro weavers, then there are elite taro harpi and elite taro basilisk which also only spawn in veil.  There are also several others, including a different entry for elite taro harpi and elite taro basilisk which spawn in all corpus proxima missions.  There are no entries for elite orm versions of fighters.  I haven't scanned the standard orm harpi or orm basilisk yet, so can't confirm that but I also haven't gone searching for them yet.

Not sure what mods are unobtainable for you, but I've gotten all but one of the new enemy mod drops so far (I'm just mission one that drops from standard Taro enemies).  If it's one of the older (formerly avionics) then you may have a point there.

 

Also, a different codex bug:

  • TYPE: In Game
  • DESCRIPTION: Corpus Proxima Volatile missions only spawn Taro Engineers, not whatever proxima group you're fighting
  • VISUAL
  • REPRODUCTION: Run a corpus volatile mission past venus proxima and pay attention to the engineers that spawn, they are all Taro Engineers, not Axio, Orm, or Vorac
  • EXPECTED RESULT: Engineers for the mission area spawn
  • OBSERVED RESULT: Only Taro Engineers spawn
  • REPRODUCTION RATE: 100% of the volatile missions I've run, with an active helios I've gotten no engineer scans besides the Taro and paying attention to their spawns I've only seen taro spawns.
Edited by souldead341
Link to comment
Share on other sites

Issue with Railjack Aura's! The Railjacks Health/Armor gets Dropped In Mission If Another Player Doesn't Have IronClad Matrix Equipped. Same Problem With the Other Aura's Too.
Running Solo The Aura's Work Fine. but If you Invite Other Players You Suffer from a Stat Drop If they Have Another Aura Equipped. If They Have a Different Aura you Lose 1k Hp and 500 Armor with IronClad Matrix as your Equipped Railjack Aura With 1 Other Player. that Drops Even More With 3 Players Running Different Railjack Aura's. 

This Happens 100% Of The Time.

Edited by MesaFalcon
Link to comment
Share on other sites

  • TYPE: In Game
  • DESCRIPTION: In railjack, sometimes the gun turret that replaced the old airlock is still an airlock instead of the gun turret.
  • VISUAL: IWjr2K.jpg
  • REPRODUCTION: I don't know, it just happens sometimes. Once it has happened, it seems to persist through missions until going back to the drydock.
  • EXPECTED RESULT: This would let me enter the turret.
  • OBSERVED RESULT: This is an exit from the railjack.
  • REPRODUCTION RATE: I don't know, I haven't used the turrets much, I just sometimes notice it.
Link to comment
Share on other sites

Hello. I have a Necramech inactivity bug.

  • TYPE: In-Game Mission
  • DESCRIPTION: Being in Turret Mode in Voidrig while firing flags you as inactive, so you don't get Mission Rewards or Affinity.
  • VISUAL: I forgot to take a screenshot.
  • REPRODUCTION: Do a Defense node (I did it in Arc Silver, Veil Proxima) and stay full time in your Voidrig's Turret Mode (skill 4). Kill stuff. Wait until Mission is over. My Voidrig is fully built with Necramech Rage + Streamline + Continuity + Flow + Necramech Repair to sustain myself in Turret Mode.
  • EXPECTED RESULT: Since I was doing 90% of the damage, I was supposed to get the Mission Rewards for Defense.
  • OBSERVED RESULT: Item in Defense was shown as "Inelegible due to inactivity."
  • REPRODUCTION RATE: I don't know if it's contant, I only tried it once.
Link to comment
Share on other sites

  • TYPE: Unable to complete railjack mission
  • DESCRIPTION: Pluto Seven Sirens exterminate mission.  Solo playing Hildryn.  Completed both cache missions.  I reveal the requirements for the exterminate mission, and it is kill two crew ships.  I kill one crew ship, then the other one just vanishes.  I'm shooting at the weak points to destroy the shield and it just disappears right in front of my eyes.  This has happened twice in the exact same way. I stayed in the mission for a long time, hoping a crew ship would spawn but it never did.  I'm forced to abandon the mission, losing all items, caches, intrinsics, and affinity.  
  • EXPECTED RESULT: Should be able to kill two crew ships to advance the mission.
  • OBSERVED RESULT: Progress is halted and I must abandon
  • REPRODUCTION RATE: I have been able to complete the mission successfully with the same scenario, so it isn't a bug 100% of the time.  
Link to comment
Share on other sites

  • TYPE: In Game
  • DESCRIPTION: Doing the Orphix missions, sometimes my Voidrig's Mausolon's ammo stops regenerating for a few minutes. So far it hasn't happened in anything but Orphix missions, but I don't use the necromech much.
  • VISUAL: It'd just be a picture of a voidrig with no ammo.
  • REPRODUCTION: No idea, sorry.
  • EXPECTED RESULT: When I stop firing my Mausolon the ammo should start to regen after a couple of seconds.
  • OBSERVED RESULT: Ammo regen didn't work for a couple of minutes.
  • REPRODUCTION RATE: 2 of the 3 times I've ran an orphix mission this has happened.

 

 

Side note, are the orphix supposed to spawn in this fast? Operation Orphix venom they spawned about every 90 seconds (if I remember right), on railjack they seem to spawn every 20-30 seconds.

Link to comment
Share on other sites

TYPE: In-Game

DESCRIPTION: Permanent screenshake after dropping into space from a crewship

REPRODUCTION:

  • Enter a Corpus crewship during a railjack mission
  • Expose and shoot the crewship reactor to start the explosion countdown; the screen now starts shaking violently
  • Get ejected into space without exiting through the airlock before the countdown finishes (not sure why, but this occasionally happens)

EXPECTED RESULT: The screen stops shaking upon exiting the crewship.

OBSERVED RESULT: The screenshake persists until you enter the pilot's seat on the railjack.

REPRODUCTION RATE: Seems to happen every time you get ejected during the countdown.

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Crafting Dome Chrages during a Railjack mission
  • VISUALhttps://imgur.com/a/02yGuZT
  • REPRODUCTION: Use a Dome Charge and then craft it
  • EXPECTED RESULT: Crafting 1 Dome Charge
  • OBSERVED RESULT: The maximum ammount of Dome Charges goes up by 1 every time it's crafted and always the max ammount is being crafted instead of just 1.
  • REPRODUCTION RATE: 100%
  • Like 1
Link to comment
Share on other sites

  • TYPE: In Game
  • DESCRIPTION: My necromech got destroyed in a railjack mission (orphix), and I got kicked into a buggy operator. I was invisible, couldn't fire my void beam, couldn't bring up the Escape menu, and the enemies acted like I wasn't there. The other players could see me running around. I wasn't the host. This also happened to a friend during a railjack defense mission, everything suddenly went back to normal after two or three waves.
  • VISUAL: Failed the mission before I could get one.
  • EXPECTED RESULT: When the necromech gets destroyed you're kicked back into your operator like normal.
  • OBSERVED RESULT: When the necromech gets destroyed, your operator is bugged out.
  • REPRODUCTION RATE: Only had it happen once so far out of 6-8 times using my necromech in railjack missions.
Link to comment
Share on other sites

  • TYPE: In-Game, All Big Map Fishing
  • DESCRIPTION: Did something get changed with Bait and Miscellanea as the secondary and tertiary gearwheel seem... wonky.  
  • VISUALkRCCjLS.jpgfJryhOZ.jpgCYdpoSr.jpgXOK3JNC.jpgiWG1LRZ.jpgHMPJBOW.jpg
  • REPRODUCTION: Nothing has changed, and saw the differences.  Then did Orb Vallis and then Cambion Drift and see no rhyme or reason why pressing and holding 2 (or 3) as to where in the gear wheel they are going to.  
  • EXPECTED RESULT: It should maintain the same orderliness as the spear (pressing & holding 1) as seen here: 5YNK9na.jpg
  • OBSERVED RESULT: N/A 
  • REPRODUCTION RATE: Consistently inconsistent since the mailnline drop.  

Also would like to note that the Cuthol Bait is not spawning Cuthol like Norg and Glappid Bait does.  Even after waiting until the bait drops to the floor of the lake, Cuthol still won't spawn.  

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...