Jump to content

Update 29.10.0: Bug Hunting Megathread (Read First Post!)


Message added by [DE]Danielle,

Please note: All known and fixed bugs, popular and live feedback, and more are being tracked on our Trello board: https://trello.com/b/K34ACrAu

We will not be updating this forum thread with the above. 

 

Recommended Posts

TYPE: in fortuna, in the ticker crewmembers shop
DESCRIPTION: I was buying crewmembers (I own many many of them already (I think I bought every single one avalible from ticker since the update)), it prompted me with a "buy crewmember slots for 20plat" like usual and I accepted as usual, and got an infinite "please wait" screen

VISUAL:

unknown.png

 

EXPECTED RESULT: me getting the crew member and not having to Alt + F4 my game.

OBSERVED RESULT: my game going into an infinite "please wait" screen, and me having to alt + F4 my game. At least, the 20plat wasn't deducted, but I missed out on pretty good crewmembers.

REPRODUCTION RATE: tried it like 5 times, did the same result each time (tried with both of the remaining avalible crewmembers on the screen, same result for both).

so, 100% reproduction rate.

EDDIT : the bug persists even after ticker's crewmembers shop reset.

Edited by Mortanoid
Link to post
Share on other sites
  • TYPE: [In-Game]
  • DESCRIPTION: Intended or exploit? Bonus Objective rewards are granted even on aborting mission, so long as objectives were completed. Bonus Objective spawns can be done quickly (~1 minute), then mission abort to dojo still grants reward. Not a cosmetic / visual bug. The rewards are actually granted. This affects both existing / old Grineer bonus objectives as well as new Corpus bonus objectives.)
  • REPRODUCTION: Go do any mission, anywhere in the star chart, do the bonus objective, and then abort to dojo; it will show you the reward. It is actually awarded.
  • EXPECTED RESULT: Hidden cache-type rewards (that don't show you what you got when you complete the objective) should only be awarded and unveiled on successful mission completion.
  • OBSERVED RESULT: Objective rewards are awarded when objective is completed & shown when you abort back to dojo.
  • REPRODUCTION RATE: 100% everytime. Needs to be clarified if intended or patched out ASAP!
Edited by Pixxel_5
Poor wording; clarified.
Link to post
Share on other sites

TYPE: In-Game as of 29.10.5
DESCRIPTION: After chaining a RJ mission, the objectives don't appear, and crewship don't appear either, making the mission incompletable. Also, the leave button disappears from group options, forcing the host to alt-F4. This was on Flexa (ie Grineer Void Mission)
VISUAL: none. 
REPRODUCTION: Happened to me 2 times in a row as host.
EXPECTED RESULT: Not being able to complete the second mission and having to alt-F4 out of the game.
OBSERVED RESULT: Losing progress having to force quit.
REPRODUCTION RATE: 2 tries out of 2, not going to test more.

Edited by Finnelis
  • Like 3
Link to post
Share on other sites
  • TYPE: Empyrean Defense
  • DESCRIPTION: Finished hacking phase on first ship, went to do the orokin derelict cache, omni'd back to railjack after collecting the cache, came back to the corpus ship and killed 2 crewships and 2 security nodes
  • EXPECTED RESULT: Next objective should appear
  • OBSERVED RESULT: Next objective did not appear, no objectives were visible after finishing the orokin derelict cache
  • REPRODUCTION RATE: Once, so far
Edited by continue
  • Like 1
Link to post
Share on other sites
  • TYPE: Affinity lost after returning from Empyrean
  • DESCRIPTION: Finished an Empyrean defense mission in which some of my equipment reached max rank
  • EXPECTED RESULT: Equipment should stay at max rank
  • OBSERVED RESULT: Equipment reverted to pre-mission levels
  • REPRODUCTION RATE: Once, so far
Link to post
Share on other sites
3 hours ago, GitchGame said:

I don't think I was clear enough, there where no more hazards on the ship for like 5 min, but the screen kept like that for the rest of the mission, and the missions after, just going normal when I left to the orbiter.

Ah. Well, in that case... yeah. LOL

Apologies if I misunderstood.

Link to post
Share on other sites

TYPE: In Game

DESCRIPTION: Replaying Bifrost Echo to farm out Athodai parts while levelling my Voidrig Necramech, the mission goal (enter the ship to exterminate the enemies) has not appeared when I reset the mission to complete for the second time. This means I have had to leave the level, losing all resources  and experience gained from the first playthrough (all except the missions 2 main rewards which are the cache drops and exterminate drop table)

REPRODUCTION: I have tried replaying having completed Bifrost Echo multiple times, and each time it has had the same result. The video included is the fourth time it has happened in a row

Link to post
Share on other sites

My group of friends have been running alot of the new railjack missions. A bug that came up very often is my friend (SykoSmyle) would sometimes not get a bonus reward. He has missed out on several bonus rewards such as Carmine Penta parts and blueprints as well as endo and relics. This is the reward screen screenshot I grabbed from his screen:T2C8BH2.png

This next image is my (Larcetosus) reward screen:

h8ist1f.jpg

 

Both identical in loot EXCEPT, SykoSmyle is missing the Lith C7 Relic. This is one of the MANY instances he did not get the bonus rewards. (ie carmine penta parts).

As you can tell, all drops for both our screens are the same. The only way for us to receive the end mission rewards is for everyone to be back on the railjack for the mission to end. He was not in operator nor was he in a mech when the end mission rewards were handed out. He was physically next to me at the navigation console on board the railjack for every end of mission.

Yes there are times where he DOES get the reward.

In the screenshot above and several instances, I was the host. So we too decided to test it out. We've both took turns being host and being client as well as bringing in more friends to test. Our results lead us nowhere with that. It happened when we did a 3 man mission recently. Syko was host, my friend and I were clients. Nautilus carapace dropped as a bonus reward. I got it. Both of them did not.

The Lith relic was an example that we caught. But we can be certain that the party that did not receive the bonus rewards, definitely do not have the rewards credited into their inventory. We knew this cause every time we had a penta component or a nautilus component dropped and someone DIDN'T receive it, we'd head back to the drydock to double check.

Link to post
Share on other sites
  • TYPE: In-Game, during ALL new Volatile Corpus Railjack Missions types
  • DESCRIPTION: TWO ON ONE:
  •     FIRST Whenever you have to "Enter the Corpus Obelisk" to do the volatile mission itself there are enemy targets for turrets outside the ship, they are Waypointed and destructable, whenever the mission doesn't bug out and stops delegating waypoints entirely. HOWEVER, and this was highly reproductable on my end, three times in a row, if I destroy them and then go do the Volatile mission, at the end of the mission instead of finishing it I'll be tasked to DESTROY THE TURRETS, which I can't do, because they STAY destroyed, rendering the mission incompleteable. 
  •     SECOND if I ever get a electric status on my Railjack and I fix it, it carries over for the ENTIRE mission regardless (see my scrambled UI)
  • VISUAL
    Spoiler

    4nuOSwt.jpg

     

  • REPRODUCTION: Every single time the mission shows me their waypoints and I choose to destroy them. The electric one, less so. Maybe it has to do with leaving the ship, or unmanning the ship which scrambles whatever state the effect should be applied in. I only noticed I was still with the "shocked" UI when I went inside another ship, realizing it probably shouldn't be like that.
  • EXPECTED RESULT: For the electric surge effect to end when fixed. For turrets that I'm tasked with destroying to spawn whenever the game asks me to destroy them, or, to correctly flag that I have already completed this objective (by making it optional, for example)
  • OBSERVED RESULT: Electric surge effect continues for entire mission. Mission incompleteable because targets didn't spawn after I destroyed them earlier before being told to do so.
Link to post
Share on other sites
  • TYPE: Railjack Keybinding
  • DESCRIPTION: Attempting to use Tactical Map with default key L only works when in the pilot seat. Rebinding this key to another (I chose ` ) allows tactical to be accessed anywhere, but not from the pilot seat.
  • VISUAL: non-visual
  • REPRODUCTION: Choose ` as a keybind for tactical while playing a mission solo
  • EXPECTED RESULT: I should have been able to access tactical from anywhere
  • OBSERVED RESULT: The keybind note on the hud goes away and the key does not function
  • REPRODUCTION RATE: 100%. Unbinding the key reverts the old behavior of not being usable outside the pilot seat.
Edited by SneakyTouchy
Link to post
Share on other sites
  • TYPE: [In-Game]
  • DESCRIPTION: [Player using gamepad,controller can't active "Flush Heat Sinks] - Gunnery Rank 9 without keyboard on PC]
  • VISUAL: [-]
  • REPRODUCTION: [Since get Gunnery Rank 9, On X-box controller we can reload with (X) botton. But on railjack it's defind to dismount form pilot seat. So everythime you press (X) you will dismount instead of cooldown turret. But even we reassigned Dismount form (X) bottom to D-Pad (Down). (X) still not active for "Flush Heat Sinks" same to all other botton. Only way to active this right now is [R] botton on keyboard.]
  • EXPECTED RESULT: [It's must have controller assigned for "Flush heat sinks"]
  • OBSERVED RESULT: [No any botton is assigned to use this Gunnery rank 9 ability]
  • REPRODUCTION RATE: [Always]
  • Like 1
Link to post
Share on other sites

Animation error while aim gliding with Zephyr Harrier

  • TYPE: In-Game - Animation - PC 29.10.5
  • DESCRIPTION: When aim gliding after rolling with Zephyr Prime Harrier in a solo mission in Orb Vallis, she did a walking animation in the air instead of the normal aim glide animation.
  • REPRODUCTION: Equip these glide/jump modifying mods on Zephyr Prime with the Harrier skin: Lvl 3 Aviator, Lvl 3 Motus Signal, Lvl 3 Aero Vantage. Start a solo mission in the Orb Vallis. Bullet jump into the air. Press Forward and Roll, and before the roll is over press and hold Aim.
  • EXPECTED RESULT: When the roll finishes Zephyr should be in the aim glide position
  • OBSERVED RESULT: When the roll finishes Zephyr is in a standing or walking animation in midair until the "aim glide" ends
  • REPRODUCTION RATE: Has happened most times I tried it across two sessions. I also crashed once while attempting to reproduce it but that did not happen again despite doing this over 20 times.
Link to post
Share on other sites
  • TYPE: ingame
  • DESCRIPTION: Arquebex always displaced cursor and viewpoint after 1-2 seconds which makes it extremely annoying to frustrating to use. As someone who has done Oprhix solo to 36 in Orphix venom. I wanted to see how decent orphix arcane farming was however I stopped at 21 because of this bug/change. Using 4 once in a while it does not have that much impact but in orphix where you are constantly using Arquebex and switching it off to use Storm Shroud it becomes EXTREMELY annoying to see your viewpoint ping pong like a tennis ball in a long rally.
  • REPRODUCTION: Every USE of ARQUEBEX
  • EXPECTED RESULT: Using Arquebex and having my viewpoint NOT shifted around to a different position
  • OBSERVED RESULT: Viewpoint moves to above VOIDRIG.
  • REPRODUCTION RATE: 100%
Link to post
Share on other sites
  • TYPE: Riven Disposition - Verglas (Nautilus Sentinel weapon)
  • DESCRIPTION: As per your policies new weapon releases start at a 0.5x disposition. Verglas... did not. As seen in the provided material not only does it display at 4/5 dispo (1.1-1.3x dispo) but the stats viewed when maxed would seem to support this. I have a very hard time believing a 0.5x dispo could achieve a critical chance over 100%, especially without a negative. The wiki (not affiliated with DE I know) also displays Verglas at 1/5 dispo, which is totally logical and apparently completely incorrect.
  • VISUALhttps://imgur.com/a/58CHmdU
  • REPRODUCTION: I'll be sure to tell you if I ever can get my hands on another Verglas riven.
  • EXPECTED RESULT: That the scaling of the riven with the disposition multiplier was garbage.
  • OBSERVED RESULT: It was not.
Link to post
Share on other sites
3 hours ago, Finnelis said:

TYPE: In-Game as of 29.10.5
DESCRIPTION: After chaining a RJ mission, the objectives don't appear, and crewship don't appear either, making the mission incompletable. Also, the leave button disappears from group options, forcing the host to alt-F4. This was on Flexa (ie Grineer Void Mission)
VISUAL: none. 
REPRODUCTION: Happened to me 2 times in a row as host.
EXPECTED RESULT: Not being able to complete the second mission and having to alt-F4 out of the game.
OBSERVED RESULT: Losing progress having to force quit.
REPRODUCTION RATE: 2 tries out of 2, not going to test more.

Seconded. Reproduction rate : 100%. (Additional 10x tries)

I would revise the above bug for this information

  • TYPE: In-Game as of Update 29.10.5
  • DESCRIPTION: Started RJ mission as chain in Flexa (Veil Proxima, Grineer Skirmish) (not from dry dock/orbiter). 2nd mission would have no objective (no fighter/crewship) information. Fighters spawned indefinitely. Objective markers appeared and doable for core objective, (unsure about derelict). Doing the core objective makes some of the objective appear (see picture below) However, due to no display of amount of fighter / crewship needed to be destroyed, mission becomes deadlocked . Players had do 'return to dojo' / abort while retaining the derelict rewards.
  • VISUAL: 1. Starting the 2nd chain mission (Flexa) . No objectives appeared in top left.
  • Warframe0024.jpg
  • Objective appeared when inside the core POI
  • Warframe0025.jpg
  • Indefinite fighter spawn, no crewships after completing the core POI
  • Warframe0026.jpg
  • REPRODUCTION: Start the chain mission in RJ (Flexa) after completing the initial mission (Flexa).
  • EXPECTED RESULT: Crewship spawns, objectives appear, mission progresses
  • OBSERVED RESULT: Deadlocked, mission does not progress, have to return to dry dock.
  • REPRODUCTION RATE: 100% of the time when chaining missions

Please let me know if I have to upload the screenshot with metadata properly since i used public image hosting to attach above screenshot. Thank you

Link to post
Share on other sites
  • TYPE: In Game - Railjack - PC
  • DESCRIPTION: My hull plating and shield array are not being applied correctly. I used to have 11k hp and like 3k shields and then i switched from the ironcald matrix to the onslaught matrix because it fits my builds better and then I noticed this bug. My maxed out plating itself gives 6000 hp and 2688 armor and these values are EXACTLY 1 below each of those. Very strange. And as I said I used to have 11k hp and 3k shields so i should have 10k hp and idk... 2.5k shields ? ( as well the shield regen ). This is obviously a bug since the BASE value of my plating as u can see is 6000 hp and 2688 armor. Please fix it´s rly annoying.
  • VISUAL: I have taken several screenshots.Warframe0002-2.jpg
  • Warframe0001-2.jpg
  • Warframe0003-2.jpgWarframe0004-2.jpg

 

  • REPRODUCTION: I think you could reproduce it urselves doing the same thing I did. I literally just switched my matrixes and this happened.
  • EXPECTED RESULT: 10k hp +/-   ,   4k armor +/-     ,   2.7k shields +/- and shield recharge I´m not sure
  • OBSERVED RESULT: As shown. And it´s still like this in my game.
Edited by PrestigeWhite
I accidentally posted without finishing.
Link to post
Share on other sites

Edit 2: Updated bugs status, as of  Hotfix 29.10.7.

Edit: Updated bugs status, as of Hotfix 29.10.6.

Lots of bugs found, most of them showed up today after the Hotfixes. Sorry for not sticking to the formatting, but I'd become crazy if I formatted all of them one by one.

I'll try to be as informative as I can without following the format, however. Cheers!

Happens 100% of the time:

  • Corpus Armaments are giving only 25 Endo when scrapped, instead of 225 like other armaments and components. Persisted after Hotfix 29.10.7.
  • After Hotfix 29.10.5, you cannot do the same node in a row without going back to the Drydock. The following mission will have no Objectives shown on the UI on the left, and it becomes impossible to complete the missions, because Crewships don't spawn. Tested in R-9 Cloud in the Veil, either with Sentient modifier or without. FIXED IN Hotfix 29.10.6!
  • After Hotfix 29.10.5, when you use the "Return to Dojo" option during a mission, you lose all items that were collected during the PREVIOUS, COMPLETED missions, except for the End Mission Rewards awarded by them. This is not an UI bug, I've verified it by exiting and entering the Dojo again, since we dropped Armaments in these missions. Persisted after Hotfix 29.10.6, but it's now a visual bug only. You get the rewards to your inventory.

Happened sometimes:

  • When you complete a primary objective, such as blowing up crewships, Loot Dungeons are still marked, but their objective inside is no longer spawned. Persisted after Hotfix 29.10.6, apparently.
  • Random UI bugs experienced after Hotfix 29.10.5. Oo idea at all on how to reproduce them, they just happened to different players. The first was taking by me as a host, the second happened to a client (Didn't happen yet post Hotfix 29.10.6):

    unknown.pngunknown.png
Edited by Lakyus
Updated bug status for Hotfix 29.10.6.
  • Like 1
Link to post
Share on other sites

TYPE: In-game Railjack visual/model bugs

DESCRIPTION: Wear and Tear / Caballero Visual Issues - The Archwing slingshot room inside the Railjack will always appear heavily worn even when wear and tear is set to 0. In addition, when viewing the outside parts of the Railjack through a window, the exterior will always appear worn regardless of wear and tear settings, and some emissive lights will be default blue instead of the chosen color. Finally, the gunner turret controls are not affected by interior colors and will appear as the default white and blue. When using the Caballero skin, the Railjack's engines and weapons will clip and appear misaligned with their mounting points. This seems to occur because the Caballero's side nacelles are angled downwards, but engines/turrets still appear parallel to the main body of the ship. There is also clipping present in the pilot's turrets. In addition, duplicate engines will appear clipped inside the normal engines when using the Caballero skin. 

VISUAL: 1. Slingshot room 2. Caballero pilot guns 3. interior turret controls 4. Caballero exterior turret 5. Exterior of Railjack viewed through window (worn, but wear sliders are set to zero 6. Caballero engine issues 7. Exterior of Railjack viewed though window (emissive issue, blue lights should be purple)q84C6cq.jpgybvLLSl.jpgerXQXru.jpgE5KlKvM.jpg OI2NrkB.jpgYlCvnO0.jpgteKAUlv.jpg

REPRODUCTION: The wear and tear issues can be seen at any time. Color issues can be seen when interior and exterior colors are customized. Caballero issues can be seen at any time while using the skin.

EXPECTED RESULT: Railjack interior and exterior should be consistent with applied customization settings. Railjack modules should fit cleanly onto the ship regardless of skin.

OBSERVED RESULT: Wear and tear appears in several areas regardless of wear and tear settings and several areas are not colored consistently according to selected colors. The Caballero skin shows many visual issues with modular parts.

REPRODUCTION RATE: Any time colors/wear and tear are changed. Always w/ Caballero skin

Edited by Blargenshpoog
Added image set
Link to post
Share on other sites
  • TYPE: In game
  • DESCRIPTION: Deimos vault 
  • VISUAL: I would love to send video but i dont have best internet.
  • REPRODUCTION: wait for someone to use Deimos vault weird teleport flower.
  • EXPECTED RESULT: Nothing should happend im did not teleport other player did, so what this bug does is it blackens screen for every players even if not using teleport flower or wth is it.
  • OBSERVED RESULT: Screen blackens same as if u would use it but, u did not right ?
  • REPRODUCTION RATE: Every damn time :D 
Edited by FermenCze
Link to post
Share on other sites

Type: ingame

Description:      I was running rail jack on Felxa node in  veil proxima, using Lavos I helmithed Perspicacity, onto his 2,( not sure if that's relevant) but the Perspicacity ability broke after the first use.  it would insta hack the first terminal and I could still recast  the skill but going up to  a second or third terminal  would force me  to complete the hack normally

Reproducible:  ran the mission 3 times and the same issue happened every time

Edited by Redhotnova
Link to post
Share on other sites

There is a bonus exp bug in railjack, in that you are not awarded the bonus after existing even tho in the rewards screen it is there, i am frankly surprised this hasn t been fixed yet because it is extremly frustrating to lose so much exp and adds to the unstable feeling of Railjack in general

It honestly makes me want to not touch Railjack until it actually fixed for good

Link to post
Share on other sites

TYPE: In-game, inventory

DESCRIPTION: Certain items are not being tracked correctly in the Mastery Log of equipment, such as the Shwaak Prism

VISUAL: 

xXurSwy.jpg26M83kN.jpg

REPRODUCTION: Maxing the SHWAAK prism, then getting disappointed that it's not tracked.

EXPECTED RESULT: To be tracked in mastery rank

OBSERVED RESULT: The shwaak prism was greyed out in my mastery log

REPRODUCTION RATE: 100%

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...