Jump to content
General Bug Report Guidelines - Please Read ×

Update 29.10.0: Bug Hunting Megathread (Read First Post!)


Message added by [DE]Danielle,

Please note: All known and fixed bugs, popular and live feedback, and more are being tracked on our Trello board: https://trello.com/b/K34ACrAu

We will not be updating this forum thread with the above. 


Recommended Posts

  • 9410cc3ab5d9f7ea7d62c32fe52163bb.jpg
  • TYPE: In-Game
  • DESCRIPTION: Mutalist Cernos, wrong damage calculation at the board and in game
  • EXPECTED RESULT: if i add an 60/60 mod it should take the whole base damage to calculate
  • OBSERVED RESULT:it just takes the elemental part of the base dmg to calculate
Edited by PhutureProgressive
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: I had ranked up and gilded both Medjay and Pharaoh predasite companions, and both of them appears as Rank 0 in Equipment Stats (as seen in the screenshot below).
  • VISUAL:M3m4Ma6.png
  • REPRODUCTION: I'm not sure if this would happen again if I get new ones.
  • EXPECTED RESULT: That you can see the max mastery rank in my profile of gilded companions.
  • OBSERVED RESULT: Profile shows no level progression. Before the last patch this was right, but not anymore since the update.


Link to comment
Share on other sites

i feeling programe missing something i mean some player can't invite me or i invite them
lure bait for fishing bit bug and animal hunt lure too
some mission hacker data is gone

Link to comment
Share on other sites

I completed the "Second Dream" Quest a while ago and just recently learned I was supposed to get a Broken War from it but I never did, my profile doesn't even say I ever got one. it appears grayed out

Link to comment
Share on other sites

Posted (edited)
  • TYPE: In-game
  • DESCRIPTION: While incubating a kubrow, i can't access my helminth. When I try to interact with my helminth my screen snaps and nothing happens.
    VISUAL: This issue has happend to me and my friend multiple times but for this post I could not replicate it (i even spend plat buying an egg lol)
  • REPRODUCTION: All I know is that when my kubrow is either done or still incubating, my helminth is unaccessable. There might be extra steps to replicate but I am not sure.*
  • EXPECTED RESULT: Helminth menu opens and I can access everything helminth has to offer.
  • OBSERVED RESULT: Menu doesn't open and instead my camera snaps to straight ahead.
  • REPRODUCTION RATE: I have only tried to forcefully reproduce it once and it did not replicate that instance. I have encountered this issue 2-3 times and my friend 1 time, I dont visit helminth enough to tell an exact rate.

    *Normally i'd be running missions and i will want to change my arsenal, so I pick some new stuff, look at mods etc. Then I would try to access helminth to no avail. But today I logged in, claimed ember from my foundry and tried to subsume her with helminth just snapping my camera to a fixed location. After claiming the kubrow my helminth was fully accessable again.
    After trying to force it to happen and it not working leaves me slightly confused, but in 2 instances I had claimed a kubrow and afterwards helminth, which previously wasnt working, worked again.
Edited by Mr.Blue_Popo
Link to comment
Share on other sites

Posted (edited)
  • TYPE: In-game
  • DESCRIPTION: Overheating guns in Railjack does not benefit from gunnery rank 9.
  • REPRODUCTION: Every time I overheat the guns it takes more than 0.5 seconds to cooldown. Fells like 2-3 seconds.
  • EXPECTED RESULT: Gunnery rank 9 is supposed to reduce the cooldown time of overheated weapons to 0.5 seconds. 
  • OBSERVED RESULT: The reduced cooldown of gunnery rank 9 does not apply - ever.
  • REPRODUCTION RATE: Every time you overheat the guns.

I am using the gun in the pilot seat. It should take effect there as well.

Side turrets show the same behavior.

I have skilled gunnery 10 as well but that should not have any impact.


*edit* Gunnery 9 seems to work fine.

I misunderstood the "reload" part of the skill.

You actively press R once overheated to trigger the skill.

As you usually do not reload RJ weapons this was not very intuitive. Not sure if the skill could be made autotrigger. Might help to counteract the negative of gunnery 10 a bit.., 

Edited by Tahroon
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...