Jump to content
General Bug Report Guidelines - Please Read ×

Update 30: Bug Reporting Megathread (Closed)


[DE]CoreyOnline
 Share

Recommended Posts

  • TYPE: In-Game
  • DESCRIPTION: Necramech weapon Mausolon cannot shoot Void Sinks
  • VISUAL: See Below at 02:57
  • REPRODUCTION: Try to damage void sink with a Necramech using the Mausolon
  • EXPECTED RESULT: Necramech using the Mausolon can destroy sinks
  • OBSERVED RESULT: Nothing happens to sink
  • REPRODUCTION RATE: 100%

 

 

Edited by SilentMobius
  • Like 1
Link to comment
Share on other sites

Game Mode: Arbitration

Warframe: Sevagoth

 

Noticed that I can collect shards in both main and shadow form however, the total count does not apply when trying to pick up a player. So if I have 2 in my main form and 3 in shadow the game mode does not recognize that I have 5 total shards. In addition, after reviving a player meeting the requirements of 5 shards the shards picked up by my shadow remain which affects both it and main forms total health.

Expected: The shards should be zeroed out once the downed player is revived however, it does not appear to do so. For example, I contributed to reviving a player using Sevagoth's main form however, the shards collected in my shadow form remained which affected both shadow and main forms total health.

Edited by EdDiesel
  • Like 1
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Excessive spawing and respawning of void sinks, creating excessive VFX especial for a solo player (Not the old bug with multiples of the VFX playing on loop)
  • VISUAL: See Below at 09:47
  • REPRODUCTION: Play a void storm mission Solo
  • EXPECTED RESULT: Void sinks should stay away for a moment when shot, not instantly respawn, 5 sinks in close proximity respawing is too many for a solo player.
  • OBSERVED RESULT: Too many void sinks respawing too fast make the display a seizure inducing nightmare.
  • REPRODUCTION RATE: Random

Please cap the number of sinks and respawn rate and lower the caps when there are less than 4 players, also please tone down the "You're close to a fissue" screen FX it's not useful.

 

 

Edited by SilentMobius
Link to comment
Share on other sites

New XBOX crash. 4/24/21 (started 4/23/21).
Clicking the + sign on start menu to open the friends list crashes to dashboard every time now.

Not a lot of extra info here. Both my GF and I play in the same house on the same network and usually don’t have any problems. She’s experiencing the bug too now. We also don’t appear to be online to each other while standing in the same relay or our clan’s dojo side by side. 

NAT settings are OPEN. connectivity is strong. Download speeds about 150mb/s

Work around to play together was to use recently played with players in the communication tab and “join” option after trying to add friend (despite already being friends). It only worked for me. Didn’t work for her to try and join my game.

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Void Storm. When I was playing Lith Grineer Skymish in a row, the relic was open even though there was not enough or 0 reactants.
  • REPRODUCTION: The first mission seemed normal, but it always happened after that.
  • EXPECTED RESULT: If there is not enough reactant, the relic will not open.
  • OBSERVED RESULT: It's open even if it's not enough.
  • REPRODUCTION RATE: I don't know, but both happened in the two times I played after I noticed.
Link to comment
Share on other sites

So, a little bug with Sevagoth.

 

Type: In-game 

Description: On leaving sevagoth's shadow, using reunite, my LB roll ejects the operator, and locks ability use until downed. 

Reproduction: fill death well, use the shadow ability, expend about half of the well, and use reunite. The first roll after will produce the bug. 

Expected result: Sevagoth should have performed his roll animation.

Observed result: Operator ejected, abilities no longer selectable.

Reproduction rate: 100%

Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: I was in necramech when crew ship that I was sabotaging got blown up by artillery
  • VISUAL:
    unknown.png
    blackscreenRJ.png
  • REPRODUCTION: Be in necramech in crew  ship when it's being destroyed with artillery (might also work when it's destroyed with just reactor)
  • EXPECTED RESULT: Kicked back into archwing mode for space roaming
  • OBSERVED RESULT: Black screen when entering any ship after bug has occured ; sometimes this kick the warframe out of the map ; when host leaves game and I get kicked back into RJ, I was unable to use any place except pilot
  • REPRODUCTION RATE: 100%
  • Like 1
Link to comment
Share on other sites

2 things, there's a Ui bug where the nightwave bounty pop-up at the bottom of the screen becomes frozen and will not disappear. Also Crewmen and pets are not resetting between railjack missions and you have to go back to the dojo for them to come back to life.

Link to comment
Share on other sites

Hi,

my 2 cents:

  • TYPE: API https://api.warframestat.us/pc
  • DESCRIPTION: Text and key are the same for some entries in fissure section
  • VISUAL: Not in-game
  • EXPECTED RESULT: Some better text about the fissure mission
  • OBSERVED RESULT: The data is the same for many fissure sub-entries after fetching API content
  • REPRODUCTION RATE: refresh...

 

I'm maintaining a little web app (https://terrysschedule.herokuapp.com/#/). It uses the DE web API (@ https://api.warframestat.xx)

Since the new update some entries seem to be wrong. It has been improved but there is probably some more to do.

In this example below we clearly see that node, missionType, missionKey, enemy, enemyKey, nodeKey are the same.

 

Citation

[....]

12    
id    "608571315eadf03b1acc6d79"
activation    "2021-04-25T14:20:01.931Z"
startString    "-54m 17s"
expiry    "2021-04-25T15:50:01.931Z"
active    true
node    "Orvin-Haarc (Venus)"
missionType    "Extermination"
missionKey    "Extermination"
enemy    "Corpus"
enemyKey    "Corpus"
nodeKey    "Orvin-Haarc (Venus)"
tier    "Lith"
tierNum    1
expired    false
eta    "35m 42s"
isStorm    true
13    
id    "608571315eadf03b1acc6d7a"
activation    "2021-04-25T14:20:01.933Z"
startString    "-54m 17s"
expiry    "2021-04-25T15:50:01.933Z"
active    true
node    "CrewBattleNode533"
missionType    "CrewBattleNode533"
missionKey    "CrewBattleNode533"
enemy    "CrewBattleNode533"
enemyKey    "CrewBattleNode533"
nodeKey    "CrewBattleNode533"
tier    "Meso"
tierNum    2
expired    false
eta    "35m 42s"
isStorm    true


PS : https://hub.warframestat.us/#/  Have the same issue happening.

 

 

 

Link to comment
Share on other sites

TYPE: In-Game
DESCRIPTION: void storm railjack mission in the Veil with only 2 players. Doing a mission with Protea and a Rhino where the Rhino had to end up dropping from the game because it was impossible to open the door because all buttons on all consoles refused to acknowledge the presence of the Rhino.

Visual : not button prompt for second player to allow for opening doors, activating consoles or doing cyphers

EXPECTED RESULT: being open the door towards the main target

OBSERVED RESULT : one player had to exit the game and couldn't be re-invited because once the door towards the main objective is opened it's locked down to invitations


REPRODUCTION: have not found not to reproduce it but it has happened twice now

Link to comment
Share on other sites

DESCRIPTION :

- during any RJ mission it happens often that the visual clue that Iron Skin is active disappears even although the Rhino still has Iron skin active, and did directly after the teammate hacks a console.

- also that the parazon mods don't seem to kick in when not the host. The reason that is easily noticeable is because one can't help but notice that master key doesn't kick in unless it's the host that does the hack

- Also that while in Archwing during RJ missions that additional revives due to high level arcanes aren't counted. As in, when one dies it doesn't count down from 6 but from 4.

- is it intentional that primed regen doesn't kick in during a mission outside of the RJ but only once one has re-entered the RJ?

- is it intentional that any Vulpaphyla can be killed in boarding parties and doesn't respawn until back on the RJ ?

 

Link to comment
Share on other sites

I apollogise if this has already been reported, could not find another bug report describing the same issue

  • TYPE: In-Game
  • DESCRIPTION: During Corpus Railjack missions, during the final "ground mission" phase, switching in and out of the Operator form sometimes ejects the player from the ground map and back into space map. Cannot re-enter the ground map to complete the objective. The mission either fails automatically or cannot be completed. You can fly around in Archwing, but cannot re-enter the ground mission map to complete the mission objectives.
  • REPRODUCTION:
    • Playing on Nintendo Switch, using solo mode (hence host)
    • Start a Corpus Railjack mission (bug observed on Calabash - Veil Proxima Exterminate).
    • Complete space objectives (including optional one) and enter main ship for the ground exterminate.
    • Spam going in and out of Operator form (healing with Magus Elevate).
  • EXPECTED RESULT: Player switches between Warframe and Operator. The ground mission continues.
  • OBSERVED RESULT: Get ejected out of the "ground phase" map and back into archwing in the "space phase" map. Either mission fails immediately or you can fly around in archwing but cannot re-enter ground map to finish the ground objective - in that case you have no choice but to abort to dojo. Railjack recall stays disabled, but can enter it by flying to it.
  • REPRODUCTION RATE: Inconsistent. Happened to me twice so far (both at Calabash, Veil Proxima). There might be an interaction with Wukong's passive in play: one of the times, bug was triggered when I was trying to trigger Magus Elevate to heal from very low health, enemies were shooting at me at the time. The second time, was jumping out of a Necramech to open a door.
Link to comment
Share on other sites

Ironclad Matrix aura doesn't work when you start a mission from orbiter it happens everytime.
To make the aura to work you must :
- Go to Dojo, dont even attempt to start a mission from normal navigation it wont apply from there either
- Go dry dock and open your Configure Railjack and notice your armor and hull stats are lower than they should be
- Go to the upgrades/mods tab and voila your stats increase magically

Now you can start a mission and the aura works as it should

 

Edited by Darkstalix
Link to comment
Share on other sites

  • TYPE: in-game
  • DESCRIPTION: game crashes when loading to or from the cambion drift.
  • VISUAL: no visual due to xbox turning off from a hard crash.
  • REPRODUCTION: tried doing iso vaults and game crashes entering cambion drift from the necrolisk and game crashes leaving the cambion drift entering the necrolisk and loses all progress.
  • EXPECTED RESULT: to not crash the game and turn off xbox (like it did before the update).
  • OBSERVED RESULT: cleared game caches,restarted router,modem,xbox and still crashes in the necrolisk.
  • REPRODUCTION RATE:100% 
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Strict nat issues, ports and firewalls. It's playing up with opened ports and disabled firewall
  • VISUAL: screen about UDP port needed to be opened 
  • EXPECTED RESULT: being able to play with people
  • OBSERVED RESULT: I'm basically playing a singeplayer warframe
  • REPRODUCTION RATE: Everytime I log in
Link to comment
Share on other sites

TYPE: Controller functionality

DESCRIPTION: Rank 9 gunnery intrinsic (reload to flush head sinks) cannot be triggered when [context action] controller binding is used for reloading. Only works if [reload] binding is specifically mapped on controller. 

REPRODUCTION: default controller setup

EXPECTED RESULT: [context action] binding on controller should trigger heat sink flush.

OBSERVED RESULT: cannot trigger heat sink flush unless [reload] specifically is mapped to controller. 

REPRODUCTION RATE: always

Proposal: add a [reload] or [flush heat sink] binding to the railjack control binding menu.

 

  • Like 1
Link to comment
Share on other sites

TYPE: In-Game

DESCRIPTION: I was on jupiter-cameria grinding on a infested survival. we were in a room and i jumped into a wall and went through it.

VISUAL: 

REPRODUCTION: in a closed room on cameria if you jump through the top half of the wall you will just clip through it 

EXPECTED RESULT: i should have hit a wall

OBSERVED RESULT: i went through the wall and fell (i also went back through the wall by flying with wukong)

REPRODUCTION RATE: every time

Link to comment
Share on other sites

On 2021-04-25 at 1:28 PM, TexMex-- said:

Hi,

my 2 cents:

  • TYPE: API https://api.warframestat.us/pc
  • DESCRIPTION: Text and key are the same for some entries in fissure section
  • VISUAL: Not in-game
  • EXPECTED RESULT: Some better text about the fissure mission
  • OBSERVED RESULT: The data is the same for many fissure sub-entries after fetching API content
  • REPRODUCTION RATE: refresh...

 

I'm maintaining a little web app (https://terrysschedule.herokuapp.com/#/). It uses the DE web API (@ https://api.warframestat.xx)

Since the new update some entries seem to be wrong. It has been improved but there is probably some more to do.

In this example below we clearly see that node, missionType, missionKey, enemy, enemyKey, nodeKey are the same.

 


PS : https://hub.warframestat.us/#/  Have the same issue happening.

 

 

 

This is not our fault, the API access point provided by DE is from here (for PC):  https://content.warframe.com/dynamic/worldState.php

The community operated site you're using is the one that's adding the node and faction names, you'll have to ask them to correct their lookup table

  • Like 9
Link to comment
Share on other sites

(I had the first 11 bugs listed originally last Friday, but when I came back to the computer my draft was gone; So I'm re-typing this)

  • (I cannot remember exactly how it was typed originally, but I'll note the important facts as they come)


Hey @[DE]CoreyOnline, I recently finished that main post!

"Post-Devstream (Railjack, etc.) feedback post (The original thread closed before I could post this)"

 

Considering that a bug is a bug, I’ll include both the Empyrean bugs I’ve found, and then the Non-Empyrean bugs below those. I’ll be sure to space out each one so it’d be a little easier to read, and separate the two sections. Each bug will also be numbered, since I have 18 of them to list (10 Empyrean, and 8 Non-Empyrean).

  • Has anyone else experienced some of these issues on other platforms? I’ve been wondering about that for some time, but from what I’ve seen of the PC and Switch update notes since Update 30 (Including all the hotfixes), none of these were mentioned.
    • For all of the bugs I’m listing, I would not rule out the possibility of PC / other consoles having the same issues, since some of these have been in the game as long as they have.
       
  • I want to note all of these bugs have been encountered in Solo mode. But I don’t have reason to believe the matchmaking mode affects any of them.
    • For some more details on these bugs (I have the most relevant stuff in this report), feel free to look at the bugs sections in the main post above.
       
  • I do have a few brief suggestions underneath a few of the bug listings, only because they relate to the affected thing at hand, which hopefully will be updated / fixed in the process. The most important thing of course is getting the bugs fixed; That said, should those suggestions go into one of the Update 30 feedback threads?

 

Empyrean-specific bugs:

1.

TYPE: In-Game, Empyrean collision detection (Missile Platform Point-of-Interest)

DESCRIPTION: Whenever a Missile Platform objective comes up in a Grineer Empyrean mission, the turrets on the top and bottom glow red-orange on the scanner, which implies that they can be scanned! So when I tried to do that, I discovered they cannot, since it looks right through them. You can also fly through either one, and striking it with an Archmelee (With or without Astral Autopsy) doesn’t affect them at all.

  • On another weird note, it seems the Blackout Pulse Avionic dealt damage to something by shooting it at the missile platform itself (Electric damage was shown in the center of the platform, while all turrets within range showed “0” damage ticks). I just wanted to see if anything else could possibly affect the turrets, but apparently that was a different outcome.
     

VISUAL: Images here:

Spoiler

Top Turret:

top_turret_resized.png

Bottom Turret:

bottom_turret_resized.png

 

As for the Blackout Pulse Avionic...

missile_platform_blackout_pulse.jpg?widt

missile_platform_blackout_pulse2.jpg?wid

missile_platform_blackout_pulse3.jpg?wid

If you look closely enough, you can see the various gray 0s around the platform; I'm guessing the Missile platform turrets technically can take damage, but are invulnerable due to their intangibility.

EXPECTED RESULT: Both missile platform turrets would have collision detection, making sure I can’t move into them and can deal damage if attempting to attack them. Due to being physical, they should be scannable as well.
 

OBSERVED RESULT: Both missile platform turrets have no physicality / hitboxes, and therefore cannot be touched, damaged or scanned. In that coincidental test with the Blackout Pulse avionic, the missile platform itself seems to have either a very high upper limit of HP (I’m surprised a POI even has HP in the first place), or no limit at all, since it showed damage ticks.
 

REPRODUCTION / RATE: This occurs 100% of the time, with any Grineer missile platform throughout Earth, Saturn & Veil Proxima. You can shoot Blackout Pulses into a Veil Proxima missile platform and see the damage numbers; That’s where I tested that part.
 

---
 

2.

TYPE: In-Game, Empyrean → Enemies not spawning / existing

DESCRIPTION: Whenever I board a Gyre or Exo Crewship, there is never a Gyre or Exo roller sentry, only the Earth Proxima-variant is ever seen; The Kosma roller sentry. This has been the case since Railjack first launched, if I’m not mistaken. It is still leveled up based on the mission level, but considering it’s largely the only type of roller sentry found in Saturn / Veil proxima regions, it seems very out-of-place. To the point where it must be bugged.
 

VISUAL: Image here:

Spoiler

Note the Veil Proxima Background:

kosma_roller_sentry_in_veil.jpg?width=65

EXPECTED RESULT: Grineer Crewships and points-of-interest should have Roller sentries that match the enemies you find there. Kosma sentries with Kosma Grineer, Gyre with Gyre, and Exo with Exo Grineer. Perhaps even Elite Exo Roller Sentries or Exo Skold Roller Sentries for those respective Crewships! As a result, all would usually come with their own codex entries to fill in.
 

OBSERVED RESULT: No such enemies appear to exist. Aboard (Most; See the note!) Saturn and Veil Proxima Grineer Crewships, you’ll find a Kosma Roller sentry among non-Kosma Grineer.
 

REPRODUCTION / RATE: This occurs 100% of the time, with any Saturn / Veil Proxima Crewship you board. Same goes for anywhere else a “Roller Sentry” shows up in Empyrean Missions, in these Proxima regions.
 

NOTE: There is now an exception to this post-Update 30. As mentioned in a bug (#8) below in the post, Exo Skold Crewships have all-Kosma Grineer to go with the Kosma Roller Sentry.
 

---
 

3.

TYPE: In-Game, Empyrean → Specific Codex Entries missing for fully-scanned targets

DESCRIPTION: After having fully scanned everything I could find in the Grineer Proxima regions (Everything aside from those missile platform turrets in the above bug), I checked my Codex, and noticed some Veil Proxima enemies do not have entries, nor do objects aboard Murex ships. I checked post-Update 30, and they all still glow green, which means they’ve remained fully scanned. But no entry has been found for them.
 

  • List of all missing enemy / object entries here:
     
    Spoiler

    (Copied & re-formatted based on the original list!)

    Enemies:

    • Elite Exo Ramsled
    • Elite Gokstad Crewship
      • Finished scanning it, logged out and back in, but still no entry.
         
    • Exo Skold Crewship
      • Also lacks an entry, probably related to the above crewship's issue!
         
    • Top missile platform Turret
      • Doesn’t have a name, but that’s basically my nickname for it.
         
    • Bottom Missile platform Turret
      • Also no name, but as mentioned above, these turrets are the same collision-less situation in any Grineer proxima.
        • That said, I do wonder if there’s 3 different entries for them from each proxima.
           
    • Gyre Roller Sentry
    • Exo Roller Sentry
      • Considering that these two sentries don’t spawn, there’s no way to directly search their names in the codex (To where it would surely pull them up). Although I didn’t see a blank space for them when searching “Gyre” or “Exo”, if that’s relevant.
         
    • Cannon Battery
      • I only learned this enemy has no entry until I was nearly done writing this whole post! It shows up on small asteroids in every Grineer Proxima region, but it seems to share scans everywhere you find it, at least.
         

    Objects:

    • Immunode
      • This object (Aboard Murex) can only be scanned with the Helios Sentinel, and even after I got it finished it still didn’t appear in the Codex. For those who’re wondering, this is the thing that makes Sentients invulnerable when they’re near it.
         
        • If you try to scan it normally, there isn’t any scannable part of the sphere that’ll register. I even tried standing on top of the node, but aiming down the north pole didn’t work either.
           
    • Sentient Murex Container
      • As there’s no entry for this either, I’m just giving it a name.
      • I finished scanning the regular objects on the Murex back during Scarlet Spear, but no entry was found ever since. I can only assume that the uncommon, rare, and reinforced variants don’t have entries either.
         
    • Various Mimic disguises
      • The Sentient Mimic enemy was scanned by my Helios Sentinel a few times during my Murex runs, and whenever I actually stopped far enough away to look at it, it’s object-form actually did glow bright red-orange, implying it could / should have some kind of entry somewhere (Or at least a different variation to swipe to in the Mimic’s personal entry?).
         
      • The odd thing is, I've already finished scanning the Mimic as far as I know. Yet helios still scanned it.
         
    • Debug Sphere?
      • In front of an Abandoned Derelict Entrance, I noticed a small round thing that you can just keep shooting at, even after the Derelict itself opens up! I even hit it with the Railjack’s artillery, dealing a large amount of Red crit damage. It makes for a perfect target to test weapons on :)
      • Noted in bug #10, further down this post! Although I'd like to think of it as a feature rather than a bug. It isn't hurting anything, really.
         
    • “DESTROY”
      • This is the core that you destroy during Shipkiller objectives. When you mouse over it though, it clearly has that name. If it weren’t for the glass around it, I imagine it might have an entry.
         
      • That being said, I’m not planning on trying to glitch into that little area just to try scanning it. But I thought it might be another example of a possible missing entry or scan-opportunity.
         
    • Grineer Mine
      • These sometimes can be found around Grineer Ship-killer platforms and the like. A cropped screenshot of this is included in the Scan collage included below.
         

    In addition to all of these missing entries, you can also scan the crewmates! They have no entries either, and it turns out when you have any one of them as a pilot, the “Pilot” of your ship can be scanned. When you have a different Crew member take the pilot seat to try scanning them, it says the target was already scanned.

    This implies to me that the "Pilot" (If not the seat itself) has its own, separate entry regardless of what crew member is involved. You can see the included images for evidence of this.

     

VISUAL: Images here:

Spoiler

First off:

finished_scans_resized.png
 

Then that "DESTROY" object:

DESTROY_grineer_empyrean_object.jpg?widt

I really wish Helios could scan through glass surfaces.
 

A more recent discovery, post-Update 30:

security_node_can_be_scanned_plus_codex_

There is a way to scan this thing actually! Apparently you need to destroy it first (The model will remain afterwards). It's unlike most other objects in the game in that regard!

  • For some reason, when you scan one of them, you cannot scan the other nodes; Might be a separate bug in and of itself.
    • I'm not sure how many total scans it'll need.
       

Last but not least, the Crew can be scanned. They didn't seem to glow red or green in the process however.

scanning_crew_member.jpg?width=657&heigh

scanning_crew_member2.jpg?width=657&heig

scanning_crew_member3.jpg?width=657&heig

 

When an individual was already scanned (To cover all the bases):

scanned_crew_member.jpg?width=657&height

 

Also, as noted in the list above;

scanning_crew_member_as_pilot.jpg?width=

Apparently if you switch them off to have a different crewmate piloting, it won't let you scan the "Pilot" again. So you'd have to do separate runs to finish that scan target.
 

One last thing; During Void Storms, Helios seems to scan the fissures that appear on the Railjack. I don't know how many scans those need to be finished, but it does imply they could have an entry as well.

EXPECTED RESULT: All enemies and objects in Empyrean Grineer missions should have codex entries to be filled in, with relevant details of course. They should be searchable as well, like all other existing entries.
 

OBSERVED RESULT: The enemies / objects I listed here have no such entry at all, despite having finished scanning them all (I haven’t fully scanned the Corpus’ Security Node as of this writing, but that should’ve been searchable at least).
 

REPRODUCTION / RATE: This occurs 100% of the time, whenever you check the codex after fully scanning the above-mentioned things, none of them will have an entry as of this writing. 
 

NOTE: Other missing entries include the Railjack’s Pilot (When you have any Crew member piloting the ship), Radiators you shoot off of some Grineer POIs, and your Crew members themselves can be scanned.
 

---
 

4.

TYPE: In-Game, Empyrean → Particle Ram is visually bugged

DESCRIPTION: After resetting my Railjack Controls to default via the workaround, I was able to activate Particle Ram again, and it functions the same as it used to, ramming into things and destroying objects, etc.; However, upon activating it post-Update 30, now it’s very dim, like it’s always visually “inactive”.

  • As shown in the included images below, if you do not move forward with the Railjack, the Particle Ram becomes nigh-invisible, as if it’s even more inactive. You can still launch it normally, but it appears inactive when you do that as well.
     

VISUAL: Images here:

Spoiler

When traveling forward in the Railjack:

bugged_particle_ram.jpg?width=657&height

Normally, the whole Ram would be as visible as that effect on the surroundings, but you can barely see the lines of it around the center of the image. It does ram into things just fine, at least.
 

When looking at the ship from outside:

bugged_particle_ram2.jpg?width=657&heigh

It looks mostly normal there, about the same dimness. Although I have not tested that while a Crew member is piloting the ship, so that's one thing to try at some point.

  • This image doubles as an example of the Odonata Prime texture bug, which is #11 in the post! More details on that can be found there.

EXPECTED RESULT: Upon activating Particle Ram, it should dim itself only when staying still, or otherwise not travelling forward. When travelling forward, it should brighten up to match the visual brightness it has when colliding with enemies / objects or terrain.
 

OBSERVED RESULT: The Particle Ram always appears visually inactive, and becomes even more dim when staying still now. It does function normally, but it just doesn’t look the way it should.
 

REPRODUCTION / RATE: This occurs 100% of the time. Simply activate Particle Ram after figuring out the default control situation (Until that issue gets fixed in and of itself), and you can test this in Free flight or other nodes.
 

SUGGESTION: I have thought of an idea for Particle Ram, for those who have completed Call of the Tempestarii. Spoilers for those who have yet to do the quest!

Spoiler

When equipping the Tempestarii as a skin, would it be possible to have the void energy effects from the skin itself extend around the outer border of the Particle Ram? It could be like a ghostly version of the avionic from ages ago, matching the old theme of the ship! I’m not sure if the Ram would have a different design to go with that, but I think it would be a neat little feature for those using the Tempestarii.

  • Those Void effects are almost like a Railjack Ephemera actually! It would be interesting if the void / mist effects were present inside the ship while the void effects are present outside of it; If not decoupling the void effects from the Tempestarii model, so you can use the effects with any ship skin.


NOTE: Be aware of the next (Below) bug when you’re about to reset your Railjack controls!
 

---
 

5.

TYPE: In-Game, Empyrean → Gunnery Intrinsic Rank 9 “Flush Heat Sinks” not functioning

DESCRIPTION: After setting the Railjack controls to default post-Update 30, the ability to “reload” while manning a Railjack turret no longer functions. I hadn’t really changed my controls beforehand as far as I recall, so something about the defaulting must have affected it.

  • On the Switch, prior to attempting the default-method to restore Offensive Avionic capabilities, I used to Flush Heat Sinks by pressing the Y button, which happens to be the same button used for regular reloads as well as Offensive Avionics, when combined with R (Right bumper). I’m wondering if that narrows down where the issue is? I hope it helps discern the problem for all the platforms.
     

VISUAL: Images here:

Spoiler

 

railjack_default_controls_heat_sink_solu

Pardon the blurred area; I tried to make it a bit easier to read amongst the bright white outlines, but that didn't work after saving the image. Essentially, it mentions to rename the action from "Reload" to "Flush Heat Sinks".

 

How things felt after having defaulted, with no reload / FHS binding:

what_did_it_cost_railjack_intrinsics.png

^ Sums it up well enough :)

EXPECTED RESULT: Flushing Heat Sinks should still be possible regardless of your Railjack controls being reset to default or not. Ideally, it should be an innate action of the controls after unlocking the intrinsic ability via Rank 9 Gunnery.
 

OBSERVED RESULT: The button previously used for Flushing Heat sinks no longer does so, after setting the Railjack controls to default.

  • Someone on the most recent Switch update notes (Call of the Tempestarii Hotfix #4) did mention a possible way to make it work again, but I still think making FHS an actual action you can set within the Railjack controls would serve much better.
     


REPRODUCTION / RATE: This now occurs 100% of the time in and of itself. If you reset your Railjack controls to default on Console (At least for Switch), you can no longer do anything with the “reload” (Y) button while manning the Railjack turrets (Including the turrets you can swap to while at the forward artillery).

  • I have not tried to set “reload” to my general control bindings, partly in the hopes that FHS will be its own action you can set. The reason being that it would make the button it’s set to a reload action for all missions, from what I understand. I’m not entirely sure how that would affect other things involving the Y button, so I think I’ll wait on it for the time being until more info on this comes to light.
     

---
 

6.

TYPE: In-Game, Empyrean → Crew Customization & Sigils

DESCRIPTION: Various Sigils appear to be darker in the Crew management screen than they do in the field (Meaning around your Railjack / Dojo, during missions, etc.). I don’t think all sigils are affected by this (At least not severely as others), which means checking through all sigils will take some time; I wish I could make a list for it, but I can’t do that entirely since I don’t own every sigil. On the bright side, I do have a couple of screenshots to show an example of it!

  • It’s worth noting that sometimes a Sigil doesn’t properly load; At least not right away. When this occurs, it looks like a darkened square. You can see that in the second image.
     

VISUAL: Images here:

Spoiler

In the Railjack, at the Dry Dock:

crew_member_sigil.jpg?width=657&height=3

 

Here's that same member / Sigil in the management screen:

crew_member_sigil2.jpg?width=657&height=

I haven't seen this with all the Sigils I have, but some do seem to be affected. Such as the Buried Debts Sigil and various Syndicate Sigils like that Red Veil one. Hostile Mergers' Sigil could be another, off the top of my head.

  • Sigils also seem to take some time to load, appearing as a darkened square (Noticeable on the right-side Crewmate). This may be a console issue for all I know, but it's another reason for asking.

EXPECTED RESULT: Any / all sigils that may be applied to one of your Crew should look the same in the Crew management screen as it does outside of that screen. That may include the glossy / shiny effect on some of them (Such as Syndicate Sigils).
 

OBSERVED RESULT: It appears that only when seeing your Crew outside of the management screen, will the Sigils look the way they’re intended.
 

REPRODUCTION / RATE: Depending on the Sigil used, this seems to be noticeable 100% of the time. The degree to which a Sigil is darkened compared to viewing them in-person may vary (Like with the Red Veil Sigil in the images).
 

NOTE: Speaking of Syndicate Sigils, I noticed that even when turning the Alpha setting down to make them more transparent on the back of my Warframes, whenever I go into a dark or shaded area (In the Orbiter, in-mission, etc.), the shiny effect and brightness of the Sigil is turned back up, regardless of the transparent setting; ← Is that intended?
 

---
 

7.

TYPE: In-Game, Empyrean → Grineer Veil Crewships can have bugged lighting(?) on the inside

DESCRIPTION: While doing some missions in Veil Proxima, every time I went inside a Grineer Crewship (Exo / Elite Exo Gokstad / Exo Skold), the entire interior of the ship was affected by some sort of shiny / glossy effect. Your Warframe, weapons, companion (Sentinel or otherwise), and even the Necramech are affected by this as well! Enemies may be affected by it to a lesser extent.

  • When I ran downstairs underneath the reactor, I noticed the effect intensified the closer I moved to a corner near the bottom turret. The front of the Crewship where the Pilot is does not seem to be as affected by this however. That said, the Pilot themselves and other enemies anywhere on the ship may be affected.
     
  • The last time I checked, I have default settings for visuals in the Options. I don’t remember seeing any settings there that would relate to this kind of effect however.

VISUAL: Images here: 

Spoiler

bugged_something_exo_crewships.jpg?width

bugged_something_exo_crewships2.jpg?widt

If the floor looks like ^ this, then it's likely that ship has been affected. I think at one point yesterday (April 25th) I saw a similar lighting issue in the Deimos Orokin Derelict tileset, but I didn't think to grab a screenshot of that.

  • I have more screenshots in bug #8 that double as examples of this (In Empyrean).

EXPECTED RESULT: Upon boarding a Grineer Crewship in the Veil, the interior lighting, etc. should be the same as it is for all other Grineer Crewships, at least to the degree as intended for the game. The lighting should just be as it is intended, rather than creating a new effect where it shouldn’t.
 

OBSERVED RESULT: Regardless of boarding the Crewship before / after shooting down it’s HP, the interior appears very shiny / reflective, and moving towards the center of the ship increases that effect for your weapons, Warframe and other things.
 

REPRODUCTION / RATE: This seemed to occur most of the time in the runs I did. I’m not informed on if this happens for any other systems, as I don’t have a way to check that myself. Simply go into the Veil Proxima (For Grineer missions; I don’t know if Corpus Crewships are affected as well), and board any Crewship you see. The interior’s lighting, etc. could be different compared to Saturn or Earth Proxima.

  • The last time I boarded some Exo Skold Crewships, the shiny effect was not there. So that confirms it may not happen for every mission.
    • Another important factor to consider here is whether or not it happens specifically during a node occupied by Sentient anomalies; I didn’t think to check for that detail unfortunately.

SUGGESTION: Is there a way to make that shiny / glossy effect a new Ephemera (Or Dojo Decoration, etc.)? I’d be lying if I said I didn’t find it interesting! Actually, if not an Ephemera, perhaps a setting you can toggle in Captura scenes?
 

---
 

8.

TYPE: In-Game, Empyrean → Exo Skold Crewships now have “Kosma” enemies

DESCRIPTION: Upon boarding an Exo Skold Crewship specifically, all the Grineer onboard appear to be Kosma variants. Their levels are scaled up to the Veil Proxima range, but all of them seem to be out-of-place, just like the Kosma Roller Sentry being in Saturn / Veil Proxima! I highly doubt this is intended.

  • I’m not totally sure if this is related to the recent issue of some Corpus ships / enemies being named the wrong things.
     

VISUAL: Images here:

Spoiler

Various examples:

kosma_guys_veil_proxima.jpg?width=657&he

kosma_butcher_in_veil.jpg?width=657&heig

^ More shininess!

kosma_gunner_in_veil.jpg?width=657&heigh

kosma_guy_in_veil_proxima.jpg?width=657&

A very nice view of Veil Proxima :)

EXPECTED RESULT: Whenever I’d board an Exo Skold Crewship, I’d expect to see only Exo Grineer enemies, just like before Update 30. Maybe a few Elite Exo Grineer, but overall no Earth or Saturn Proxima enemies should spawn outside of their regions.
 

OBSERVED RESULT: Aboard every Exo Skold Crewship I found, they all had Kosma enemies. I couldn’t tell at the time if they were truly Kosma Grineer, or just accidentally-renamed Exo Grineer (Similar to that Corpus naming issue) since I was more focused on finding whatever bugs I could that seem obvious.
 

REPRODUCTION / RATE: This occurs 100% of the time for Exo Skold Crewships. Exo / Elite Exo Gokstad Crewships have the proper Exo Grineer enemies (Unless you count them all having Kosma Roller Sentries). Just like the shiny bug mentioned above, it doesn’t matter if you damage the Crewship or not before boarding it.
 

---
 

9.

TYPE: In-Game, Empyrean → Level Rendering / draw distance specific model swap bugged

DESCRIPTION: Whenever I enter a Grineer Veil mission with a “busted-up” derelict-like object as part of the level’s debris, it isn’t shown as such until I fly close enough to it. Whenever I’m farther away, it appears as a massive Orokin Derelict (With a Golden center at one end of it). In a run I did recently, I encountered the objects & model swapping for two different instances of it. I’m guessing both had a similar viewing distance to where the change occurs.
 

VISUAL: Images here:

Spoiler

The small derelict, within that distance:

busted_derelict_within_range.jpg?width=6

 

The bigger version:

busted_derelict_outside_of_range.jpg?wid

 

Some close-ups of the smaller one:

busted_derelict_in_person.jpg?width=657&

busted_derelict_in_person2.jpg?width=657

You can also see that a different, actual Derelict is marked near the top of the screenshot coincidentally, showing that the big derelict was not the same kind.
 

Both versions from another angle:

farther_from_derelict_alternate_angle.jp

closer_to_derelict_alternate_angle.jpg?w

The waypoint vanished by the time I took those last screenshots, but I stayed roughly at the swapping distance. Apparently if you're right on that borderline, you can see the swapping happen by getting in / out of the pilot's seat.

EXPECTED RESULT: The models of terrain shouldn’t have that big of a size difference whenever I’m at a certain viewing distance away from them (Where it appears like a completely different thing).

  • Of course that probably depends on the type of game, as far as that goes.
     

OBSERVED RESULT: For this object in particular, the model swaps to the (I’m assuming) intended busted-up Derelict object when I’m close enough to see it. When I’m even slightly farther away than a certain distance (It seems to be roughly between 7100 - 7200 meters, give or take), it becomes the much bigger, not so damaged object.

  • If you move the ship so it sits right on the draw distance, etc. border, then you could even see the object change models by simply getting in / out of the pilot seat!
     

REPRODUCTION / RATE: As shown in the images, it is confirmed not to be the type of Derelict you can visit (Because it will not be marked by Piloting Intrinsic 5), although from far enough away the model does resemble that, perhaps. As you move in closer however (In Archwing or Railjack), the model will swap to the much smaller, busted-up Derelict (With the metallics being kind of Bronze in color?).
 

---
 

10.

TYPE: In-Game, Empyrean → Debug Sphere in front of Derelicts

DESCRIPTION: Even before Update 30, I discovered this little object in front of Derelict entrances. It appeared to make for a great test target to fire Railjack weapons at (Considering we don’t have a Simulacrum for the Railjack weapons or Archwings yet!). This is one of the reasons why I like it so much, since it has potential for a lot of use in the future.

Striking it with Archmelee, shooting it with Archguns or Railjack turrets, even the forward Artillery won’t shove it around, it just displays damage numbers far away from the object itself, implying it has a large hitbox.

  • I was also able to fly through it in Archwing, if I recall correctly. I have absolutely no idea what the name of it is, so I'm just calling it a Debug Sphere. No idea if it has a Codex entry, but as much as I’d like to see John Prodman’s entry, I would love to see this object in the Codex as well!
     

VISUAL: Images here:

Spoiler

This first image was taken before Update 30:

debug_sphere_derelict_resized.png

 

The rest of these images came from after Update 30:

debug_sphere_scanned.jpg?width=657&heigh

 When ^ scanned!

  • Not quite sure how many scans it needs though.

 

It can definitely take some punishment. Apparently it's hitbox is waaay beyond the Derelict's entrance:

debug_sphere_archgun.jpg?width=657&heigh

Looking at where the numbers are ^ that is. The sphere itself is that tiny little thing by the bright light.


Railjack turrets:

debug_sphere_railjack_turrets.jpg?width=

 

Forward Artillery:

debug_sphere_artillery.jpg?width=657&hei

This is a great example of why it should be added to the Simulacrum, I think. Of course fixing the bugs comes first, but I would like to see this be a feature more than a "bug".

  • (Railjack Simulacrum expansion someday? It could even be modeled after the Dry dock, with a path going off to one direction where it takes you to an open space area, away from the normal Simulacrum)

EXPECTED RESULT: A developer-object normally would not be visible in-game for a regular player, I would think.
 

OBSERVED RESULT: Whenever I near one of the Derelict entrances, I can see that little thing right in front of the entrance. It did seem to go away after shooting it for so long, but as shown above I was also able to scan it! Personally speaking, I actually liked seeing it; It was a cool discovery.
 

REPRODUCTION / RATE: This can be found 100% of the time in front of Derelict entrances (At least on the Switch; I’m not informed on if PC has these or not). You can shoot it as much as you want with anything you have on hand, it’ll just continue to take damage for quite awhile! It does not affect the entrance itself; It basically seems like an extra little thing (An Easter Egg, if you will) to me!
 

NOTE / SUGGESTION: Since this Debug Sphere can be scanned, does it truly have a Codex entry, or does it not? I’m not sure who’s in charge of the Codex at DE, but have you heard of this before @[DE]CoreyOnline? Could it be added to the Simulacrum as a test object to fire weapons at?

  • If it could, I think setting an amount of armor, various weaknesses and resistances to it would be a useful feature, so that you can test the damage of your weapons without having to run back to the console and respawn a standard enemy, etc.; Perhaps a Steel-Path toggle (On / Off) could be added to enhance the stats you set for the target :)
     

------------------

 

Non-Empyrean-specific bugs:
 

11.

TYPE: In-Game, Archwing Texture glitch

DESCRIPTION: The texture of the Odonata Prime seems to glitch at some point in any mission where Archwings can be used, including Empyrean and free roam areas. I’m not 100% sure, but it partly seems like the secondary color is being swapped for the accent colors; However as you can see in some of the Empyrean bug images, parts of the gold are trying to escape the purple areas.

  • I have not tested this with any other Archwings, but I wouldn’t rule this out for them.
     
  • After seeing this occur so many times, it almost seems like a matter of “when” this bug will occur, rather than “if” it’ll happen. Not that I’m complaining; It just seems like something triggers it no matter where I go :)

VISUAL: Images here:

Spoiler

Normal texture for comparison:

odonata_prime_normal_texture_resized.png

 

The following texture glitch images were taken in Captura, but as mentioned below, it can happen basically anywhere you use an Archwing.

Side view of the texture glitch:

odonata_prime_texture_glitch_resized.png

 

Top view of the texture glitch:

odonata_prime_texture_glitch_resized2.pn

 

Back view of the texture glitch:

odonata_prime_texture_glitch_resized3.pn

 

Also, post-Update 30 I actually noticed it extends underneath the Archwing in parts:

odonata_prime_texture_glitch_underneath.

This ^ involves a slightly different color change; Gray to blue, gray-white to a clearer white, and a better-looking purple color from the previous purple.

  • Most, if not all the images I've included for Empyrean bugs involve that color change, to clarify. The texture glitch here is obviously it's own issue regardless of which colors there are.
     

By sheer happenstance, I had this happen for the first time recently:

mirage_texture_bug.jpg?width=657&height=

I've only ever had this happen the one time, and I'm not exactly sure what caused it (Boarding the Crewship as it's turning upwards / to the left?). This bug lasted while I was in the Crewship, and in the rest of the Crewships I boarded, it didn't happen again.

  • I just noticed the blue / white similarities between this and the Odonata Prime's pattern, so I thought I'd share it. Looking it back over, apparently Mirage Prime's head was left alone here. That might be because you can switch certain helmets around separately from a skin.

EXPECTED RESULT: The texture should’ve remained as normal throughout the mission(s).
 

OBSERVED RESULT: At an unknown point in time during your mission / Captura instance, and due to an unknown cause the texture split in half along the top / bottom of the Odonata Prime. The top half was bugged, while the bottom half stayed largely normal. In more recent missions (Since before Deimos Arcana?) however, both halves of the Odonata’s texture are being affected now.
 

REPRODUCTION / RATE: Possibly 51 - 100% likely to occur anywhere Archwings can be used. As of yet, I’m still not sure what circumstances trigger it, except to say that it very likely doesn’t matter what Warframe you have at the time. For me lately, it seems to occur pretty quickly in any AW area, if it were to happen. Could anyone confirm if this occurs on PC as well?

  • Considering the fact it uses part of Odonata's own colors, that is.
     
    • One idea I hadn’t considered until now is, what if it has something to do with checking your Archwing in the Arsenal before going on a mission? I haven’t tried that before, but it’s just a thought.
       
  • On another note, I almost feel like this qualifies for the “Bug Bounty” thing on the Trello board, since the circumstances haven’t been confirmed for a long time (I’ve spent a lot of time thinking about it on my own, even). Not to mention that, it could even be triggered by more than one method, for all we know.
     
  • It’s not game-breaking however, so any other bounty would take priority over this of course.
     

SUGGESTION: Would there be a way to update the energy trails from the Odonata / other Archwings to use your secondary energy color, like with K-Drives?

Spoiler

Archwing trails with only one energy color involved:

odonata_energy_trails_resized.png

Blinking already uses both energy colors, so I don't think it would be a bad idea to implement that for regular trails as well!
 

One example of dual-energy trails:

misplaced_jet_trails_resized.png

The trail colors blend together ^ pretty well!

  • This image doubles as an example of bug #15 in this post.

 

---
 

12.

TYPE: In-Game, Mining UI

DESCRIPTION: At least in Free Roam areas (And possibly regular star chart missions), whenever you aim with the Sunpoint Plasma Drill the bars on either side of the UI will suddenly shorten themselves by the same amount. This may also happen by merely equipping the drill, in which case both bars will shorten even further, when aiming. The performance of the drill doesn’t seem affected.

  • The number of nearby mining areas does not seem to be affected either, I think.
     

VISUAL: Images here:

Spoiler

I've got a before & after example!

Before:

plasma_drill_UI_before_resized.png

 

After aiming for any amount of time:

plasma_drill_UI_after_resized.png

EXPECTED RESULT: Equipping the drill would only bring up the UI on-screen. Aiming with it would not alter the UI in and of itself.
 

OBSERVED RESULT: When taking aim (Even just for a moment) with the Sunpoint Plasma Drill, the white bars on either side of the UI are cut off equally. It’s not always by the same length however.

Furthermore, under unknown circumstances the UI can be cut off by merely equipping the drill (Without aiming it). If you do aim it in that state, then both bars get cut off even more, still by an equal amount. I’m not sure if the two bugs are connected, but I hope it helps.

There is literally nothing you can do to restore the mining UI to its proper state if it occurs. Not even dying & reviving, or diving into the water and respawning. Going into a new mission should fix it until you take aim again, unless the second bug happens.
 

REPRODUCTION / RATE: When you aim the Sunpoint drill (Probably also other drills, don’t forget to test it), this occurs 100% of the time (At least in Open World areas). The second bug (Where the UI is cut off when you just equip the drill) isn’t super-rare, but not common due to the unknown triggers.

  • I’d guess the second bug may be ~45% likely, since I don’t always see it. The last time I had it happen was a few days ago (Which was April 13th or 14th as of this bug’s writing).
     

NOTE: Aboard Grineer Crewships (And possibly Empyrean missions overall, I have yet to test this), the Sunpoint Plasma Drill’s UI appears to function normally, even when aiming with it. I’m not sure why that is however, compared to the Open world areas.

  • I’m not sure if it is related to whether or not you equip / summon other gear before equipping the Sunpoint Plasma drill. But the thought crossed my mind at one point; I have not tested for that.
     

SUGGESTION: Is there a way to customize the colors of the drill’s beam, or the drill’s UI colors? That would be rather interesting to implement someday.
 

---
 

13.

TYPE: In-Game, Acolytes & Necramech

DESCRIPTION: In every Steel Path open world area, if an Acolyte appears (Whether or not you get into your Necramech beforehand), the Acolyte will leave if your Necramech is brought down to 0 HP by any source of damage. You aren’t downed, but they act like you were. This can happen with either Necramech, and vs any of the Acolytes.
 

VISUAL: I have not been able to get a good screenshot of this. One example of such would be seeing your Operator’s HP the very moment your Necramech goes down. Pay attention to the Acolyte’s UI!
 

EXPECTED RESULT: I would’ve still gone into Operator, put some distance between me and the Acolyte and transferred back to my Warframe to continue the battle.
 

OBSERVED RESULT: As soon as the Necramech crumbles from whatever kills it, the Acolyte leaves even though I wasn’t actually “downed”. A thought came to mind after a while; Maybe the Acolyte saw I had 0 HP, and wanted to escape before I annihilated them back :)
 

REPRODUCTION / RATE: This occurs 100% of the time. You only need to go into an Open world on the Steel Path (I like the Orb Vallis most of all), kill some enemies, etc. until any Acolyte shows up. Then let your Necramech be killed by any source of damage.

  • If / when Necramechs would be in regular missions with said Acolyte, I’m very sure this bug would happen there too, hypothetically. It’d be great to nip this in the bud before then.
     

---
 

14.

TYPE: In-Game, K-Drive VFX

DESCRIPTION: When you make medium-speed movements (Or while boosting, sometimes) on the K-Drive, you can see a third orange trail coming from the center of the board. I remember seeing this with the original Bondi K-Drive as well, but I don’t know why it’s there.

  • It just seems a bit out-of-place, since there isn’t a lit-up area underneath the board to show where that light could come from.
     

VISUAL: Image here:

Spoiler

This image was taken before Update 30, but I have since confirmed it's still occurring:

orange_board_trail_resized.png

^ Taken in-mission. Although it can be seen in captura as well.

EXPECTED RESULT: For any K-Drive (Including the Bondi, when I still had that), when I make certain turns or strafe around, there shouldn’t be a third trail coming from the board itself; Perhaps unless there was ever an update to K-Drives that planned for expanding them in some way.
 

OBSERVED RESULT: An orange trail (Just like the Bondi’s orange colors) can be seen if you make certain maneuvers on the ground no matter if you’re boosting or just going around without boosting.
 

REPRODUCTION / RATE: It can be done 100% of the time, if you’re moving in the right ways. Like strafing around in a circle, and paying attention to the board itself. You’ll see the bits of the third trail here and there.

One example would be moving around in a circle with only the movement stick / button (Without turning the camera). If you look closely at the center of the board, you’ll see glimpses of the trail. You can see it a little easier if you don’t move too fast, but as noted in the visual it can occur while boosting as well.

  • I’m guessing it’s a remnant of the original Bondi K-Drive?
     

---
 

15.

TYPE: In-Game, K-Drive Jets’ VFX

DESCRIPTION: When you summon your K-Drive and ride around on it, you can see the lights of energy and jet trails coming from a misplaced point within the jets; The center of them, similar to the above K-Drive bug. You can also get a very close look at that point if you move the camera around while standing next to your K-Drive.

  • When viewing your K-Drive in the Arsenal, you may be able to see the points of energy coming from the center of the jets there as well, which is probably a connected issue to this.
     

VISUAL: Image here:

Spoiler

As shown earlier:

misplaced_jet_trails_resized.png

The trails may look nice, but they're coming from the center of these jets, rather than the tip of the models.

EXPECTED RESULT: For almost any pair of K-Drive jets, the trails shouldn’t be starting from the center of the jets themselves, but rather the tips of them. Same thing goes for the small lights of energy that can be seen.

  • Realistically speaking, I would think the energy itself would be from the tip of the K-Drive jets (Or still in the center for the Fatboys | WARFRAME Wiki | Fandom), so that the trails come out from there.
     

OBSERVED RESULT: Both the energy and the jet trails come from the center of the jets themselves. This occurs with any pair of jets. Very noticeable if you move sideways with the K-Drive.
 

REPRODUCTION / RATE: It can be seen 100% of the time. Even simply summoning the K-Drive is enough to see the issue. I’m somewhat wondering if the energy being in the center of each jet is directly related to why the trails come from the centers?

  • That’s assuming that the small light of energy is actually what generates the trails (Like if you make a particle effect in blender, etc.?), to connect the two.
     

SUGGESTION: I would probably recommend leaving those Semicircle jets alone, since it appears to look nice with them. But fixing the rest of the jets (And any future K-Drive parts?) to have the trails come out of the intended (Logical? Heh) areas would be good.
 

Spoiler

Whoever originally comes up with the concept for said jets is who I’d check with, to make sure their work is accurately depicted; But that’s my creative side talking :)

  • On that note, perhaps different jets could have their own trail designs? Like if the Step Tens were venting out heat to stay aloft? The Twin Kavats / Thugs would probably retain the original (Current) trails, I imagine.

 

---
 

16.

TYPE: In-Game, Arsenal → K-Drive

DESCRIPTION: When viewing your K-Drive in the arsenal, the board is upside-down. I have seen this with both K-Drives that I own, leading me to suspect it happens with all crafted K-Drives.
 

VISUAL: Images here:

Spoiler

The K-Drive in-arsenal:

kDrive_arsenal_resized2.png

 

The same board, as it was from the Ventkids:

kDrive_ventkids_resized.png

 

EXPECTED RESULT: Viewing the K-drive in the Arsenal should not show it being flipped upside-down. I’d expect it to be the same as when you first build it at the Ventkids.

  • Or perhaps laying the board flat, and allowing you to rotate the board up / down as well as left and right? You’d be able to get a full picture of the board that way.
     

OBSERVED RESULT: It appears that the board’s model is flipped 180° backwards, where the top of the board is underneath, and vice versa.
 

REPRODUCTION / RATE: This occurs 100% of the time, with any K-Drive you own. Viewing it in your Arsenal would be a very fast test, I’m sure.
 

---
 

17.

TYPE: In-Game, K-Drive → Warframe upper body loose, etc. after falling a certain distance, etc.

DESCRIPTION: If you summon your K-Drive on any surface where it looks like you’re standing on nothing, the board will fall to just below where your feet were like you’re falling. Your frame’s arms go up in the air, and the upper body spins around the waist, stretching more and more on every repetition to infinity.

It can be done in Captura scenes or in-mission, and you can basically undo the stretching / spinning part by doing a trick of some sort (Since the board thinks it’s in mid-air).
 

VISUAL:

  • Phone recording I made on April 11th: K-Drive upper body glitch
     
  • Evidently, other people on YouTube have since made videos showcasing this glitch as well. If there would be a way to preserve how interesting it is, maybe it could be a toggle in Captura? For those who'd rather not see it go away :)


EXPECTED RESULT: Summoning the K-Drive on a surface like shown in the video (Where it looks like you’re standing on nothing), would simply treat it as normal ground. It would not act like it’s in mid-air, thus moving around normally.

  • Simply coasting off the tip of an Orokin tower and falling should not eventually affect the model in unforeseen ways.
     

OBSERVED RESULT: Boarding a K-Drive on such a surface makes the K-Drive think it’s falling, which is made evident by the Poppin’ Vert mod when you do a trick (The capability of doing a trick on supposed “ground” also clued me into the mid-air thing).

After “falling” for so long, the Warframe’s upper body begins to become disjointed (Pivoting around the waist), and it loops around in a circle over and over, stretching in a seemingly exponential manner to infinity. Performing a trick undoes this until you get off / back onto the K-Drive. The head and arms are not stretched.

  • Coincidentally, that video also clearly shows the above-mentioned bug of jet energy / trails coming from the center of K-Drive jets.
     

REPRODUCTION / RATE: 100% likely to occur on the correct type of surface (Like the top of the Spaceport tower in the Orb Vallis). You can also see this happen if you just ride off the top of an Orokin tower there, as long as you don’t jump off or do a trick. That led me to believe it’s largely based on how much you fall at a time without a trick involved.

  • There is one thing I’m curious about. Regarding an elevated location like the Spaceport tower that you can walk on, is that part of why the K-Drive thinks it’s in the air? Then again, the affected part of the tower is just the center / middle of it, where the light shoots out.
     

---
 

18.

TYPE: In-Game, Cosmetic → TennoCon 2021 shoulder Armor misplaced on Mirage Prime

DESCRIPTION: I got the TennoCon 2021 Digital pack the other night, and wanted to see how that Armor would look on Mirage Prime. I discovered that on her right shoulder, that Armor piece is placed above her shoulder, instead of properly sitting on it like the left shoulder is. I made sure to test this with some other frames (Limbo Prime, Mesa Prime, Frost Prime, and Excalibur Umbra, and then regular Mirage), but as I don’t own all the frames quite yet, I cannot test them all. But the ones I have tested turned out alright; For some reason only Mirage Prime herself was affected.

  • This reminds me of how the Itzal Armor shoulder piece (The right shoulder, I believe) is misaligned on Volt Prime; Last I checked, it still was. But I will check that again later today.
     
  • Also I’m not sure if it’s by design / intention or not, but as shown in the images below, Emblems displayed with the TennoCon 2021 shoulder Armor are not placed on the shoulder either; This is something I noticed with all the frames I tested however, which implies to me it might be intended. Is that another bug, however?
     

VISUAL: Images here:

Spoiler

Exhibit A:

tennocon_2021_right_shoulder.jpg?width=6

tennocon_2021_emblem_shoulder_placement.

Emblem Projectors (Is that what they're called?) are also misplaced it seems, unless that's an intended design choice. I would've expected the Emblems to be placed / projected from the surface of the shoulders themselves rather than hovering off of them like the right-shoulder Armor piece does.

  • All the Frames I tested showed normal Armor placement, but the emblems were not placed onto the shoulders at all; Which makes me wonder if that part is actually intended or a bug.

 

With normal Mirage:

tennocon_2021_normal_mirage_shoulder.jpg

The right shoulder is properly placed, but the Emblem Projectors are clearly not on her shoulders.

 

Some profile angles, as another example:

tennocon_2021_right_shoulder_profile.jpg

tennocon_2021_right_shoulder_profile2.jp

tennocon_2021_right_shoulder_profile3.jp

The left shoulder Armor and the rest of the set itself looks properly placed at least!

  • Briefly regarding the clan name, if anyone was wondering; I just started that clan in case some friends from back home were to start Warframe someday. It references a concept one of them thought of years ago :)
     
    • In any case, I've just been focusing on research first, then decorating, etc. someday.
       

A couple of viewpoints from the Arsenal:

tennocon_2021_right_shoulder_arsenal.jpg

tennocon_2021_right_shoulder_arsenal2.jp

At the time I thought that would be another way to show the hovering projector.

 

And last but not least, an image with the Shedu (Speaking of the Arsenal!):

tennocon_2021_right_shoulder_shedu.jpg?w

I thought of it last-second, and apparently this is the result! It almost works, but it still clips a bit. I haven't crafted the Bubonico yet, but I imagine the same could happen.

 

EXPECTED RESULT: The TennoCon 2021 Armor pieces should be placed in the same spot as the opposing side, parallel to one another. Depending on whether the Emblem placement is intended or a bug, I would normally expect those small Emblem projectors (Not sure if that’s what they’re called) to also be placed directly on a Warframe’s shoulders (Any Warframe / skin), or perhaps out-of-sight so that it appears the Armor itself projects the Emblem image.

  • Regarding the Emblem placement, that’s why I was wondering if that’s a bug or not; Because knowing whether something is intended or not will help to understand why something is the way it is. In this case, the possible design choice of where Emblems are for the new TennoCon Armor.
     

OBSERVED RESULT: Only discovered on Mirage Prime herself (So far), the right shoulder piece of the TennoCon 2021 armor is placed off of her right shoulder, therefore not evenly lined up with the rest of the Armor set, or at least her opposite shoulder. Evidently, Emblems are also placed off the surface of shoulders for any Warframe that wears that Armor.

  • Regular Mirage, Mesa Prime, Limbo Prime, Frost Prime, and Excalibur Umbra (& hopefully all other frames) do not appear to have this issue with the Armor placement, thankfully.
     

REPRODUCTION / RATE: For Mirage Prime, this is 100% likely to occur it would seem. I did test this with her other skins, and only the Prime skin is affected. There’s a fair chance this issue occurs on all other platforms, considering it isn’t the first time a specific Warframe / skin was affected by a specific piece of Armor (Coincidentally on their shoulder as well).

  • I do have more frames to test it with, but there are some I don't own yet. Excalibur Prime of course I cannot test, but he's still a possible candidate for the TennoCon 2021 armor issue until proven to be issue-free.
     

NOTE: Just in case, I would make sure other skins for other Warframes don’t have this issue as well; I don’t have the means to test all the combinations, but I hope that will help.

 

I hope that these bug reports help make the next update a bit better for PC and Console players! Let me know if any further information is required; I’ll be looking in the future patch notes to see they’re fixed in the near future :)

  • Like 3
Link to comment
Share on other sites

  • TYPE: In-Game
  • DESCRIPTION: Hydroid falls through the floor when in stain form and can get stuck in tiny gaps when going out of stain. (found in syndicate onslaught if that matters)
  • VISUAL:  https://imgur.com/a/2zrHQna
  • REPRODUCTION: Find place where there could be gap between tiles (often doors). Go into stain form. Move for a bit.
  • EXPECTED RESULT: Well hydroid (or stain actually) should just navigate through doors.
  • OBSERVED RESULT: Hydroid falls through the map.
  • REPRODUCTION RATE: Every time you do this on certain door/tile edge.
  • Note: it seems that stain form makes hydroid's dimensions ridiculously small and changing than may help. 
Link to comment
Share on other sites

Type: In-Game

Description: The Sigma and Octantis uses the first attack of neutral standing regardless of stance

Reproduction: Use the Sigma and try attacking with any combo

Expected result: Combos will begin to act strange

Observed Result: Combos act strange

Reproduction Rate: every time you melee

Note: The only issue is that the stance acts funkalicous, other than that the weapon operates as expected

Edited by (XBOX)NightLock2917
Did not follow operations with first post
Link to comment
Share on other sites

  • TYPE: In-Game (XBOX)
  • DESCRIPTION: Forward artillery wouldn't charge, or it would charge but then not discharge.  Was not host.  Had been host for a few back to back missions but (set to public but not paired  with anyone with no issues until it randomly took me off my own railjack and  paired me on a different RJ (even though I hadn't returned to drydock was just doing back-to-back-to-back...
  • EXPECTED RESULT: Enter artillery with plenty of dome charges, I expect to be able to use them.
  • OBSERVED RESULT: Could not use them - I could switch to turret mode, and the turrets would shoot, but the artillery acted like I had no dome charges (most of the time) or if I had just switched back from turret mode, it would give the charge up animation with the lines, but it would never discharge.  Another user in the squad said they could only fire it if they switched to turret and back between each shot - So for him it was only 1/2 broken.
    • I did try crafting even more dome charges (until I had 15+),
    • exiting the artillery seat and re-entering
    • exiting artillery, going to an actual turret, exiting that, returning to artillery
    • exiting RJ to archwing, and re-entering artillery
    • launching a new mission (not by returning to dry dock)

      Problem persisted through all of that - for about 4 missions until the squad got sick of dealing with it and returned to dry dock and disbanded.

 

  • REPRODUCTION RATE: 100% of the time in that mission.  Was the only time I've seen it - but then i was only in a public RJ mission accidently having forgotten to switch to solo mode before launching mission to avoid 1/2 these bugs.
Link to comment
Share on other sites

Hello I’m posting this because there hasn’t really been much done addressing the lack of functionality of the mouse and keyboard on Xbox, I created a thread discussing the topic and someone found a fix involving disconnecting your m&k and reconnecting it but there is still no function with the mouse scroll wheel, could you look into this?

 

- ps. Another bug involving mouse and keyboard that has been around for quite a while is that there is no way to use a key bind to use a cipher when hacking and there is no way to set a key for it, this remains a problem as of April 26th 2021 and I would really appreciate it if you looked into this as well. Thanks for all you guys do at DE to make an amazing game!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...