Jump to content
General Bug Report Guidelines - Please Read ×

Atlas Rubble Mechanic Completely Bugged When Infusing Over Petrify


Sbimon
 Share

Recommended Posts

Posted (edited)

When doing tests in the simulacron (was also tested in a normal mission) the ability-petrify is NEVER used to petrify enemies and subsequently generate rubble. I am only using Path of Statues augment to petrify enemies and then pick up rubble once they die. If abilities are infused over petrify, enemies still petrify from Path of Statues but no rubble is dropped. The rubble drop mechanic seem to be coded to ONLY work when the ability-petrify is present, even if it is never used itself. This makes no sense if you read carefully into the abilities of atlas and the rubble mechanic (rubble drops from petrified enemies, regardless of how they are petrified).

By just replacing the ability-petrify you essentially bug out the entire rubble mechanic and break a large chunk of atlas abilities, augments, and general usability.

I made sure to test the same "setup" and made myself invincible to make sure rubble was not just healing me. I hope it was just an oversight and that it gets fixed soon!

Here are the two setups for reference:

Screenshot_437.pngScreenshot_438.png

As you can see rubble is building on the OG build below:

unknown.png

Below are the results using the Subsume build and there is no rubble dropping (this is with roar infused over petrify):

unknown.png

P.S. For those wondering why anyone would infuse over petrify.... Well I built this to be one of the best landslide builds available and petrify is used even less than tectonics and rumblers.

*I did more testing with spawning in the rumblers and despawning them -> they still drop rubble with the Subsume build. So far only landslide setup is getting affected by the removal of petrify.

**More testing: Enemies that are petrified when summoning rumblers also do not drop rubble when killed with the Subsume build.

Edited by Sbimon
More testing done 2x/formatting
  • Like 3
Link to comment
Share on other sites

  • Sbimon changed the title to Atlas Rubble Mechanic Completely Bugged When Infusing Over Petrify

So how does one know if the bug report is "accepted" or in line to be and just pending dev intervention? As from looking at the bug reports, forum moderators selectively choose which ones they reply to and it just causes players to bump or make the same thread again as we don't know what's going on. Other games forums I go to have a very controlled bug report section and this just looks like a dumping ground comparatively. 

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Tested as of update Sisters of Parvos. Bug is crawling around here somewhere! Sooo I called pest control, you guys gonna send someone to take care of it soon?

  • Like 1
Link to comment
Share on other sites

Tested as of Hotfix 30.5.3. 51 days later... Almost feels like I watched 28 days later twice. Also it's still broken in case you forgot. 🙃

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Tested as of Hotfix 30.5.4. Well I watched 28 days later twice... Day 1: Exposure - Day 3: Infection - Day 8: Epidemic - Day 20: Evacuation - Day 28: Devastation - Today: Depression

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
On 2021-05-23 at 2:12 PM, Sbimon said:

So how does one know if the bug report is "accepted" or in line to be and just pending dev intervention?

Unless they acknowledge the bug on their bug tracker (trello board) or simply reply, there's little to no way to tell. It's an unfortunate reality as things stand, just making bug reporting harder and less impactful.

  • Like 2
Link to comment
Share on other sites

On 2021-09-17 at 12:04 PM, CyberneticSusurrus said:

Wow. This is ridiculous.

That's almost 4 months and not even an acknowledgement of the issue, much less a fix.

I have pinged the warframe staff, they did see and like the post but nothing more than that... 👌 The bug is also noted on the warframe wiki in the helminth section under bugs. XD

One day it will get fixed and I can get back to seeing ridiculous dmg numbers with my fav frame!

Edited by Sbimon
Missing Content/Proof Reading
Link to comment
Share on other sites

Is the reason this is 'overlooked' or gone unoticed because Atlas is a low play time frame? this would nerf his current user base if he cant use the helminth properly. 4+ months and no fix/mention of this despite the traction it has. (being here, on the wiki and countless people knowing within official warframe twitch community.

Link to comment
Share on other sites

Hope it gets fixed, but considering Yarelli's aquablades still don't work on almost all hard cc frames and she's brand new, I'm not too surprised. (Definitely not still salty that I reported a nightwatch napalm bug in the first week that didn't get fixed for years and someone else's post was cited for the bug LOL)

Link to comment
Share on other sites

1 hour ago, Nobilus said:

Hope it gets fixed, but considering Yarelli's aquablades still don't work on almost all hard cc frames and she's brand new, I'm not too surprised. (Definitely not still salty that I reported a nightwatch napalm bug in the first week that didn't get fixed for years and someone else's post was cited for the bug LOL)

its like forum moderators put all the bug reports they see into a hat and then devs pull a few out at a time and the other persons was picked out the hat before yours

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...