Jump to content

Sisters of Parvos: Hotfix 30.5.1


Recommended Posts

Posted (edited)

Sisters of Parvos: Hotfix 30.5.1  



  • Increased Yareli’s Armor to 100 from 65.

  • Restored the correct crafting requirements to the Exilus Weapon Adapter Blueprint.

    • Blueprint no longer requires a built Exilus Weapon Adapter to craft an Exilus Weapon Adapter like some foundry-dwelling Ouroborus

  • Updated the OULL Requiem Mod description to remove the ‘needed to complete a lethal sequence’ line. 

  • Removed mentions of Arcane Adapter Blueprints in Tehsin’s Steel Honors store - the full item is what’s purchasable. 

  • Removed the Ambassador weapon eligibility from Conclave. 



  • Fixed no enemies spawning during the final stage of the Once Awake Quest(Defend the Cascade Bomb).

  • Fixed a crash that could occur during the Volatile Railjack gamemode. 

  • Fixed a crash that could occur if you died on a K-Drive.

  • Fixed a crash when falling off the K-Drive.

  • Fixed players who had previously Vanquished a Kuva Lich not receiving the Oull Requiem at login.

    • We’re working on a script to provide the Oull Requiem to those effected. 

      • A script has been run on ALL platforms! Those who were eligible but did not receive their OULL Requiem upon login please relog!

  • Fixed players that deleted their Waverider Inbox message and was thus unable to progress. After going back to your Orbiter it will progress the Quest automatically.

  • Fixed a temporary inability to progress in the Waverider Quest if you opened Roky's Inbox message while in Fortuna.

  • Fixed Hosts keeping their goods after aborting the Lich showdown mission once their Lich has been Converted/Vanquished, which also punished the other squadmates.

  • Fixed the Sisters of Parvos cinematic opening playing for everyone on login as opposed to the intended viewing of eligible players.

  • Fixed inability to redeem Medallions for K-Drive Standing while the Waverider Quest is active.

  • Fixed Clients seeing the Corpus Axio Crewship with two shields.

  • Fixed duplicate instances of Kuva Grattler in Profile and Codex.

  • Fixed a few abilities, items and screens that were not applying weapon noise reduction properly nor correctly interacting with Mods that have that effect.

    • This should resolve issues with Ivara’s Prowl, Loki’s Hushed Invisibility, Banshee’s passive

  • Fixed an issue where all Mining lasers could benefit from the Silencer Widget, but all along it was intended that only the Sunpoint Plasma Drill could benefit.

  • Fixed some tint coloring on Yareli’s body. 

  • Fixed Hound Diversified Denial ability FX and coloring.

  • Fixed PHs appearing in Arcane Adapter.

  • Fixed missing Standing gain UI popup when redeeming Medallions.

  • Fixed issue where the backer of the Mod frames when Gilding/Polarizing a modular weapon of the day would be slightly hidden.

  • Fixed some Syndicate Armor offsets.

  • Fixed a script error occurring when viewing the Lich screen under poor network conditions. 

  • Fixed script error that could occur if you cast an ability right before the Hound's Denial aura expired.

  • Fixed several script errors in the Chains of Harrow Quest.

  • Fixed harmless script error you could run into when entering Railjack warp to escape a Lich.

  • Fixed a script error when casting Yareli’s Riptide.

  • Fixed a script error when the Candidate despawns. 

  • Fixed a script error during a Kuva Lich/Sister showdown mission.

Edited by [DE]Megan
A script has been run on ALL platforms! Those who were eligible but did not receive their OULL Requiem upon login please relog!
  • Like 46
Link to comment
Share on other sites

  • [DE]Megan changed the title to Sisters of Parvos: Hotfix 30.5.1
Posted (edited)

Kuva Liches were fun before. The process to get them now is extremely tedious. I've done over 50 Kuva Liches and never thought there was a problem. Now that I need to do the extra Railjack mission just to kill it doesn't seem necessary. The wild card of a Requiem mod was a nice touch. However the process to get the Kuva Lich weapon seems exponentially longer even if it takes less murmurs.


On another note, do only 4 Hounds spawn in long missions for Sisters?


[Edit] I thought the Galvanized Mods were going to be bought with Steel Path Essence?


[Edit] Teammate and I killed both our Sisters in the railjack mission. When we got back to the railjack, the mission was failed for no reason and we both have our Sisters active. What is this even? Lol


[Edit] My Sister is weak against Viral. Cool. I use Viral weapons and it tickles her with 10 - 50 dmg per hit. Was this intended? What's the point of putting the weaknesses if they're not accurate?

Edited by Selinurr
  • Like 24
Link to comment
Share on other sites

No fix for Sister candidates not spawning even after successfully reaching rank 1 in a Zenith void? Wow. I can't be the only person having this problem.

  • Like 16
Link to comment
Share on other sites

Are you going to address the Kuva Hek issue? The weapon cannot use Scattered Justice, the weapon is a slight upgrade but does it really warrant the restriction of NOT being able to use the Scattered Justice Mod?

  • Like 31
Link to comment
Share on other sites

Can you take a look on Deimos bounties? The spawn rate of enemies looks really nerfed. Doing it solo is taking A LOT longer than before, expecially that bounty with the grineer squad.

  • Like 4
Link to comment
Share on other sites

Posted (edited)

Did they fix knockdowns in eidolons? Sometimes even in void mode you can get knocked down. As host aswell when you go into operator and go back to your warframe it picks up the shield.


Edited by Chromazoma
  • Like 8
Link to comment
Share on other sites

Posted (edited)

apparently, you can only ever have one Oull mod at the same time?

edit: As in, you cannot acquire more than one, because drops don't arrive in your collection

edit2: seems like you do get it, but can't use it because it's bugged and goes to inventory instead of mods


Edited by Her_Lovely_Tentacles
  • Like 4
Link to comment
Share on other sites

Game still crashes at login.

Was fine prior to todays update.

Tried validating, no issues found.

Tried optimising, it crashed.

Tried several times now, login loads, the second i click into it, it crashes.

doesn't seem to generate error reports.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...