Jump to content
General Bug Report Guidelines - Please Read ×

Warframe from Steam and the Launcher does not open


Somnumm
 Share

Recommended Posts

Every time I try to launch Warframe from either the launcher or steam, it doesn't work.

If I try to open it through steam by hitting the 'Play' button, the 'Play' button is replaced with a 'X Stop' button for a couple seconds then it reverts to the 'Play' button.

When I try to open the launcher, my cursor shows that something is loading, then does nothing. I have tried running both the launcher and the game itself as admin, restarting my computer, uninstalling and reinstalling the launcher from Warframe.com, uninstalling and reinstalling the game by Steam, checking if the game is blocked by a firewall in Windows Defender Firewall (everything appeared fine; With green checkmarks.) I have also tried checking Task Manager, and nothing Warframe related shows up.

I have not been able to play the game for 3 days as of yet.

Edited by Somnumm
punctuation
Link to comment
Share on other sites

1 minute ago, Hobie-wan said:

Check event viewer for any errors happening when you try to launch it. Also make sure you haven't set some Windows compatibility mode on the WF executable.

I've checked event viewer and I see a bunch of application errors at the same time I try to launch Warframe and Warframe's independant launcher

Link to comment
Share on other sites

This is what I get when I click on the Warframe Launcher error

 

Spoiler

Log Name:      Application
Source:        Application Error
Date:          8/10/2021 8:19:42 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-R8Q1KLD
Description:
Faulting application name: Launcher.exe_unknown, version: 2021.7.5.22, time stamp: 0x60e3bf2d
Faulting module name: ntdll.dll, version: 10.0.19041.1110, time stamp: 0xe7a22463
Exception code: 0xc0000374
Fault offset: 0x00000000000ff259
Faulting process id: 0xc78
Faulting application start time: 0x01d78e4694a12907
Faulting application path: D:\Steam\steamapps\common\Warframe\Tools\Launcher.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: a3b9cd95-2ef9-4a5e-8547-c73abab975c8
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2021-08-11T00:19:42.8834727Z" />
    <EventRecordID>12411</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>DESKTOP-R8Q1KLD</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Launcher.exe_unknown</Data>
    <Data>2021.7.5.22</Data>
    <Data>60e3bf2d</Data>
    <Data>ntdll.dll</Data>
    <Data>10.0.19041.1110</Data>
    <Data>e7a22463</Data>
    <Data>c0000374</Data>
    <Data>00000000000ff259</Data>
    <Data>c78</Data>
    <Data>01d78e4694a12907</Data>
    <Data>D:\Steam\steamapps\common\Warframe\Tools\Launcher.exe</Data>
    <Data>C:\WINDOWS\SYSTEM32\ntdll.dll</Data>
    <Data>a3b9cd95-2ef9-4a5e-8547-c73abab975c8</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

17 hours ago, Hobie-wan said:

Check event viewer for any errors happening when you try to launch it. Also make sure you haven't set some Windows compatibility mode on the WF executable.

Link to comment
Share on other sites

Unfortunately that's a super generic error. Try updating/reinstalling video drivers or seeing if windows update installed any updated recently that might be broken. You could try running sfc /scannow from an elevated CMD window to check for any messed up windows files. Make sure you check that WF didn't get set to compatibility for an older version of windows as well.

Link to comment
Share on other sites

I have ran sfc /scannow and checked all of my drivers, the scan repaired some files and all of my drivers are up to date. The problem still persists; I have a support request to DE on 'digitalextremes.zendesk.com' that hasn't been responded to for about 3 1/2 hours and I am replying regularly with information. (information like running sfc /scannow, checking drivers, etc) 

I haven't had this rig for long, I bought it in Februrary, so it cannot be a compatibility problem with an older version of Windows. At the moment I am just waiting for a reply with support.

17 hours ago, Hobie-wan said:

Check event viewer for any errors happening when you try to launch it. Also make sure you haven't set some Windows compatibility mode on the WF executable.

 

I do not own Warframe on the Epic Games' launcher so it shouldn't be a problem with that, thank you for the suggestion though.

I wonder if the issue was caused by the most recent patch, as the game was running fine up until now

15 hours ago, Marcus.Argonius said:

I've got similar Steam Warframe launch problem once when I tried to start it while having Epic Launcher running in the background (WF is installed there too, I think that was the cause). Ive closed the EGS and Steam WF started normally. 

 

I have uninstalled and reinstalled Warframe 3 times and the launcher 4 times, still no luck. I checked to make sure Steam's client is up to date and found that it is. I am currently backing up all of my Steam games to reinstall Steam all together, if that doesn't work, my only hope is to wait for someone to reply to my support request at DE.

Link to comment
Share on other sites

20 hours ago, Somnumm said:

I haven't had this rig for long, I bought it in Februrary, so it cannot be a compatibility problem with an older version of Windows. At the moment I am just waiting for a reply with support.

Ok, let me explain further.

Find the actual WF executable, right click, and do properties on it. Go to the compatibility tab and make sure that somehow it hasn't gotten set to run in compatibility mode for an older version of windows. Also make sure it hasn't gotten set to run in low color mode or 640 x 480 or something dumb. Ran into this a few times at my previous job even though I know the people I was talking to definitely didn't find their way to those settings and change them on their own, yet they were somehow set oddly and causing a program to crash. Windows remembers those settings too even if you un/reinstall stuff since it keeps it in the registry.

Edited by Hobie-wan
Link to comment
Share on other sites

7 minutes ago, Hobie-wan said:

Ok, let me explain further.

Find the actual WF executable, right click, and do properties on it. Go to the compatibility tab and make sure that somehow it hasn't gotten set to run in compatibility mode for an older version of windows. Also make sure it hasn't gotten set to run in low color mode or 640 x 480 or something dumb. Ran into this a few times at my previous job even though I know the people I was talking to definitely didn't find their way to those settings and change them on their own, yet they were somehow set oddly and causing a program to crash. Windows remembers those settings too even if you un/reinstall stuff since it keeps it in the registry.

What specifically am I looking for, I am in the Warframe.x64 Properties tab and I am in the compatibility section, there are no checkboxes checked at all.

Link to comment
Share on other sites

Alright, I found an automated email from WARFRAME asking for EE.log Launcher.log and DxDiag. They asked for me to go into my launcher, click the gear icon and click a GET LOGS button to submit the logs they need to fix the issue.

My problem is that I cannot access the launcher to begin with so I had to brute-force my way to the files by searching for about an hour.

I submitted the required files and I am currently waiting for a response, here goes nothing.

Link to comment
Share on other sites

I got a response from an employee, they asked me to turn off both my computer and router and unplug them for 2 minutes, then open the launcher, hit the gear icon and verify the launcher.

Is there a manual way to do this? I am not able to access the launcher to begin with.

Link to comment
Share on other sites

DE Support helped me sort out the issue.

The Audiodrivers were the reason for everything.

Also unlike this fellow i could launch the launcher. Though you still might wanna go through your drivers and do a general update to everything.

Windows does weird things sometimes when drivers arent what they want them to be.

Edited by Kayantao
Link to comment
Share on other sites

  • 2 weeks later...

I got it to work, I did a manual reset of all of my programs in my computer, uninstalling and reinstalling. I deleted my usual browser, I cleared warframe's data cache in steam library, cleared all files that had warframe, checked my firewall and found no unusual restrictions to warframe. I had, and still have no idea why it happened, but the bug is fixed. after I did what is basically a factory reset.

I hope no person on this Earth ever has what happened to me to happen to them, thank you all for the suggestions and I thank DE as well for trying to help.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

I have something similar too. As i try to start Warframe ber Steam Client, it starts but, it immediately tells me says "Update failed! WAR Number blablabla" even though i don't see a damn WAR Number or anything. I just started Warframe and immediately get this. It all happen because i changed the WF Language from english back to german. It never happen before and now it did. Weirdly though, the launcher works fine if i open it in the Steam Files.

Link to comment
Share on other sites

  • 2 months later...

This bug is still going on and not related to Steam at all. The launcher also crashes instantly when launched manually from Warframe's installation directory, even on a fresh installation of Windows 10.

The weird thing is that it works fine occasionally, but this dreaded ntdll error keeps coming back.

I tried so far:
- verifying game files
- reinstalling warframe
- dism and sfc /scannow
- reinstalling windows

Nothing worked. Windows Error log still lists error code 0xc0000374

 

Edited by Xenofarion
more details
Link to comment
Share on other sites

  • 3 weeks later...

IMPORTANT PRECURSOR:

Wow, wow, wow, I uninstalled and reinstalled the game this time, and this time the launcher opened! Unfortunately, after I agreed to the license agreement, the launcher ran into a problem, and asked to make error logs which I now have. I will likely be contacting support directly soon to see if I can make anything of the issue now.

You can still read my issue below, maybe you can still help, but I suddenly now have something to go off of, so sorry about the giant message!



I am experiencing an issue very closely related to the original poster's description. Specifically, when I try to open the game, by any reasonable means I know (steam, steam shortcut, .exe in the files) the launcher may open for a few frames, and only sometimes it will do this, before immediately closing. I have no realistic access to the Warframe launcher in any capacity.

I looked around at some FAQs initially, no help. I looked around the internet for the reason why it is doing this (still with no idea why), and so far I've:

- Restarted my computer many times.

- Uninstalled and reinstalled the game multiple times.

- Manually moved the files to a different drive, at first without being in a steam library, then being in a steam library. Also, steam can't "find" Warframe in the standard drive I have steam games in (drive D) in order for Steam to "move" it to the other drive (drive C). The Warframe files are currently where all my steam games are, the D drive.

- Verified the game files through steam, and made sure it was updated through steam. To note, I don't believe I have touched Warframe's cache? I am not an expert so I have no idea.

- I heard Razer software could cause problems, their software I did have, so I completely nuked them from my computer. The uninstall from their end didn't fully work, but I found some remaining software files lurking in the Windows folder in my C drive, and I believe Razer is gone from my device. I do have a razer headset with "speakers" and a microphone though, but this shouldn't matter.

- Made sure windows firewall wasn't blocking Warframe specifically.

The only things left that I have any clue as to why this is happening, is that either the files themselves are messed up, or that moving Steam itself to a non-native drive (my D drive) has caused problems. Maybe the fact that I haven't accessed the launcher in over a year is a reason? I have literally no idea. I appreciate any help I can get, I see the original poster essentially factory reset and got Warframe fixed, but I'd prefer not to go through all that trouble until I have no other options. I thank you greatly for your time.

Edited by PrimeXander
1st edit: Better clarification, and conciseness of text. 2nd edit: I miraculously made progress and the post could lead to unneeded responses without my precursor.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...