Jump to content
General Bug Report Guidelines - Please Read ×

Someone started a Bounty during "The Mask Of the Revenant" Quest and I left after defeating the Specter but mission did not finish nor did I receive the Blueprint


QuantumAim
 Share

Recommended Posts

I was doing the "Mask of the Revenant" Quest and I had followed all the steps. I built both the Chassis and Systems for the Revenant Warframe before starting the quest so when I did play it, I had no need to leave the quest or anything and followed the quest to until the part where I fight the specter. Before I could finish defeating the specter however, someone had started a bounty (I don't know whether that was the reason the mission bugged or not but I feel it is important to note). And so I defeated the specter during that bounty but nothing happened after that, no voice lines had played nor had anything dropped. I thought all I needed to do was extract so I headed to the gates of Cetus and Nakkak (I think that's her name, the one who sells the Mask of the Lost One) said something which I don't recall but was similar to just being disappointed I didn't finish the quest before leaving, which I found odd but extracted anyway. Then I found out that the kill hadn't counted and that I hadn't finished the mission so I headed back there at the next night cycle but now, there are no waypoints, no dialogue, and no anything related to the quest. For a few days I tried a lot of things, I talked the Nakkak again, I tried relogging, doing a different quest and coming back to it, unequipping the mask and reequipping it, talking to Konzu (Who has no new dialogue options or anything, this idea came from the fact that some people had told me he would say something about the Revenant), and farming some of the part blueprints again. Still, the quest is just stuck on "Investigate the Plains, with the mask on, at night, Plains of Eidolon, with no waypoints, no dialogue, or anything. I even went back to the place where I had fought the specter to see if  he would respawn, which he didn't, and now I am stumped.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...