Jump to content

Changing alias not working


Heli0s100
 Share

Recommended Posts

Not sure where to post this so I'm gonna post this here.

 

When I try to change my alias under edit account all it gives me after I click "change alias" is "please confirm your new alias. But no further instructions where to confirm your new alias or anything. Yes I have checked "I understand 200 Platinum will be subtracted from my account balance.".

 

before I contact support I just want to know if I'mdoing something wrong. Do I need to confirm this somewhere else? I'm not getting any mail or any further instruction so I don't know what to do.

 

Link to comment
Share on other sites

12 minutes ago, Heli0s100 said:

Not sure where to post this so I'm gonna post this here.

 

When I try to change my alias under edit account all it gives me after I click "change alias" is "please confirm your new alias. But no further instructions where to confirm your new alias or anything. Yes I have checked "I understand 200 Platinum will be subtracted from my account balance.".

 

before I contact support I just want to know if I'mdoing something wrong. Do I need to confirm this somewhere else? I'm not getting any mail or any further instruction so I don't know what to do.

 

It was not working for me for few months
And i decided i just gonna contact support
My nickname was changed after few days and they just charged my account for that 200 plat without any problem

So dont even bother with asking here go straight to guys that will solve your problem

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...