Jump to content

PLAGUE STAR 2021: September 8 at 2 p.m ET - Sept 30 at 2 p.m ET. All Platforms.


Recommended Posts

This is not the first and not the second time we run with an issue when a update come out, i REALLY love this game but this kind of thing is such a bucket of cold water in the head dude... sorry if it seems like im flaming over something small but this really punched me in the stomach, been waiting for almost a year to get the keewar and h*ll yeah, I'm sad.

  • Like 1
Link to comment
Share on other sites

Is the reward drop table glitched? We've run it at least five times now and haven't earned a single relic. Has anyone else noticed this?

Edit: Just got relics in the last run. Guess it's good to go!

Edited by perle.von.nurnberg
update cause I'm wrong
  • Like 1
Link to comment
Share on other sites

3rd hemocyte suddenly despawned. It spawned, started walking outside the boil and - poof! - it's gone. I used Wukong's Cloud Walker at that time, maybe that caused this issue, not sure. Was on 4 infested catalyst + 4 eidolon phylaxis. Infested were spawning just fine. Retried 2 times, once with 3 ic + 2 ep, once without anything additional, bug didn't reappear. Strange stuff.

Link to comment
Share on other sites

30 minutes ago, staticall said:

3rd hemocyte suddenly despawned. It spawned, started walking outside the boil and - poof! - it's gone. I used Wukong's Cloud Walker at that time, maybe that caused this issue, not sure. Was on 4 infested catalyst + 4 eidolon phylaxis. Infested were spawning just fine. Retried 2 times, once with 3 ic + 2 ep, once without anything additional, bug didn't reappear. Strange stuff.

we had this same issue and found him toward the exit near a body of water. 

  • Like 1
Link to comment
Share on other sites

Just want to say that the Xbox version of the game isn't working and the mobile companion isn't loading either. 

With the Xbox version it just says "connecting" when sitting on the launch screen and originally when I tried to download the update it got stuck on 53% in game and it's still been having these issues since the update dropped.

 

I have tried reinstalling both the game and the companion app as well as hard resetting my console and neither of them work so another fix may be needed for this.

Edited by (XBOX)Unhing3dGamer
Link to comment
Share on other sites

2 hours ago, (NSW)ShyGuyy said:

I've been having trouble being able to stay in a group. I always get kicked off as soon as they start a mission and I have to join in their session just to play with them. 

Check your port and maybe increase or decrease your allowable ping. I had that problem when I had bad (ATT) internet. 

Link to comment
Share on other sites

1 hour ago, (PSN)BdotRASS said:

Looks like that super annoying ui bug is back, where the nightwave bounty popup never leaves the screen.

Been back and new players especially hate it when it's covering screen and they can't even do that content. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...