Jump to content
General Bug Report Guidelines - Please Read ×

sands of inaros


RE.prime
 Share

Recommended Posts

so iam suppose to fulfill my third vessel challenge at the quest but i did that like countless time and when i view my vessel its already fulfilled and  equipped how i can make any progress or procced to the next mission coz i still have to fulfill my vessel which again as u can see i already did that i tried restarting my quest and equipped my vessel again to my gear but nothing happens its just the same problem and now iam stuck on that stupid mission coz i cant fulfill my fulfilled vessel
and i tried killing extra targets just it doesnt matter how many i kill its the same bug
restarting my game dont help too 
Capture.PNG

Edited by RE.prime
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...