Jump to content

Warframe Launcher Issue Workaround (Quebec Region) [RESOLVED]


[DE]Megan
 Share

Recommended Posts

12/20/2021:

From what we can tell, the ISP has resolved the issues on their end - yay!!

Resolving/closing thread.

---------------------

 

Hello Tenno!

Thanks to some helpful Tenno we’ve been able to find a workaround for reported Warframe Launchers being stuck on “Checking For Updates” for PC players in the Quebec region.
 

For those in the Quebec region, here's how to get the workaround:

Shut down the launcher and download https://content.warframe.com/dl/Launcher.zip 

Find the Launcher in your Warframe install:

If you installed from Steam it'll probably be in:

  • C:\Program Files (x86)\Steam\steamapps\common\Warframe\Tools\

  • (If you selected a different download location just look under the Warframe\Tools folder)

 

If you installed the standalone build from warframe.com it'll be in:

  • %LOCALAPPDATA%\Warframe\Downloaded\Public\Tools

 

If you installed from the Epic Online Store it'll probably be in:

  • C:\Program Files\Epic Games\Warframe\Downloaded\Tools

  • (If you selected a different download location just look under the Warframe\Tools folder)

 

Extract the Launcher.exe from the zip you downloaded and replace the one in your install.

Start Warframe, click the gear in the upper-right, click the Versions button: the Launcher version should be 2021.12.17.10.29 or newer.


 

If this workaround does not solve your Launcher issue, please create a ticket with your Launcher.log with our Support team for further diagnostics. Steps to find your Launcher.log can be found here

Note: until the ISP involved fixes the problem on their end, the Launcher will be extra slow and you may experience a few problems (Network Not Responding) but for the time being you’ll be able to play Warframe.

------------------------------

Salut les Tennos !

Grâce à certains Tennos, nous avons pu trouver une solution pour contourner le problème signalé des Lanceurs Warframe bloqués sur « Vérification des mises à jour » pour les joueurs PC du Québec.
 

Pour nos Tennos du Québec, voici comment contourner le problème :

Fermez le Lanceur et téléchargez https://content.warframe.com/dl/Launcher.zip

Trouvez le Lanceur dans votre installation Warframe :

Si vous avez installé à partir de Steam, ce sera probablement dans : 

  • C:\Program Files (x86)\Steam\steamapps\common\Warframe\Tools\

  • (Si vous avez sélectionné un emplacement de téléchargement différent, regardez simplement dans le dossier Warframe\Tools)

 Si vous avez installé la version autonome de warframe.com, elle sera dans :

  • %LOCALAPPDATA%\Warframe\Téléchargé\Public\Outils

 Si vous avez installé à partir d’Epic Online Store, ce sera probablement dans :

  • C:\Program Files\Epic Games\Warframe\Downloaded\Tools

  • (Si vous avez sélectionné un emplacement de téléchargement différent, regardez simplement dans le dossier Warframe\Tools)

Extrayez le fichier Launcher.exe du zip que vous avez téléchargé et remplacez celui de votre installation.

Démarrez Warframe, cliquez sur l'engrenage en haut à droite, cliquez sur le bouton Versions : la version du Lanceur doit être 2021.12.17.10.29 ou plus récente.

 

Si cette solution ne résout pas votre problème de Lanceur, veuillez envoyer un ticket avec votre Launcher.log à notre Équipe d'Assistance pour obtenir des diagnostics plus approfondis. Les étapes pour trouver votre Launcher.log peuvent être trouvées ici.

Remarque : jusqu'à ce que le FAI concerné résolve le problème de son côté, le Lanceur sera très lent et vous pourriez rencontrer quelques problèmes (“le réseau ne répond pas”), mais pour le moment, vous pourrez jouer à Warframe.

Edited by [DE]Megan
resolved
  • Like 21
Link to comment
Share on other sites

yeah, Videotron are really stubborn mules, but now that it was acknowledged by DE, we have a chance. 

Tho, since the first Hotfix, there is very often freezes in relays and open world hub, even if it never happened before. any idea what what that is, megan? 

the freezes happens regularly, each 20 or 30 seconds. it freezes 10 to 15 seconds, then repeat. it only started after the first hotfix. 

  • Like 3
Link to comment
Share on other sites

il y a 9 minutes, trunks013 a dit :

Weirdly enough that does not seems to be generalized because i do not seem to have it strangely.

Still ill take it in note and use it if the bug shows up.

It seems to only affect certain ISP only

I have actually called my ISP (videotron) to report this specific issue (and mentionning them this forum), and they said they will investigate on this and call me back, but I'm really not sure they can do anything on their side, that's the problem.

  • Like 6
Link to comment
Share on other sites

7 minutes ago, QcDarkNinja said:

It seems to only affect certain ISP only

I have actually called my ISP (videotron) to report this specific issue (and mentionning them this forum), and they said they will investigate on this and call me back, but I'm really not sure they can do anything on their side, that's the problem.

welll, it's not like it's the user who #*!%ed, here. it's either DE and their server, or the IPS ( videotron ) . so one way or another, we know it ain't our stuff to fix. 

  • Like 2
Link to comment
Share on other sites

1Ko/s really ?

Really playable in-game? No, I don't think.

What did Videotron do on Wednesday to break everything like this?

Thanks for the effort. Sorry, I give up for now.

I can't play anymore to my favorite game.

Link to comment
Share on other sites

Thanks so muck to everyone who worked on this ( Staff and Community). I've passed the word to every Tenno in my clan who have this issue and with enough time and pressure Videotron should be able to do something. 

il y a une heure, TheDeadC0de a dit :

Giving me credits by name would have been really awesome, but thank you nonetheless for making a fix 

Sometimes heroes works in the shadows and doesn't wear capes. You made it possible for alot of people from QC to be able to enjoy the new quest so don't worry about recognition.

Thank you !

Edited by Illunir
  • Like 2
Link to comment
Share on other sites

Sorry, but your solution doesn't work. I called my ISP (Videotron) today again, spoke for 2h30 with a senior technician, did several tests with them (TCP / UDP, advanced security disabled). In return, on the DE side, download problem, Network not responding, a new Launcher. And the result, still the same problem. The only way I have found is to use a VPN (Proton) to be able to date with your game. But I have several softwares not working when I use the VPN. I am really disappointed. In the meantime, I am losing the various boosters.

  • Like 1
Link to comment
Share on other sites

1 minute ago, Irchrael said:

EU region - Steam launcher spits out an error during "Checking for new content".
But downloaded launcher wants me to download entire game yet again.

A) This isn't a fix for the EU, it's a workaround for QC's Videotron ISP.

B ) the launcher is supposed to replace the one that is currently in the warframe folder as indicated at the top of the page and then launched via steam, if you launch from the launcher directly it doesn't detect the game as installed.

Link to comment
Share on other sites

2 hours ago, QcDarkNinja said:

It seems to only affect certain ISP only

I have actually called my ISP (videotron) to report this specific issue (and mentionning them this forum), and they said they will investigate on this and call me back, but I'm really not sure they can do anything on their side, that's the problem.

Just spent a hour on the phone with them to make them understand it wasn't an issue related to my router lmao. They said in the end that their engineering team is on it since multiple clients have reported a similar issue, though I wouldn't expect anything for a couple weeks, knowing their efficiency. 

Link to comment
Share on other sites

5 minutes ago, UrbRainEd142 said:

Just spent a hour on the phone with them to make them understand it wasn't an issue related to my router lmao. They said in the end that their engineering team is on it since multiple clients have reported a similar issue, though I wouldn't expect anything for a couple weeks, knowing their efficiency. 

I know the pain...spent a long time years ago telling them that the router couldn't communicate properly with them after several reboots.. it ended up being a faulty line outside.

Link to comment
Share on other sites

12 minutes ago, Vanguard836 said:

A) This isn't a fix for the EU, it's a workaround for QC's Videotron ISP.

B ) the launcher is supposed to replace the one that is currently in the warframe folder as indicated at the top of the page and then launched via steam, if you launch from the launcher directly it doesn't detect the game as installed.

A) I know - but since I was able to play yesterday and today my launcher spits out errors before login, I tried to check if it works. And it does, in some way

B) I know - the thing is, the results are different when I launcher game directly via launcher or via steam.

  • Like 1
Link to comment
Share on other sites

1 hour ago, TheDeadC0de said:

Giving me credits by name would have been really awesome, but thank you nonetheless for making a fix 

i actually sent it in saying you had found a fix

i sent it by my ticket i had so they could work on it

thx again for you help btw you are a legend

Edited by blackmoonTPN
Link to comment
Share on other sites

  • [DE]Megan changed the title to Warframe Launcher Issue Workaround (Quebec Region) [RESOLVED]
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...