Jump to content
General Bug Report Guidelines - Please Read ×

Riven not loading/working to unveil


(NSW)Mythryth
 Share

Recommended Posts

"land X consecutive headshots while in archwing in Plains of Eidolon with such and such conditions" is not loading when I go into the Plains.

So like when you land into the mission the Riven will come up as a task to do and keeps track, right? Well it's not. I keep loading in and out and checking my gear to make sure I meet the requirements or that I actually have it on. I have 3 rivens like this, 2 melee and 1 rifle. I had to use a cipher on 1 to unveil it as it wouldn't load. Even when I open the menu, and the riven thing pops up to remind you what to do, it won't show up either. I went and made some headshots, not counting them. 

Link to comment
Share on other sites

On 2022-01-11 at 3:16 PM, (PSN)iuvenilis said:

Try entering PoE directly from your Orbiter (i.e. not from Cetus). If that doesn't work, try opening the riven while replaying Sayas Vigil. 

I had not tried Sayas Vigil, but I had tried everything else to get the riven to register. I will try that next.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...