Jump to content

Recommended Posts

try connecting your pc directly into your wall jack. this should lead to your apartment complex's router. which in turn leads to your apartment complex's modem.

depending on the settings for it (hopefully it has upnp enabled) this might work for you without the need for anything else.

if it does, you should be able to change your router out for a switch (if you have need for more devices to be plugged in)

 

this won't help you in the arena of wifi, but for testing purposes you can see if you can at least get up and running.

 

if not, follow the advice of Raelus and see if whomever handles the apartment complex's IT can help you get things configured / forwarded.

Link to post
Share on other sites


try connecting your pc directly into your wall jack. this should lead to your apartment complex's router. which in turn leads to your apartment complex's modem.
depending on the settings for it (hopefully it has upnp enabled) this might work for you without the need for anything else.
if it does, you should be able to change your router out for a switch (if you have need for more devices to be plugged in)

this won't help you in the arena of wifi, but for testing purposes you can see if you can at least get up and running.

if not, follow the advice of Raelus and see if whomever handles the apartment complex's IT can help you get things configured / forwarded.


This was a suggestion I was reluctant to make because, depending on the complexity of the apartment network, he may expose his computer, printers, shared files, etc, to all other users on the apartment network whereas his router prevented that leak.

To expand on Xethier's solution, if you do find that it works by plugging in your PC straight to the apartment network without the router you can use the router as a switch by not connecting a wire to the WAN port; just plug the apartment network into one of the four switch ports. This will allow you to still use multiple devices and wifi without buying more stuff. However, you'll need to set a static IP on the router for this to work.

I discourage this solution due to the potential privacy implications but it's your decision to make. Edited by Raelus
Link to post
Share on other sites

This was a suggestion I was reluctant to make because, depending on the complexity of the apartment network, he may expose his computer, printers, shared files, etc, to all other users on the apartment network whereas his router prevented that leak.

To expand on Xethier's solution, if you do find that it works by plugging in your PC straight to the apartment network without the router you can use the router as a switch by not connecting a wire to the WAN port; just plug the apartment network into one of the four switch ports. This will allow you to still use multiple devices and wifi without buying more stuff. However, you'll need to set a static IP on the router for this to work.

I discourage this solution due to the potential privacy implications but it's your decision to make.

 

if his router is getting a class C ip. then he's already firewalled by whatever router is serving the network above his wall jack. (according to his supplied information his router is on 192.168.1.10 which is a class C)

additionally, if you plug everything into your router as is suggested here, then you must disable DHCP or you risk causing problems across the entire network as his DHCP server would be conflicting with the one already serving. setting a static IP on the router would probably lead to conflicts with the DHCP server upstream additionally as with the number of connections he could very well cause a duplicate between his router and another client on the network.

 

this is not an end-all solution, this is simply for testing purposes to glean more about the network topography.

the downside here is that anybody in his apartment building would have quite a bit of access to his systems. but he is protected (as much as he was before) from the larger internet. 

Link to post
Share on other sites

The router has a private IP and is already shielded from the open internet, you're correct. I was thinking about exposure to all other users on the apartment's private network (the guy next door, etc).

 

And yes, I forgot to mention disabling the DHCP server if he's going to use it as an access point as opposed to a router. Setting a static IP in the lease range shouldn't break it though as long as the IP chosen isn't currently in use. Any properly configured DHCP server tests an IP before leasing it in case someone is squatting on it (though yes, it is improper and a potential problem). All of his other devices would receive IPs from the apartment's upstream DHCP server; it's just the router that would need to be statically set due to GUI restrictions. Ideally flash it with 3rd party firmware where it can be configured to be a DHCP client on something other than the WAN interface but this can be difficult for a novice and outside the support scope I can assist with.

 

Long term, you're right. Replace it in this scenario.

Edited by Raelus
Link to post
Share on other sites

looking at his supplied information a bit more. his router is supplying the same range of IP's as it's receiving. (192.168.1.X)

and doesn't offer the ability to change it.

 

that's another problem... if you can update your firmware, i'd highly recommend you do.

the E1200 does work with ddwrt if i remember correctly. (be very careful of doing this, you can brick your router)

 

but as for testing to see if the upstream router has upnp enabled and will work for warframe... just jack directly in and give it a shot.

make sure to reset everything back to it's current setup once you're done. (i.e. don't leave it like this)

Link to post
Share on other sites

looking at his supplied information a bit more. his router is supplying the same range of IP's as it's receiving. (192.168.1.X)

and doesn't offer the ability to change it.

 

192.168.1.10 is the router's IP on the LAN interface (his pdf link, page 3). You can also confirm this by noting that the DHCP server lease range skips 192.168.1.10.

 

The WAN interface is set to DHCP. We can't see the IP it's getting unless he posts the router's status page; the configuration page isn't showing the leased IP.

Link to post
Share on other sites

192.168.1.10 is the router's IP on the LAN interface (his pdf link, page 3). You can also confirm this by noting that the DHCP server lease range skips 192.168.1.10.

 

The WAN interface is set to DHCP. We can't see the IP it's getting unless he posts the router's status page; the configuration page isn't showing the leased IP.

 

ah, you're right.

 

as good as linksys hardware is. (about the best you're going to find for commodity hardware routers)

it's software does leave a bit to be desired.

i build my own routers so... i haven't actually touched commodity routers in quite awhile. (except to remove them) :P

Link to post
Share on other sites

same S#&$ here i log in all system nominal log out log in again strict nat port forward doesnt help firewall disabled doesnt work viruscanner disabled geus wot doesnt work. this is not a problem on our side its them they screwing us over with there servers they use. me and me m8 played i think a few matches together by just a gues being lucky that the servers let us trough. all other games i play we can join up use in game voice chat etc etc etc we even tried logmein hamachi or some S#&$ that we creat a private network just for us two but geus wot happend IT DIDNT WORK

Link to post
Share on other sites

same S#&$ here i log in all system nominal log out log in again strict nat port forward doesnt help firewall disabled doesnt work viruscanner disabled geus wot doesnt work. this is not a problem on our side its them they screwing us over with there servers they use. me and me m8 played i think a few matches together by just a gues being lucky that the servers let us trough. all other games i play we can join up use in game voice chat etc etc etc we even tried logmein hamachi or some S#&$ that we creat a private network just for us two but geus wot happend IT DIDNT WORK

 

calm down brother, let's see what the community can do for ya.

first, there isn't a server on DE's end so it's definitely something on yours. (other players connect directly to your system so it's definitely not DE's issue here) that's the nature of peer to peer.

 

the software firewall being disabled is a good start. virus scanning shouldn't matter.

first, do you have access to your router? if so, check to see if upnp is enabled, additionally, check to see if you can forward your ports. if you can, do so. make sure the ports match up to what warframe is set to use. (config)

additionally, check to see what IP your router is receiving. post all that info here and we'll see what we can do.

Link to post
Share on other sites

ah, you're right.

 

as good as linksys hardware is. (about the best you're going to find for commodity hardware routers)

it's software does leave a bit to be desired.

i build my own routers so... i haven't actually touched commodity routers in quite awhile. (except to remove them) :P

 

pfSense is my personal favorite as of late.

 

same S#&$ here i log in all system nominal log out log in again strict nat port forward doesnt help firewall disabled doesnt work viruscanner disabled geus wot doesnt work. this is not a problem on our side its them they screwing us over with there servers they use. me and me m8 played i think a few matches together by just a gues being lucky that the servers let us trough. all other games i play we can join up use in game voice chat etc etc etc we even tried logmein hamachi or some S#&$ that we creat a private network just for us two but geus wot happend IT DIDNT WORK

 

Curious, but what's the router model and approximately how large are your clan and friend lists?

 

Working initially and not working shortly after leads me to believe a router issue and there's a potential problem related to large friend lists that fits this behavior.

 

EDIT: Also, do you have more than one computer running Warframe in your home?

Edited by Raelus
Link to post
Share on other sites

i have a zyxel router and my friend list is maybe 4 a 5 people on so that cant be problem aswell we forward the ports on router a few times now and doesnt help aswell i logg in get strict log out again log in all systems are nominal every then he can see me on list then he cant reboot game few times and we can see eachother again other game we play like D3 SC2 COH2 etc etc etc we inv eachother and it works with out any problems i can host he can host. so yeah im the only one in this house that is playing WF if this is so hard to connect and need to do so much @(*()$ effort to try to connect to eachother. i also have a PS3 and my nat type is open there so yeah plz explain that also im not the only one that forwards ports etc etc etc and do all the steps u guys tells us to do and doesnt work so yeah for me its hard to believe its on my side the problem because on wot i say before all vokking other game works. 

Link to post
Share on other sites

Hey guys,

 

I've had this problem aswell before but, I managed to fix it...

IF you're behind 2 routers on default, then that would be your problem.
NOTE: Your modem is also a router.

 

To solve this:
Basically, your modem is the one 'dialing' to your ISP. What you need to do is to bridge your modem to your router(which in this case, where your PC and others connect to) and change your router to PPPoE setting.

What does the bridge from modem to router mean?
Doing this will make your router be doing the 'dialing' this time. Your modem will now really be acting just like a bridge. How it should be. Like it's not there.

How do you do this?
Find out the name of your modem and router and go consult Google-sensei on how to do it. LOL


Once your done, your Router should be the one giving off your INTERNET IP ADDRESS now.

 

On another NOTE: I've noticed that I only get strict NAT when my INTERNET IP ADDRESS is NOT starting at 180.xxx.xxx.xxx
120., 10. don't work.

HOW do you get that 180.xxx.xxx.xxx? Just disconnect/reconnect through your router's UI until you get that starting IP.

(I live in the Ph so, I don't know about that 180.xxx.xxx.xxx if it's only for Ph)

Edited by michaelgt
Link to post
Share on other sites

Hey guys,

 

I've had this problem aswell before but, I managed to fix it...

IF you're behind 2 routers on default, then that would be your problem.

NOTE: Your modem is also a router.

 

To solve this:

Basically, your modem is the one 'dialing' to your ISP. What you need to do is to bridge your modem to your router(which in this case, where your PC and others connect to) and change your router to PPPoE setting.

What does the bridge from modem to router mean?

Doing this will make your router be doing the 'dialing' this time. Your modem will now really be acting just like a bridge. How it should be. Like it's not there.

How do you do this?

Find out the name of your modem and router and go consult Google-sensei on how to do it. LOL

Once your done, your Router should be the one giving off your INTERNET IP ADDRESS now.

 

On another NOTE: I've noticed that I only get strict NAT when my INTERNET IP ADDRESS is NOT starting at 180.xxx.xxx.xxx

120., 10. don't work.

HOW do you get that 180.xxx.xxx.xxx? Just disconnect/reconnect through your router's UI until you get that starting IP.

(I live in the Ph so, I don't know about that 180.xxx.xxx.xxx if it's only for Ph)

 

not all modems are routers (in the case of cable, almost none are)

sounds to me that you're using a DSL connection. most of those settings will be specific to your ISP.

 

please, please, please, unless you know how to manage your router / modem settings, don't blindly follow advice like this. 

 

no offense michaelgt, i know you're only trying to help. but in this instance you could do more harm than good.

Link to post
Share on other sites

not all modems are routers (in the case of cable, almost none are)

sounds to me that you're using a DSL connection. most of those settings will be specific to your ISP.

 

please, please, please, unless you know how to manage your router / modem settings, don't blindly follow advice like this. 

 

no offense michaelgt, i know you're only trying to help. but in this instance you could do more harm than good.

 

 

Aye. Sorry about that. I guess this only applies to DSL connections then?

Edited by michaelgt
Link to post
Share on other sites

Hey guys,

 

I've had this problem aswell before but, I managed to fix it...

IF you're behind 2 routers on default, then that would be your problem.

NOTE: Your modem is also a router.

 

To solve this:

Basically, your modem is the one 'dialing' to your ISP. What you need to do is to bridge your modem to your router(which in this case, where your PC and others connect to) and change your router to PPPoE setting.

What does the bridge from modem to router mean?

Doing this will make your router be doing the 'dialing' this time. Your modem will now really be acting just like a bridge. How it should be. Like it's not there.

How do you do this?

Find out the name of your modem and router and go consult Google-sensei on how to do it. LOL

Once your done, your Router should be the one giving off your INTERNET IP ADDRESS now.

 

On another NOTE: I've noticed that I only get strict NAT when my INTERNET IP ADDRESS is NOT starting at 180.xxx.xxx.xxx

120., 10. don't work.

HOW do you get that 180.xxx.xxx.xxx? Just disconnect/reconnect through your router's UI until you get that starting IP.

(I live in the Ph so, I don't know about that 180.xxx.xxx.xxx if it's only for Ph)

 

PH huh.

 

State your ISP and modem hardware/s.

 

 

I use a CDR-king Router, with all warframe ports forwarded,and a Globe Tattoo Huawei BM622m Wimax CPE with 2013 edition firmware.

 

I have been tracking Symbianize if they have found a way to enable port forwarding on the BM622m/2013- or heck even just access the administration GUI.

 

As long as the CPE issue is not fixed, Strict NAT ahead for the next 9001 miles. 

 

The only thing good that happened so far is making the UPNP malfunction.

Edited by iamablocker
Link to post
Share on other sites

For fellow Tenno in the PH (specifically Metro Manila), here are some things you need to consider regarding the popular ISP's and how they affect Warframe:

 

PLDT - port forwarding is disabled unless you're subscribed to a higher priced "business plan"

PLDT Home Fibr - unknown, their sales and support reps have no idea what port forwarding is

Globe - port forwarding is disabled unless you're subscribed to a higher priced "business plan"

Sky Cable - port forwarding enabled, no strict NAT

Link to post
Share on other sites

Neither me nor a friend have any errors, all systems nominal when checking.

Cannot play with each other at all, any time we try, and any way we try to we get the session unavailable error. This went on for 30 minutes before we just gave up and uninstalled. Seems pointless to have a game like this and be unable to play with friends.

Link to post
Share on other sites

So from reading this whole topic, is there a way to get past this error on a university internet or am I doomed to play solo until the winter break? I have just started playing this game and I really enjoy it, but it starts to get dull after the tenth or eleventh solo mission in a row.

Link to post
Share on other sites

So from reading this whole topic, is there a way to get past this error on a university internet or am I doomed to play solo until the winter break? I have just started playing this game and I really enjoy it, but it starts to get dull after the tenth or eleventh solo mission in a row.

 

i doubt you'll be able to get around this given the way most universities control their network.

however, that doesn't mean you'll be limited to solo play, it just means you won't be able to host.

you should still be able to join games others are hosting without issue.

Link to post
Share on other sites

-Lame. Been playing all day and part the night. Been using the community amenity center/clubhouse wifi to play this game since August. After playing update 11 most of the day and night, i go for dinner, take my laptop with me (so that means game is closed out). Come back and I can't see/get invites.

 

No voids for me, even though an hour ago I was doing voids left and right. This is lame. Especially since its a public wifi, i dont have acess to router. Have ever damn frame except Trinity and the new ones and cant fully play....

 

Anyone wanna buy an account?!  -_-

Link to post
Share on other sites

they've stated that they're working on ironing out some issues with matchmaking given that they've just completely overhauled the friendslist system. (previously it was requiring that you connect directly to everyone in your list, now it's working through a central system controlled by DE)

 

i wouldn't give up just yet.

Link to post
Share on other sites

Makes me want to cry.... I finally get some free time and decide to come back to this great game, hoping that the strict NAT b/s would get fixed... COME ON! I even payed to support this game via Founders Package and problems like this still existe??

 

At least they've directly addressed it with the latest update for a change. You can't expect it to be permenantly fixed, its a caveat of the peer to peer architecture, but at least they're taking steps to try and minimize its effect. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...