Jump to content

Recommended Posts

I managed to resolve this on my Technicolor TG582n.  After trying the fixes suggested by the OP,  I used Telnet to access the router CLI.  The following is taken from http://forums.modem-help.co.uk/viewtopic.php?t=9257 , which in turn is a summary from http://forums.whirlpool.net.au/forum-replies.cfm?t=1736568&p=4#r75 .

 

 

1) Install Telnet (I use Win7, which by default doesn't install it; go to Control Panel - Programs - Turn Windows features on or off, and select Telnet)

 

2) In a command prompt, type  Telnet 192.168.1.254   (The IP is your routers IP.)

 

3) Input your username and password for the router (this is case sensitive)

 

4) Type the following;

 

connection bind application=CONE(UDP) port=4950
connection bind application=CONE(UDP) port=4955
saveall
exit

 

 

If you use different ports than 3960 & 3692, then put the ones you use in their place.  This worked for me.  Since doing this, I have heard one brief burst of chatter in game!

 

FYI; before I tried this I had removed Warframe from the Windows Firewall (CP - Systems & Security - Windows Firewall - Allow a Program... ;  untick Warframe entries), then ran Warframe again to redo the firewall rules.

 

Also, I had UPnP turned off in both router & game.  After I used Telnet, and saw the strict NAT message was gone, I turned UPnP back on.  This gave an error message about a possible firewall problem, but shutting down and restarting Warframe got rid of that.

 

Also  conection bindlist   will give a list of all bindings in the router, so you can use that to check if the above bindings have been applied or are still present.

Edited by Alec709
Link to post
Share on other sites

We all have the same issues with the NAT and it's kinda of a rage topic if you ask me but although with the NAT problem I was able to join a game this morning. But take note, that was the time I didn't port forward 3960-3962 then I tried joining a game again and I wasn't able to join anymore.  Additionally my IP add was at 180.x.x.x that time yet weirdly enough, I was able to host a game back then and 3-4 players got in. This evening though I port forwarded 3960-3962 and had a 120.x.x.x for an IP add then by some luck, I got to join and finish a mission with those settings. I don't know how to explain this but have anyone had a similar situation like mine? It might be because of the server's/host's ping limit or I'm not in the region as the other hosts that I dc'ed with. Still, it's a mystery *queue the twilight zone theme*.

 

I'm from the PH anyway and using globe DSL as an ISP.

Link to post
Share on other sites

I managed to resolve this on my Technicolor TG582n.  After trying the fixes suggested by the OP,  I used Telnet to access the router CLI.  The following is taken from http://forums.modem-help.co.uk/viewtopic.php?t=9257 , which in turn is a summary from http://forums.whirlpool.net.au/forum-replies.cfm?t=1736568&p=4#r75 .

 

 

1) Install Telnet (I use Win7, which by default doesn't install it; go to Control Panel - Programs - Turn Windows features on or off, and select Telnet)

 

2) In a command prompt, type  Telnet 192.168.1.254   (The IP is your routers IP.)

 

3) Input your username and password for the router (this is case sensitive)

 

4) Type the following;

 

connection bind application=CONE(UDP) port=3960

connection bind application=CONE(UDP) port=3962

saveall

exit

 

 

If you use different ports than 3960 & 3692, then put the ones you use in their place.  This worked for me.  Since doing this, I have heard one brief burst of chatter in game!

 

FYI; before I tried this I had removed Warframe from the Windows Firewall (CP - Systems & Security - Windows Firewall - Allow a Program... ;  untick Warframe entries), then ran Warframe again to redo the firewall rules.

 

Also, I had UPnP turned off in both router & game.  After I used Telnet, and saw the strict NAT message was gone, I turned UPnP back on.  This gave an error message about a possible firewall problem, but shutting down and restarting Warframe got rid of that.

After gaining root access to my ISP provided Technicolor TG784n v3 (it's just Thompson's new name) and opening ports 3 different ways trough the telnet menus this was what finally worked.

This router as single handed redefined my notion of crap hardware...

One change to your instructions though, putty is considerably better then the Windows 7 telnet client so i'd recommend using that instead.

Edited by dafzor
Link to post
Share on other sites

Hah!  I used to use a Belkin F5D7632, and the Technicolor is HUGE improvement on that.  The Belkin had the built-in ability to connect to their site and download the newest firmware for the router - pity it downloaded the wrong one...

Link to post
Share on other sites

if upnp is working. port forwarding is unnecesary. 

 

Translation: Captain obvious is obvious

 

p.s. Back playing after a 6 month sabbatical... nice to see some things never change. 

 

obvious to those that already know better, many don't.

MasterKT above wrote that disabling upnp and properly port forwarding, then re-enabling upnp worked for him.

he shouldn't have had to re-enable upnp...

Link to post
Share on other sites

My network has always been fine until recently.

Now it's 90% of games I get disconnected from, losing mods, credits and whatever else I picked up. This is getting ridiculous and means I can barely play the game. UPNP is set up to work, there is no strict NAT message, nothing. Yet it still persists.

 

I feel this is less of a user problem than a netcode issue.

Link to post
Share on other sites

My network has always been fine until recently.

Now it's 90% of games I get disconnected from, losing mods, credits and whatever else I picked up. This is getting ridiculous and means I can barely play the game. UPNP is set up to work, there is no strict NAT message, nothing. Yet it still persists.

 

I feel this is less of a user problem than a netcode issue.

 

absolutely, the netcode in this game is abysmal.

120k/sec upload speed required to properly host 3 players concurrently.

the host election system doesn't take maximum bandwidth into account so you might have a DSL user with 80k/sec max upload speed that can host two other players fine and still show a sub 100ms ping to the last player. but upon his connection the host's upload speed is saturated and leads to a host migration and usually the loss of advancement for that match (or an immediate trip back to the main menu)

 

however, these are two separate issues. not being able to connect to others games, or lobbies is a far cry from bandwidth issues.

Link to post
Share on other sites

i tend to avoid belkin routers for a number of reasons...

check to make sure that you're forwarding UDP and not TCP.

and make sure that if you're using upnp in the game that it is, in fact, enabled on the router. (some come disabled by default)

Link to post
Share on other sites

i tend to avoid belkin routers for a number of reasons...

check to make sure that you're forwarding UDP and not TCP.

and make sure that if you're using upnp in the game that it is, in fact, enabled on the router. (some come disabled by default)

 

I am forwarding with UDP, I've also forwarded tcp ports 80 and 443, i have also tried without them, upnp is enabled on the router and in the game, but the game still insists that the ports are not forwarded and upnp is not working.

Edited by hrudzie
Link to post
Share on other sites

ports 80 (http) and 443 (https) shouldn't have anything to do with warframe in terms of matchmaking or gameplay.

 

The only other thing you might check is to see if you're being NAT-ted by your isp. (known as carrier grade NAT)

or if they're blocking the default warframe ports. (unlikely)

 

you might also try non-standard port forwards. 4950/4951 -- or any other pair that warframe will allow you to use. 

(check your settings)

Link to post
Share on other sites
  • 2 weeks later...

I use USB internet 3g service. when i login it says strict nat detected . but when i go to settings it shows that upnp enabled. what i should do to get rid of this prob ? All my friends also got same problem .

 

it's entirely possible that there is no solution in this situation.

you may be under carrier grade NAT, which means no way to port forward at all.

call your isp (cell carrier) and find out if you have the ability to UDP port forward.

Link to post
Share on other sites

И так, у меня в игре пропал ключ - Руины орокин (защита) его нельзя скрафтить, купить, продать, в общем он пропал и не знаю что длеать, присоединяюсь к другим игрокам на (руины орокин) у меня вылетает на волне 40 - 50. Исправьте ошибку !

Link to post
Share on other sites

Hello, i have the same UPnP problem. I'm using a small ZTE MF60 hotspot modem. 

I opened the ports, tried different combinations, with the game and the router, but nothing seems to work.... 

i don't know how to upload an image so i cant show how it looks, but i'm sure that what i'm doing is the right thing (according to all the manuals here and other port forwarding manuals). 

If anyone can help me with that, id be really thankful... plus i already contributed to the game so ;)

i really love this game, it took me 5 minutes to fall in love with it, i'd really love if i could play with my friends... 

thank you.

 

I've also found that my modem has and option for mac/ip/port filtering. maybe if i could set a rule there, i could solve it. but for that i need a MAC address a Dest. IP Address and Source IP Address... if you could give me a hint about what to write there.. i'd be happy...

​btw the address that the game tells me to open is 192.168.0.100.. if that helps.... 

Edited by eXtremeAkim
Link to post
Share on other sites

Hello, i have the same UPnP problem. I'm using a small ZTE MF60 hotspot modem. 

I opened the ports, tried different combinations, with the game and the router, but nothing seems to work.... 

i don't know how to upload an image so i cant show how it looks, but i'm sure that what i'm doing is the right thing (according to all the manuals here and other port forwarding manuals). 

If anyone can help me with that, id be really thankful... plus i already contributed to the game so ;)

i really love this game, it took me 5 minutes to fall in love with it, i'd really love if i could play with my friends... 

thank you.

 

I've also found that my modem has and option for mac/ip/port filtering. maybe if i could set a rule there, i could solve it. but for that i need a MAC address a Dest. IP Address and Source IP Address... if you could give me a hint about what to write there.. i'd be happy...

​btw the address that the game tells me to open is 192.168.0.100.. if that helps.... 

 

if you're running windows open your command console and type:

ipconfig /all

look for "Physical Address"

It will be a series of 6 hexidecimal numbers.

example: 70-71-BC-AC-77-D3

 

if you're using a wired card that will never change.

you *can* change a wifi mac address but it isn't necessary and as long as you don't futz with it, it won't change on it's own.

 

if the game is reporting an ip address of 192.168.0.100 then it's probably correct, but the IP address you are currently being given is also shown in the : ipconfig /all -- output.

Link to post
Share on other sites

i had a open nat one time but when zephryr update come i have strict nat i tried evrything and still i have strict nat i forwarding  ports but still nothing help me please

Edited by Arenise
Link to post
Share on other sites

if you're running windows open your command console and type:

ipconfig /all

look for "Physical Address"

It will be a series of 6 hexidecimal numbers.

example: 70-71-BC-AC-77-D3

 

if you're using a wired card that will never change.

you *can* change a wifi mac address but it isn't necessary and as long as you don't futz with it, it won't change on it's own.

 

if the game is reporting an ip address of 192.168.0.100 then it's probably correct, but the IP address you are currently being given is also shown in the : ipconfig /all -- output.

still doesn't work.... i guess my wi-fi modem just sucks..... 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...