Jump to content

Recommended Posts

What do I do if I do not have control over my router? I am in an apartment and internet is included in the rent; I do not have access to the router and am only using an ethernet cable or wifi

 

nothing you can do unfortunately

Link to post
Share on other sites

What do I do if I do not have control over my router? I am in an apartment and internet is included in the rent; I do not have access to the router and am only using an ethernet cable or wifi

 

You pay rent for it, so talk to your landlord.  Even then depending on the router it still might not work if you landlord adds the WF ports to the firewall.

Link to post
Share on other sites

Anyone here having nat problems

 

What do I do if I do not have control over my router? I am in an apartment and internet is included in the rent; I do not have access to the router and am only using an ethernet cable or wifi

Find friends!!! and join them, my friend has NAT, but I don't have NAT and he can join my games fine.

Link to post
Share on other sites

Anyone here having nat problems

 

Find friends!!! and join them, my friend has NAT, but I don't have NAT and he can join my games fine.

 

this is correct.

people languishing under "strict nat" issues can join games just fine. so if you find a good clan or get a robust list of friends you can count on, you can always join their games. 

Link to post
Share on other sites

Just got this error message today after downloading the latest patch and logging in. I don't know if it has any effects on my gameplay or matchmaking yet, but it seems like every other patch I go through, it causes some sort of matchmaking problem for me. First it was firewall ports, now this. And I had just started getting used to having no errors, too.

Link to post
Share on other sites

A little new here. I'm from the Philippines and use a PLDT MyDSL connection at 4mb/s (which is actually quite high already considering the usual speeds given to home networks). I've had this Strict NAT problem since I first started playing Warframe. Never had a problem with other online games other than this. I downloaded the port checker at portforward.com and got these results.

 

5h8JE2R.jpg

 

zgloguj.jpg

 

I don't know why I can't ping my router.

 

Here's my router interface.

 

TGYLMKU.jpg

 

UPnP is enabled on the router.

 

1VYO7QC.jpg

 

I also tried following steps on how to port forward as listed in their site.

 

YAJW1Vt.jpg

 

Still, nothing works. I tried calling them and they said that port forwarding is "impossible" on my connection since it needs a Static IP, but my router is giving out a Dynamic IP. For sure I am using the IP provided by my router (usually changes from 192.168.1.(5~18), depending on the number of devices using our network. However, only my unit is playing Warframe, the rest are just used for browsing or streaming.

 

How can I possibly fix this problem?

 

Edited by PhAYSe
Link to post
Share on other sites

A little new here. I'm from the Philippines and use a PLDT MyDSL connection at 4mb/s (which is actually quite high already considering the usual speeds given to home networks). I've had this Strict NAT problem since I first started playing Warframe. Never had a problem with other online games other than this. I downloaded the port checker at portforward.com and got these results.

 

-image snip for brevity-

 

Still, nothing works. I tried calling them and they said that port forwarding is "impossible" on my connection since it needs a Static IP, but my router is giving out a Dynamic IP. For sure I am using the IP provided by my router (usually changes from 192.168.1.(5~18), depending on the number of devices using our network. However, only my unit is playing Warframe, the rest are just used for browsing or streaming.

 

How can I possibly fix this problem?

 

in all respects, you should be running. 

 

try disabling upnp on both your router and warframe.

if the ports are forwarded properly (as the port checker website is showing they are)

then you shouldn't need upnp.

 

make sure the local forward address is actually pointing to your desktop. there is a chance (especially if you're using wifi as a local connection) that the ip address may have changed as your dhcp server (router in this instance) has assigned you a different ip than the last time you set this up.

 

other than that, it looks as if you should be chugging along properly without the strict nat error.

Link to post
Share on other sites

Me again. I logged in with the setup I had above. Strict NAT message popped up. I tried disabling both router and Warframe's UPnP as suggested.

 

6nybSwd.jpg

 

sqnYD4d.jpg

 

And yet, when I ran the Analyze Network, still Strict NAT.

 

8PXtkvQ.jpg

 

And I can confirm that I'm using the IP address assigned by my router as it matches the IP address listed in the 'firewall-virtual server' picture I posted above.

 

welI8Ew.jpg

 

I'm totally lost.

 

 

Link to post
Share on other sites

Hello my Brethren,

 

I just finished somehow reading to some of your posts, and it is kinda a show of Despair.

Sanity and Madness fighting against Despair... we could need reassuring words from DE, that we all fight on the same side. If we ignore, and stop communicating. that would be the first sign of degeneration in cocnerns of communication.

 

But nevertheless.

 

I had the Problem with Strict Nat Detected, was kinda annoyed by the consequences of my configuration.

Then i read through a couple of things regarding Port Forwarding and similar mechanisms ( like Trigger Port ).

 

At that point I was not sure how to configure, but i tried to learn and researched a bit about Port Triggering as well.

 

I set the Trigger to open a defined pair of Ports ( Trigger : 3960 ; Public Port 3960-3962 ), it surely depends on the Hardware and Software of your Router / Modem. It's a really dynamic Issue in itself and I am sure I know not enough to be of real Help. There is always hope, if there is despair. If something goes wrong, it is most likely to have a proper functioning way to go.

I still have problems from time to time regarding Host Migration and that the game freezes just before the host migrates. Sometimes we can continue playing, sometimes we can't. Depends on each configuration regarding each player in that sessions, is what I guess.

 

But i never got the Strict NAT issue again. As soon as i set the Trigger Ports, it worked in most cases.

 

Just try a couple of settings. Always ( if the problems still occur ) overlook what you did, try to comprehend and analyse. If all that still won't work and you are 100% sure it is not your fault. contact your Internet Provider. If everything is configured how it should be... there has to be a bug or another kind of disturbing issue ( maybe related to hardware, your computer hardware or the internet connection hardware.. you never know all there is, so its worth to doubt anything and investigate further ).

If all of those things may not help. You could be doomed to master Solo play or to play hide and seek in the forest.

 

Please help the community. DE.

 

They tried to be Sane and calm. You could try to reassure them in some honest way ( once more ).

 

Thats all. Take care. Fight for Balance ( in reality and in virtuality ).

Edited by smargardka
Link to post
Share on other sites

So, it seems after I DCed in the middle of a mission, the strict NAT message has been popping up for me as well. I went and manually forwarded my ports to the default 3960-3962, and verified it with some of the tools in this thread. No go, apparently my ports are "closed" while they're open. I'm frankly shocked that they still haven't fixed this over a year later.

Link to post
Share on other sites

This message (the Strict NAT - malfunctioning, fix your ports) just started popping up last night.  Oddly enough, I now cannot join my clanmates or friends in missions, either.

 

So after double-checking, re-forwarding manually, and then finally just disabling the ports - the game has set itself properly and seems to be working again.

 

::shrugs::

Link to post
Share on other sites

will it help me if i just put my modem/router to bridge mode? will that allow me to open ports from just my wireless router or do i have to do another thing before this could work?

 

not quite sure of your network topography.

but if you're modem has a router built-in and then you have an additional router (with wifi) under that, then yes.

by turning your modem/router combo into nothing more than a modem (bridge mode) that's exactly what you'll want to do.

Link to post
Share on other sites

yes my setup is a modem/router --> 3rd party router

 

being the paranoid side of me, it will not affect my internet connection, yes? it won't be cut-off or something?

 

if it's a go ill give it a try and hopefully, it'll end my misery

Link to post
Share on other sites

yes my setup is a modem/router --> 3rd party router

 

being the paranoid side of me, it will not affect my internet connection, yes? it won't be cut-off or something?

 

if it's a go ill give it a try and hopefully, it'll end my misery

 

if it's a DSL, you'll have to reconfigure your router to properly use the pppoe connection.

if it's a cable connection, it's as easy as defining your WAN port as DHCP. (usually)

Link to post
Share on other sites

i have an adsl type so how do i do that exactly?

 

you'll need to know your password (usually your phone number)

best bet is to contact your isp about it.

it's a fairly straightforward procedure, but they'll know all the details.

shouldn't cost anything.

Link to post
Share on other sites

ok so i can randomly play with a friend  and its goten to  the point im thinking the game might not be worth the trouble we have done every thing stated here.im not sure how to fix it at this point just got the primeacsess loki pack of everything so you know sorta wona play with the friend i got the game to play with...

fixed the nat/upnp nonsence by entering my router and disabling it thin disableing it on warframe thin reenabling it on both after loging out thin into warframe hope that helps others..

DE i respect the fact you have alot on your plate the game is beautifull it runs good when it dose run at all but for a up to 4 player co-op game that is truely only fun when your with people you know [no offence to others] it needs alot of work done on the matchmakeing lobby system TY for your time if you read this

Edited by scaily
Link to post
Share on other sites

A little new here. I'm from the Philippines and use a PLDT MyDSL connection at 4mb/s (which is actually quite high already considering the usual speeds given to home networks). I've had this Strict NAT problem since I first started playing Warframe. Never had a problem with other online games other than this. I downloaded the port checker at portforward.com and got these results.

 

Still, nothing works. I tried calling them and they said that port forwarding is "impossible" on my connection since it needs a Static IP, but my router is giving out a Dynamic IP. For sure I am using the IP provided by my router (usually changes from 192.168.1.(5~18), depending on the number of devices using our network. However, only my unit is playing Warframe, the rest are just used for browsing or streaming.

 

How can I possibly fix this problem?

 

 

Me again. I logged in with the setup I had above. Strict NAT message popped up. I tried disabling both router and Warframe's UPnP as suggested.

 

I have a simple answer - the problem lies with the ISP. PLDT enforces NAT (but they won't tell you) on their newer hardware. I know this because I helped a friend set up their home business network with old and new PLDT DSL modems, and I'm connected to a PLDT myDSL business plan on my apartment wifi.

 

There are three ways you can get around this limitation:

 

1. If you can somehow request an older model where you can forward ports properly - unlikely unless you have certain, er, "sources". :D

 

2. Upgrade your subscription to a business tier where port forwarding will work.

 

3. Switch to an ISP where you won't have port forwarding issues regardless of your subscription tier, like Sky Broadband.

Link to post
Share on other sites
  • 2 weeks later...

this is $&*&*#(%& ive tried all of this 3 or 4 times and still get strict NAT, obviously its a game issue and not player side if so many ppl are having the same exact issue, why not remove it from the game itself or tweak the program to allow all players to play with each other rather then have to sift thru all this crap and make players do all this other stuff just to play a f2p game. the game itself is awsome im just beyond frustrated that i cant go any farther in the game cuz i cant solo the levels or get the materials to build new warframes alone, in a group its easy but with NAT crap its like over half of the players online arent registering to my client that they are there. either way this is stupid if u ask me

Link to post
Share on other sites

this is $&*&*#(%& ive tried all of this 3 or 4 times and still get strict NAT, obviously its a game issue and not player side if so many ppl are having the same exact issue, why not remove it from the game itself or tweak the program to allow all players to play with each other rather then have to sift thru all this crap and make players do all this other stuff just to play a f2p game. the game itself is awsome im just beyond frustrated that i cant go any farther in the game cuz i cant solo the levels or get the materials to build new warframes alone, in a group its easy but with NAT crap its like over half of the players online arent registering to my client that they are there. either way this is stupid if u ask me

 

it's not a game issue beyond the underpinned design. so many people are having these issues because ISP's and router suppliers cut so many corners that UDP port forwards and upnp can be wonky (routers) and live ip's aren't always available (isp).

 

with strict nat, you should still be able to connect to other players hosted games. you can use the recruitment channel to find a group of folks that are working on completion. or you can join a large clan with many active players to work with.

 

i completely understand your frustration but unless DE is willing to spend millions of dollars deploying servers around the globe and run the matches, this isn't going to change. 

Link to post
Share on other sites

Here is one thing i solved yesterday where my (a)friend never could join my lobby when i try to host while it can join my (b)friend's lobby and i join in as well.

 

Windows guide: 

-Remember default port numbers written in Warframe settings and close the game.

- Just to be sure: Disable UPnP and save settings in your router/modem. After that, re-enable it and save again.

- Go to your router/modem settings where you can port forward. 

- Port forward the 2 ports in UDP/BOTH to your computer IP ( Check in your Command prompt [cmd]  ipconfig /all)

- Go to start and type in the search box: Windows Firewall with advanced security.

- Click on INBOUND RULES then create a new rule [at right panel]

- At the popped up window, click Port then next.

- Select UDP and full in the port numbers below either 2 separated by comma or use range method by typing a minus in between the 2 numbers [examples seen right under the input field]. Click next.

- DON'T CHANGE ANY THING ON THIS 2 PAGEs, JUST CLICK NEXT TWICE.

- Give it a name. for example Warframe UDP. No need for description. Then click finish.

- Start your Warframe and try it out and see if people who never could join you[HOST] to test if it's working or not.

- If still not working, Try use Hamachi to host a server and let YOUR FRIENDS join that server through Hamachi. Give it another go on Warframe.

 

Some routers have different settings and even grayed out fields that won't allow you to port forward, my advice, get a new cheap router or ask for replacement if possible...  Because Port Forward is a very useful for making open NAT in many games.

 

=====

Notice:

 

For people who have more than 1 player playing Warframe at same time on same LAN, you need to port forward different ports to different pc.. as in Warframe settings, one player can change the port number to another port so you can port forward that one too.

=====

 

If this guide not helping you, then i am out of idea for now.

 

 

PS. i am lazy right now, not in mood to make screenshots or video for this..Maybe Friday i'll make it.

Link to post
Share on other sites

-snip-

Some routers have different settings and even grayed out fields that won't allow you to port forward, my advice, get a new cheap router or ask for replacement if possible...  Because Port Forward is a very useful for making open NAT in many games.

-snip-

 

please don't do this. don't support companies that make crappy hardware. if you're going to buy a new router don't cheap out.

get something decent. or better yet, build one yourself or have it built by a professional. (i know plenty of linux hobbyists that will do this for free or a very small fee)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...