Jump to content
[DE]Glen

Strict Nat

Recommended Posts

sadly im getting tired of this bull..love your game but why does this strict nat bull have to ruin the game for me.. spent 3 days now forwording my nat calling my net suport and FINALY it works,my nat is norminal! i can play with my buds...its a happy two huers..then i log out..then it wont work again dame strict nat bull....PLEASE fix your game!!! 1000 players souldent have this dam problem! i played this for a year once before i got it to work on a old rouder..but same thing happend...set up a dam sever for us or somthing..

 

Angry Brian =(

Share this post


Link to post
Share on other sites

we tried this and were able to connect, the lag makes it completely unplayable however.

 

made a forum post on it, no response from DE.

 

try turning off all encryption. it tends to slow things down.

Share this post


Link to post
Share on other sites

I use a mobile broadband connection and i have come up with a work around to this problem...

 

Because Cellular providers assign random IP addresses you might find your ip address throws up the strict message and this hampers your game not allowing you to  join parties or invite friends to join you also Hsdpa+ and wcdma connections provided by cellular companies tend to be a bit of a problem as they do not allow DHCP. 
 
1st on your windows computer hit winkey + r this opens a run command 
 
1.1 type > cmd this opens a terminal type > ipconfig /all this lists all of your devices as well as the physical address you will need in the next area right click next to the physical address click mark then highlight the number and press ctrl+c that will copy the information
armed with this number proceed should you see "DHCP = no" we will sort this out in a second. 
 
1.2 type > regedit... this opens the windows registry editor... find
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters\Interfaces  
then right click the interfaces file and press find press ctrl+v to paste the ip number and select the file we are looking for in the file you will see a list of process names find the one marked EnableDHCP if your DHCP was disabled before double click and change the value to 1. this setting will remain till you next restart your pc. 
 
step 2 
press winkey+r to open run again and type >services.msc
find a process called "SSDP Discovery Service" and right click it for properties select it to automatically start and press ok then start the process. 
 
Now disconnect from your mobile connection and reconnect and double check your ip address using method discribed in 1.1
The game will have a problem if your ip address starts with any number other than 1 eg... 197.168.0.24 or 10.168.0.24 will work fine however addresses starting for example 41.168.0.24 will throw up the same error. 
 
On occation it may take 1 or 2 disconnects and reconnects to get an ip with a number starting with 1 but once you do you will find the game starts fine and you no longer have the problem... 
 
if this is done correctly you will only have to redo step 1.2 after you restart your PC. 
 
feel free to check with me if you have any further questions sometimes you may have to tweak a few other things but you may email me or message me in game and i will gladly assist if i can. 
 
I am always looking to lvl my Volt warframe so i will gladly accept any invites to parties :D
And close the cmd and registry editor. 
Edited by wgs_shaun

Share this post


Link to post
Share on other sites

Agreed, they seams to have abandoned us that have gotten strict nat after the update and say that we are a minority of there players, i guess thats true for some of us but for the rest of us that was able to play just fine until the latest update we don't Think we are a minority. This is DE's fault and its up to them to fix it!

 

Regards,

Centclip

Share this post


Link to post
Share on other sites

Just bought a replacement router for my ISP issued Technicolor TG582n, replaced with a Billion 8800NL.  Warframe worked with no ports being mapped out of the box.

 

So if you are a ADSL user with a crappy ISP router with strictnat, the Billion 8800NL works just your wallet will be lighter £70 / 112 US $ and a added bonus its a VDSL modem as well, so its fibre ready.

Share this post


Link to post
Share on other sites

I fixed my strict NAT by Setting the matchmaking ping limit to no limit. Sometimes strict NAT comes back but when i restart my router, it just goes back to normal.

Share this post


Link to post
Share on other sites

there still no fix?, forwarded ports already.

i think they abandoned this issue

yes, they only add new experimental features (nat-pmp) without fixing bugs in basic features (port forwarding).

and i am ashamed to admit that i still like bugframe.

Share this post


Link to post
Share on other sites

You can fault DE all you want on this issue, but the bottom line is that if you can't provide a network environment that's capable of running warframe, then it's on you. not DE.

 

If you're looking to place blame, far more falls on your ISP and choice of router.

 

I build custom routers & do remote admin support for a living and my years of experience can attest to the fact that almost every commodity router out there is a total piece of junk. The modem/router combos supplied by your isp are even worse.

 

If you're going to be gaming for the forseeable future and you're willing to throw down thousands of dollars for a gaming rig, why do those same people spend $40 on a crap router and blame the game? What kind of sense does that make?

 

You can buy a decent commodity router that's capable of being flashed with ddwrt or openwrt or you can build your own x86 system and run a custom distro designed to be a router itself. (ipfire is one of my favorites) You can easily do this for ~$200.

 

I can promise you, that unless your ISP is blocking ports or otherwise using some draconian practice, this will solve your problem. Every single strict-nat problem that i've seen in regards to warframe can be traced back to a router or ISP that's not following the rules.

 

(there have been isolated incidents where DE's actions have caused strict-nat warnings in error, but those were all rapidly fixed and did not persist)

Share this post


Link to post
Share on other sites

Well i just bought i playstation 4 some days ago, and directly downloaded warframe since i like the game on pc but it wasent the best experience since its some old junk. Anyway my PS4 tells me i have a nat type 2, and i can play other games just fines, but when i comes to warframe it the same "Strict NAT detected. UPnP malfunctioning. Please foward UDP ports 4950 & 4966 to 10.0.0.16".

 

I have tried alot of different options like:

 

Log in in to my router and manual open the ports.

Called my internet provider, make them open my ports for the game,

Try to use telnet, but can't connect to port 23 - Did try to just open that port and dissable firewall, not working.

Used putty, but cant get login to appear.

 

BTW, im using a Technicolor router. Im out of options right now, so decided to write in here.

Any advice on how i can play with others in warframe, like would a new router help or something else. PLEASE!

Share this post


Link to post
Share on other sites

-snip-

 

you're not the first to mention a technicolor router. it seems they have some trouble with warframe.

 

for compatibility, going with a linksys or netgear will probably solve your problem. doubly so if you make sure the one you buy can be flashed with ddwrt or openwrt.

 

http://www.dd-wrt.com/site/index

https://openwrt.org

 

my advice (if you want to do this cheaply) is to take a look at those, and figure out which router works with them and also falls into your price range. (and isn't too difficult to flash)

 

if you're somewhat technically savvy, you can build your own router and use any of these:

http://en.wikipedia.org/wiki/List_of_router_and_firewall_distributions

(personally, i like ipfire)

 

these links will provide the resources to explain the details of how to go about getting these running. if you have specific details you need help on, please feel free to contact me directly via the messaging system on the forums. (this goes for anybody interested)

Edited by xethier

Share this post


Link to post
Share on other sites

OK people. This is just frustrating.
I kep getting STRICT NAT problem for about 2 months now.I've been playing Warframe for, well, I dont know how long but its defineitely over 2 years now, and I never had this problem before.
WHAT CHANGED?
I keep forwardin those damn 4950 & 4955 ports but it seems to have no effect on the game. I disabled my firewalls, established new rules to let WF contact in and out, opened ports - windows, router, whatever (changed to startic IP)... and NOTHING.

I cant play normally most of the time, I can play with others in PUG parties. I can trade with some and join in Towers co-op but its like 60:40%
How does it work? I can join some players but not the other group?

The problem presists, I'm at wits end here. I think latest updates are making the problem worse because the pop-up about forwarding ports is showing after logging in which never happened before (earlier I was getting the message "stric NAT problem" when failed to join on invite).

Can somebody figure it out for me?

Share this post


Link to post
Share on other sites

Bit of advice for some, if you tried the known fixes, don't waste any more time if it's still not working. Me and others had problems that suddenly fixed themselves after some hotfixes or what I had after a router software update, or there is no known way to fix it unless you're some super nerd, so it's just no use.

Like I got StrictNAT long before the router needed an update, then suddenly it was gone, came back, over and over... so if you tried several fixes it's either somewhere you don't know or it's from the game's end and needs some good (hot)fix.

 

Also why not edit the main post with a list of possible fixes? And not just the standard notepad copy-paste *cough* "stuff", but everything, what can be found through google, on random threads/posts, etc, would really help.

Share this post


Link to post
Share on other sites

I keep getting a strict nat message i have tried all of the available network ports and i keep getting the error message if anyone can help me out it be great

Edited by Beowulf57

Share this post


Link to post
Share on other sites

Well. It was a good run. The game was working fine until the latest patch when this started showing up. Overzealous devs really do ruin everything. I'm just glad I didn't spend any money on the game.

Share this post


Link to post
Share on other sites

-Ramble ramble ramble- im having the same problem as everyone else. DE sucks and i cant fix my own problems.. -ramble ramble ramble- 

but in all seriousness. anyone know any 3rd party free software that could perhaps auto map out the ports needed for warframe? Im not good when it comes to moddems.. thanks :)

Share this post


Link to post
Share on other sites

-Ramble ramble ramble- im having the same problem as everyone else. DE sucks and i cant fix my own problems.. -ramble ramble ramble- 

but in all seriousness. anyone know any 3rd party free software that could perhaps auto map out the ports needed for warframe? Im not good when it comes to moddems.. thanks :)

 

the ports are the ports. whatever you set in warframe's config is what you need to set on your router.

along with the ip address being assigned to your computer from your router. (assuming your router is supplying dhcp, which is true in 99.999% of home systems and that 0.001% is usually being run by a very tech savvy person that doesn't need this explanation)

 

4950 and 4955 are the defaults these days. if memory serves.

as for how to configure your router... there isn't software for that.

you'll need to log into your router and configure it, check the manufacturer for details. 

Share this post


Link to post
Share on other sites

the ports are the ports. whatever you set in warframe's config is what you need to set on your router.

along with the ip address being assigned to your computer from your router. (assuming your router is supplying dhcp, which is true in 99.999% of home systems and that 0.001% is usually being run by a very tech savvy person that doesn't need this explanation)

 

4950 and 4955 are the defaults these days. if memory serves.

as for how to configure your router... there isn't software for that.

you'll need to log into your router and configure it, check the manufacturer for details. 

Well, for me it doesnt do S#&$. So again, how do you fix this problem which stems imo from the game itself?

Share this post


Link to post
Share on other sites

Well, for me it doesnt do S#&$. So again, how do you fix this problem which stems imo from the game itself?

 

i can repeat the quote you applied to your post, but it isn't going to change.

that's how you setup port forwards.

if you are still running into problems, contact support for your router or your isp and try to track down what's causing your problems.

Share this post


Link to post
Share on other sites

If the Warframe network analysis tool detected a problem with your network this could be the root cause of contact list, matchmaking and even voice-communication issues. Since Warframe is much more fun with friends we want to help you sort out your network troubles and get you back in the game!

Almost all home internet routers use NAT to allow you to share your internet connection with multiple devices on your home network. For security reasons routers may opt to enforce a more careful packet forwarding policy that may interfere with your game. If you are behind a Strict NAT you will have problems connecting to other players and likely appear offline to your friends.

Routers can be configured with NAT rules to direct traffic to specific hosts automatically using the Universal Plug and Play protocol (UPnP). UPnP is more convenient and secure than manually forwarding ports and also will allow you to run more than one copy of Warframe on your home network.

UPnP may not be working for one of several reasons:

1. UPnP is disabled in Warframe – the option to re-enable UPnP is in the Settings menu; re-enable it and restart Warframe.

2. UPnP was not detected – the service may be disabled on your router; enable it according to the manufacturer’s instructions.

3. UPnP is malfunctioning – if you have more than one person on your LAN try changing them to use different network ports (in the in-game settings).

Another possible source of problem is old router firmware; please check for updates according to the manufacturer’s instructions. There is also a component to UPnP that runs as part of the Windows operating system itself; you should also check for Windows Updates.

After upgrading router firmware or enabling features on the router you may need to reboot windows. After rebooting, test your network again from Warframe to see if you have solved the Strict NAT problem with UPnP.

If your router does not support UPnP you should be able to forward the UDP ports manually on your router.

Please note that if you are forwarding the ports manually you should disable UPnP first to avoid it interfering (you can disable it on your router or in the Warframe settings).

Warframe normally uses UDP ports 4950 and 4955. Your router needs to let traffic on those ports through to your PC. For your convenience these ports and your local IP address are shown in the network analysis dialog.

The instructions for forwarding ports on your router vary by manufacturer and model; please consult your router’s documentation for details on how to forward these ports to your PC.

 

For people trying to use USB Tether (Android OR Iphone), I found a fix!

On the phone, you should port forward your UDP (whichever you used, I use 4990 and 4995)

On the PC, right click the connection in Network Connections > Properties > Sharing (tab) > Check Allow Other Network Users... > Check Allow Other Network Users... (2nd one) > Settings > Add... > Desc Of Service : Warframe (or what ever you want) / Name or IP address : (start up cmd.exe and type 'ipconfig' then look for the 'default gateway' on the connection you are working on, example : 192.168.19.1) / Enter your port (only one for incoming/outgoing, select UDP.

Repeat the Add... with a slightly different name (example : Warframe_1) then use the other port there.

 

This resolved ALL strict NAT and 'failed to join session' errors for me!

Edited by D4_C0D3R
  • Applause 1

Share this post


Link to post
Share on other sites

After gaining root access to my ISP provided Technicolor Technicolor TG784n v3(it's just Thompson's new name) and opening ports 3 different ways trough the telnet menus this was what finally worked.

This router as single handed redefined my notion of crap hardware...

One change to your instructions though, putty is considerably better then the Windows 7 telnet client so i'd recommend using that instead.

 

My ISP just gave a new shiny router... a wonderful Technicolor TG784n v3:(

So i was stric natted, and even forwarding the ports i used for the game didn't help.

Then i googled and found a video from one italian guy (

) and apparently the trick is to abilitate the DMZ on the ip where Warframe is running.

This works. But mess up any further utilization of DMZ :S

I might change ISP asap, because it is way too crappy (they modded the router firmware, you can log as super user only) and just profit on the fact of being one of the first of serving 100mbit/s home fiber connections (FASTWEB spa/IT, FYI), but now there are many others.

Edited by perfectStranger

Share this post


Link to post
Share on other sites

My ISP just gave a new shiny router... a wonderful Technicolor TG784n v3:(

So i was stric natted, and even forwarding the ports i used for the game didn't help.

Then i googled and found a video from one italian guy (

) and apparently the trick is to abilitate the DMZ on the ip where Warframe is running.

This works. But mess up any further utilization of DMZ :S

I might change ISP asap, because it is way too crappy (they modded the router firmware, you can log as super user only) and just profit on the fact of being one of the first of serving 100mbit/s home fiber connections (FASTWEB spa/IT, FYI), but now there are many others.

 

If setting your system's IP as DMZ resolves the problem... Then your router is restricting access and you know exactly what your problem is. (the router) You can add a new router in-line between the technicolor and your network, setting the new router up as the DMZ. Then forwarding properly through your new router.

 

At least this wouldn't leave your system wide-open to the internet.

 

I'm assuming this TG784Nv3 is both a modem/router combo?

If it is possible, have your ISP replace it with a modem ONLY and get your own router that can actually use uPNP properly. (or at least forward ports properly) If that isn't possible, then the above method should work and not necessitate that your system be totally insecure.

Share this post


Link to post
Share on other sites

I dont have access to my modem/routers settings so I cant do anything with uPNP or Port Forwarding.

I cant invite or join a mates session, however since getting the "Strict Nat" message I have had other random players join my session and I even once joined someone elses. So if not having uPNP or PF BLOCKS matchmaking then how come I am able to have random people join me?

Share this post


Link to post
Share on other sites

And again today I get the Strict NAT warning yet was invited to a mission with someone from my Clan and also friends list, but a Friend only (no clan) cant invite me or me them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...