Jump to content
[DE]Glen

Strict Nat

Recommended Posts

Frustrating, I never had this problem until Mesa uptdate, is it really because of my Router? I never ever had any problem on any game until now, I can't connect to anyone except a very very FEW, including just one friend (and we are a group of 4 playing, so it increases my frustration to play) it's sometimes really horrible

 

And these are the consecuences

 

I can't farm and get mastery points efficiently, so my warframes keep being quite noobey (I only have frost and Volt)

 

Because of that I can't perform well on Void, I can't just solo or duo everything...

 

I keep depending on this friend to do difficult missions, which is completely not supposed to happen all the time

 

I don't even have all the nodes unlocked, therefore I lose alerts and special missions ( I just lost for the 3rd time Rejuvenation, just great)

 

No party, no void, no prime, no anything, this is getting boring and sad.

 

 

....Now that I vented all my stress it's time to ask my question, why is this happening? if I did not have any problem before mesa, why am I having it right now>? it makes no sense, I did not make any changes on my computer, I didn't even touch my router until now(I'm violating it everyday trying to make this work since Mesa), and if it's not entirely my fault, why is this not fixed already, this problem is making my Warframe experience go 10%, this is multiplayer for godsake!

Share this post


Link to post
Share on other sites

been having an issue playing with my brother at home. We both are running on different ports and we cant even get into matchmaking together. Sometimes if i join, it kicks him and i become the host and very rarely we can play together.

My brother is finding issues with matchmaking over all though. He cant join others missions. He has to be the host otherwise it boots him to lobby

Edited by zachi2

Share this post


Link to post
Share on other sites

Frustrating, I never had this problem until Mesa uptdate, is it really because of my Router? I never ever had any problem on any game until now, I can't connect to anyone except a very very FEW, including just one friend (and we are a group of 4 playing, so it increases my frustration to play) it's sometimes really horrible

 

And these are the consecuences

 

I can't farm and get mastery points efficiently, so my warframes keep being quite noobey (I only have frost and Volt)

 

Because of that I can't perform well on Void, I can't just solo or duo everything...

 

I keep depending on this friend to do difficult missions, which is completely not supposed to happen all the time

 

I don't even have all the nodes unlocked, therefore I lose alerts and special missions ( I just lost for the 3rd time Rejuvenation, just great)

 

No party, no void, no prime, no anything, this is getting boring and sad.

 

 

....Now that I vented all my stress it's time to ask my question, why is this happening? if I did not have any problem before mesa, why am I having it right now>? it makes no sense, I did not make any changes on my computer, I didn't even touch my router until now(I'm violating it everyday trying to make this work since Mesa), and if it's not entirely my fault, why is this not fixed already, this problem is making my Warframe experience go 10%, this is multiplayer for godsake!

i've had the same issues after the mesa update aswell! i've never had problems with nat before in game, i've tried every possible fix but it hasn't worked. worst part is that there isn't any official statement from DE about the issue. all we can do is wait for now...

Share this post


Link to post
Share on other sites

Anyone Using TP-LINKS router with strict nat issues? Im using WR720N model. Been doing all the guides I can found everywhere, but still won't work.

Share this post


Link to post
Share on other sites

27 pages, and nothing.

1. Settings in game don`t send information to router or windows UPnP

2. You can set any UDP port, but game use standart.

Share this post


Link to post
Share on other sites

I have had "Strict NAT detected. UPnP not detected. Please forward UDP ports..." warning showing up for nearly 6 months, and I finally fixed it today. This has been causing many people to have "Failed to join" error when trying to join with me in matchmaking. I did all the basics setup static IP, used different set of ports because of multiple computers running warframe on the same LAN, port forwarded the separate ports to the respective computers, verified firewall permissions for warframe ports, but it still did not work.

ATT is my ISP, I am using a Motorolla POS modem, and a Cisco Linksys E1200 Router on a wireless network. For the longest time I had felt like my problem was similar to what I have experienced in the past when using a home network behind two routers and a modem as opposed to the typical one router one modem setup. I think in the end that is essentially what the problem was. I think my modem was acting like a second router by using an internal IP with my actual router.

My modem has an 'advanced' setting that says "yes, use public IP address". Simply selecting 'yes' instead of the default 'no' immediately stopped the strict NAT warnings in game. I hope this helps some poor soul out there like me!

Here are pics to take a look at some of my config.

http://imgur.com/a/kyk2P

Cheers Tenno!

Share this post


Link to post
Share on other sites

Although I think it would be much more easier if they remove the Strict Nat. Rather than making every single person that have Strict Nat, to report Strict Nat problem, while we do not have any knowledge about port forwarding.

 

For you who have knowledge about port forwarding then good for you.

 

But for us who don't have any single knowledge, it's doom for us. and while don't have knowledge, we instead, try every single thing to remove this Strict Nat thing in setting or option or whatever it appears, and In process we destroy our own router or modem or whatever you use.

 

I almost make my PC got infected by virus to rid the Strict Nat. Also there are some modem that doesn't have port forwarding. So well, that's suck for me, I don't have port forwarding in my modem.

 

So if you would kindly enough to remove Strict Nat, I would appreciate that. If not well, I just say forever to my friend who have Strict Nat and can't play together. 

 

Only one trick for people who have Strict Nat who doesn't have any knowledge about port forwarding like me : 

1. Ask your friend or complete total stranger who doesn't have Strict Nat issue or Failed To Join Session issue (basically these 2 issues that I've experienced) to invite you and your friends who got Strict Nat to join in one session.

2. Now you can play together.

3. When Squad got disband for example like Disconnected or Session unavailable or you forced to get back to Login Screen, ask that person to invite both of you or 3 of you again.

4. Now you can play again.

 

Repeat the process if you know that person you only need to repeat 3 and 4. If you play with complete total stranger repeat 1-4 although along the way you getting along with each other just repeat 3 and 4.

 

It also depends how long your Squad want to play.

 

But if all your friends have Strict Nat, then sorry, I can't give you a trick there.

Share this post


Link to post
Share on other sites

it's still weird that some people (including me) started getting strict nat messages after the mesa update. in my case i haven't had a nat problem with the game until that update.

Share this post


Link to post
Share on other sites

it's still weird that some people (including me) started getting strict nat messages after the mesa update. in my case i haven't had a nat problem with the game until that update.

 

Indeed, never had a problem before Mesa.

Share this post


Link to post
Share on other sites

E: Never mind, found this. I am going to try it and come back here to tell if it works or not

http://portforward.com/english/routers/port_forwarding/Asus/RT-N10U/Warframe.htm

 

E2: Nope, not even with the settings from the site. I finally talked my friends to download warframe and now I can't play with them :P sucks.

 

E3: With a help from someone that knows what is he talking about I ended up with this

http://i.imgur.com/5xG5Q2m.png

Still doesn't work, I feel like killing someone now.

 

E4: on a different forum I found out, that I ahve to have public IP in order to forward any ports. Which I do not have and I can't even get that. So I guess the game is simply telling me "suck on that". I really wanted to enjoy the game but problems with updates, problems with playing with friends... IDK

 

If someone sees what the hell am I doing wrong than I would appreciate any help.

 

http://i.imgur.com/Krn7TbQ.png

 

The strange thing is that I have upnp enabled in the settings and in windows and in the game, yet I still get the error message in game so I figured I better forward the ports. But I can't get it right it seems... (First time doing something like this)

Edited by Kujar3

Share this post


Link to post
Share on other sites

Why this thread even open ? This strict has done the damage it could do. Friends in irl left wf cause even after 1 year they just cannot join me nor can i. so **** this. never ending misery .

Share this post


Link to post
Share on other sites

Hi, so i'm having strict nat problems.  Tells me to port fwd.  Never ever had this problem till today.  Was able to play in squad last night till today ;c. Halp pls!

Share this post


Link to post
Share on other sites

Try using a VPN service to fix the strict NAT problem. I'm not sure if DE are ignorant or in denial about this but it should really be included on the support page.

Share this post


Link to post
Share on other sites

Try using a VPN service to fix the strict NAT problem. I'm not sure if DE are ignorant or in denial about this but it should really be included on the support page.

 

Any not so too much expensive service you can suggest me?

Share this post


Link to post
Share on other sites

Any not so too much expensive service you can suggest me?

My personal favourite is called AirVPN. The sign up/installation is quick and painless. They have a 3 day trial for 1 euro and it is 15 euros for 3 months. It allows 3 connections at a time so you can share it with your friends. From the UK I get my full ~6MB/sec download with minimal ping increase.

 

There are also free VPNs but having not tested any I can't guarantee they work, or that they will allow you to route all your data through them for free without lag.

Share this post


Link to post
Share on other sites

Hi there, I try also to use this guide but I'm still having the issue

bY3BUyc.jpg

 

I also opened manually the doors through the router

zur3Yfd.png

 

I don't really know what to do more for this issue. I'm totally done I have this problem just on Warframe, this isn't normal. Someone can help me? :/

Share this post


Link to post
Share on other sites

Hi there, I try also to use this guide but I'm still having the issue

bY3BUyc.jpg

 

I also opened manually the doors through the router

zur3Yfd.png

 

I don't really know what to do more for this issue. I'm totally done I have this problem just on Warframe, this isn't normal. Someone can help me? :/

 

you need two entries with internal and external ports matching.

so :: warframe :: 192.168.1.38 :: udp :: 4950 :: 4950 

and :warframe :: 192.168.1.38 :: udp :: 4955 :: 4955

external and internal ports need to match

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...