Jump to content
Sign in to follow this  
[DE]Glen

Strict Nat

Recommended Posts

I'm sorry I need to ask. I get the "Strict UPnP" message when I log in the game (Warframe - PC) but I don't seem to encounter a problem with contact list and voip.

I'm planning to set up another warframe on another pc for another player in the network.

Does the issues only apply when multiple warframe applications are running in the network?

Should I expect no problem when I'm the only warframe running on my network?

Thanks!

Share this post


Link to post
Share on other sites

"Could not deliver invitation to xxx"/"Host unreachable" after the Beasts of Sanctuary update I can't invite ~90% of players to my party either join theirs. Ports are forwarded. still i getting this message: https://imgur.com/a/eY9AsoZ . Also i can only host mission and not able to find a party before i become host.

Edited by Lerkeer

Share this post


Link to post
Share on other sites
15 hours ago, Lerkeer said:

"Could not deliver invitation to xxx"/"Host unreachable" after the Beasts of Sanctuary update I can't invite ~90% of players to my party either join theirs. Ports are forwarded. still i getting this message: https://imgur.com/a/eY9AsoZ . Also i can only host mission and not able to find a party before i become host.

I am having a similar problem, only difference is just that I am able to host public missions, and join public missions.

Share this post


Link to post
Share on other sites

T^T

Okay i tried reading this thread but i could not understand anything 

Im getting that strict Nat message and i can do anything about it cuase im not using a router instead im using my phone  and making a wifi hotspot with it 

this has never given me any problems with all the other online games ive tried

Please help

Share this post


Link to post
Share on other sites

So at home I don't get this issue and I can play fine.

At work I get the strict Nat warning immediately upon logging in. I can dismiss the warning but the game will literally be unplayable at that point since it will freeze up for half a second every 5-6 seconds non stop.

Since this is happening at work, I don't have access to the router and can't set up port forwarding myself. IT will likely deny any request as they'd be perfectly justified in considering it a security risk to forward ports for no valid reason. Note that I work at a game dev studio where employees play all kinds of online and MMOs all day with zero issues. Warframe seems to be the only game that doesn't play by the rules and needs special setup outside the game.

Here are my questions...

If I am getting the strict NAT issue and don't have access to the router, does this mean I cannot play Warframe at all?
Is there literally no workaround except to get access to the router?
Are the devs working on a proper fix to this issue?

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 2014-12-12 at 11:11 AM, D4_C0D3R said:

 

For people trying to use USB Tether (Android OR Iphone), I found a fix!

On the phone, you should port forward your UDP (whichever you used, I use 4990 and 4995)

On the PC, right click the connection in Network Connections > Properties > Sharing (tab) > Check Allow Other Network Users... > Check Allow Other Network Users... (2nd one) > Settings > Add... > Desc Of Service : Warframe (or what ever you want) / Name or IP address : (start up cmd.exe and type 'ipconfig' then look for the 'default gateway' on the connection you are working on, example : 192.168.19.1) / Enter your port (only one for incoming/outgoing, select UDP.

Repeat the Add... with a slightly different name (example : Warframe_1) then use the other port there.

 

This resolved ALL strict NAT and 'failed to join session' errors for me!

Okay

I have no idea how to do that 

On 2015-05-18 at 6:06 PM, S1gnas said:

Strict NAT user here, and will be for a while, im tethering  internet from my phone to be able to play warframe at home with out paying hand and foot for internet.

 

Anyways, around the time the NAT servers were implemented (U15? ill edit it later) i have been unable to play warframe at all multiplayer.  

"Host migration in progress please wait" 

aww crap got booted back to the parent post again, let me logg back in....

 

Matchmaking servers will put me into games all day ju... "Host migration in progress please wait" ,crap back at the liset again, st to boot me back to the liset with in 3-5 seconds.  It has gotten worse in the last week and will completely log me out of the game even.

 

Before the Strict nat servers were up i only had a friend list full of no to very little lag and could join on certain clansmembers if any one person had connectivity issues to me, or me to them.  I could play the game to its fullest with 3 other people regularly.  

 

Now the only way i can play warframe is to solo i cannot trade in the dojo anymore i cant visit relays. (can only get in there when the relay bugs out and i join my own instance of a relay, but i cant do anything in there anyways) im missing out on most of warframe due to something that was done on DE side of the game.

I also have the same problem 

I use my phone as a hotspot and i keep getting that message 

I cant host any games ,as when i host and try to invite friends that say they cant join or when i join a squad of random strangers they get kicked when they try to play with me and i end up alone 

T^T

People have problems inviting me into their games and when i successfully join i get so much so much lag and get kicked out sometimes

Ive looked all over this thread and it looks like DE have given up on us 

Share this post


Link to post
Share on other sites

I'm suddenly having constant connection errors and I get the strict NAT warning, although my router is configured correctly.

This has been happening today with no apparent reason. Anybody have the same issue?

I opened a thread here:

 

Share this post


Link to post
Share on other sites

I keep getting this error, though it doesn't seem to affect anything for me at all.

I have followed all steps and both my router and Windows support UPnP. I can still play on public sessions and I get no connection problems at all, only the annoying error message when I boot up Warframe.

I even checked if there was traffic going through the ports Warframe uses, and it also worked which means the error message shouldn't display at all. Does the error message appear because of a bug or something else?

 

Really late edit:

My problem was caused by pfSense, I found the fix on a different forum where people were experiencing the same problem.

Quote

 

You have to set an outbound NAT rule:

NAT: Outbound
Hybrid or Manual
Add
Source is your IP/32
(1 person commented they had to change /32 to /24, not sure if that's a rare occurrence but still noting it just to be safe)
Check Static Port box
Save
make sure rule is at the top of the list.

Connection successful.

 

 

Edited by nepvee
Added a solution to the problem

Share this post


Link to post
Share on other sites

I have strict Nat and it is confirmed by my isp.Only trouble I have is that other players can't invite me to squad but I can invite them.

Share this post


Link to post
Share on other sites

Started getting the "Strict NAT" message today. Never got it before now in my 600+ hours of play time and nothing's changed in terms of router or Windows settings.

Forwarded the proper UDP ports on my router (because it's a piece of garbage and doesn't allow/support UPnP for some unknown reason), but the message still pops up when I log in. Strange part is, nothing seems to be affected. I can join/host pup games fine, I'm not having issues using chat, be it clan or in general, either.

Not sure if it's just WF being weird, my router being utter crap or some combination of both.

Share this post


Link to post
Share on other sites

I resolved this problem for myself by finding an odd setting in my firewall. Some firewalls use a higher level of security by randomizing the outbound port number as traffic passes back out through the NAT from the LAN to the WAN. This is a good thing, in general, as it prevents spoofing and it overcomes the fact that most applications do a terrible job of port randomization.

 

The problem here is, it breaks Warframe's networking in lots of odd ways. The remote host you're connecting to expects that warframe traffic is going to be over those specific ports. What happens when your firewall wants to get tricky and start randomizing things is that remote connection doesn't know what to do and you get "Strict NAT" even though you're otherwise properly configured.

 

Don't ask me how to turn it off, or even if you can, or even if it's a thing on your firewall I don't suspect most Best Buy clearance grade routes would have this feature or if they did, whether they'd have a way to toggle it on or off. I use pfSense, myself, and this is where I found it:

https://www.netgate.com/docs/pfsense/nat/static-port.html

 

If you don't control your router, I'm sorry, this probably isn't an option for you, but it solved my problem completely!

 

Best to all,

Pol

Share this post


Link to post
Share on other sites

I have the same ... just that I am connected by cable.
I've tried all this, but I still have the same problem, I honestly do not know what else to do.

Share this post


Link to post
Share on other sites

Hi DE, my ISP closed my ports. The internet service I'm using does not allow port opening ISP side. I want to have an option in WF to disable showing that absolutely useless message every time I log on.

  • Upvote 1

Share this post


Link to post
Share on other sites

Just becarfull with port forwarding its easyer to get virusses and hacks going on if they got in. My was told its good for a connection but makes it less safe.

Share this post


Link to post
Share on other sites

Started getting the strict NAT message today.

jBlomD0.png

Port forward testing app shows that both UDP ports are open.

b5Ohpzt.png

I tried disabling UPnP in both the game and router and letting the game run strictly on the open ports but it didn't work (and the other way round). I'm mostly having problems joining to other people's dojos or inviting to mine.

Share this post


Link to post
Share on other sites
Posted (edited)

I am having the same problem. Tried all the instructions here, disabled UPnP first on warframe, then manually forwarded the UPnP and TCP ports on my router, reboot everything, still error. 

Failed to join session error comes up when someone invites me, but problem does not occur everytime. For example, was playing fine tonight in public sessions, but after going afk for 30 minutes, problem come back again. The UPnP malfunction message do appear everytime I start warframe.

More importantly, I have been playing fine for 2 months now. Problem started to occur from yesterday after a minor update on Warframe. I doubt it's my ISP problem and doubt it's my router.

PLEASE FIND A SOLUTION FOR THIS. 

 

Edited by Temjinck

Share this post


Link to post
Share on other sites

eu abro chat regional e mesmo assim fica carregando infinito parecendo que vai mostrar vai mostrar algo mas não mostra como é que eu posso resolver isso

 

 

Share this post


Link to post
Share on other sites

Same problem here, I was playing 3 months ago and it was all good, but now every time I log in, I get this "Please ensure that your firewall permits UDP ports 4950 & 4955". And yes, I tried everything, portforwarding, UPnP... Can't play with my brother, he's next door and we can't bloody play together.

Share this post


Link to post
Share on other sites

What @[DE]Glen fails to mention in his post is that restriction can also be applied at ISP level! For very specific security reasons. And in worst case, you cannot lift that restriction, unless you double your internet service fee. For WF? Hell no!
I find it absolutely annoying to be greeted by that Strict NAT blah blah message on every damn logon! There's nothing I can do, since I have ISP level restriction. I can play WF fine. Maybe rarely there are players who have issues with me, but majority don't complain. Ofc I don't know what really causes the issues, since there aren't any error messages ever.

Can we some beautiful day opt out from that super annoying, useless, greeting message?

Share this post


Link to post
Share on other sites
On 2019-07-16 at 10:42 PM, tape_drive_TS1140 said:

What @[DE]Glen fails to mention in his post is that restriction can also be applied at ISP level! For very specific security reasons. And in worst case, you cannot lift that restriction, unless you double your internet service fee. For WF? Hell no!
I find it absolutely annoying to be greeted by that Strict NAT blah blah message on every damn logon! There's nothing I can do, since I have ISP level restriction. I can play WF fine. Maybe rarely there are players who have issues with me, but majority don't complain. Ofc I don't know what really causes the issues, since there aren't any error messages ever.

Can we some beautiful day opt out from that super annoying, useless, greeting message?

Finally! I found someone that have same ISP level restriction with me lol

btw do you sometimes lagging when doing multiplayer?

Share this post


Link to post
Share on other sites

I do not know how to forward port. I have an arris router with an ethernet cable connected to my computer. I have been having an issue where at random as I play with friends or randoms on public, the squad will all stop moving and leave squad. If anyone can help me out with this it would be so greatly appreciated that I can't even think of words to describe. Thank you.

Share this post


Link to post
Share on other sites
On 2019-08-16 at 10:57 PM, Ic3Wolv3s said:

I do not know how to forward port. I have an arris router with an ethernet cable connected to my computer. I have been having an issue where at random as I play with friends or randoms on public, the squad will all stop moving and leave squad. If anyone can help me out with this it would be so greatly appreciated that I can't even think of words to describe. Thank you.

Hello there.. are you currently using Public IP Address? if you are unsure, please contact your ISP.. or try to enable UPnP on your router (just google the "Arris Router Enable UPnP")..

because we can't port forward without using the Public IP (based on my experience and some research, cmiiw)

it happened to me before i'm start using Public IP.. Strict NAT detected and UPnP malfunctioning alert and LAG-A-LOT while playing with friends or randoms.. which is annoying and frustating me, so I stopped playing for a while..
then i'm trying to contact my ISP and subscribe to their Public IP (small additional fee) and then Boom!! no more Strict NAT warning, no more laggy gameplay on Public, everything is good!

so i'm suggest you to contact your ISP.. and ask about the Public IP and Port Forward

sorry for my bad english

Have a great day 😁

Edited by LANdroid7_
typo haha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...