Jump to content
  • 0

Fullscreen Mode Forces Wrong Monitor



Hey guys, I didn't see a "Support" forum other than this one. I could be blind though.. if so, I apologize. :D

I am running true dual monitor with 2 discrete video cards. For whatever reason, Warframe automatically fullscreens to my secondary monitor. It -refuses- to to to my main monitor. Anyone know how to fix this? Or what could be causing the issue? Its not a problem in anything but Warframe.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

There doesn't seem to be a way to set a preferred display in warframe.


My issue is similar but not identical. I'm running one card and two displays. It always starts on my primary but I'd like it to run on my secondary (I actually haven't tested if it'll start on the other monitor if I configure windows/nvidia to have that as my primary).


Workaround: Alt-Enter to go to windowed mode. Move the window to the preferred monitor. Alt-enter to go full screen. Go to your video settings and switch a few things back to how you want them (for example vsync always gets turned off when going to windowed mode, but it doesn't remember to turn it back on when re-entering full screen -- there are others but this may not affect you).


Edit: I've started just setting the launcher (look for the config icon in the upper right) to not enter fullscreen by default so I don't have to leave it in the first place. This seems a bit more reliable (and the resolution options for my larger "secondary" display are present without a client restart).

Edited by LakeSolon
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...