Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Progress lost after mission.


Recommended Posts

This has been happening for the last couple of hours. I noticed something was wrong with my account when i first tried logging in. It gave me errors about how i couldn't connect to the server. I tried logging in at least 10 times. Still same error. Exited the client and tried logging in again, NOPE. Waited a couple of mintues and i finally was able to login. My friend could login smoothly, so he had to wait for me to login. Then i got logged out again, and had to do the same S#&$ all over again. Been keeping up with this for a couple of hours now. And then when i finally play COOP with my friend, all hell breaks loose. After finishing my mission, they wouldn't save S#&$. I lost my exp, points any progress i made from that mission and it automatically logged me out of the friggin game. Thought it was a one-time thing so i decided ti try agian. So now i just played 10 min of this one mission, cleared everything, BAM no progress from that mission was saved. Then it logged me out of the game. So yeah. Now im going to try and login again and try to finish some missions so i can level my my friggin sword and add some cool effect on my sword.

Edit 1: @(*()$ bullS#&$, finished another mission and nothing was saved once agian.

Edited by Rerox
Link to comment
Share on other sites

Same thing for me, just got the beta last night, worked no problem and earlier today aswell.

Now i can't connect to server but my friends can no problem. Also game crashed just at the end of a mission twice and gave me the lost progress msg before i started getting this login issue, but no idea if its connected.

Anyone have any ideas?

Link to comment
Share on other sites


Dude.. This is *closed beta*. You're complaining like this is a release game.

This is beta, and the purpose of this thread is to let the developers know that there's a BUG which they should know of, so they an fix it. Im doing them a favor. Im complaining like this is a closed beta, so they can fix it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...