Jump to content
Dante Unbound: Known Issues ×
Dante Unbound: Share Bug Reports and Feedback Here! ×

This Game Is Trying To Melt My Graphics Card.


Salganos
 Share

Recommended Posts

And today, I found out how and why: the framerate is completely uncapped.

 

After an issue a few weeks ago with a dead secondary outtake fan on my case, I found that my card's bios was not changing the fan speed with temperature and had to set up software control to do it for me, so I've been carefully monitoring my GPU's temperature since.  I also opened the case and propped a window fan against it in case of emergencies (I'm waiting on replacement parts). Then I started playing Warframe again, and found that unlike with every other game, the GPU was still getting insanely hot when I played this one, which I hadn't been playing before the issue.  I thought it was especially odd how sometimes Warframe would raise the GPU temperature above 90 °C no matter what, and other times would never get above 80 (both of which are higher than I would like, though 80 is tolerable), with no change in settings.  Even odder was how changing the graphical settings from highest to lowest had no effect on the resulting temperatures.

 

Worth noting, I have the game on borderless fullscreen, because on normal fullscreen the mouse cursor has some weird-&#! disgusting acceleration horribleness going on, and I have v-sync off because it makes even the cursor lag VERY noticeably.  I will not be changing either, because v-sync is terrible and unnecessary and I don't get screen tearing, and until normal fullscreen stops implementing its own absolutely revolting mouse settings, that's staying off too.

 

So, today, I started the game, and then alt-tabbed to finish looking at something else, and then reflexively checked my GPU temperature, only to find it at 105 °C! This, needless to say, is a terrible temperature to find the GPU at, and I turned my fan on and opened my window wide to the frigid air, and was relieved to find the temperature rapidly becoming sane again.

 

I then remembered that this wasn't the first time the temperature was abnormally (but not quite so) hot on the title screen, and logged in.  I then had an idea, turned the fps display on, and found it reaching over 130 fps on the system screen.  I then Googled the topic, and found archived threads on this forum, from last November, on lesser versions of this very subject, with complaints of the log-in screen reaching 700 fps (its over 340 for me).

 

The fps needs to be cappable.  Neither this game nor any other has any business forcing a poor old GTX 285 to run itself into the ground and melt by running the game at 140 fps on low (my screen's refresh rate is only 60!), let alone 340 on title-screen.  I know people turn down effects to up the framerate, but when you force it to go so high it massively outdoes the effect shaders on heat production and threatens the integrity of the hardware, that's just silly.  I expect lower graphical settings to mean my card doesn't have to try as hard, not that it's going to try five times harder.

 

DE, I would appreciate it if your game's graphical engine weren't classifiable as hardware-endangering malware, especially on the title screen of all places.

Edited by Salganos
Link to comment
Share on other sites

Warframe is not malware or a power virus. Your card should be able to render anything it's told to, as fast as it possibly can, without thermal issues. If it can't it either needs to be cleaned, or is broken.

 

Your card will always try as hard as it can, unless something deliberately caps it's performance, reducing quality settings will not lower the load on the GPU unless a bottleneck develops elsewhere, and a decent CPU can feed nearly empty frames to the GPU very quickly.

 

You will either need to turn on vsync, or use a third party utility to cap frame rate.

 

You should not be getting mouse issues full screen. If you are, I would check your Windows settings, and possibly disable cursor acceleration.

 

Vsync can indeed cause input lag, but you should be able to dramatically reduce this by setting frames render ahead (aka flip queue size) to 1 (default is 3). This way your input will only be a single frame behind, as opposed to potentially several. Don't set 0, it doesn't actually work.

Link to comment
Share on other sites

not sure whats going on with your system but i used to run this game on a gtx 260 and the temp never went above 76, i am running a 660 oc now and the temp still never goes above 76 for any game and i run everything on ultra, it may be a quirk with your graphics card.  The strangest things can set them off, for six months i thought my 260 was bricked, turned out it was the psu at fault think it hemorrhaged a few watts somewhere

Link to comment
Share on other sites

It would explain why my GC "died" one and a half year after its installation and playing nearly only WF...

I'm going to check temperature (and if necessary take a pause in WF), until this matters is solved.

Edited by Marnus
Link to comment
Share on other sites

Warframe is not malware or a power virus. Your card should be able to render anything it's told to, as fast as it possibly can, without thermal issues. If it can't it either needs to be cleaned, or is broken.

 

Your card will always try as hard as it can, unless something deliberately caps it's performance, reducing quality settings will not lower the load on the GPU unless a bottleneck develops elsewhere, and a decent CPU can feed nearly empty frames to the GPU very quickly.

 

You will either need to turn on vsync, or use a third party utility to cap frame rate.

 

You should not be getting mouse issues full screen. If you are, I would check your Windows settings, and possibly disable cursor acceleration.

 

Vsync can indeed cause input lag, but you should be able to dramatically reduce this by setting frames render ahead (aka flip queue size) to 1 (default is 3). This way your input will only be a single frame behind, as opposed to potentially several. Don't set 0, it doesn't actually work.

 

Cursor acceleration has been murdered in a dark cabin deep in the northern woods many many years ago.  Any infants of its I find are always immediately sacrificed to a random chosen eldritch diety from beyond space and time.  The problem with fullscreen Warframe is with fullscreen Warframe.  It appears to ignore my mouse preferences altogether and institute its own sensitivity, coupled with an input lag that only worsens with v-sync on.  It is not mouse acceleration, but it is so slippery it feels like it.

 

Also, I ran tests with v-sync turned on through nVidia software, however I am dismayed to find that, when restarted, the game ignores both these and its own v-sync settings half the time and renders things 200 times a second anyways, just because.  Sometimes it even ignores v-sync being turned off.  While in this very sleepy instance I did not experience noticeable input lag, and while the heat problems went away, the complete unreliability coupled with the chance of more "cursor on ice" action does not make this a viable long-term solution.

 

And I don't care what you think my card should be able to do.  Its a five year old card, and not the kind with an entire radiator screwed onto the heatsink.  It can still run this game at maximum settings, not dipping below 30 fps, without overheating NEARLY as badly as what the title screen pulled.  This is an issue.

Edited by Salganos
Link to comment
Share on other sites

Cursor acceleration has been murdered in a dark cabin deep in the northern woods many many years ago.  Any infants of its I find are always immediately sacrificed to a random chosen eldritch diety from beyond space and time.  The problem with fullscreen Warframe is with fullscreen Warframe.  It appears to ignore my mouse preferences altogether and institute its own sensitivity, coupled with an input lag that only worsens with v-sync on.  It is not mouse acceleration, but it is so slippery it feels like it.

 

Also, I ran tests with v-sync turned on through nVidia software, however I am dismayed to find that, when restarted, the game ignores both these and its own v-sync settings half the time and renders things 200 times a second anyways, just because.  Sometimes it even ignores v-sync being turned off.  While in this very sleepy instance I did not experience noticeable input lag, and while the heat problems went away, the complete unreliability coupled with the chance of more "cursor on ice" action does not make this a viable long-term solution.

 

Have you tried changing frames render ahead to 1? No improvement?

 

 

And I don't care what you think my card should be able to do.  Its a five year old card, and not the kind with an entire radiator screwed onto the heatsink.  It can still run this game at maximum settings, not dipping below 30 fps, without overheating NEARLY as badly as what the title screen pulled.  This is an issue.

 

An in-game frame limiter setting would be a nice addition, I agree.

 

Untill then, you'll need another solution. Have you tried a 3rd party frame rate limiter? Plenty of tools have them. The one most likely to work on your card would probably be the one included with MSI Afterburner.

Link to comment
Share on other sites

GPUs are designed to run at 100% utilization. If I was hitting 105C, I wouldn't just pawn it off as "Its the game", I would get furmark or something and stress test the card and see how it handles. I get anywhere from 400-500fps on loading screens, and about 130-150fps ingame and my GTX 760 always peaks at 82C.

99% of "This game is overheating my PC" is usually a cooling issue outside of the game. Hardware is designed to run maxed out and keep itself with in thermal limits.

Quick fix has been said, turn on V-sync (My GPU does run 20C cooler with it on, and about 40-50% utilization). Long term fix, check your system has enough airflow, your cooler is clean and that your fans profiles are set high enough. 

Edited by Snougar
Link to comment
Share on other sites

To be less terse, V-Sync forces the GPU to produce no more frames than your monitor's current refresh rate.  Theoretically, your monitor cannot display more frames per second than its refresh rate allows, so a 60hz monitor can only display 60fps regardless of how fast the engine can turn out frames.  120hz monitors will display 120fps with V-Sync turned on.  It's a good idea to run with V-Sync on if you want to run at under 100% utilization.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...